[jitsi-dev] Jicofo Ping Time Out


#1

Hi,

I believe it is the same problem experienced by jitsi-videobridge earlier.

On a Ubuntu machine, try to copy the following java class i.e.
jicoco-1.0-20160109.203023-16.jar
from jitsi-videobridge installed directory /usr/share/jitsi-videobridge/lib

to jicofo installed directory /usr/share/jicofo/lib

and restart jicofo.

Regards,

CM Eng

···

-------------------------------------------------------

Message: 1

Date: Sun, 17 Jan 2016 12:35:35 +0100

From: Stefan Fuhrmann <stefan@fuhrmann.homedns.org>

To: Jitsi Developers <dev@jitsi.org>

Subject: Re: [jitsi-dev] handleIQError jitsi-videobridge ejabberd ping

                timeout

Message-ID: <1750926.Iuk0iLj3Rz@stefan-ubu>

Content-Type: text/plain; charset="us-ascii"

Hello all,

after last update videobridge its running now.

But jicofo not:

org.jitsi.jicofo.ComponentsDiscovery.discoverServices().264 Feature list
changed for: jitsi-videobridge.doamin.tld

2016-01-17 12:30:49.545 SCHWERWIEGEND: [33]

org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
6F03r-15

2016-01-17 12:30:50.026 SCHWERWIEGEND: [33]

org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
6F03r-16

2016-01-17 12:30:54.551 INFORMATION: [58]

org.jitsi.jicofo.xmpp.FocusComponent.handleIQError() (serving component
'Jitsi Meet Focus') IQ stanza of type <tt>error</tt> received:

Can someone help?

tia

Stefan

Am Thursday 14 January 2016, 23:34:52 schrieb Stefan Fuhrmann:

Hello all,

Im trying a new setup with ejabberd, jitsi-videobridge and jicofo.,

Jitsi-meet should run on another machine.

ubuntu server 14.04

java version "1.8.0_66"

Java(TM) SE Runtime Environment (build 1.8.0_66-b17)

followed instructions:

https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

and getting this in jvb.log when starrting the bridge:

Jan 14, 2016 8:41:24 PM org.jitsi.util.Logger info

INFORMATION: RECV: <iq from="domain.tld" to="jitsi-videobridge.domain.tld"

type="error" id="QiBAF-32"><ping xmlns="urn:xmpp:ping"/><error code="501"

type="cancel"><feature-not-implemented

xmlns="urn:ietf:params:xml:ns:xmpp-

stanzas"/></error></iq>

Jan 14, 2016 8:41:29 PM net.java.sip.communicator.util.Logger error

SCHWERWIEGEND: Ping timeout for ID: QiBAF-32 Jan 14, 2016 8:41:34 PM

org.xmpp.component.AbstractComponent handleIQError

INFORMATION: (serving component 'JitsiVideobridge') IQ stanza of type

<tt>error</tt> received:

ejabberd log shows okay:

[debug] <0.795.0>@ejabberd_receiver:process_data:349 Received XML on

stream = <<"<iq id=\"mh20R-4\" to=\"jitsi-videobridge.domain.tld\"

from=\"jitsi- videobridge.jitsi-videobridge.domain.tld\"

type=\"get\"><ping xmlns= \"urn:xmpp:ping\"></ping></iq>">>

I tried alot around and did searching on the web but can not solve it.

Im having another test machine with prosody. There is no such error.

How can I solve it?

Can someone help?

tia

Stefan

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


#2

Hello,

Hi,

I believe it is the same problem experienced by jitsi-videobridge earlier.

On a Ubuntu machine, try to copy the following java class i.e.
jicoco-1.0-20160109.203023-16.jar
from jitsi-videobridge installed directory /usr/share/jitsi-videobridge/lib

to jicofo installed directory /usr/share/jicofo/lib

and restart jicofo.

I did that but same error:

2016-01-19 07:21:35.670 SCHWERWIEGEND: [35]
org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
UrR7J-128
2016-01-19 07:21:35.955 SCHWERWIEGEND: [35]
org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
UrR7J-129
2016-01-19 07:21:40.668 INFORMATION: [58]
org.jitsi.jicofo.xmpp.FocusComponent.handleIQError() (serving component 'Jitsi
Meet Focus') IQ stanza of type <tt>error</tt> received:

tia
Stefan

···

Am Tuesday 19 January 2016, 00:39:54 schrieb cmeng.gm: