[jitsi-dev] Jicofo: Failed to allocate channels - no bridge configured


#1

Hi all!

Earlier I tried to start a conference with other people and I got the
message "Unfortunately, something went wrong. We're trying to fix this".
I noticed this message on another occasion when the "too many open
files" problem occurred, but I was checking the JVB logs and I do not
see traces of "too many open files".

I found this in the Jicofo's log:

···

-----------------------------------------------------------------------
Jcofo 2017-02-13 13:05:43.071 SEVERE: [92]
org.jitsi.jicofo.ChannelAllocator.log() Failed to allocate channels for
inmobiliariaortega@conference.conf.opcion-libre.com.ar/4ce8717c
net.java.sip.communicator.service.protocol.OperationFailedException:
Failed to allocate channels - no bridge configured
        at
org.jitsi.jicofo.ChannelAllocator.allocateChannels(ChannelAllocator.java:372)
        at
org.jitsi.jicofo.ChannelAllocator.createOffer(ChannelAllocator.java:307)
        at
org.jitsi.jicofo.ChannelAllocator.discoverFeaturesAndInvite(ChannelAllocator.java:166)
        at org.jitsi.jicofo.ChannelAllocator.run(ChannelAllocator.java:135)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)
Jicofo 2017-02-13 13:05:43.080 SEVERE: [92]
org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.checkIfDisposed().148
Not doing expireConference - bridge not initialize
-----------------------------------------------------------------------

Any idea what might be the cause of this problem? After restarting
Jicofo and Jitsi, it was solved.

Thanks in advance.

Kind regards,
Daniel


#2

Hi again.

I would appreciate if you have any clue about what may be the cause of this.

Thanks in advance.

Kind regards,
Daniel

···

On 13/02/17 15:36, Daniel Bareiro wrote:

Earlier I tried to start a conference with other people and I got the
message "Unfortunately, something went wrong. We're trying to fix this".
I noticed this message on another occasion when the "too many open
files" problem occurred, but I was checking the JVB logs and I do not
see traces of "too many open files".

I found this in the Jicofo's log:

-----------------------------------------------------------------------
Jcofo 2017-02-13 13:05:43.071 SEVERE: [92]
org.jitsi.jicofo.ChannelAllocator.log() Failed to allocate channels for
inmobiliariaortega@conference.conf.opcion-libre.com.ar/4ce8717c
net.java.sip.communicator.service.protocol.OperationFailedException:
Failed to allocate channels - no bridge configured
        at
org.jitsi.jicofo.ChannelAllocator.allocateChannels(ChannelAllocator.java:372)
        at
org.jitsi.jicofo.ChannelAllocator.createOffer(ChannelAllocator.java:307)
        at
org.jitsi.jicofo.ChannelAllocator.discoverFeaturesAndInvite(ChannelAllocator.java:166)
        at org.jitsi.jicofo.ChannelAllocator.run(ChannelAllocator.java:135)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)
Jicofo 2017-02-13 13:05:43.080 SEVERE: [92]
org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.checkIfDisposed().148
Not doing expireConference - bridge not initialize
-----------------------------------------------------------------------

Any idea what might be the cause of this problem? After restarting
Jicofo and Jitsi, it was solved.