[jitsi-dev] jain-sip upgrade to the latest version.


#1

Hi All,

   I have downloaded the newest version of jain-sip-ri.jar from jsip.java.net,

and upgraded the jain-sip-ri.jar in lib/installer-exclude of jitsi.
result in registration problem.

So I have a close look to the jar,the original is jain-sip-ri-1.2.159.jar
which is built on 2010,
and the newer from java.net is jain-sip-ri-1.2.2341.jar,
  So my question: is there any plan to upgrade this dependency?

    Best Regards,

frank.zheng


#2

Hi All,

   I have downloaded the newest version of jain-sip-ri.jar from
jsip.java.net,

and upgraded the jain-sip-ri.jar in lib/installer-exclude of jitsi. result
in registration problem.

So I have a close look to the jar,the original is jain-sip-ri-1.2.159.jar
which is built on 2010,
and the newer from java.net is jain-sip-ri-1.2.2341.jar,
  So my question: is there any plan to upgrade this dependency?

No, not for the time being (although I did think we had a later
version). We don't have any outstanding issues with jsip so there's no
need to upgrade it.

Emil

···

On Mon, Sep 29, 2014 at 9:12 AM, Zheng Frank <zhengyumingapple@gmail.com> wrote:

    Best Regards,

frank.zheng

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org


#3

Hi Emil,
  After review the change logs from rev.159 to 2341,There are a lot of bugs
fixed and Nio feature added.
Maybe upgrade is reasonable nowadays or in the future,
  Anyway,I will dig into jitsi for a while and thanks for your great work.

Best Regards,

frank.zheng

···

2014-09-29 15:25 GMT+08:00 Emil Ivov <emcho@jitsi.org>:

On Mon, Sep 29, 2014 at 9:12 AM, Zheng Frank <zhengyumingapple@gmail.com> > wrote:
> Hi All,
>
> I have downloaded the newest version of jain-sip-ri.jar from
> jsip.java.net,
>
> and upgraded the jain-sip-ri.jar in lib/installer-exclude of jitsi.
result
> in registration problem.
>
> So I have a close look to the jar,the original is jain-sip-ri-1.2.159.jar
> which is built on 2010,
> and the newer from java.net is jain-sip-ri-1.2.2341.jar,
> So my question: is there any plan to upgrade this dependency?

No, not for the time being (although I did think we had a later
version). We don't have any outstanding issues with jsip so there's no
need to upgrade it.

Emil

> Best Regards,
>
> frank.zheng
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev