[jitsi-dev] Jabber login problem


#1

The website identifies this as the place to report problems. I couldn't find this one in the bug tracking system.

I've set up a Jabber account with the following settings:

XMPP username: khagler@orange-road.com
Password: <the correct password>

All other settings are left at the default. When I click on "next" and then "sign in," I get a password prompt. If I re-enter the password, I then get another password prompt that now says "Authentication failed for khagler@orange-road.com (Jabber). The password you entered is not valid."

The username and password definitely are valid. I can connect to this account from the same machine with the same settings in Adium. I can connect to other Jabber accounts (Gmail and Jabber.org) from this machine in Jitsi. It's just the one account that has a problem.

The account I can't connect to is on a Mac Mini Server which I control, running Mac OS X Server 10.7.5 (build 11G63). The service log shows the following lines when I attempt to sign in from Jitsi:

Oct 25 22:47:15 frontier jabberd/c2s[168]: [11] [::ffff:192.168.11.1, port=54590] connect
Oct 25 22:47:16 frontier jabberd/c2s[168]: ODKVerifyClientRequestFixed: Unable to authenticate: Credentials could not be verified, username or password is invalid.
Oct 25 22:47:16 frontier jabberd/c2s[168]: Authentication failed, mech: DIGEST-MD5 client IP: ::ffff:192.168.11.1 client port: 54590 username: ?
Oct 25 22:47:16 frontier jabberd/c2s[168]: [11] packet sent before session start, closing stream
Oct 25 22:47:16 frontier jabberd/c2s[168]: [11] [::ffff:192.168.11.1, port=54590] disconnect jid=unbound, packets: 1
Oct 25 22:47:16 frontier jabberd/c2s[168]: [11] [::ffff:192.168.11.1, port=54591] connect

The Jitsi version is 1.1.4299.10025, and the computer I'm running it on has Mac OS X 10.8.2.

···

--
                              Ken Hagler

                  http://www.orange-road.com/ |
  And tho' we are not now that strength which in old days |
  Moved earth and heaven, that which we are, we are --Tennyson |


#2

Hey Ken,

This is probably not going to be helpful but I am not sure what could be
causing this.

One thing though. Do addresses always appear in your logs in that 6to4
format?

Emil

···

On 26.10.12, 14:04, Ken Hagler wrote:

The website identifies this as the place to report problems. I couldn't find this one in the bug tracking system.

I've set up a Jabber account with the following settings:

XMPP username: khagler@orange-road.com
Password: <the correct password>

All other settings are left at the default. When I click on "next" and then "sign in," I get a password prompt. If I re-enter the password, I then get another password prompt that now says "Authentication failed for khagler@orange-road.com (Jabber). The password you entered is not valid."

The username and password definitely are valid. I can connect to this account from the same machine with the same settings in Adium. I can connect to other Jabber accounts (Gmail and Jabber.org) from this machine in Jitsi. It's just the one account that has a problem.

The account I can't connect to is on a Mac Mini Server which I control, running Mac OS X Server 10.7.5 (build 11G63). The service log shows the following lines when I attempt to sign in from Jitsi:

Oct 25 22:47:15 frontier jabberd/c2s[168]: [11] [::ffff:192.168.11.1, port=54590] connect
Oct 25 22:47:16 frontier jabberd/c2s[168]: ODKVerifyClientRequestFixed: Unable to authenticate: Credentials could not be verified, username or password is invalid.
Oct 25 22:47:16 frontier jabberd/c2s[168]: Authentication failed, mech: DIGEST-MD5 client IP: ::ffff:192.168.11.1 client port: 54590 username: ?
Oct 25 22:47:16 frontier jabberd/c2s[168]: [11] packet sent before session start, closing stream
Oct 25 22:47:16 frontier jabberd/c2s[168]: [11] [::ffff:192.168.11.1, port=54590] disconnect jid=unbound, packets: 1
Oct 25 22:47:16 frontier jabberd/c2s[168]: [11] [::ffff:192.168.11.1, port=54591] connect

The Jitsi version is 1.1.4299.10025, and the computer I'm running it on has Mac OS X 10.8.2.

--
https://jitsi.org


#3

Yes, I just checked the log when connecting via Adium (which worked) and saw the same thing.

···

On Nov 7, 2012, at 2:07 PM, Emil Ivov <emcho@jitsi.org> wrote:

One thing though. Do addresses always appear in your logs in that 6to4
format?

--
                              Ken Hagler

                  http://www.orange-road.com/ |
  And tho' we are not now that strength which in old days |
  Moved earth and heaven, that which we are, we are --Tennyson |