[jitsi-dev] Issues with Jitsi Meet after update from Prosody 0.9.x to Prosody 0.10.x on Debian Jessie


#1

Hi, Jitsi team!

A few days ago I updated Debian Jessie and I found a new version of
Prosody in the standard repositories.

So I decided to install the maintainer version for the configuration
files and then compare the differences between the new configuration
file (/etc/prosody/prosody.cfg.lua) and the old one
(/etc/prosody/prosody.cfg.lua.dpkg-old).

In principle I added the following changes for use of authentication and
Jigasi, which is something I am using in my particular case:

···

-----------------------------------------------------------------------
--authentication = "internal_hashed"
authentication = "internal_plain"

Component "callcontrol.conf.opcion-libre.com.ar"
    component_secret = "topsecret"
-----------------------------------------------------------------------

But after restarting Prosody, there seemed to be some problem of
interconnection between the components of Jitsi Meet. I solved this by
adding this line:

-----------------------------------------------------------------------
Include "conf.d/*.cfg.lua"
-----------------------------------------------------------------------

I think the previous version of Prosody added this "Include" by default
at the end of the configuration file, so I don't know if the absence of
this line in the new configuration file could be considered a bug to report.

Even so, authentication was not working. After entering the name for a
new room, the login screen was not displayed to enter username /
password so I was not able to create the rooms. And the video was not
shown either, but maybe that was a consequence of not having authenticated.

I was able to resolve this with the following change:

-----------------------------------------------------------------------
-- c2s_require_encryption = true
c2s_require_encryption = false
-----------------------------------------------------------------------

This makes sense? Ah, it should be noted that I did not find any errors
in the Chromium console or the Jicofo/Prosody logs.

Comments are welcome.

Thanks in advance.

Kind regards,
Daniel


#2

Hi,

For new installations the missing of conf.d case is handled:
https://github.com/jitsi/jitsi-meet/blob/8da0d3a1f1d68d1718fcb395bc0340c2a7eba39c/debian/jitsi-meet-prosody.postinst#L100

But this is not the case for upgrades, we should change that. Thanks
for the heads up.

For the other thing about 'c2s_require_encryption = false', we have it
in our template, can you check do you have it in your config that is
under conf.d and it is just not taken into account when that option is
set in general config?
https://github.com/jitsi/jitsi-meet/blob/9fb49cb59b45b4e2ee85a7ccaa2a392719ad3f55/doc/debian/jitsi-meet-prosody/prosody.cfg.lua-jvb.example#L26

Thanks
damencho

···

On Wed, Oct 4, 2017 at 9:47 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Jitsi team!

A few days ago I updated Debian Jessie and I found a new version of
Prosody in the standard repositories.

So I decided to install the maintainer version for the configuration
files and then compare the differences between the new configuration
file (/etc/prosody/prosody.cfg.lua) and the old one
(/etc/prosody/prosody.cfg.lua.dpkg-old).

In principle I added the following changes for use of authentication and
Jigasi, which is something I am using in my particular case:

-----------------------------------------------------------------------
--authentication = "internal_hashed"
authentication = "internal_plain"

Component "callcontrol.conf.opcion-libre.com.ar"
    component_secret = "topsecret"
-----------------------------------------------------------------------

But after restarting Prosody, there seemed to be some problem of
interconnection between the components of Jitsi Meet. I solved this by
adding this line:

-----------------------------------------------------------------------
Include "conf.d/*.cfg.lua"
-----------------------------------------------------------------------

I think the previous version of Prosody added this "Include" by default
at the end of the configuration file, so I don't know if the absence of
this line in the new configuration file could be considered a bug to report.

Even so, authentication was not working. After entering the name for a
new room, the login screen was not displayed to enter username /
password so I was not able to create the rooms. And the video was not
shown either, but maybe that was a consequence of not having authenticated.

I was able to resolve this with the following change:

-----------------------------------------------------------------------
-- c2s_require_encryption = true
c2s_require_encryption = false
-----------------------------------------------------------------------

This makes sense? Ah, it should be noted that I did not find any errors
in the Chromium console or the Jicofo/Prosody logs.

Comments are welcome.

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

Hi, Damian.

For new installations the missing of conf.d case is handled:
https://github.com/jitsi/jitsi-meet/blob/8da0d3a1f1d68d1718fcb395bc0340c2a7eba39c/debian/jitsi-meet-prosody.postinst#L100

But this is not the case for upgrades, we should change that. Thanks
for the heads up.

Ah, then it is likely that the Prosody 0.9.x configuration file didn't
have this line either and it was then added when installing the
jitsi-meet-prosody package.

Let me know if you wish me to open a Github issue for this.

For the other thing about 'c2s_require_encryption = false', we have it
in our template, can you check do you have it in your config that is
under conf.d and it is just not taken into account when that option is
set in general config?
https://github.com/jitsi/jitsi-meet/blob/9fb49cb59b45b4e2ee85a7ccaa2a392719ad3f55/doc/debian/jitsi-meet-prosody/prosody.cfg.lua-jvb.example#L26

It seems that I don't have that line:

···

On 04/10/17 11:57, Damian Minkov wrote:

------------------------------------------------------------------------
root@conference:/etc/prosody/conf.d# grep c2s_require_encryption
conf.opcion-libre.com.ar.cfg.lua
------------------------------------------------------------------------

But perhaps the cause of this is that I have modified the file to add
authentication, and that line has been introduced by the installer after
the time I manually modified the configuration file.

I could try adding the line in the file under conf.d and reverse the
change in /etc/prosody.cfg.lua for that line, to see if this file
override what we have in conf.d.

Thanks for your reply.

Kind regards,
Daniel


#4

Hi, Damian.

For the other thing about 'c2s_require_encryption = false', we have it
in our template, can you check do you have it in your config that is
under conf.d and it is just not taken into account when that option is
set in general config?
https://github.com/jitsi/jitsi-meet/blob/9fb49cb59b45b4e2ee85a7ccaa2a392719ad3f55/doc/debian/jitsi-meet-prosody/prosody.cfg.lua-jvb.example#L26

It seems that I don't have that line:

------------------------------------------------------------------------
root@conference:/etc/prosody/conf.d# grep c2s_require_encryption
conf.opcion-libre.com.ar.cfg.lua
------------------------------------------------------------------------

But perhaps the cause of this is that I have modified the file to add
authentication, and that line has been introduced by the installer after
the time I manually modified the configuration file.

I could try adding the line in the file under conf.d and reverse the
change in /etc/prosody.cfg.lua for that line, to see if this file
override what we have in conf.d.

I have tested with "c2s_require_encryption = true" in the
/etc/prosody/prosody.cfg.lua and using "c2s_require_encryption = false"
in the configuration file under conf.d, but on this way Jitsi Meet is
not working. Maybe the configuration in prosody.cfg.lua is overriding
the configuration in conf.d. Can you replicate it?

Kind regards,
Daniel

···

On 04/10/17 13:47, Daniel Bareiro wrote: