[jitsi-dev] Issue with jitsi-meet


#1

Hi,

while i'm trying to install jitsi-meet im getting following error can you
please resolve this issue

apt-get -y install jitsi-meet
Reading package lists... Done
Building dependency tree
Reading state information... Done
jitsi-meet is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up jitsi-meet-prosody (1.0.1063-1) ...
Generating a 4096 bit RSA private key
...................................................................................................................................................................................................................................++
........................................................................++
writing new private key to '/var/lib/prosody/Laurel.key'

···

-----
Setting up jitsi-meet (1.0.1063-1) ...
invoke-rc.d: unknown initscript, /etc/init.d/nginx not found.
dpkg: error processing package jitsi-meet (--configure):
subprocess installed post-installation script returned error exit status
100
Errors were encountered while processing:
jitsi-meet
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Laurel:/home/rdkc/rdk-c/Jitsi_Local_Server_Setup# apt-get install nginx
Reading package lists... Done
Building dependency tree
Reading state information... Done
nginx is already the newest version.
nginx set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up jitsi-meet (1.0.1063-1) ...
invoke-rc.d: unknown initscript, /etc/init.d/nginx not found.
dpkg: error processing package jitsi-meet (--configure):
subprocess installed post-installation script returned error exit status
100
Errors were encountered while processing:
jitsi-meet
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks & Regards,
Krunal Soni


#2

# apt-get -y install jitsi-meet

...

jitsi-meet is already the newest version.

...

invoke-rc.d: unknown initscript, /etc/init.d/nginx not found.

# apt-get install nginx

...

nginx is already the newest version.

...

Setting up jitsi-meet (1.0.1063-1) ...
invoke-rc.d: unknown initscript, /etc/init.d/nginx not found.

This looks like an nginx installation problem, not a Jitsi-meet problem - I
suggest you reinstall (or purge and then install). If nginx is correctly
installed on a Debian machine then there should be an /etc/init.d/nginx
script.

Antony.

···

On Thursday 23 June 2016 at 19:13:56, soni krunal wrote:

--
I conclude that there are two ways of constructing a software design: One way
is to make it so simple that there are _obviously_ no deficiencies, and the
other way is to make it so complicated that there are no _obvious_
deficiencies.

- C A R Hoare

                                                   Please reply to the list;
                                                         please *don't* CC me.