[jitsi-dev] Issue when installing jitsi-meet : jicofo : Dépend: libc6-i386 (>= 2.1.3) qui est un paquet virtuel


#1

Hi,

I got an issue when trying to install jitsi-meet on a debian 64 bits.
The machine is a virtual machine running on vmware.

Please find below the logs.

In advance thanks for your support.

Hervé.

···

----------------------------------------------------------------------------------------------------------------------------------
root@debian:~# aptitude update
Atteint http://ftp.fr.debian.org wheezy Release.gpg
Atteint http://download.jitsi.org unstable/ Release.gpg
Prendre : 1 http://security.debian.org wheezy/updates Release.gpg [836 B]
Prendre : 2 http://ftp.fr.debian.org wheezy-updates Release.gpg [836 B]
Atteint http://download.jitsi.org unstable/ Release
Prendre : 3 http://security.debian.org wheezy/updates Release [102 kB]
Atteint http://download.jitsi.org unstable/ Packages
Prendre : 4 http://security.debian.org wheezy/updates/main Sources [144 kB]
Atteint http://ftp.fr.debian.org wheezy Release
Prendre : 5 http://ftp.fr.debian.org wheezy-updates Release [124 kB]
Prendre : 6 http://security.debian.org wheezy/updates/main i386 Packages
[230 kB]
Ignoré http://download.jitsi.org unstable/ Translation-fr_FR
Ignoré http://download.jitsi.org unstable/ Translation-fr
Ignoré http://download.jitsi.org unstable/ Translation-en
Atteint http://ftp.fr.debian.org wheezy/main Sources
Atteint http://ftp.fr.debian.org wheezy/main i386 Packages
Atteint http://ftp.fr.debian.org wheezy/main Translation-fr
Atteint http://ftp.fr.debian.org wheezy/main Translation-en
Prendre : 7 http://ftp.fr.debian.org wheezy-updates/main Sources [1 805 B]
Atteint http://ftp.fr.debian.org wheezy-updates/main i386 Packages/DiffIndex
Atteint http://ftp.fr.debian.org wheezy-updates/main
Translation-en/DiffIndex
Prendre : 8 http://security.debian.org wheezy/updates/main Translation-en
[129 kB]
733 ko téléchargés en 8s (82,0 ko/s)

root@debian:~# dpkg -L | grep libc6
dpkg-query : erreur : --listfiles a besoin d'au moins un nom de paquet
comme paramètre

Utiliser --help pour de l'aide sur la recherche de paquets.
root@debian:~# dpkg -l | grep libc6
ii libc6:i386 2.13-38+deb7u6 i386
        Embedded GNU C Library: Shared libraries
ii libc6-amd64 2.13-38+deb7u6 i386
        Embedded GNU C Library: 64bit Shared libraries for AMD64
ii libc6-i686:i386 2.13-38+deb7u6 i386
        Embedded GNU C Library: Shared libraries [i686 optimized]
root@debian:~# aptitude install jitsi-meet
Les NOUVEAUX paquets suivants vont être installés :
  ca-certificates-java{a} dbus{a} default-jre-headless{a}
icedtea-6-jre-cacao{a} icedtea-6-jre-jamvm{a} java-common{a}
javascript-common{a} jicofo{ab} jitsi-meet
  jitsi-meet-prosody{a} jitsi-videobridge{a} libavahi-client3{a}
libavahi-common-data{a} libavahi-common3{a} libcups2{a} libdbus-1-3{a}
libgd2-noxpm{a} libjpeg8{a}
  libjs-jquery{a} libjs-jquery-ui{a} libjs-strophe{a} liblcms2-2{a}
liblua5.1-0{a} libnspr4{a} libnss3{a} libpcsclite1{a} libpng12-0{a}
libsystemd-login0{a}
  libxslt1.1{a} lua-event{a} lua-expat{a} lua-filesystem{a} lua-sec{a}
lua-socket{a} lua5.1{a} nginx{a} nginx-common{a} nginx-full{a}
openjdk-6-jre-headless{a}
  openjdk-6-jre-lib{a} prosody{a} ssl-cert{a} tzdata-java{a}
wwwconfig-common{a}
0 paquets mis à jour, 44 nouvellement installés, 0 à enlever et 0 non mis à
jour.
Il est nécessaire de télécharger 70,1 Mo d'archives. Après dépaquetage, 133
Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
jicofo : Dépend: libc6-i386 (>= 2.1.3) qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1) jicofo [Non installé]
2) jitsi-meet [Non installé]
3) jitsi-meet-prosody [Non installé]

Accepter cette solution ? [Y/n/q/?] y
Les NOUVEAUX paquets suivants vont être installés :
  libpcsclite1{a} libpng12-0{a}
0 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à
jour.
Il est nécessaire de télécharger 250 ko d'archives. Après dépaquetage, 429
ko se
Voulez-vous continuer ? [Y/n/?] y
Prendre : 1 http://ftp.fr.debian.org/debian/ wheezy/main libpcsclite1 i386
1.8.
Prendre : 2 http://ftp.fr.debian.org/debian/ wheezy/main libpng12-0 i386
1.2.49
250 ko téléchargés en 3s (67,6 ko/s)
Sélection du paquet libpcsclite1:i386 précédemment désélectionné.
(Lecture de la base de données... 28312 fichiers et répertoires déjà
installés.)
Dépaquetage de libpcsclite1:i386 (à partir de
.../libpcsclite1_1.8.4-1+deb7u1_i3
Sélection du paquet libpng12-0:i386 précédemment désélectionné.
Dépaquetage de libpng12-0:i386 (à partir de
.../libpng12-0_1.2.49-1_i386.deb) ..
Paramétrage de libpcsclite1:i386 (1.8.4-1+deb7u1) ...
Paramétrage de libpng12-0:i386 (1.2.49-1) ...
---------------------------------------------------------------------------------------------------------------------------------------------


#2

I got an issue when trying to install jitsi-meet on a debian 64 bits.

Hi, sorry for the late reply, you are saying that it is 64bit but from the
output I'd guess that you have a multiarch with a default architecture
i386...?

root@debian:~# dpkg -l | grep libc6

ii libc6:i386 2.13-38+deb7u6
i386 Embedded GNU C Library: Shared libraries
ii libc6-amd64 2.13-38+deb7u6
i386 Embedded GNU C Library: 64bit Shared libraries for AMD64
ii libc6-i686:i386 2.13-38+deb7u6
i386 Embedded GNU C Library: Shared libraries [i686 optimized]

You can check with:
dpkg --print-architecture
dpkg --print-foreign-architectures

The first one would be the default arch.

jicofo : Dépend: libc6-i386 (>= 2.1.3) qui est un paquet virtuel

We'll check the issue with the i386 package for jicofo.

P.S.: Please use the standard C locale (or at least some English locale)
when reporting console output.
Thanks and happy new year :slight_smile:

···

2014-12-21 0:04 GMT+02:00 Hervé Rosse <herve.rosse@gmail.com>:

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#3

Hi,

Just to tell you that my issue is resolved.
Maybe it is a specific issue with jitsi-meet easy installer and Debian
wheezy.
I tried it on latest ubuntu server and everythink was ok.

Regards,

···

---------- Message transféré ----------
De : Hervé Rosse <herve.rosse@gmail.com>
Date : 20 décembre 2014 22:04
Objet : Issue when installing jitsi-meet : jicofo : Dépend: libc6-i386 (>=
2.1.3) qui est un paquet virtuel
À : dev@jitsi.org

Hi,

I got an issue when trying to install jitsi-meet on a debian 64 bits.
The machine is a virtual machine running on vmware.

Please find below the logs.

In advance thanks for your support.

Hervé.

----------------------------------------------------------------------------------------------------------------------------------
root@debian:~# aptitude update
Atteint http://ftp.fr.debian.org wheezy Release.gpg
Atteint http://download.jitsi.org unstable/ Release.gpg
Prendre : 1 http://security.debian.org wheezy/updates Release.gpg [836 B]
Prendre : 2 http://ftp.fr.debian.org wheezy-updates Release.gpg [836 B]
Atteint http://download.jitsi.org unstable/ Release
Prendre : 3 http://security.debian.org wheezy/updates Release [102 kB]
Atteint http://download.jitsi.org unstable/ Packages
Prendre : 4 http://security.debian.org wheezy/updates/main Sources [144 kB]
Atteint http://ftp.fr.debian.org wheezy Release
Prendre : 5 http://ftp.fr.debian.org wheezy-updates Release [124 kB]
Prendre : 6 http://security.debian.org wheezy/updates/main i386 Packages
[230 kB]
Ignoré http://download.jitsi.org unstable/ Translation-fr_FR
Ignoré http://download.jitsi.org unstable/ Translation-fr
Ignoré http://download.jitsi.org unstable/ Translation-en
Atteint http://ftp.fr.debian.org wheezy/main Sources
Atteint http://ftp.fr.debian.org wheezy/main i386 Packages
Atteint http://ftp.fr.debian.org wheezy/main Translation-fr
Atteint http://ftp.fr.debian.org wheezy/main Translation-en
Prendre : 7 http://ftp.fr.debian.org wheezy-updates/main Sources [1 805 B]
Atteint http://ftp.fr.debian.org wheezy-updates/main i386 Packages/DiffIndex
Atteint http://ftp.fr.debian.org wheezy-updates/main
Translation-en/DiffIndex
Prendre : 8 http://security.debian.org wheezy/updates/main Translation-en
[129 kB]
733 ko téléchargés en 8s (82,0 ko/s)

root@debian:~# dpkg -L | grep libc6
dpkg-query : erreur : --listfiles a besoin d'au moins un nom de paquet
comme paramètre

Utiliser --help pour de l'aide sur la recherche de paquets.
root@debian:~# dpkg -l | grep libc6
ii libc6:i386 2.13-38+deb7u6 i386
        Embedded GNU C Library: Shared libraries
ii libc6-amd64 2.13-38+deb7u6 i386
        Embedded GNU C Library: 64bit Shared libraries for AMD64
ii libc6-i686:i386 2.13-38+deb7u6 i386
        Embedded GNU C Library: Shared libraries [i686 optimized]
root@debian:~# aptitude install jitsi-meet
Les NOUVEAUX paquets suivants vont être installés :
  ca-certificates-java{a} dbus{a} default-jre-headless{a}
icedtea-6-jre-cacao{a} icedtea-6-jre-jamvm{a} java-common{a}
javascript-common{a} jicofo{ab} jitsi-meet
  jitsi-meet-prosody{a} jitsi-videobridge{a} libavahi-client3{a}
libavahi-common-data{a} libavahi-common3{a} libcups2{a} libdbus-1-3{a}
libgd2-noxpm{a} libjpeg8{a}
  libjs-jquery{a} libjs-jquery-ui{a} libjs-strophe{a} liblcms2-2{a}
liblua5.1-0{a} libnspr4{a} libnss3{a} libpcsclite1{a} libpng12-0{a}
libsystemd-login0{a}
  libxslt1.1{a} lua-event{a} lua-expat{a} lua-filesystem{a} lua-sec{a}
lua-socket{a} lua5.1{a} nginx{a} nginx-common{a} nginx-full{a}
openjdk-6-jre-headless{a}
  openjdk-6-jre-lib{a} prosody{a} ssl-cert{a} tzdata-java{a}
wwwconfig-common{a}
0 paquets mis à jour, 44 nouvellement installés, 0 à enlever et 0 non mis à
jour.
Il est nécessaire de télécharger 70,1 Mo d'archives. Après dépaquetage, 133
Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
jicofo : Dépend: libc6-i386 (>= 2.1.3) qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1) jicofo [Non installé]
2) jitsi-meet [Non installé]
3) jitsi-meet-prosody [Non installé]

Accepter cette solution ? [Y/n/q/?] y
Les NOUVEAUX paquets suivants vont être installés :
  libpcsclite1{a} libpng12-0{a}
0 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à
jour.
Il est nécessaire de télécharger 250 ko d'archives. Après dépaquetage, 429
ko se
Voulez-vous continuer ? [Y/n/?] y
Prendre : 1 http://ftp.fr.debian.org/debian/ wheezy/main libpcsclite1 i386
1.8.
Prendre : 2 http://ftp.fr.debian.org/debian/ wheezy/main libpng12-0 i386
1.2.49
250 ko téléchargés en 3s (67,6 ko/s)
Sélection du paquet libpcsclite1:i386 précédemment désélectionné.
(Lecture de la base de données... 28312 fichiers et répertoires déjà
installés.)
Dépaquetage de libpcsclite1:i386 (à partir de
.../libpcsclite1_1.8.4-1+deb7u1_i3
Sélection du paquet libpng12-0:i386 précédemment désélectionné.
Dépaquetage de libpng12-0:i386 (à partir de
.../libpng12-0_1.2.49-1_i386.deb) ..
Paramétrage de libpcsclite1:i386 (1.8.4-1+deb7u1) ...
Paramétrage de libpng12-0:i386 (1.2.49-1) ...
---------------------------------------------------------------------------------------------------------------------------------------------