[jitsi-dev] Issue Report: jitsi does not rely on hosts on Windows


#1

Hi!

2 days ago I installed openfire server on one box in my lan, I started to
use jitsi as client.
To avoid situation when Internet connection is down, and dns lookup is
unavailable, i added record to hosts file, like

192.168.1.110 myjabber.homeip.net

But when Internet is down, jitsi did not connect to server, when I tried to
connect with user admin@myjabber.homeip.net. The only valid workaround is
use IP, and connect as admin@192.168.1.100, but this is odd and ugly.

Andriy


#2

Hey

This is a known issue with the DNS library we use (dnsjava) and we cannot change it. The author of dnsjava would accept a contribution to include that though.

Regards,
Ingo

···

-----Original Message-----
From: Андрій Жук [mailto:zhouck@gmail.com]
Sent: Dienstag, 19. März 2013 14:59
To: dev@jitsi.java.net
Subject: [jitsi-dev] Issue Report: jitsi does not rely on hosts on Windows
Hi!

2 days ago I installed openfire server on one box in my lan, I started to use
jitsi as client.

To avoid situation when Internet connection is down, and dns lookup is
unavailable, i added record to hosts file, like

192.168.1.110 myjabber.homeip.net

But when Internet is down, jitsi did not connect to server, when I tried to
connect with user admin@myjabber.homeip.net. The only valid workaround is use
IP, and connect as admin@192.168.1.100, but this is odd and ugly.

Andriy


#3

Hi,

did you try editing the xmpp account and check the option "Override
server default options" and there specify the address you want?

Regards
damencho

···

On Tue, Mar 19, 2013 at 3:58 PM, Андрій Жук <zhouck@gmail.com> wrote:

Hi!

2 days ago I installed openfire server on one box in my lan, I started to
use jitsi as client.
To avoid situation when Internet connection is down, and dns lookup is
unavailable, i added record to hosts file, like

192.168.1.110 myjabber.homeip.net

But when Internet is down, jitsi did not connect to server, when I tried to
connect with user admin@myjabber.homeip.net. The only valid workaround is
use IP, and connect as admin@192.168.1.100, but this is odd and ugly.

Andriy

.