[jitsi-dev] Invite Error: Your Conference is Currently being Created


#1

Dear Fellow Jitsi Developers,

As we did not receive any solution to the following issue that we posted a month ago, we did a few additional tests and are posting it again with additional information. Perhaps someone could assist us with this additional information.

We installed Jitsi Meet and can access it from both WAN and LAN by typing server_name (http://<our.internal.domain.name <http://%3cour.internal.domain.name>> or http://<Our.FullyQualified.domain.name <http://%3cOur.FullyQualified.domain.name>>). Our external domain name (<Our.FullyQualified.domain.name>) is mapped to <our.internal.domain.name> through a local DNS server and port 80 at the WAN gateway. When we invite others, it gives the error:

Your conference is currently being created...

(1)JavaScript log from Chrome gives cross-domain request error (No 'Access-Control-Allow-Origin' header is present on the requested resource), despite adding this header in nginx.conf.

(2)URL http://<our.internal.domain.com>:5280/http-bind <http://%3cour.internal.domain.com%3e:5280/http-bind>' gives 404 error

To overcome this �cross-domain request� error, stackoverflow gives an example for PHP programs �<?php header('Access-Control-Allow-Origin: *'); ?>� Do we need to add similar code to Jitsi-Meet application to overcome the �cross-domain request� error? If so, which file?

We would appreciate any assistance to get around this error. Here are various logs (prosody) and config settings (prosody.cfg.lua, nginx.conf, config.js). Thank you.

···

-----------------

Javascript log from Chrome: Pawel Domas suggestion (https://github.com/jitsi/jitsi-meet/issues/300) ctrl+shift+j gave �no access control allow origin� (cross domain request) error. So, we added a location directive to nginx.conf (http://stackoverflow.com/questions/21436835/setting-access-control-allow-origin-on-cloudfront-cached-object).

�This appears to be Chrome

Strophe status changed to CONNECTING null

Failed to load resource: the server responded with a status of 404 (Not Found)

XMLHttpRequest cannot load http://<our.internal.domain.name>:5280/http-bind <http://%3cour.internal.domain.name%3e:5280/http-bind>.

*No 'Access-Control-Allow-Origin' header is present on the requested resource.* Origin 'http://<our.FullyQualified.domain.name>:80' is therefore not allowed access. The response had HTTP status code 404.

Strophe: request id 1.1 error 0 happened

Strophe: request errored, status: 0, number of errors: NaN

Config.js: bosh: '//<our.internal.domain.com>:5280/http-bind'

Prosody Log: Jitsi is starting properly. Both components Jitsi-videobridge and focus are authenticated successfully.

PROSODY.CFG.LUA global settings: component_ports { 5347 }

NGINX.conf settings:

   server {

listen 80;

server_name <our.internal.domain.com>;

# set the root

root /usr/local/jitsi.<our.internal.domain.com>;

index index.html;

location ~ ^/([a-zA-Z0-9=\?]+)$ {

rewrite ^/(.*)$ / break;

}

location / {

ssi on;

}

location ~* ^.*?\.(eot)|(ttf)|(woff)$ {

add_header Access-Control-Allow-Origin *;

      }

# BOSH

location /http-bind {

proxy_pass http://localhost:5280/http-bind;

proxy_set_header X-Forwarded-For $remote_addr;

proxy_set_header Host $http_host;

}

Thank you.

Sincerely,

Susheel Jalali

Coscend Communications Solutions
_Susheel.Jalali@CoscendCommunications.com_

Web site:www.CoscendCommunications.com <http://www.coscendcommunications.com/>

------------------------------------------------------------------

CONFIDENTIALITY NOTICE: See 'Confidentiality Notice Regarding E-mail Messages from Coscend Communications Solutions' posted at: http://www.CoscendCommunications.com/Terms_and_Conditions.html <http://www.coscendcommunications.com/Terms_and_Conditions.html>


#2

Hi Susheel,

Have you enabled BOSH in Prosody? http://<our.internal.domain.com>:5280/http-bind’ shouldn’t give a 404.

Best,
George

···

On Jul 17, 2015, at 6:21 AM, Susheel Jalali <Susheel.Jalali@CoscendCommunications.com> wrote:

Dear Fellow Jitsi Developers,
As we did not receive any solution to the following issue that we posted a month ago, we did a few additional tests and are posting it again with additional information. Perhaps someone could assist us with this additional information.

We installed Jitsi Meet and can access it from both WAN and LAN by typing server_name (http://<our.internal.domain.name> or http://<Our.FullyQualified.domain.name>). Our external domain name (<Our.FullyQualified.domain.name>) is mapped to <our.internal.domain.name> through a local DNS server and port 80 at the WAN gateway. When we invite others, it gives the error:

Your conference is currently being created...

(1) JavaScript log from Chrome gives cross-domain request error (No 'Access-Control-Allow-Origin' header is present on the requested resource), despite adding this header in nginx.conf.

(2) URL http://<our.internal.domain.com>:5280/http-bind' gives 404 error

To overcome this ‘cross-domain request’ error, stackoverflow gives an example for PHP programs “<?php header('Access-Control-Allow-Origin: *'); ?>” Do we need to add similar code to Jitsi-Meet application to overcome the ‘cross-domain request’ error? If so, which file?

We would appreciate any assistance to get around this error. Here are various logs (prosody) and config settings (prosody.cfg.lua, nginx.conf, config.js). Thank you.

-----------------

Javascript log from Chrome: Pawel Domas suggestion (https://github.com/jitsi/jitsi-meet/issues/300) ctrl+shift+j gave “no access control allow origin” (cross domain request) error. So, we added a location directive to nginx.conf (http://stackoverflow.com/questions/21436835/setting-access-control-allow-origin-on-cloudfront-cached-object).

…This appears to be Chrome

Strophe status changed to CONNECTING null

Failed to load resource: the server responded with a status of 404 (Not Found)

XMLHttpRequest cannot load http://<our.internal.domain.name>:5280/http-bind.

*No 'Access-Control-Allow-Origin' header is present on the requested resource.* Origin 'http://<our.FullyQualified.domain.name>:80' is therefore not allowed access. The response had HTTP status code 404.

Strophe: request id 1.1 error 0 happened

Strophe: request errored, status: 0, number of errors: NaN

Config.js: bosh: '//<our.internal.domain.com>:5280/http-bind'

Prosody Log: Jitsi is starting properly. Both components Jitsi-videobridge and focus are authenticated successfully.

PROSODY.CFG.LUA global settings: component_ports { 5347 }

NGINX.conf settings:

  server {

     listen 80;

     server_name <our.internal.domain.com>;

     # set the root

     root /usr/local/jitsi.<our.internal.domain.com>;

     index index.html;

     location ~ ^/([a-zA-Z0-9=\?]+)$ {

         rewrite ^/(.*)$ / break;

     }

     location / {

         ssi on;

     }

     location ~* ^.*?\.(eot)|(ttf)|(woff)$ {

        add_header Access-Control-Allow-Origin *;

     }

     # BOSH

     location /http-bind {

         proxy_pass http://localhost:5280/http-bind;

         proxy_set_header X-Forwarded-For $remote_addr;

         proxy_set_header Host $http_host;

     }

Thank you.

Sincerely,

Susheel Jalali

Coscend Communications Solutions
Susheel.Jalali@CoscendCommunications.com
Web site: www.CoscendCommunications.com
------------------------------------------------------------------
CONFIDENTIALITY NOTICE: See 'Confidentiality Notice Regarding E-mail Messages from Coscend Communications Solutions' posted at: http://www.CoscendCommunications.com/Terms_and_Conditions.html

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev