[jitsi-dev] Invite Error: Your conference is currently, being created...


#1

Dear Damencho,

(1) > bosh: '//jitsi-meet.ourdomain.com:5347/http-bind'

>You should remove the 5347 port from your bosh url in config.js.

We did it.

(2) >if your instance is not running on public ip address, in that case you should also forward udp traffic to that machine port range - 10000:20000.

We allowed these ports in our firewall.

Pawel Domas suggested (https://github.com/jitsi/jitsi-meet/issues/300) to collect JavaScript console logs from Chrome via ctrl+shift+j. It gave “no access control allow origin” (cross domain request) error. So, we added a location directive to nginx.conf (http://stackoverflow.com/questions/21436835/setting-access-control-allow-origin-on-cloudfront-cached-object).

Still we are getting the error: Your conference is currently being created...

Do we need to add any cross-domain request code to Jitsi-Meet application? Any assistance to get around the cross-domain request error would be appreciated.

Javascript log from Chrome:

…This appears to be Chrome

Strophe status changed to CONNECTING null

Failed to load resource: the server responded with a status of 404 (Not Found)

XMLHttpRequest cannot load http://<our <http://%3cour>.internal.domain.name>:5280/http-bind.

*No 'Access-Control-Allow-Origin' header is present on the requested resource.* Origin 'http://<our.FQdomain.name>:5480' is therefore not allowed access. The response had HTTP status code 404.

Strophe: request id 1.1 error 0 happened

Strophe: request errored, status: 0, number of errors: NaN

Added the following to nginx.conf:

location ~* ^.*?\.(eot)|(ttf)|(woff)$ {

        add_header Access-Control-Allow-Origin *;

}

Thank you.

Sincerely,

Susheel Jalali

Customer Operations Leader,

Coscend Communications Solutions

_Susheel.Jalali@CoscendCommunications.com_

Web site:www.CoscendCommunications.com <http://www.coscendcommunications.com/>

···

------------------------------------------------------------------

CONFIDENTIALITY NOTICE: See 'Confidentiality Notice Regarding E-mail Messages from Coscend Communications Solutions' posted at: http://www.CoscendCommunications.com/Terms_and_Conditions.html <http://www.coscendcommunications.com/Terms_and_Conditions.html>

Date: Tue, 23 Jun 2015 13:58:47 +0300
From: Damian Minkov<damencho@jitsi.org>
To: Jitsi Developers<dev@jitsi.org>
Subject: Re: [jitsi-dev] Invite Error: Your conference is currently
  being created...
Message-ID:
  <CAE07f0JUSxJp0KrvBHV4usZJq52hTMBZO-jdeev05qmz3PrFcg@mail.gmail.com>
Content-Type: text/plain; charset=UTF-8

Hi,

On Tue, Jun 23, 2015 at 12:32 PM, Susheel Jalali <Susheel.Jalali@coscendcommunications.com> wrote:

Dear Fellow Jitsi Developers,

We installed Jitsi Meet and can access it, via but are not able to invite
others. When we click on invite others it gives:

Your conference is currently being created...

Based on the following links, we made changes to config.js and
sip-communicator.properties. Still we get the same error message. Could
you please advise how we could fix this?

https://github.com/jitsi/jitsi-meet/issues/105

https://github.com/jitsi/jitsi-meet/issues/300

https://github.com/jitsi/jitsi-meet/issues/280

http://lists.jitsi.org/pipermail/users/2014-August/007753.html

Based on above links, we have the following configurations:

    (1). We added in config.js: bosh: '//jitsi.<our
>.com:5347/http-bind

    (2) In prosody.cfg.lua, we have in global settings:
      component_ports { 5347 }

    (3) We have In nginx.conf:

  server {
     listen 80;
     server_name jitsi.<our domain.com>;
     # set the root
     root /usr/local/jitsi.<ourdomain.com>;
     index index.html;

     location ~ ^/([a-zA-Z0-9=\?]+)$ {
         rewrite ^/(.*)$ / break;
     }
     location / {
         ssi on;
     }
     # BOSH
     location /http-bind {
         proxy_passhttp://localhost:5280/http-bind;
         proxy_set_header X-Forwarded-For $remote_addr;
         proxy_set_header Host $http_host;
     }

---
From Prosody Log it appears that Jitsi is starting properly. Both
components Jitsi-videobridge and focus are authenticated successfully.

We have disabled the linux firewall via "service iptables stop".
We are able to access successfully both ways - by using our internal IP
Address URL, or publicly visible URL.
However we are unable to "invite others". For last 2 weeks we are stuck
here.

Kindly suggest if there is anything else to be done?

     (4) Should we add any port to the 'bosh' entry in config.js? If so,
is this the syntax:

     bosh: '//jitsi-meet.ourdomain.com:5347/http-bind'

You should remove the 5347 port from your bosh url in config.js.

     (5) Should we also add in sip-communicator.properties

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false

     org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=<Our.Local.IP.Address>

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=<Our.Public.IP.Address>

This is needed if your instance is not running on public ip address,
in that case you should also forward udp traffic to that machine port
range - 10000:20000.

Regards
damencho


#2

Hi Susheel,

Dear Damencho,

(1) > bosh: '//jitsi-meet.ourdomain.com:5347/http-bind'

>You should remove the 5347 port from your bosh url in config.js.

We did it.

(2) >if your instance is not running on public ip address, in that case
you should also forward udp traffic to that machine port range -
10000:20000.

We allowed these ports in our firewall.

Pawel Domas suggested (https://github.com/jitsi/jitsi-meet/issues/300)
to collect JavaScript console logs from Chrome via ctrl+shift+j. It
gave “no access control allow origin” (cross domain request) error. So,
we added a location directive to nginx.conf
(http://stackoverflow.com/questions/21436835/setting-access-control-allow-origin-on-cloudfront-cached-object).

Still we are getting the error: Your conference is currently being
created...

Do we need to add any cross-domain request code to Jitsi-Meet
application? Any assistance to get around the cross-domain request
error would be appreciated.

Javascript log from Chrome:

…This appears to be Chrome

Strophe status changed to CONNECTING null

Failed to load resource: the server responded with a status of 404 (Not
Found)

XMLHttpRequest cannot load http://<our
<http://%3cour>.internal.domain.name>:5280/http-bind.

*No 'Access-Control-Allow-Origin' header is present on the requested
resource.* Origin 'http://<our.FQdomain.name>:5480' is therefore not
allowed access. The response had HTTP status code 404.

In order to use the same domain/port pair and not run into HTTP access control issues we use nginx to proxy requests to "/http-bind" to prosody. So you don't need the ":5280" here as it causes the error above. Also, you probably need to "location" directives in the nginx config for both virtual domains.

If you want to access the Jitsi Meet installation using two different domain names, you could try to set the domain set in the config.bosh variable (in config.js) dynamically like this:
bosh: '//'+document.location.hostname+'/http-bind'

Note that I haven't tested this and there might be more issues coming up because of the different domain names.

Regards,
Boris

···

On 24/06/15 03:12, Susheel Jalali wrote: