[jitsi-dev] Invite Error: Your conference is currently being created...


#1

Dear Fellow Jitsi Developers,

We installed Jitsi Meet and can access it, via but are not able to invite others. When we click on invite others it gives:

Your conference is currently being created...

Based on the following links, we made changes to config.js and sip-communicator.properties. Still we get the same error message. Could you please advise how we could fix this?

https://github.com/jitsi/jitsi-meet/issues/105

https://github.com/jitsi/jitsi-meet/issues/300

https://github.com/jitsi/jitsi-meet/issues/280

http://lists.jitsi.org/pipermail/users/2014-August/007753.html

Based on above links, we have the following configurations:

    (1). We added in config.js: bosh: '//jitsi.<our

.com:5347/http-bind

    (2) In prosody.cfg.lua, we have in global settings:
      component_ports { 5347 }

    (3) We have In nginx.conf:

  server {
     listen 80;
     server_name jitsi.<our domain.com>;
     # set the root
     root /usr/local/jitsi.<ourdomain.com>;
     index index.html;

     location ~ ^/([a-zA-Z0-9=\?]+)$ {
         rewrite ^/(.*)$ / break;
     }
     location / {
         ssi on;
     }
     # BOSH
     location /http-bind {
         proxy_pass http://localhost:5280/http-bind;
         proxy_set_header X-Forwarded-For $remote_addr;
         proxy_set_header Host $http_host;
     }

···

---
From Prosody Log it appears that Jitsi is starting properly. Both components Jitsi-videobridge and focus are authenticated successfully.

We have disabled the linux firewall via "service iptables stop".
We are able to access successfully both ways - by using our internal IP Address URL, or publicly visible URL.
However we are unable to "invite others". For last 2 weeks we are stuck here.

Kindly suggest if there is anything else to be done?

     (4) Should we add any port to the 'bosh' entry in config.js? If so, is this the syntax:

     bosh: '//jitsi-meet.ourdomain.com:5347/http-bind'

     (5) Should we also add in sip-communicator.properties

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=<Our.Local.IP.Address>

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=<Our.Public.IP.Address>

Thank you.

--

Sincerely,

Susheel Jalali

Coscend Communications Solutions
_Susheel.Jalali@CoscendCommunications.com_

Web site:www.CoscendCommunications.com <http://www.coscendcommunications.com/>

------------------------------------------------------------------

CONFIDENTIALITY NOTICE: See 'Confidentiality Notice Regarding E-mail Messages from Coscend Communications Solutions' posted at: http://www.CoscendCommunications.com/Terms_and_Conditions.html <http://www.coscendcommunications.com/Terms_and_Conditions.html>


#2

Hi,

Dear Fellow Jitsi Developers,

We installed Jitsi Meet and can access it, via but are not able to invite
others. When we click on invite others it gives:

Your conference is currently being created...

Based on the following links, we made changes to config.js and
sip-communicator.properties. Still we get the same error message. Could
you please advise how we could fix this?

https://github.com/jitsi/jitsi-meet/issues/105

https://github.com/jitsi/jitsi-meet/issues/300

https://github.com/jitsi/jitsi-meet/issues/280

http://lists.jitsi.org/pipermail/users/2014-August/007753.html

Based on above links, we have the following configurations:

   (1). We added in config.js: bosh: '//jitsi.<our
>.com:5347/http-bind

   (2) In prosody.cfg.lua, we have in global settings:
     component_ports { 5347 }

   (3) We have In nginx.conf:

server {
    listen 80;
    server_name jitsi.<our domain.com>;
    # set the root
    root /usr/local/jitsi.<ourdomain.com>;
    index index.html;

    location ~ ^/([a-zA-Z0-9=\?]+)$ {
        rewrite ^/(.*)$ / break;
    }
    location / {
        ssi on;
    }
    # BOSH
    location /http-bind {
        proxy_pass http://localhost:5280/http-bind;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $http_host;
    }

---
From Prosody Log it appears that Jitsi is starting properly. Both
components Jitsi-videobridge and focus are authenticated successfully.

We have disabled the linux firewall via "service iptables stop".
We are able to access successfully both ways - by using our internal IP
Address URL, or publicly visible URL.
However we are unable to "invite others". For last 2 weeks we are stuck
here.

Kindly suggest if there is anything else to be done?

    (4) Should we add any port to the 'bosh' entry in config.js? If so,
is this the syntax:

    bosh: '//jitsi-meet.ourdomain.com:5347/http-bind'

You should remove the 5347 port from your bosh url in config.js.

    (5) Should we also add in sip-communicator.properties

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false

    org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=<Our.Local.IP.Address>

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=<Our.Public.IP.Address>

This is needed if your instance is not running on public ip address,
in that case you should also forward udp traffic to that machine port
range - 10000:20000.

Regards
damencho

···

On Tue, Jun 23, 2015 at 12:32 PM, Susheel Jalali <Susheel.Jalali@coscendcommunications.com> wrote:

Thank you.

--

Sincerely,

Susheel Jalali

Coscend Communications Solutions
Susheel.Jalali@CoscendCommunications.com

Web site: www.CoscendCommunications.com

------------------------------------------------------------------

CONFIDENTIALITY NOTICE: See 'Confidentiality Notice Regarding E-mail
Messages from Coscend Communications Solutions' posted at:
http://www.CoscendCommunications.com/Terms_and_Conditions.html

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev