[jitsi-dev] Image magnified when sharing screen with Firefox 52


#1

Hi, Jitsi Team.

Doing some screen sharing tests, I'm noticing that in my installation
the image looks magnified:

https://ibin.co/3XfqYzST1znJ.jpg

This does not happen in meet.jit.si doing the test with the same browser
from the same notebook:

https://ibin.co/3XfqzWqaivdt.jpg

Should I make any changes to some configuration file?

Thanks in advance.

Regards,
Daniel


#2

Hi again.

Hi, Jitsi Team.

Doing some screen sharing tests, I'm noticing that in my installation
the image looks magnified:

https://ibin.co/3XfqYzST1znJ.jpg

This does not happen in meet.jit.si doing the test with the same browser
from the same notebook:

https://ibin.co/3XfqzWqaivdt.jpg

Should I make any changes to some configuration file?

Just to confirm, I applied the last update but there were no changes:

jitsi-meet [1.0.2369-1 -> 1.0.2376-1]
jitsi-meet-prosody [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web-config [1.0.2219-1 -> 1.0.2224-1]
jitsi-videobridge [985-1 -> 987-1]

If there is anything else that I can try from my side, please let me know.

Thanks in advance.

Kind regards,
Daniel

···

On 21/08/17 16:08, Daniel Bareiro wrote:


#3

Is that stable or nightly? I’m not sure if the work on fixing that reached the stable packages.

Cheers,

···

On Aug 22, 2017, at 13:27, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi again.

On 21/08/17 16:08, Daniel Bareiro wrote:

Hi, Jitsi Team.

Doing some screen sharing tests, I'm noticing that in my installation
the image looks magnified:

https://ibin.co/3XfqYzST1znJ.jpg

This does not happen in meet.jit.si doing the test with the same browser
from the same notebook:

https://ibin.co/3XfqzWqaivdt.jpg

Should I make any changes to some configuration file?

Just to confirm, I applied the last update but there were no changes:

jitsi-meet [1.0.2369-1 -> 1.0.2376-1]
jitsi-meet-prosody [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web-config [1.0.2219-1 -> 1.0.2224-1]
jitsi-videobridge [985-1 -> 987-1]

If there is anything else that I can try from my side, please let me know.

--
Saúl


#4

Hi, Saúl.

Doing some screen sharing tests, I'm noticing that in my installation
the image looks magnified:

https://ibin.co/3XfqYzST1znJ.jpg

This does not happen in meet.jit.si doing the test with the same browser
from the same notebook:

https://ibin.co/3XfqzWqaivdt.jpg

Should I make any changes to some configuration file?

Just to confirm, I applied the last update but there were no changes:

jitsi-meet [1.0.2369-1 -> 1.0.2376-1]
jitsi-meet-prosody [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web-config [1.0.2219-1 -> 1.0.2224-1]
jitsi-videobridge [985-1 -> 987-1]

If there is anything else that I can try from my side, please let me know.

Is that stable or nightly? I’m not sure if the work on fixing that reached
the stable packages.

This happens in an installation made from 'testing' repo and I have also
find it compiling Jitsi Meet.

I just updated the testing packages to these versions:

jitsi-meet [1.0.2383-1 -> 1.0.2389-1]
jitsi-meet-prosody [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web-config [1.0.2230-1 -> 1.0.2235-1]
jitsi-videobridge [988-1 -> 989-1]

And here I am also finding this issue.

Thanks for your reply.

Kind regards,
Daniel

···

On 25/08/17 05:34, Saúl Ibarra Corretgé wrote:


#5

Hi, Saúl.

Doing some screen sharing tests, I'm noticing that in my installation
the image looks magnified:

https://ibin.co/3XfqYzST1znJ.jpg

This does not happen in meet.jit.si doing the test with the same browser
from the same notebook:

https://ibin.co/3XfqzWqaivdt.jpg

Should I make any changes to some configuration file?

Just to confirm, I applied the last update but there were no changes:

jitsi-meet [1.0.2369-1 -> 1.0.2376-1]
jitsi-meet-prosody [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web-config [1.0.2219-1 -> 1.0.2224-1]
jitsi-videobridge [985-1 -> 987-1]

If there is anything else that I can try from my side, please let me know.

Is that stable or nightly? I’m not sure if the work on fixing that reached
the stable packages.

This happens in an installation made from 'testing' repo and I have also
find it compiling Jitsi Meet.

I just updated the testing packages to these versions:

jitsi-meet [1.0.2383-1 -> 1.0.2389-1]
jitsi-meet-prosody [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web-config [1.0.2230-1 -> 1.0.2235-1]
jitsi-videobridge [988-1 -> 989-1]

And here I am also finding this issue.

Hum. Do you have this setting set to the default value? https://github.com/jitsi/jitsi-meet/blob/master/interface_config.js#L101

···

On Aug 25, 2017, at 14:58, Daniel Bareiro <daniel-listas@gmx.net> wrote:
On 25/08/17 05:34, Saúl Ibarra Corretgé wrote:

Thanks for your reply.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl


#6

Hi, Saúl.

Doing some screen sharing tests, I'm noticing that in my installation
the image looks magnified:

https://ibin.co/3XfqYzST1znJ.jpg

This does not happen in meet.jit.si doing the test with the same browser
from the same notebook:

https://ibin.co/3XfqzWqaivdt.jpg

Should I make any changes to some configuration file?

Just to confirm, I applied the last update but there were no changes:

jitsi-meet [1.0.2369-1 -> 1.0.2376-1]
jitsi-meet-prosody [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web-config [1.0.2219-1 -> 1.0.2224-1]
jitsi-videobridge [985-1 -> 987-1]

If there is anything else that I can try from my side, please let me know.

Is that stable or nightly? I’m not sure if the work on fixing that reached
the stable packages.

This happens in an installation made from 'testing' repo and I have also
find it compiling Jitsi Meet.

I just updated the testing packages to these versions:

jitsi-meet [1.0.2383-1 -> 1.0.2389-1]
jitsi-meet-prosody [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web-config [1.0.2230-1 -> 1.0.2235-1]
jitsi-videobridge [988-1 -> 989-1]

And here I am also finding this issue.

Hum. Do you have this setting set to the default value?> https://github.com/jitsi/jitsi-meet/blob/master/interface_config.js#L101

In the case of the installation with the 'testing' repo, the variable
MAXIMUM_ZOOMING_COEFFICIENT was not configured. Possibly because I'm
using a different interface-config.js to keep the persistence of some
changes and at that time the variable had not yet been entered. However,
I have just added 'MAXIMUM_ZOOMING_COEFFICIENT: 1.3' but there were no
changes.

root@conference:/usr/share/jitsi-meet# grep MAXIMUM_ZOOMING_COEFFICIENT
interface_config*
interface_config.js: MAXIMUM_ZOOMING_COEFFICIENT: 1.3
interface_config-persistent.js: MAXIMUM_ZOOMING_COEFFICIENT: 1.3

Regarding to the compiled installation of Jitsi Meet, I can confirm that
I already had configured interface_config-persistent.js with
"MAXIMUM_ZOOMING_COEFFICIENT: 1.3"

Thanks for your time.

Kind regards,
Daniel

···

On 25/08/17 12:42, Saúl Ibarra Corretgé wrote:


#7

Lenny, do you have any clue?

···

On Aug 25, 2017, at 18:25, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Saúl.

On 25/08/17 12:42, Saúl Ibarra Corretgé wrote:

Doing some screen sharing tests, I'm noticing that in my installation
the image looks magnified:

https://ibin.co/3XfqYzST1znJ.jpg

This does not happen in meet.jit.si doing the test with the same browser
from the same notebook:

https://ibin.co/3XfqzWqaivdt.jpg

Should I make any changes to some configuration file?

Just to confirm, I applied the last update but there were no changes:

jitsi-meet [1.0.2369-1 -> 1.0.2376-1]
jitsi-meet-prosody [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web [1.0.2219-1 -> 1.0.2224-1]
jitsi-meet-web-config [1.0.2219-1 -> 1.0.2224-1]
jitsi-videobridge [985-1 -> 987-1]

If there is anything else that I can try from my side, please let me know.

Is that stable or nightly? I’m not sure if the work on fixing that reached
the stable packages.

This happens in an installation made from 'testing' repo and I have also
find it compiling Jitsi Meet.

I just updated the testing packages to these versions:

jitsi-meet [1.0.2383-1 -> 1.0.2389-1]
jitsi-meet-prosody [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web [1.0.2230-1 -> 1.0.2235-1]
jitsi-meet-web-config [1.0.2230-1 -> 1.0.2235-1]
jitsi-videobridge [988-1 -> 989-1]

And here I am also finding this issue.

Hum. Do you have this setting set to the default value?> https://github.com/jitsi/jitsi-meet/blob/master/interface_config.js#L101

In the case of the installation with the 'testing' repo, the variable
MAXIMUM_ZOOMING_COEFFICIENT was not configured. Possibly because I'm
using a different interface-config.js to keep the persistence of some
changes and at that time the variable had not yet been entered. However,
I have just added 'MAXIMUM_ZOOMING_COEFFICIENT: 1.3' but there were no
changes.

root@conference:/usr/share/jitsi-meet# grep MAXIMUM_ZOOMING_COEFFICIENT
interface_config*
interface_config.js: MAXIMUM_ZOOMING_COEFFICIENT: 1.3
interface_config-persistent.js: MAXIMUM_ZOOMING_COEFFICIENT: 1.3

Regarding to the compiled installation of Jitsi Meet, I can confirm that
I already had configured interface_config-persistent.js with
"MAXIMUM_ZOOMING_COEFFICIENT: 1.3"

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl


#8

Nothing stands out to me. I tried using the same interfaceConfig as the
installation, at least what I could see while at the password prompt, and
didn't see the issue. That bit of video resizing is done through JS after
the onplaying callback, so I'd also look for any weird JS errors. I can try
on the installation with the problem but I would need to know how to get
passed the password prompt.

···

On Mon, Aug 28, 2017 at 12:57 AM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

Lenny, do you have any clue?

> On Aug 25, 2017, at 18:25, Daniel Bareiro <daniel-listas@gmx.net> wrote:
>
> Hi, Saúl.
>
> On 25/08/17 12:42, Saúl Ibarra Corretgé wrote:
>
>>>>>> Doing some screen sharing tests, I'm noticing that in my
installation
>>>>>> the image looks magnified:
>>>>>>
>>>>>> https://ibin.co/3XfqYzST1znJ.jpg
>>>>>>
>>>>>> This does not happen in meet.jit.si doing the test with the same
browser
>>>>>> from the same notebook:
>>>>>>
>>>>>> https://ibin.co/3XfqzWqaivdt.jpg
>>>>>>
>>>>>>
>>>>>> Should I make any changes to some configuration file?
>
>>>>> Just to confirm, I applied the last update but there were no changes:
>>>>>
>>>>> jitsi-meet [1.0.2369-1 -> 1.0.2376-1]
>>>>> jitsi-meet-prosody [1.0.2219-1 -> 1.0.2224-1]
>>>>> jitsi-meet-web [1.0.2219-1 -> 1.0.2224-1]
>>>>> jitsi-meet-web-config [1.0.2219-1 -> 1.0.2224-1]
>>>>> jitsi-videobridge [985-1 -> 987-1]
>>>>>
>>>>> If there is anything else that I can try from my side, please let me
know.
>
>>>> Is that stable or nightly? I’m not sure if the work on fixing that
reached
>>>> the stable packages.
>
>>> This happens in an installation made from 'testing' repo and I have
also
>>> find it compiling Jitsi Meet.
>>>
>>> I just updated the testing packages to these versions:
>>>
>>> jitsi-meet [1.0.2383-1 -> 1.0.2389-1]
>>> jitsi-meet-prosody [1.0.2230-1 -> 1.0.2235-1]
>>> jitsi-meet-web [1.0.2230-1 -> 1.0.2235-1]
>>> jitsi-meet-web-config [1.0.2230-1 -> 1.0.2235-1]
>>> jitsi-videobridge [988-1 -> 989-1]
>>>
>>> And here I am also finding this issue.
>
>> Hum. Do you have this setting set to the default value?>
https://github.com/jitsi/jitsi-meet/blob/master/interface_config.js#L101
>
> In the case of the installation with the 'testing' repo, the variable
> MAXIMUM_ZOOMING_COEFFICIENT was not configured. Possibly because I'm
> using a different interface-config.js to keep the persistence of some
> changes and at that time the variable had not yet been entered. However,
> I have just added 'MAXIMUM_ZOOMING_COEFFICIENT: 1.3' but there were no
> changes.
>
> root@conference:/usr/share/jitsi-meet# grep MAXIMUM_ZOOMING_COEFFICIENT
> interface_config*
> interface_config.js: MAXIMUM_ZOOMING_COEFFICIENT: 1.3
> interface_config-persistent.js: MAXIMUM_ZOOMING_COEFFICIENT: 1.3
>
> Regarding to the compiled installation of Jitsi Meet, I can confirm that
> I already had configured interface_config-persistent.js with
> "MAXIMUM_ZOOMING_COEFFICIENT: 1.3"
>
>
> Thanks for your time.
>
> Kind regards,
> Daniel
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Hi, Lenny.

Nothing stands out to me. I tried using the same interfaceConfig as the
installation, at least what I could see while at the password prompt,
and didn't see the issue. That bit of video resizing is done through JS
after the onplaying callback, so I'd also look for any weird JS errors.
I can try on the installation with the problem but I would need to know
how to get passed the password prompt.

Thanks for your interest.

I just updated to the latest versions available in 'testing' repo:

jitsi-meet [1.0.2393-1 -> 1.0.2397-1]
jitsi-meet-prosody [1.0.2239-1 -> 1.0.2243-1]
jitsi-meet-web [1.0.2239-1 -> 1.0.2243-1]
jitsi-meet-web-config [1.0.2239-1 -> 1.0.2243-1]

Among the visible changes, I found that the avatars have changed and now
match those in meet.jit.si, but I also see that the issue I mentioned
with the Firefox screen sharing has been solved.

Any clue what might have been the cause of that issue?

I have not yet tested again on my compiled installation, but I will pull
and report the results.

Kind regards,
Daniel

···

On 28/08/17 23:51, Leonard Kim wrote: