[jitsi-dev] How to resolve jvb and jicofo port assignments?


#1

Thanks a heap @damencho for telling me me to look away from $ make for the
source of the issue.
The actual problem it seems is with my prosody config.
I'm able to get either jvb or jicofo up, but not both.
How can I config to start both jvb (via localhost) and jicofo (via static
domain URL 192.168.1.150) ?
Do i need to assign a port other than { 5347 } for jicofo component?
I've tried including a bosh port 5280 but that doesn't seem to help much
either.
The lua config is at the paste URL below, if you feel like having a look.

http://paste.ubuntu.com/23780762/

Thanks for any pointers with this- I've spent several days trying to get
this up and running without success! [^_^]

Best Regards & Totally Bamboozled,
mkr


#2

Hi Mkr, Also reasonably new both to prosody and jitsi, therefore YMMV. best
regards Hugh

Thanks a heap @damencho for telling me me to look away from $ make for the
source of the issue.
The actual problem it seems is with my prosody config.

I notice duplicate declarations at the bottom of the the main config and
your included config:

VirtualHost "auth.ubuntuhome.example.com"
    authentication = "internal_plain"

admins = { "focus@auth.ubuntuhome.example.com" }

Component "conference.ubuntuhome.example.com" "muc"
Component "jitsi-videobridge.ubuntuhome.example.com"
    component_secret = "SECRET1"
Component "focus.ubuntuhome.example.com"
    component_secret = "SECRET2"

I'm able to get either jvb or jicofo up, but not both.

Also, apologies for being Captain Obvious, is there anything useful in the
contents of /var/log/jitsi/ ?

How can I config to start both jvb (via localhost) and jicofo (via static

domain URL 192.168.1.150) ?

Probably have a look at the quickstart configs. They work for me.

Do i need to assign a port other than { 5347 } for jicofo component?

According to my current understanding the components multiplex on 5347, as
I am using the quick start packages at the moment, I have no port
declaration in my main config for the components or for bosh.

I've tried including a bosh port 5280 but that doesn't seem to help much
either.

This is default, but one can also check the bosh connection with curl, see
this thread:
https://groups.google.com/forum/#!topic/prosody-dev/P20SMROJDpU

···

On 11 January 2017 at 09:49, mkr <info.steppenwolf@gmail.com> wrote:

The lua config is at the paste URL below, if you feel like having a look.

http://paste.ubuntu.com/23780762/

Thanks for any pointers with this- I've spent several days trying to get
this up and running without success! [^_^]

Best Regards & Totally Bamboozled,
mkr

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
http://www.hughbarnard.org
http://www.twitter.com/hughbarnard
http://www.big-wave-heuristics.com/
<http://www.hackney-environment-network.org.uk/>


#3

If you have any questions please don’t hesitate to ask in the respective request.

jitsi-videobridge: PR #380 - https://github.com/jitsi/jitsi-videobridge/pull/380
- A fix for some users not receiving video when their joining doesn’t update the last-n endpoints.

lib-jitsi-meet: PR #337 - https://github.com/jitsi/lib-jitsi-meet/pull/337
- Added support for pinning multiple users when last-n is enabled.

jicofo: PR #82 - https://github.com/jitsi/jicofo/pull/82
- A change to allow multiple FocusListeners so that they don’t overwrite each other.
- This may also fix issue #39.

jicofo: PR #32 - https://github.com/jitsi/jicofo/pull/32
- A simple change to allow for an optional configuration of the jicofo max memory.

Thank You and have a good day.
Brock

Disclaimer

The information contained in this communication from the sender is confidential. It is intended solely for use by the recipient and others authorized to receive it. If you are not the recipient, you are hereby notified that any disclosure, copying, distribution or taking action in relation of the contents of this information is strictly prohibited and may be unlawful.

This email has been scanned for viruses and malware, and may have been automatically archived by Mimecast Ltd, an innovator in Software as a Service (SaaS) for business. Providing a safer and more useful place for your human generated data. Specializing in; Security, archiving and compliance. To find out more visit the Mimecast website.