[jitsi-dev] How to hide the "Share the link" button at the side bar


#1

Hi,

I want to keep just the participants list without the sharing button.

In which file can I change it and hide the share dialog?

<img src=’/uploads/jitsi/original/2X/7/7f5ad0f89e7ae209a2f0fa9c4e6d8e4f03f805ad.png’ width=‘349’ height=‘242’>

Thanks,
David


#2

Anyone please?

Thanks!

···

On Sat, Apr 29, 2017 at 9:03 PM, David King <davidbking086@gmail.com> wrote:

Hi,

I want to keep just the participants list without the sharing button.

In which file can I change it and hide the share dialog?

[image: Inline image 1]

Thanks,
David


#3

Hi,

There is no such option currently.

In this place in the source code is where the button is created and added
at the moment:
https://github.com/jitsi/jitsi-meet/blob/55c3f5ddff8a975a91f940ed34968156e41051fc/modules/UI/side_pannels/contactlist/ContactListView.js#L100-L100

Regards
damencho

···

On Sun, Apr 30, 2017 at 3:25 PM, David King <davidbking086@gmail.com> wrote:

Anyone please?

Thanks!

On Sat, Apr 29, 2017 at 9:03 PM, David King <davidbking086@gmail.com> > wrote:

Hi,

I want to keep just the participants list without the sharing button.

In which file can I change it and hide the share dialog?

[image: Inline image 1]

Thanks,
David

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Thank you Damencho, but I am not able to find the "modules" library in my
configuration.

This is what I have:

*/usr/share/jitsi-meet# ls*
*404.html base.html conference.js css
index.android.js interface_config.js plugin.head.html
unsupported_browser.html*
*analytics.js close2.html config.js favicon.ico
index.html lang prosody-plugins utils.js*
*app.js close.html connection.js fonts
index.ios.js libs sounds
webpack.config.js*
*authError.html close.js connection_optimization images
interface_config_bu.js logging_config.js title.html*

Thanks,
David

···

On Sun, Apr 30, 2017 at 11:55 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

There is no such option currently.

In this place in the source code is where the button is created and added
at the moment:
https://github.com/jitsi/jitsi-meet/blob/55c3f5ddff8a975a91f940ed349681
56e41051fc/modules/UI/side_pannels/contactlist/
ContactListView.js#L100-L100

Regards
damencho

On Sun, Apr 30, 2017 at 3:25 PM, David King <davidbking086@gmail.com> > wrote:

Anyone please?

Thanks!

On Sat, Apr 29, 2017 at 9:03 PM, David King <davidbking086@gmail.com> >> wrote:

Hi,

I want to keep just the participants list without the sharing button.

In which file can I change it and hide the share dialog?

[image: Inline image 1]

Thanks,
David

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

It is in the source code, which is available at
https://github.com/jitsi/jitsi-meet.
You need to checkout the source code, change it, make it (doing npm install
before that, check the README). You will need nodejs installed.

Regards
damencho

···

On Sun, Apr 30, 2017 at 4:09 PM, David King <davidbking086@gmail.com> wrote:

Thank you Damencho, but I am not able to find the "modules" library in my
configuration.

This is what I have:

*/usr/share/jitsi-meet# ls*
*404.html base.html conference.js css
index.android.js interface_config.js plugin.head.html
unsupported_browser.html*
*analytics.js close2.html config.js favicon.ico
index.html lang prosody-plugins utils.js*
*app.js close.html connection.js fonts
index.ios.js libs sounds
webpack.config.js*
*authError.html close.js connection_optimization images
interface_config_bu.js logging_config.js title.html*

Thanks,
David

On Sun, Apr 30, 2017 at 11:55 PM, Damian Minkov <damencho@jitsi.org> > wrote:

Hi,

There is no such option currently.

In this place in the source code is where the button is created and added
at the moment:
https://github.com/jitsi/jitsi-meet/blob/55c3f5ddff8a975a91f
940ed34968156e41051fc/modules/UI/side_pannels/contactlist/Co
ntactListView.js#L100-L100

Regards
damencho

On Sun, Apr 30, 2017 at 3:25 PM, David King <davidbking086@gmail.com> >> wrote:

Anyone please?

Thanks!

On Sat, Apr 29, 2017 at 9:03 PM, David King <davidbking086@gmail.com> >>> wrote:

Hi,

I want to keep just the participants list without the sharing button.

In which file can I change it and hide the share dialog?

[image: Inline image 1]

Thanks,
David

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hello all,

I have tried that, but when I do 'npm install' I get this error:

git-validate@2.2.2 install /srv/jitsi.example.com/node_

modules/git-validate

node bin/install

fs.js:584
  return binding.open(pathModule._makeLong(path), stringToFlags(flags),
mode);
                 ^

Error: EACCES: permission denied, open '/srv/jitsi.example.com/.git/
hooks/pre-commit'
    at Object.fs.openSync (fs.js:584:18)
    at Object.fs.writeFileSync (fs.js:1316:33)
    at Object.exports.installHooks (/srv/jitsi.example.com/node_
modules/git-validate/lib/utils.js:248:12)
    at Object.<anonymous> (/srv/jitsi.example.com/node_
modules/git-validate/bin/install.js:3:7)
    at Module._compile (module.js:571:32)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:488:32)
    at tryModuleLoad (module.js:447:12)
    at Function.Module._load (module.js:439:3)
    at Module.runMain (module.js:605:10)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0
(node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for
fsevents@1.1.1: wanted {"os":"darwin","arch":"any"} (current:
{"os":"linux","arch":"x64"})
npm WARN babel-loader@7.0.0 requires a peer of webpack@2 but none was
installed.
npm WARN eslint-plugin-mocha@2.0.0 requires a peer of eslint@^2.0.0 but
none was installed.
npm ERR! Linux 4.8.0-49-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v7.9.0
npm ERR! npm v4.2.0
npm ERR! code ELIFECYCLE
npm ERR! errno 1

npm ERR! git-validate@2.2.2 install: `node bin/install`
npm ERR! Exit status 1

npm ERR!
npm ERR! Failed at the git-validate@2.2.2 install script 'node bin/install'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the git-validate
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node bin/install
npm ERR! You can get information on how to open an issue for this project
with:
npm ERR! npm bugs git-validate
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls git-validate
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/ubuntu/.npm/_logs/2017-05-03T14_41_37_330Z-debug.log

How can I solve it?

Thanks.

···

El 30 abr. 2017 11:27 p. m., "Damian Minkov" <damencho@jitsi.org> escribió:

Hi,

It is in the source code, which is available at https://github.com/jitsi/
jitsi-meet.
You need to checkout the source code, change it, make it
(doing npm install before that, check the README). You will need
nodejs installed.

Regards
damencho

On Sun, Apr 30, 2017 at 4:09 PM, David King <davidbking086@gmail.com> > wrote:

Thank you Damencho, but I am not able to find the "modules" library in my
configuration.

This is what I have:

*/usr/share/jitsi-meet# ls*
*404.html base.html conference.js css
index.android.js interface_config.js plugin.head.html
unsupported_browser.html*
*analytics.js close2.html config.js favicon.ico
index.html lang prosody-plugins utils.js*
*app.js close.html connection.js fonts
index.ios.js libs sounds
webpack.config.js*
*authError.html close.js connection_optimization images
interface_config_bu.js logging_config.js title.html*

Thanks,
David

On Sun, Apr 30, 2017 at 11:55 PM, Damian Minkov <damencho@jitsi.org> >> wrote:

Hi,

There is no such option currently.

In this place in the source code is where the button is created and
added at the moment:
https://github.com/jitsi/jitsi-meet/blob/55c3f5ddff8a975a91f
940ed34968156e41051fc/modules/UI/side_pannels/contactlist/Co
ntactListView.js#L100-L100

Regards
damencho

On Sun, Apr 30, 2017 at 3:25 PM, David King <davidbking086@gmail.com> >>> wrote:

Anyone please?

Thanks!

On Sat, Apr 29, 2017 at 9:03 PM, David King <davidbking086@gmail.com> >>>> wrote:

Hi,

I want to keep just the participants list without the sharing button.

In which file can I change it and hide the share dialog?

[image: Inline image 1]

Thanks,
David

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

You have file permissions problems, you had cloned repo with one account
and compiling with another account, I suppose.

···

On Wed, May 3, 2017 at 11:05 AM, Carles Morales <carlesm.95@gmail.com> wrote:

Error: EACCES: permission denied, open '/srv/jitsi.example.com/.git/h
ooks/pre-commit'


#8

No, I only have one account. I have tried with this solution:
https://docs.npmjs.com/getting-started/fixing-npm-permissions#option-2-change-npms-default-directory-to-another-directory

but it doesn't work.

···

2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

On Wed, May 3, 2017 at 11:05 AM, Carles Morales <carlesm.95@gmail.com> > wrote:

Error: EACCES: permission denied, open '/srv/jitsi.example.com/.git/h
ooks/pre-commit'

You have file permissions problems, you had cloned repo with one account
and compiling with another account, I suppose.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

So have you check the file permissions of that file? What is the
result of this commands:
$ whoami
$ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit

···

On Wed, May 3, 2017 at 11:40 AM, Carles Morales <carlesm.95@gmail.com> wrote:

No, I only have one account. I have tried with this solution:
https://docs.npmjs.com/getting-started/fixing-npm-permissions#option-2-change-npms-default-directory-to-another-directory

but it doesn't work.

2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

On Wed, May 3, 2017 at 11:05 AM, Carles Morales <carlesm.95@gmail.com> >> wrote:

Error: EACCES: permission denied, open
'/srv/jitsi.example.com/.git/hooks/pre-commit'

You have file permissions problems, you had cloned repo with one account
and compiling with another account, I suppose.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

$ whoami
root
$ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
ls: cannot access to '/srv/jitsi.example.com/.git/hooks/pre-commit': No
such *file* or directory

···

2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

So have you check the file permissions of that file? What is the
result of this commands:
$ whoami
$ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit

On Wed, May 3, 2017 at 11:40 AM, Carles Morales <carlesm.95@gmail.com> > wrote:
> No, I only have one account. I have tried with this solution:
> https://docs.npmjs.com/getting-started/fixing-npm-
permissions#option-2-change-npms-default-directory-to-another-directory
>
> but it doesn't work.
>
>
>
> 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>
>>
>> On Wed, May 3, 2017 at 11:05 AM, Carles Morales <carlesm.95@gmail.com> > >> wrote:
>>>
>>> Error: EACCES: permission denied, open
>>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>>
>>
>> You have file permissions problems, you had cloned repo with one account
>> and compiling with another account, I suppose.
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

Ok, seems like I have solved it by entering 'chmod -R 777 .git/'. Now my
question is, how do I should install jitsi-meet in order to have all
dependencies working in local? I mean, what I have done now is clone the
repository and follow the README instructions but jitsi-meet is not running
in my computer and if I follow the quick-install guide I can't do npm
install because there is no package.json there. So, how can I do some
changes in the code an test it in local?

Thanks.

···

2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:

$ whoami
root
$ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
ls: cannot access to '/srv/jitsi.example.com/.git/hooks/pre-commit': No
such *file* or directory

2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

So have you check the file permissions of that file? What is the
result of this commands:
$ whoami
$ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit

On Wed, May 3, 2017 at 11:40 AM, Carles Morales <carlesm.95@gmail.com> >> wrote:
> No, I only have one account. I have tried with this solution:
> https://docs.npmjs.com/getting-started/fixing-npm-permission
s#option-2-change-npms-default-directory-to-another-directory
>
> but it doesn't work.
>
>
>
> 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>
>>
>> On Wed, May 3, 2017 at 11:05 AM, Carles Morales <carlesm.95@gmail.com> >> >> wrote:
>>>
>>> Error: EACCES: permission denied, open
>>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>>
>>
>> You have file permissions problems, you had cloned repo with one
account
>> and compiling with another account, I suppose.
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Hi,

So the easiest way to make modifications and test them:
- install nginx
- deploy from debian packages, make sure it works (open two tabs, do
you see video)
- clone jitsi-meet, make it, let's say it is in /srv/jitsi.example.com/
- change nginx config in:
/etc/nginx/sites-available/jitsi.example.com.conf, this line: root
/usr/share/jitsi-meet;
Change it to read: root /srv/jitsi.example.com/;
- /etc/init.d/nginx reload

And now your deployment is using jitsi-meet from source.

Regards
damencho

···

On Wed, May 3, 2017 at 1:34 PM, Carles Morales <carlesm.95@gmail.com> wrote:

Ok, seems like I have solved it by entering 'chmod -R 777 .git/'. Now my
question is, how do I should install jitsi-meet in order to have all
dependencies working in local? I mean, what I have done now is clone the
repository and follow the README instructions but jitsi-meet is not running
in my computer and if I follow the quick-install guide I can't do npm
install because there is no package.json there. So, how can I do some
changes in the code an test it in local?

Thanks.

2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:

$ whoami
root
$ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
ls: cannot access to '/srv/jitsi.example.com/.git/hooks/pre-commit': No
such file or directory

2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

So have you check the file permissions of that file? What is the
result of this commands:
$ whoami
$ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit

On Wed, May 3, 2017 at 11:40 AM, Carles Morales <carlesm.95@gmail.com> >>> wrote:
> No, I only have one account. I have tried with this solution:
>
> https://docs.npmjs.com/getting-started/fixing-npm-permissions#option-2-change-npms-default-directory-to-another-directory
>
> but it doesn't work.
>
>
>
> 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>
>>
>> On Wed, May 3, 2017 at 11:05 AM, Carles Morales <carlesm.95@gmail.com> >>> >> wrote:
>>>
>>> Error: EACCES: permission denied, open
>>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>>
>>
>> You have file permissions problems, you had cloned repo with one
>> account
>> and compiling with another account, I suppose.
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

Hi,

I have done that but only works for the index page. When I implement
changes in other files, for example in
react/features/toolbox/defaultToolbarButtons.js it doesn't work, loads the
file from the quick install. I think I have to do make everytime I made a
change and restart videobridge? Am I right?

Thanks,
Carles.

···

2017-05-03 21:11 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

Hi,

So the easiest way to make modifications and test them:
- install nginx
- deploy from debian packages, make sure it works (open two tabs, do
you see video)
- clone jitsi-meet, make it, let's say it is in /srv/jitsi.example.com/
- change nginx config in:
/etc/nginx/sites-available/jitsi.example.com.conf, this line: root
/usr/share/jitsi-meet;
Change it to read: root /srv/jitsi.example.com/;
- /etc/init.d/nginx reload

And now your deployment is using jitsi-meet from source.

Regards
damencho

On Wed, May 3, 2017 at 1:34 PM, Carles Morales <carlesm.95@gmail.com> > wrote:
> Ok, seems like I have solved it by entering 'chmod -R 777 .git/'. Now my
> question is, how do I should install jitsi-meet in order to have all
> dependencies working in local? I mean, what I have done now is clone the
> repository and follow the README instructions but jitsi-meet is not
running
> in my computer and if I follow the quick-install guide I can't do npm
> install because there is no package.json there. So, how can I do some
> changes in the code an test it in local?
>
> Thanks.
>
> 2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:
>>
>> $ whoami
>> root
>> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> ls: cannot access to '/srv/jitsi.example.com/.git/hooks/pre-commit': No
>> such file or directory
>>
>>
>> 2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>>
>>> So have you check the file permissions of that file? What is the
>>> result of this commands:
>>> $ whoami
>>> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>>>
>>>
>>>
>>> On Wed, May 3, 2017 at 11:40 AM, Carles Morales <carlesm.95@gmail.com> > >>> wrote:
>>> > No, I only have one account. I have tried with this solution:
>>> >
>>> > https://docs.npmjs.com/getting-started/fixing-npm-
permissions#option-2-change-npms-default-directory-to-another-directory
>>> >
>>> > but it doesn't work.
>>> >
>>> >
>>> >
>>> > 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>> >>
>>> >>
>>> >> On Wed, May 3, 2017 at 11:05 AM, Carles Morales < > carlesm.95@gmail.com> > >>> >> wrote:
>>> >>>
>>> >>> Error: EACCES: permission denied, open
>>> >>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>>> >>
>>> >>
>>> >> You have file permissions problems, you had cloned repo with one
>>> >> account
>>> >> and compiling with another account, I suppose.
>>> >>
>>> >> _______________________________________________
>>> >> dev mailing list
>>> >> dev@jitsi.org
>>> >> Unsubscribe instructions and other list options:
>>> >> http://lists.jitsi.org/mailman/listinfo/dev
>>> >
>>> >
>>> >
>>> > _______________________________________________
>>> > dev mailing list
>>> > dev@jitsi.org
>>> > Unsubscribe instructions and other list options:
>>> > http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Hi,

Are you using jvb to serve meet? If this is the case, I'm not sure
whether jetty caches something and jvb restart is needed.

But if you are using jvb to serve meet in the above steps I described
you don't need to edit
/etc/nginx/sites-available/jitsi.example.com.conf you need to edit
/etc/jitsi/videobridge/sip-communicator.properties and change the
following line:
org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/usr/share/jitsi-meet
to be:
org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/srv/jitsi.example.com/

Regards
damencho

···

On Wed, May 3, 2017 at 4:20 PM, Carles Morales <carlesm.95@gmail.com> wrote:

Hi,

I have done that but only works for the index page. When I implement changes
in other files, for example in
react/features/toolbox/defaultToolbarButtons.js it doesn't work, loads the
file from the quick install. I think I have to do make everytime I made a
change and restart videobridge? Am I right?

Thanks,
Carles.

2017-05-03 21:11 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

Hi,

So the easiest way to make modifications and test them:
- install nginx
- deploy from debian packages, make sure it works (open two tabs, do
you see video)
- clone jitsi-meet, make it, let's say it is in /srv/jitsi.example.com/
- change nginx config in:
/etc/nginx/sites-available/jitsi.example.com.conf, this line: root
/usr/share/jitsi-meet;
Change it to read: root /srv/jitsi.example.com/;
- /etc/init.d/nginx reload

And now your deployment is using jitsi-meet from source.

Regards
damencho

On Wed, May 3, 2017 at 1:34 PM, Carles Morales <carlesm.95@gmail.com> >> wrote:
> Ok, seems like I have solved it by entering 'chmod -R 777 .git/'. Now my
> question is, how do I should install jitsi-meet in order to have all
> dependencies working in local? I mean, what I have done now is clone the
> repository and follow the README instructions but jitsi-meet is not
> running
> in my computer and if I follow the quick-install guide I can't do npm
> install because there is no package.json there. So, how can I do some
> changes in the code an test it in local?
>
> Thanks.
>
> 2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:
>>
>> $ whoami
>> root
>> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> ls: cannot access to '/srv/jitsi.example.com/.git/hooks/pre-commit': No
>> such file or directory
>>
>>
>> 2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>>
>>> So have you check the file permissions of that file? What is the
>>> result of this commands:
>>> $ whoami
>>> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>>>
>>>
>>>
>>> On Wed, May 3, 2017 at 11:40 AM, Carles Morales <carlesm.95@gmail.com> >> >>> wrote:
>>> > No, I only have one account. I have tried with this solution:
>>> >
>>> >
>>> > https://docs.npmjs.com/getting-started/fixing-npm-permissions#option-2-change-npms-default-directory-to-another-directory
>>> >
>>> > but it doesn't work.
>>> >
>>> >
>>> >
>>> > 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>> >>
>>> >>
>>> >> On Wed, May 3, 2017 at 11:05 AM, Carles Morales >> >>> >> <carlesm.95@gmail.com> >> >>> >> wrote:
>>> >>>
>>> >>> Error: EACCES: permission denied, open
>>> >>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>>> >>
>>> >>
>>> >> You have file permissions problems, you had cloned repo with one
>>> >> account
>>> >> and compiling with another account, I suppose.
>>> >>
>>> >> _______________________________________________
>>> >> dev mailing list
>>> >> dev@jitsi.org
>>> >> Unsubscribe instructions and other list options:
>>> >> http://lists.jitsi.org/mailman/listinfo/dev
>>> >
>>> >
>>> >
>>> > _______________________________________________
>>> > dev mailing list
>>> > dev@jitsi.org
>>> > Unsubscribe instructions and other list options:
>>> > http://lists.jitsi.org/mailman/listinfo/dev
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

Hi,

yes, I'm using jvb to serve meet, is like the quick-install does. I have
done that change but continues without working. In fact,
/etc/jitsi/videobridge/sip-communicator.properties file was empty, I added
the line you said but continues without working if I change something. Any
suggestions?

Kind regards,
Carles.

···

2017-05-03 23:29 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

Hi,

Are you using jvb to serve meet? If this is the case, I'm not sure
whether jetty caches something and jvb restart is needed.

But if you are using jvb to serve meet in the above steps I described
you don't need to edit
/etc/nginx/sites-available/jitsi.example.com.conf you need to edit
/etc/jitsi/videobridge/sip-communicator.properties and change the
following line:
org.jitsi.videobridge.rest.jetty.ResourceHandler.
resourceBase=/usr/share/jitsi-meet
to be:
org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/srv/jitsi.
example.com/

Regards
damencho

On Wed, May 3, 2017 at 4:20 PM, Carles Morales <carlesm.95@gmail.com> > wrote:
> Hi,
>
> I have done that but only works for the index page. When I implement
changes
> in other files, for example in
> react/features/toolbox/defaultToolbarButtons.js it doesn't work, loads
the
> file from the quick install. I think I have to do make everytime I made a
> change and restart videobridge? Am I right?
>
> Thanks,
> Carles.
>
> 2017-05-03 21:11 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>
>> Hi,
>>
>> So the easiest way to make modifications and test them:
>> - install nginx
>> - deploy from debian packages, make sure it works (open two tabs, do
>> you see video)
>> - clone jitsi-meet, make it, let's say it is in /srv/jitsi.example.com/
>> - change nginx config in:
>> /etc/nginx/sites-available/jitsi.example.com.conf, this line: root
>> /usr/share/jitsi-meet;
>> Change it to read: root /srv/jitsi.example.com/;
>> - /etc/init.d/nginx reload
>>
>> And now your deployment is using jitsi-meet from source.
>>
>> Regards
>> damencho
>>
>> On Wed, May 3, 2017 at 1:34 PM, Carles Morales <carlesm.95@gmail.com> > >> wrote:
>> > Ok, seems like I have solved it by entering 'chmod -R 777 .git/'. Now
my
>> > question is, how do I should install jitsi-meet in order to have all
>> > dependencies working in local? I mean, what I have done now is clone
the
>> > repository and follow the README instructions but jitsi-meet is not
>> > running
>> > in my computer and if I follow the quick-install guide I can't do npm
>> > install because there is no package.json there. So, how can I do some
>> > changes in the code an test it in local?
>> >
>> > Thanks.
>> >
>> > 2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:
>> >>
>> >> $ whoami
>> >> root
>> >> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >> ls: cannot access to '/srv/jitsi.example.com/.git/hooks/pre-commit':
No
>> >> such file or directory
>> >>
>> >>
>> >> 2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >>>
>> >>> So have you check the file permissions of that file? What is the
>> >>> result of this commands:
>> >>> $ whoami
>> >>> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >>>
>> >>>
>> >>>
>> >>> On Wed, May 3, 2017 at 11:40 AM, Carles Morales < > carlesm.95@gmail.com> > >> >>> wrote:
>> >>> > No, I only have one account. I have tried with this solution:
>> >>> >
>> >>> >
>> >>> > https://docs.npmjs.com/getting-started/fixing-npm-
permissions#option-2-change-npms-default-directory-to-another-directory
>> >>> >
>> >>> > but it doesn't work.
>> >>> >
>> >>> >
>> >>> >
>> >>> > 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >>> >>
>> >>> >>
>> >>> >> On Wed, May 3, 2017 at 11:05 AM, Carles Morales > >> >>> >> <carlesm.95@gmail.com> > >> >>> >> wrote:
>> >>> >>>
>> >>> >>> Error: EACCES: permission denied, open
>> >>> >>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>> >>> >>
>> >>> >>
>> >>> >> You have file permissions problems, you had cloned repo with one
>> >>> >> account
>> >>> >> and compiling with another account, I suppose.
>> >>> >>
>> >>> >> _______________________________________________
>> >>> >> dev mailing list
>> >>> >> dev@jitsi.org
>> >>> >> Unsubscribe instructions and other list options:
>> >>> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >>> >
>> >>> >
>> >>> >
>> >>> > _______________________________________________
>> >>> > dev mailing list
>> >>> > dev@jitsi.org
>> >>> > Unsubscribe instructions and other list options:
>> >>> > http://lists.jitsi.org/mailman/listinfo/dev
>> >>>
>> >>> _______________________________________________
>> >>> dev mailing list
>> >>> dev@jitsi.org
>> >>> Unsubscribe instructions and other list options:
>> >>> http://lists.jitsi.org/mailman/listinfo/dev
>> >>
>> >>
>> >
>> >
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

If that file is empty, this means that meet is served using nginx or
apache, you need to find which one, and whether the document root is
correctly pointing to your source checkout.
After the modifications in the source are you doing npm install and make?

···

On Wed, May 3, 2017 at 4:48 PM, Carles Morales <carlesm.95@gmail.com> wrote:

Hi,

yes, I'm using jvb to serve meet, is like the quick-install does. I have
done that change but continues without working. In fact,
/etc/jitsi/videobridge/sip-communicator.properties file was empty, I added
the line you said but continues without working if I change something. Any
suggestions?

Kind regards,
Carles.

2017-05-03 23:29 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

Hi,

Are you using jvb to serve meet? If this is the case, I'm not sure
whether jetty caches something and jvb restart is needed.

But if you are using jvb to serve meet in the above steps I described
you don't need to edit
/etc/nginx/sites-available/jitsi.example.com.conf you need to edit
/etc/jitsi/videobridge/sip-communicator.properties and change the
following line:

org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/usr/share/jitsi-meet
to be:

org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/srv/jitsi.example.com/

Regards
damencho

On Wed, May 3, 2017 at 4:20 PM, Carles Morales <carlesm.95@gmail.com> >> wrote:
> Hi,
>
> I have done that but only works for the index page. When I implement
> changes
> in other files, for example in
> react/features/toolbox/defaultToolbarButtons.js it doesn't work, loads
> the
> file from the quick install. I think I have to do make everytime I made
> a
> change and restart videobridge? Am I right?
>
> Thanks,
> Carles.
>
> 2017-05-03 21:11 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>
>> Hi,
>>
>> So the easiest way to make modifications and test them:
>> - install nginx
>> - deploy from debian packages, make sure it works (open two tabs, do
>> you see video)
>> - clone jitsi-meet, make it, let's say it is in /srv/jitsi.example.com/
>> - change nginx config in:
>> /etc/nginx/sites-available/jitsi.example.com.conf, this line: root
>> /usr/share/jitsi-meet;
>> Change it to read: root /srv/jitsi.example.com/;
>> - /etc/init.d/nginx reload
>>
>> And now your deployment is using jitsi-meet from source.
>>
>> Regards
>> damencho
>>
>> On Wed, May 3, 2017 at 1:34 PM, Carles Morales <carlesm.95@gmail.com> >> >> wrote:
>> > Ok, seems like I have solved it by entering 'chmod -R 777 .git/'. Now
>> > my
>> > question is, how do I should install jitsi-meet in order to have all
>> > dependencies working in local? I mean, what I have done now is clone
>> > the
>> > repository and follow the README instructions but jitsi-meet is not
>> > running
>> > in my computer and if I follow the quick-install guide I can't do npm
>> > install because there is no package.json there. So, how can I do some
>> > changes in the code an test it in local?
>> >
>> > Thanks.
>> >
>> > 2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:
>> >>
>> >> $ whoami
>> >> root
>> >> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >> ls: cannot access to '/srv/jitsi.example.com/.git/hooks/pre-commit':
>> >> No
>> >> such file or directory
>> >>
>> >>
>> >> 2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >>>
>> >>> So have you check the file permissions of that file? What is the
>> >>> result of this commands:
>> >>> $ whoami
>> >>> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >>>
>> >>>
>> >>>
>> >>> On Wed, May 3, 2017 at 11:40 AM, Carles Morales >> >> >>> <carlesm.95@gmail.com> >> >> >>> wrote:
>> >>> > No, I only have one account. I have tried with this solution:
>> >>> >
>> >>> >
>> >>> >
>> >>> > https://docs.npmjs.com/getting-started/fixing-npm-permissions#option-2-change-npms-default-directory-to-another-directory
>> >>> >
>> >>> > but it doesn't work.
>> >>> >
>> >>> >
>> >>> >
>> >>> > 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >>> >>
>> >>> >>
>> >>> >> On Wed, May 3, 2017 at 11:05 AM, Carles Morales >> >> >>> >> <carlesm.95@gmail.com> >> >> >>> >> wrote:
>> >>> >>>
>> >>> >>> Error: EACCES: permission denied, open
>> >>> >>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>> >>> >>
>> >>> >>
>> >>> >> You have file permissions problems, you had cloned repo with one
>> >>> >> account
>> >>> >> and compiling with another account, I suppose.
>> >>> >>
>> >>> >> _______________________________________________
>> >>> >> dev mailing list
>> >>> >> dev@jitsi.org
>> >>> >> Unsubscribe instructions and other list options:
>> >>> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >>> >
>> >>> >
>> >>> >
>> >>> > _______________________________________________
>> >>> > dev mailing list
>> >>> > dev@jitsi.org
>> >>> > Unsubscribe instructions and other list options:
>> >>> > http://lists.jitsi.org/mailman/listinfo/dev
>> >>>
>> >>> _______________________________________________
>> >>> dev mailing list
>> >>> dev@jitsi.org
>> >>> Unsubscribe instructions and other list options:
>> >>> http://lists.jitsi.org/mailman/listinfo/dev
>> >>
>> >>
>> >
>> >
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#17

I only have nginx, not apache. And yes, what I was trying to say is that
when I do a change, if I do 'make' and restart videobridge, then I can see
the changes. That's the only way right? There's not another way to do it
simply doing a jvb restart or something? Because it takes about 4 minutes
to do the 'make'.

Thank you,
Carles.

···

2017-05-03 23:57 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

If that file is empty, this means that meet is served using nginx or
apache, you need to find which one, and whether the document root is
correctly pointing to your source checkout.
After the modifications in the source are you doing npm install and make?

On Wed, May 3, 2017 at 4:48 PM, Carles Morales <carlesm.95@gmail.com> > wrote:
> Hi,
>
> yes, I'm using jvb to serve meet, is like the quick-install does. I have
> done that change but continues without working. In fact,
> /etc/jitsi/videobridge/sip-communicator.properties file was empty, I
added
> the line you said but continues without working if I change something.
Any
> suggestions?
>
> Kind regards,
> Carles.
>
> 2017-05-03 23:29 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>
>> Hi,
>>
>> Are you using jvb to serve meet? If this is the case, I'm not sure
>> whether jetty caches something and jvb restart is needed.
>>
>> But if you are using jvb to serve meet in the above steps I described
>> you don't need to edit
>> /etc/nginx/sites-available/jitsi.example.com.conf you need to edit
>> /etc/jitsi/videobridge/sip-communicator.properties and change the
>> following line:
>>
>> org.jitsi.videobridge.rest.jetty.ResourceHandler.
resourceBase=/usr/share/jitsi-meet
>> to be:
>>
>> org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/srv/
jitsi.example.com/
>>
>> Regards
>> damencho
>>
>>
>> On Wed, May 3, 2017 at 4:20 PM, Carles Morales <carlesm.95@gmail.com> > >> wrote:
>> > Hi,
>> >
>> > I have done that but only works for the index page. When I implement
>> > changes
>> > in other files, for example in
>> > react/features/toolbox/defaultToolbarButtons.js it doesn't work,
loads
>> > the
>> > file from the quick install. I think I have to do make everytime I
made
>> > a
>> > change and restart videobridge? Am I right?
>> >
>> > Thanks,
>> > Carles.
>> >
>> > 2017-05-03 21:11 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >>
>> >> Hi,
>> >>
>> >> So the easiest way to make modifications and test them:
>> >> - install nginx
>> >> - deploy from debian packages, make sure it works (open two tabs, do
>> >> you see video)
>> >> - clone jitsi-meet, make it, let's say it is in /srv/
jitsi.example.com/
>> >> - change nginx config in:
>> >> /etc/nginx/sites-available/jitsi.example.com.conf, this line: root
>> >> /usr/share/jitsi-meet;
>> >> Change it to read: root /srv/jitsi.example.com/;
>> >> - /etc/init.d/nginx reload
>> >>
>> >> And now your deployment is using jitsi-meet from source.
>> >>
>> >> Regards
>> >> damencho
>> >>
>> >> On Wed, May 3, 2017 at 1:34 PM, Carles Morales <carlesm.95@gmail.com > > > >> >> wrote:
>> >> > Ok, seems like I have solved it by entering 'chmod -R 777 .git/'.
Now
>> >> > my
>> >> > question is, how do I should install jitsi-meet in order to have
all
>> >> > dependencies working in local? I mean, what I have done now is
clone
>> >> > the
>> >> > repository and follow the README instructions but jitsi-meet is not
>> >> > running
>> >> > in my computer and if I follow the quick-install guide I can't do
npm
>> >> > install because there is no package.json there. So, how can I do
some
>> >> > changes in the code an test it in local?
>> >> >
>> >> > Thanks.
>> >> >
>> >> > 2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:
>> >> >>
>> >> >> $ whoami
>> >> >> root
>> >> >> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >> >> ls: cannot access to '/srv/jitsi.example.com/.git/
hooks/pre-commit':
>> >> >> No
>> >> >> such file or directory
>> >> >>
>> >> >>
>> >> >> 2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >> >>>
>> >> >>> So have you check the file permissions of that file? What is the
>> >> >>> result of this commands:
>> >> >>> $ whoami
>> >> >>> $ ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >> >>>
>> >> >>>
>> >> >>>
>> >> >>> On Wed, May 3, 2017 at 11:40 AM, Carles Morales > >> >> >>> <carlesm.95@gmail.com> > >> >> >>> wrote:
>> >> >>> > No, I only have one account. I have tried with this solution:
>> >> >>> >
>> >> >>> >
>> >> >>> >
>> >> >>> > https://docs.npmjs.com/getting-started/fixing-npm-
permissions#option-2-change-npms-default-directory-to-another-directory
>> >> >>> >
>> >> >>> > but it doesn't work.
>> >> >>> >
>> >> >>> >
>> >> >>> >
>> >> >>> > 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >> >>> >>
>> >> >>> >>
>> >> >>> >> On Wed, May 3, 2017 at 11:05 AM, Carles Morales > >> >> >>> >> <carlesm.95@gmail.com> > >> >> >>> >> wrote:
>> >> >>> >>>
>> >> >>> >>> Error: EACCES: permission denied, open
>> >> >>> >>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>> >> >>> >>
>> >> >>> >>
>> >> >>> >> You have file permissions problems, you had cloned repo with
one
>> >> >>> >> account
>> >> >>> >> and compiling with another account, I suppose.
>> >> >>> >>
>> >> >>> >> _______________________________________________
>> >> >>> >> dev mailing list
>> >> >>> >> dev@jitsi.org
>> >> >>> >> Unsubscribe instructions and other list options:
>> >> >>> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >> >>> >
>> >> >>> >
>> >> >>> >
>> >> >>> > _______________________________________________
>> >> >>> > dev mailing list
>> >> >>> > dev@jitsi.org
>> >> >>> > Unsubscribe instructions and other list options:
>> >> >>> > http://lists.jitsi.org/mailman/listinfo/dev
>> >> >>>
>> >> >>> _______________________________________________
>> >> >>> dev mailing list
>> >> >>> dev@jitsi.org
>> >> >>> Unsubscribe instructions and other list options:
>> >> >>> http://lists.jitsi.org/mailman/listinfo/dev
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > dev mailing list
>> >> > dev@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/dev
>> >>
>> >> _______________________________________________
>> >> dev mailing list
>> >> dev@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >
>> >
>> >
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#18

You don't need to restart jvb, just refresh or hard refresh the browser
page is enough, after make.

···

On May 3, 2017 17:09, "Carles Morales" <carlesm.95@gmail.com> wrote:

I only have nginx, not apache. And yes, what I was trying to say is that
when I do a change, if I do 'make' and restart videobridge, then I can see
the changes. That's the only way right? There's not another way to do it
simply doing a jvb restart or something? Because it takes about 4 minutes
to do the 'make'.

Thank you,
Carles.

2017-05-03 23:57 GMT+02:00 Damian Minkov <damencho@jitsi.org>:

If that file is empty, this means that meet is served using nginx or
apache, you need to find which one, and whether the document root is
correctly pointing to your source checkout.
After the modifications in the source are you doing npm install and make?

On Wed, May 3, 2017 at 4:48 PM, Carles Morales <carlesm.95@gmail.com> >> wrote:
> Hi,
>
> yes, I'm using jvb to serve meet, is like the quick-install does. I have
> done that change but continues without working. In fact,
> /etc/jitsi/videobridge/sip-communicator.properties file was empty, I
added
> the line you said but continues without working if I change something.
Any
> suggestions?
>
> Kind regards,
> Carles.
>
> 2017-05-03 23:29 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>>
>> Hi,
>>
>> Are you using jvb to serve meet? If this is the case, I'm not sure
>> whether jetty caches something and jvb restart is needed.
>>
>> But if you are using jvb to serve meet in the above steps I described
>> you don't need to edit
>> /etc/nginx/sites-available/jitsi.example.com.conf you need to edit
>> /etc/jitsi/videobridge/sip-communicator.properties and change the
>> following line:
>>
>> org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBas
e=/usr/share/jitsi-meet
>> to be:
>>
>> org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/srv/
jitsi.example.com/
>>
>> Regards
>> damencho
>>
>>
>> On Wed, May 3, 2017 at 4:20 PM, Carles Morales <carlesm.95@gmail.com> >> >> wrote:
>> > Hi,
>> >
>> > I have done that but only works for the index page. When I implement
>> > changes
>> > in other files, for example in
>> > react/features/toolbox/defaultToolbarButtons.js it doesn't work,
loads
>> > the
>> > file from the quick install. I think I have to do make everytime I
made
>> > a
>> > change and restart videobridge? Am I right?
>> >
>> > Thanks,
>> > Carles.
>> >
>> > 2017-05-03 21:11 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >>
>> >> Hi,
>> >>
>> >> So the easiest way to make modifications and test them:
>> >> - install nginx
>> >> - deploy from debian packages, make sure it works (open two tabs, do
>> >> you see video)
>> >> - clone jitsi-meet, make it, let's say it is in /srv/
jitsi.example.com/
>> >> - change nginx config in:
>> >> /etc/nginx/sites-available/jitsi.example.com.conf, this line: root
>> >> /usr/share/jitsi-meet;
>> >> Change it to read: root /srv/jitsi.example.com/;
>> >> - /etc/init.d/nginx reload
>> >>
>> >> And now your deployment is using jitsi-meet from source.
>> >>
>> >> Regards
>> >> damencho
>> >>
>> >> On Wed, May 3, 2017 at 1:34 PM, Carles Morales < >> carlesm.95@gmail.com> >> >> >> wrote:
>> >> > Ok, seems like I have solved it by entering 'chmod -R 777 .git/'.
Now
>> >> > my
>> >> > question is, how do I should install jitsi-meet in order to have
all
>> >> > dependencies working in local? I mean, what I have done now is
clone
>> >> > the
>> >> > repository and follow the README instructions but jitsi-meet is
not
>> >> > running
>> >> > in my computer and if I follow the quick-install guide I can't do
npm
>> >> > install because there is no package.json there. So, how can I do
some
>> >> > changes in the code an test it in local?
>> >> >
>> >> > Thanks.
>> >> >
>> >> > 2017-05-03 18:59 GMT+02:00 Carles Morales <carlesm.95@gmail.com>:
>> >> >>
>> >> >> whoami &gt;&gt; &gt;&gt; &gt;&gt; root &gt;&gt; &gt;&gt; &gt;&gt; ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >> >> ls: cannot access to '/srv/jitsi.example.com/.git/h
ooks/pre-commit':
>> >> >> No
>> >> >> such file or directory
>> >> >>
>> >> >>
>> >> >> 2017-05-03 18:49 GMT+02:00 Damian Minkov <damencho@jitsi.org>:
>> >> >>>
>> >> >>> So have you check the file permissions of that file? What is the
>> >> >>> result of this commands:
>> >> >>> whoami &gt;&gt; &gt;&gt; &gt;&gt;&gt; ls -l /srv/jitsi.example.com/.git/hooks/pre-commit
>> >> >>>
>> >> >>>
>> >> >>>
>> >> >>> On Wed, May 3, 2017 at 11:40 AM, Carles Morales >> >> >> >>> <carlesm.95@gmail.com> >> >> >> >>> wrote:
>> >> >>> > No, I only have one account. I have tried with this solution:
>> >> >>> >
>> >> >>> >
>> >> >>> >
>> >> >>> > https://docs.npmjs.com/getting-started/fixing-npm-permission
s#option-2-change-npms-default-directory-to-another-directory
>> >> >>> >
>> >> >>> > but it doesn't work.
>> >> >>> >
>> >> >>> >
>> >> >>> >
>> >> >>> > 2017-05-03 18:22 GMT+02:00 Damian Minkov <damencho@jitsi.org
>:
>> >> >>> >>
>> >> >>> >>
>> >> >>> >> On Wed, May 3, 2017 at 11:05 AM, Carles Morales >> >> >> >>> >> <carlesm.95@gmail.com> >> >> >> >>> >> wrote:
>> >> >>> >>>
>> >> >>> >>> Error: EACCES: permission denied, open
>> >> >>> >>> '/srv/jitsi.example.com/.git/hooks/pre-commit'
>> >> >>> >>
>> >> >>> >>
>> >> >>> >> You have file permissions problems, you had cloned repo with
one
>> >> >>> >> account
>> >> >>> >> and compiling with another account, I suppose.
>> >> >>> >>
>> >> >>> >> _______________________________________________
>> >> >>> >> dev mailing list
>> >> >>> >> dev@jitsi.org
>> >> >>> >> Unsubscribe instructions and other list options:
>> >> >>> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >> >>> >
>> >> >>> >
>> >> >>> >
>> >> >>> > _______________________________________________
>> >> >>> > dev mailing list
>> >> >>> > dev@jitsi.org
>> >> >>> > Unsubscribe instructions and other list options:
>> >> >>> > http://lists.jitsi.org/mailman/listinfo/dev
>> >> >>>
>> >> >>> _______________________________________________
>> >> >>> dev mailing list
>> >> >>> dev@jitsi.org
>> >> >>> Unsubscribe instructions and other list options:
>> >> >>> http://lists.jitsi.org/mailman/listinfo/dev
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > dev mailing list
>> >> > dev@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/dev
>> >>
>> >> _______________________________________________
>> >> dev mailing list
>> >> dev@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >
>> >
>> >
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev