[jitsi-dev] How to config for multi jitsi-video-bridge instance?


#1

Dear Jitsi Team,

I want to ask how to config for multi jitsi-video-bridge instance.
Right now, in server 1, I already setup prosody and nginx and jicofo.
My prosody config in server 1 is:

VirtualHost "domain.of.server.1"

authentication = "anonymous"

ssl = {

key = "/var/lib/prosody/domain.of.server.1.key";

certificate = "/var/lib/prosody/domain.of.server.1.crt";

}

modules_enabled = {

"bosh";

"pubsub";

"s2s";

}

VirtualHost "auth.domain.of.server.1"

authentication = "internal_plain"

admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"

component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"

component_secret = "YOURSECRET2"

admins = {"domain.of.server.1","domain.of.server.2"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.2"

And in home/user/.sip-communicator/sip.comunicator.properties file, I
already added these lines:

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
  org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1

org.jitsi.videobridge.ENABLE_STATISTICS=true

org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub

org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1

org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1

org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

In server 2, I download Jitsi-video-bridge, and in
home/user/.sip-communicator/sip.comunicator.properties
file, I already added theses lines:

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2

org.jitsi.videobridge.ENABLE_STATISTICS=true

org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub

org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1

org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

But when I run this command in Jitsi-video-bridge on server 2:

screen ./jvb.sh --hosts=domain.of.server.1 --domain=domain.of.server.1
--port=8888
--secret=YOURSECRET1

It seems can connected to server 1, but can't get any information. The log
is:

org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
contained no data, host:domain.of.server.1, port:8888

In server 1, I checked the log in prosody, the component can't not be
bounded. The log is:

jitsi-videobridge1.domain.of.server.1:component warn Component not
connected, bouncing error for: <iq id='X01u5-819' type='get'
to='jitsi-videobridge1.domain.of.server.1'
from='focus@auth.domain.of.server.1/focus2936228778827373'>

Where do I wrong, thank you so much guys, have a good coding time.


#2

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1 as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins = {"jitsi-videobridge.domain.of.server.1","jvb2.domain.of.server.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

···

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov <damencho@damencho.com> wrote:

Have you tried using port 3478, the default one for connecting xmpp
components to prosody, port 8888 is for jvb health checking.

On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> wrote:

Dear Jitsi Team,

I want to ask how to config for multi jitsi-video-bridge instance.
Right now, in server 1, I already setup prosody and nginx and jicofo.
My prosody config in server 1 is:

VirtualHost "domain.of.server.1"

authentication = "anonymous"

ssl = {

key = "/var/lib/prosody/domain.of.server.1.key";

certificate = "/var/lib/prosody/domain.of.server.1.crt";

}

modules_enabled = {

"bosh";

"pubsub";

"s2s";

}

VirtualHost "auth.domain.of.server.1"

authentication = "internal_plain"

admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"

component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"

component_secret = "YOURSECRET2"

admins = {"domain.of.server.1","domain.of.server.2"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.2"

And in home/user/.sip-communicator/sip.comunicator.properties file, I
already added these lines:

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1

org.jitsi.videobridge.ENABLE_STATISTICS=true

org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub

org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1

org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1

org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

In server 2, I download Jitsi-video-bridge, and in
home/user/.sip-communicator/sip.comunicator.properties file, I already added
theses lines:

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2

org.jitsi.videobridge.ENABLE_STATISTICS=true

org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub

org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1

org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

But when I run this command in Jitsi-video-bridge on server 2:

screen ./jvb.sh --hosts=domain.of.server.1 --domain=domain.of.server.1
--port=8888 --secret=YOURSECRET1

It seems can connected to server 1, but can't get any information. The log
is:

org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
contained no data, host:domain.of.server.1, port:8888

In server 1, I checked the log in prosody, the component can't not be
bounded. The log is:

jitsi-videobridge1.domain.of.server.1:component warn Component not
connected, bouncing error for: <iq id='X01u5-819' type='get'
to='jitsi-videobridge1.domain.of.server.1'
from='focus@auth.domain.of.server.1/focus2936228778827373'>

Where do I wrong, thank you so much guys, have a good coding time.
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Have you tried using port 3478, the default one for connecting xmpp
components to prosody, port 8888 is for jvb health checking.

···

On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> wrote:

Dear Jitsi Team,

I want to ask how to config for multi jitsi-video-bridge instance.
Right now, in server 1, I already setup prosody and nginx and jicofo.
My prosody config in server 1 is:

VirtualHost "domain.of.server.1"

authentication = "anonymous"

ssl = {

key = "/var/lib/prosody/domain.of.server.1.key";

certificate = "/var/lib/prosody/domain.of.server.1.crt";

}

modules_enabled = {

"bosh";

"pubsub";

"s2s";

}

VirtualHost "auth.domain.of.server.1"

authentication = "internal_plain"

admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"

component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"

component_secret = "YOURSECRET2"

admins = {"domain.of.server.1","domain.of.server.2"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.2"

And in home/user/.sip-communicator/sip.comunicator.properties file, I
already added these lines:

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
  org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1

org.jitsi.videobridge.ENABLE_STATISTICS=true

org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub

org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1

org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1

org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

In server 2, I download Jitsi-video-bridge, and in home/user/.sip-communicator/sip.comunicator.properties
file, I already added theses lines:

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1

org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2

org.jitsi.videobridge.ENABLE_STATISTICS=true

org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub

org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1

org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

But when I run this command in Jitsi-video-bridge on server 2:

screen ./jvb.sh --hosts=domain.of.server.1 --domain=domain.of.server.1 --port=8888
--secret=YOURSECRET1

It seems can connected to server 1, but can't get any information. The log
is:

org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
contained no data, host:domain.of.server.1, port:8888

In server 1, I checked the log in prosody, the component can't not be
bounded. The log is:

jitsi-videobridge1.domain.of.server.1:component warn Component not
connected, bouncing error for: <iq id='X01u5-819' type='get'
to='jitsi-videobridge1.domain.of.server.1'
from='focus@auth.domain.of.server.1/focus2936228778827373'>

Where do I wrong, thank you so much guys, have a good coding time.
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Thank you so much Damian Minkov :smiley:

···

On Wed, Mar 28, 2018 at 10:15 PM, Damian Minkov <damencho@damencho.com> wrote:

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is
ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1 as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins = {"jitsi-videobridge.domain.of.server.1","jvb2.domain.of.
server.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov <damencho@damencho.com> > wrote:
> Have you tried using port 3478, the default one for connecting xmpp
> components to prosody, port 8888 is for jvb health checking.
>
> On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> wrote:
>>
>> Dear Jitsi Team,
>>
>> I want to ask how to config for multi jitsi-video-bridge instance.
>> Right now, in server 1, I already setup prosody and nginx and jicofo.
>> My prosody config in server 1 is:
>>
>> VirtualHost "domain.of.server.1"
>>
>> authentication = "anonymous"
>>
>> ssl = {
>>
>> key = "/var/lib/prosody/domain.of.server.1.key";
>>
>> certificate = "/var/lib/prosody/domain.of.server.1.crt";
>>
>> }
>>
>> modules_enabled = {
>>
>> "bosh";
>>
>> "pubsub";
>>
>> "s2s";
>>
>> }
>>
>> VirtualHost "auth.domain.of.server.1"
>>
>> authentication = "internal_plain"
>>
>> admins = { "focus@auth.domain.of.server.1"}
>>
>> Component "conference.domain.of.server.1" "muc"
>>
>> Component "jitsi-videobridge.domain.of.server.1"
>>
>> component_secret = "YOURSECRET1"
>>
>> Component "focus.domain.of.server.1"
>>
>> component_secret = "YOURSECRET2"
>>
>> admins = {"domain.of.server.1","domain.of.server.2"}
>>
>> allow_anonymous_s2s = true
>>
>> component_ports = { 8888 }
>>
>> component_interface = "ip.of.server.2"
>>
>>
>> And in home/user/.sip-communicator/sip.comunicator.properties file, I
>> already added these lines:
>>
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=
false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>> org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
>>
>> org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode
>>
>>
>> In server 2, I download Jitsi-video-bridge, and in
>> home/user/.sip-communicator/sip.comunicator.properties file, I already
added
>> theses lines:
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=
false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>>
>> But when I run this command in Jitsi-video-bridge on server 2:
>>
>> screen ./jvb.sh --hosts=domain.of.server.1 --domain=domain.of.server.1
>> --port=8888 --secret=YOURSECRET1
>>
>>
>> It seems can connected to server 1, but can't get any information. The
log
>> is:
>>
>> org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
>> contained no data, host:domain.of.server.1, port:8888
>>
>>
>> In server 1, I checked the log in prosody, the component can't not be
>> bounded. The log is:
>>
>> jitsi-videobridge1.domain.of.server.1:component warn Component not
>> connected, bouncing error for: <iq id='X01u5-819' type='get'
>> to='jitsi-videobridge1.domain.of.server.1'
>> from='focus@auth.domain.of.server.1/focus2936228778827373'>
>>
>>
>> Where do I wrong, thank you so much guys, have a good coding time.
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Dear Damian Minkov,

After config and running the command, it said:

org.jitsi.meet.ComponentMain.call().278 unsupported-stanza-type,

Where can I fix this error. Thank you so much.

···

On Wed, Mar 28, 2018 at 10:34 PM, Trần Hoài Nam <namth4@topica.edu.vn> wrote:

Thank you so much Damian Minkov :smiley:

On Wed, Mar 28, 2018 at 10:15 PM, Damian Minkov <damencho@damencho.com> > wrote:

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is
ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1 as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins = {"jitsi-videobridge.domain.of.server.1","jvb2.domain.of.serv
er.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov <damencho@damencho.com> >> wrote:
> Have you tried using port 3478, the default one for connecting xmpp
> components to prosody, port 8888 is for jvb health checking.
>
> On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> wrote:
>>
>> Dear Jitsi Team,
>>
>> I want to ask how to config for multi jitsi-video-bridge instance.
>> Right now, in server 1, I already setup prosody and nginx and jicofo.
>> My prosody config in server 1 is:
>>
>> VirtualHost "domain.of.server.1"
>>
>> authentication = "anonymous"
>>
>> ssl = {
>>
>> key = "/var/lib/prosody/domain.of.server.1.key";
>>
>> certificate = "/var/lib/prosody/domain.of.server.1.crt";
>>
>> }
>>
>> modules_enabled = {
>>
>> "bosh";
>>
>> "pubsub";
>>
>> "s2s";
>>
>> }
>>
>> VirtualHost "auth.domain.of.server.1"
>>
>> authentication = "internal_plain"
>>
>> admins = { "focus@auth.domain.of.server.1"}
>>
>> Component "conference.domain.of.server.1" "muc"
>>
>> Component "jitsi-videobridge.domain.of.server.1"
>>
>> component_secret = "YOURSECRET1"
>>
>> Component "focus.domain.of.server.1"
>>
>> component_secret = "YOURSECRET2"
>>
>> admins = {"domain.of.server.1","domain.of.server.2"}
>>
>> allow_anonymous_s2s = true
>>
>> component_ports = { 8888 }
>>
>> component_interface = "ip.of.server.2"
>>
>>
>> And in home/user/.sip-communicator/sip.comunicator.properties file, I
>> already added these lines:
>>
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.
checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>> org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
>>
>> org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode
>>
>>
>> In server 2, I download Jitsi-video-bridge, and in
>> home/user/.sip-communicator/sip.comunicator.properties file, I
already added
>> theses lines:
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.
checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>>
>> But when I run this command in Jitsi-video-bridge on server 2:
>>
>> screen ./jvb.sh --hosts=domain.of.server.1 --domain=domain.of.server.1
>> --port=8888 --secret=YOURSECRET1
>>
>>
>> It seems can connected to server 1, but can't get any information. The
log
>> is:
>>
>> org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
>> contained no data, host:domain.of.server.1, port:8888
>>
>>
>> In server 1, I checked the log in prosody, the component can't not be
>> bounded. The log is:
>>
>> jitsi-videobridge1.domain.of.server.1:component warn Component not
>> connected, bouncing error for: <iq id='X01u5-819' type='get'
>> to='jitsi-videobridge1.domain.of.server.1'
>> from='focus@auth.domain.of.server.1/focus2936228778827373'>
>>
>>
>> Where do I wrong, thank you so much guys, have a good coding time.
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Did you use the component port for connecting, the one that prosody is
using?
What is the value of component_ports = { 5347 } in
your /etc/prosody/prosody.cfg.lua?

···

On Wed, Mar 28, 2018 at 12:55 PM, Trần Hoài Nam <namth4@topica.edu.vn> wrote:

Dear Damian Minkov,

After config and running the command, it said:

org.jitsi.meet.ComponentMain.call().278 unsupported-stanza-type,

Where can I fix this error. Thank you so much.

On Wed, Mar 28, 2018 at 10:34 PM, Trần Hoài Nam <namth4@topica.edu.vn> > wrote:

Thank you so much Damian Minkov :smiley:

On Wed, Mar 28, 2018 at 10:15 PM, Damian Minkov <damencho@damencho.com> >> wrote:

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is
ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1 as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins = {"jitsi-videobridge.domain.of.server.1","jvb2.domain.of.serv
er.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.i
p.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.i
p.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov <damencho@damencho.com> >>> wrote:
> Have you tried using port 3478, the default one for connecting xmpp
> components to prosody, port 8888 is for jvb health checking.
>
> On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> >>> wrote:
>>
>> Dear Jitsi Team,
>>
>> I want to ask how to config for multi jitsi-video-bridge instance.
>> Right now, in server 1, I already setup prosody and nginx and jicofo.
>> My prosody config in server 1 is:
>>
>> VirtualHost "domain.of.server.1"
>>
>> authentication = "anonymous"
>>
>> ssl = {
>>
>> key = "/var/lib/prosody/domain.of.server.1.key";
>>
>> certificate = "/var/lib/prosody/domain.of.server.1.crt";
>>
>> }
>>
>> modules_enabled = {
>>
>> "bosh";
>>
>> "pubsub";
>>
>> "s2s";
>>
>> }
>>
>> VirtualHost "auth.domain.of.server.1"
>>
>> authentication = "internal_plain"
>>
>> admins = { "focus@auth.domain.of.server.1"}
>>
>> Component "conference.domain.of.server.1" "muc"
>>
>> Component "jitsi-videobridge.domain.of.server.1"
>>
>> component_secret = "YOURSECRET1"
>>
>> Component "focus.domain.of.server.1"
>>
>> component_secret = "YOURSECRET2"
>>
>> admins = {"domain.of.server.1","domain.of.server.2"}
>>
>> allow_anonymous_s2s = true
>>
>> component_ports = { 8888 }
>>
>> component_interface = "ip.of.server.2"
>>
>>
>> And in home/user/.sip-communicator/sip.comunicator.properties file, I
>> already added these lines:
>>
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.che
ckReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>> org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
>>
>> org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode
>>
>>
>> In server 2, I download Jitsi-video-bridge, and in
>> home/user/.sip-communicator/sip.comunicator.properties file, I
already added
>> theses lines:
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.che
ckReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>>
>> But when I run this command in Jitsi-video-bridge on server 2:
>>
>> screen ./jvb.sh --hosts=domain.of.server.1 --domain=domain.of.server.1
>> --port=8888 --secret=YOURSECRET1
>>
>>
>> It seems can connected to server 1, but can't get any information.
The log
>> is:
>>
>> org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
>> contained no data, host:domain.of.server.1, port:8888
>>
>>
>> In server 1, I checked the log in prosody, the component can't not be
>> bounded. The log is:
>>
>> jitsi-videobridge1.domain.of.server.1:component warn Component not
>> connected, bouncing error for: <iq id='X01u5-819' type='get'
>> to='jitsi-videobridge1.domain.of.server.1'
>> from='focus@auth.domain.of.server.1/focus2936228778827373'>
>>
>>
>> Where do I wrong, thank you so much guys, have a good coding time.
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi,

Glad it worked.
Can you please close any tickets left open on this subject. You can leave a
comment pointing to this thread:
http://lists.jitsi.org/pipermail/dev/2018-March/037380.html

Thanks
damencho

···

On Wed, Mar 28, 2018 at 2:31 PM, Trần Hoài Nam <namth4@topica.edu.vn> wrote:

Thank you again for helping me. You are so kind and supportive :smiley:

On Thu, Mar 29, 2018 at 2:26 AM Trần Hoài Nam <namth4@topica.edu.vn> > wrote:

Thank you so much, that’s my mistake. I fixed that. :D.

On Thu, Mar 29, 2018 at 1:39 AM Damian Minkov <damencho@jitsi.org> wrote:

Did you use the component port for connecting, the one that prosody is
using?
What is the value of component_ports = { 5347 } in
your /etc/prosody/prosody.cfg.lua?

On Wed, Mar 28, 2018 at 12:55 PM, Trần Hoài Nam <namth4@topica.edu.vn> >>> wrote:

Dear Damian Minkov,

After config and running the command, it said:

org.jitsi.meet.ComponentMain.call().278 unsupported-stanza-type,

Where can I fix this error. Thank you so much.

On Wed, Mar 28, 2018 at 10:34 PM, Trần Hoài Nam <namth4@topica.edu.vn> >>>> wrote:

Thank you so much Damian Minkov :smiley:

On Wed, Mar 28, 2018 at 10:15 PM, Damian Minkov <damencho@damencho.com >>>>> > wrote:

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is
ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1 as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins = {"jitsi-videobridge.domain.of.server.1","jvb2.domain.of.
server.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=
internal.ip.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=
internal.ip.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov <damencho@damencho.com> >>>>>> wrote:
> Have you tried using port 3478, the default one for connecting xmpp
> components to prosody, port 8888 is for jvb health checking.
>
> On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> >>>>>> wrote:
>>
>> Dear Jitsi Team,
>>
>> I want to ask how to config for multi jitsi-video-bridge instance.
>> Right now, in server 1, I already setup prosody and nginx and
jicofo.
>> My prosody config in server 1 is:
>>
>> VirtualHost "domain.of.server.1"
>>
>> authentication = "anonymous"
>>
>> ssl = {
>>
>> key = "/var/lib/prosody/domain.of.server.1.key";
>>
>> certificate = "/var/lib/prosody/domain.of.server.1.crt";
>>
>> }
>>
>> modules_enabled = {
>>
>> "bosh";
>>
>> "pubsub";
>>
>> "s2s";
>>
>> }
>>
>> VirtualHost "auth.domain.of.server.1"
>>
>> authentication = "internal_plain"
>>
>> admins = { "focus@auth.domain.of.server.1"}
>>
>> Component "conference.domain.of.server.1" "muc"
>>
>> Component "jitsi-videobridge.domain.of.server.1"
>>
>> component_secret = "YOURSECRET1"
>>
>> Component "focus.domain.of.server.1"
>>
>> component_secret = "YOURSECRET2"
>>
>> admins = {"domain.of.server.1","domain.of.server.2"}
>>
>> allow_anonymous_s2s = true
>>
>> component_ports = { 8888 }
>>
>> component_interface = "ip.of.server.2"
>>
>>
>> And in home/user/.sip-communicator/sip.comunicator.properties
file, I
>> already added these lines:
>>
>>
>> org.jitsi.impl.neomedia.transform.srtp.
SRTPCryptoContext.checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>> org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
>>
>> org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode
>>
>>
>> In server 2, I download Jitsi-video-bridge, and in
>> home/user/.sip-communicator/sip.comunicator.properties file, I
already added
>> theses lines:
>>
>> org.jitsi.impl.neomedia.transform.srtp.
SRTPCryptoContext.checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>>
>> But when I run this command in Jitsi-video-bridge on server 2:
>>
>> screen ./jvb.sh --hosts=domain.of.server.1
--domain=domain.of.server.1
>> --port=8888 --secret=YOURSECRET1
>>
>>
>> It seems can connected to server 1, but can't get any information.
The log
>> is:
>>
>> org.jitsi.meet.ComponentMain.call().278 java.io.EOFException:
input
>> contained no data, host:domain.of.server.1, port:8888
>>
>>
>> In server 1, I checked the log in prosody, the component can't not
be
>> bounded. The log is:
>>
>> jitsi-videobridge1.domain.of.server.1:component warn Component not
>> connected, bouncing error for: <iq id='X01u5-819' type='get'
>> to='jitsi-videobridge1.domain.of.server.1'
>> from='focus@auth.domain.of.server.1/focus2936228778827373'>
>>
>>
>> Where do I wrong, thank you so much guys, have a good coding time.
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Thank you so much, that’s my mistake. I fixed that. :D.

···

On Thu, Mar 29, 2018 at 1:39 AM Damian Minkov <damencho@jitsi.org> wrote:

Did you use the component port for connecting, the one that prosody is
using?
What is the value of component_ports = { 5347 } in
your /etc/prosody/prosody.cfg.lua?

On Wed, Mar 28, 2018 at 12:55 PM, Trần Hoài Nam <namth4@topica.edu.vn> > wrote:

Dear Damian Minkov,

After config and running the command, it said:

org.jitsi.meet.ComponentMain.call().278 unsupported-stanza-type,

Where can I fix this error. Thank you so much.

On Wed, Mar 28, 2018 at 10:34 PM, Trần Hoài Nam <namth4@topica.edu.vn> >> wrote:

Thank you so much Damian Minkov :smiley:

On Wed, Mar 28, 2018 at 10:15 PM, Damian Minkov <damencho@damencho.com> >>> wrote:

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is
ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1 as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins =
{"jitsi-videobridge.domain.of.server.1","jvb2.domain.of.server.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov <damencho@damencho.com> >>>> wrote:
> Have you tried using port 3478, the default one for connecting xmpp
> components to prosody, port 8888 is for jvb health checking.
>
> On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> >>>> wrote:
>>
>> Dear Jitsi Team,
>>
>> I want to ask how to config for multi jitsi-video-bridge instance.
>> Right now, in server 1, I already setup prosody and nginx and jicofo.
>> My prosody config in server 1 is:
>>
>> VirtualHost "domain.of.server.1"
>>
>> authentication = "anonymous"
>>
>> ssl = {
>>
>> key = "/var/lib/prosody/domain.of.server.1.key";
>>
>> certificate = "/var/lib/prosody/domain.of.server.1.crt";
>>
>> }
>>
>> modules_enabled = {
>>
>> "bosh";
>>
>> "pubsub";
>>
>> "s2s";
>>
>> }
>>
>> VirtualHost "auth.domain.of.server.1"
>>
>> authentication = "internal_plain"
>>
>> admins = { "focus@auth.domain.of.server.1"}
>>
>> Component "conference.domain.of.server.1" "muc"
>>
>> Component "jitsi-videobridge.domain.of.server.1"
>>
>> component_secret = "YOURSECRET1"
>>
>> Component "focus.domain.of.server.1"
>>
>> component_secret = "YOURSECRET2"
>>
>> admins = {"domain.of.server.1","domain.of.server.2"}
>>
>> allow_anonymous_s2s = true
>>
>> component_ports = { 8888 }
>>
>> component_interface = "ip.of.server.2"
>>
>>
>> And in home/user/.sip-communicator/sip.comunicator.properties file, I
>> already added these lines:
>>
>>
>>
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>> org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
>>
>> org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode
>>
>>
>> In server 2, I download Jitsi-video-bridge, and in
>> home/user/.sip-communicator/sip.comunicator.properties file, I
already added
>> theses lines:
>>
>>
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>>
>> But when I run this command in Jitsi-video-bridge on server 2:
>>
>> screen ./jvb.sh --hosts=domain.of.server.1
--domain=domain.of.server.1
>> --port=8888 --secret=YOURSECRET1
>>
>>
>> It seems can connected to server 1, but can't get any information.
The log
>> is:
>>
>> org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
>> contained no data, host:domain.of.server.1, port:8888
>>
>>
>> In server 1, I checked the log in prosody, the component can't not be
>> bounded. The log is:
>>
>> jitsi-videobridge1.domain.of.server.1:component warn Component not
>> connected, bouncing error for: <iq id='X01u5-819' type='get'
>> to='jitsi-videobridge1.domain.of.server.1'
>> from='focus@auth.domain.of.server.1/focus2936228778827373'>
>>
>>
>> Where do I wrong, thank you so much guys, have a good coding time.
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Thank you again for helping me. You are so kind and supportive :smiley:

···

On Thu, Mar 29, 2018 at 2:26 AM Trần Hoài Nam <namth4@topica.edu.vn> wrote:

Thank you so much, that’s my mistake. I fixed that. :D.

On Thu, Mar 29, 2018 at 1:39 AM Damian Minkov <damencho@jitsi.org> wrote:

Did you use the component port for connecting, the one that prosody is
using?
What is the value of component_ports = { 5347 } in
your /etc/prosody/prosody.cfg.lua?

On Wed, Mar 28, 2018 at 12:55 PM, Trần Hoài Nam <namth4@topica.edu.vn> >> wrote:

Dear Damian Minkov,

After config and running the command, it said:

org.jitsi.meet.ComponentMain.call().278 unsupported-stanza-type,

Where can I fix this error. Thank you so much.

On Wed, Mar 28, 2018 at 10:34 PM, Trần Hoài Nam <namth4@topica.edu.vn> >>> wrote:

Thank you so much Damian Minkov :smiley:

On Wed, Mar 28, 2018 at 10:15 PM, Damian Minkov <damencho@damencho.com> >>>> wrote:

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is
ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1 as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins =
{"jitsi-videobridge.domain.of.server.1","jvb2.domain.of.server.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.ip.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov <damencho@damencho.com> >>>>> wrote:
> Have you tried using port 3478, the default one for connecting xmpp
> components to prosody, port 8888 is for jvb health checking.
>
> On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> >>>>> wrote:
>>
>> Dear Jitsi Team,
>>
>> I want to ask how to config for multi jitsi-video-bridge instance.
>> Right now, in server 1, I already setup prosody and nginx and
jicofo.
>> My prosody config in server 1 is:
>>
>> VirtualHost "domain.of.server.1"
>>
>> authentication = "anonymous"
>>
>> ssl = {
>>
>> key = "/var/lib/prosody/domain.of.server.1.key";
>>
>> certificate = "/var/lib/prosody/domain.of.server.1.crt";
>>
>> }
>>
>> modules_enabled = {
>>
>> "bosh";
>>
>> "pubsub";
>>
>> "s2s";
>>
>> }
>>
>> VirtualHost "auth.domain.of.server.1"
>>
>> authentication = "internal_plain"
>>
>> admins = { "focus@auth.domain.of.server.1"}
>>
>> Component "conference.domain.of.server.1" "muc"
>>
>> Component "jitsi-videobridge.domain.of.server.1"
>>
>> component_secret = "YOURSECRET1"
>>
>> Component "focus.domain.of.server.1"
>>
>> component_secret = "YOURSECRET2"
>>
>> admins = {"domain.of.server.1","domain.of.server.2"}
>>
>> allow_anonymous_s2s = true
>>
>> component_ports = { 8888 }
>>
>> component_interface = "ip.of.server.2"
>>
>>
>> And in home/user/.sip-communicator/sip.comunicator.properties file,
I
>> already added these lines:
>>
>>
>>
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>> org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
>>
>> org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode
>>
>>
>> In server 2, I download Jitsi-video-bridge, and in
>> home/user/.sip-communicator/sip.comunicator.properties file, I
already added
>> theses lines:
>>
>>
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>>
>> But when I run this command in Jitsi-video-bridge on server 2:
>>
>> screen ./jvb.sh --hosts=domain.of.server.1
--domain=domain.of.server.1
>> --port=8888 --secret=YOURSECRET1
>>
>>
>> It seems can connected to server 1, but can't get any information.
The log
>> is:
>>
>> org.jitsi.meet.ComponentMain.call().278 java.io.EOFException: input
>> contained no data, host:domain.of.server.1, port:8888
>>
>>
>> In server 1, I checked the log in prosody, the component can't not
be
>> bounded. The log is:
>>
>> jitsi-videobridge1.domain.of.server.1:component warn Component not
>> connected, bouncing error for: <iq id='X01u5-819' type='get'
>> to='jitsi-videobridge1.domain.of.server.1'
>> from='focus@auth.domain.of.server.1/focus2936228778827373'>
>>
>>
>> Where do I wrong, thank you so much guys, have a good coding time.
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi,

Sure, but I don't see any button that help me to close tickets. Or I
misunderstand what you want, can you tell me clearly.

Thank you so much.

···

On Thu, Mar 29, 2018 at 2:49 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Glad it worked.
Can you please close any tickets left open on this subject. You can leave
a comment pointing to this thread: http://lists.jitsi.
org/pipermail/dev/2018-March/037380.html

Thanks
damencho

On Wed, Mar 28, 2018 at 2:31 PM, Trần Hoài Nam <namth4@topica.edu.vn> > wrote:

Thank you again for helping me. You are so kind and supportive :smiley:

On Thu, Mar 29, 2018 at 2:26 AM Trần Hoài Nam <namth4@topica.edu.vn> >> wrote:

Thank you so much, that’s my mistake. I fixed that. :D.

On Thu, Mar 29, 2018 at 1:39 AM Damian Minkov <damencho@jitsi.org> >>> wrote:

Did you use the component port for connecting, the one that prosody is
using?
What is the value of component_ports = { 5347 } in
your /etc/prosody/prosody.cfg.lua?

On Wed, Mar 28, 2018 at 12:55 PM, Trần Hoài Nam <namth4@topica.edu.vn> >>>> wrote:

Dear Damian Minkov,

After config and running the command, it said:

org.jitsi.meet.ComponentMain.call().278 unsupported-stanza-type,

Where can I fix this error. Thank you so much.

On Wed, Mar 28, 2018 at 10:34 PM, Trần Hoài Nam <namth4@topica.edu.vn> >>>>> wrote:

Thank you so much Damian Minkov :smiley:

On Wed, Mar 28, 2018 at 10:15 PM, Damian Minkov < >>>>>> damencho@damencho.com> wrote:

On a second look at your config, there are multiple issues ...

server1, is running nginx, prosody and jvb1 and its address is
ip.of.server.1.
server2 is running only jvb and its address is ip.of.server.2

So I assume when you were installing you entered domain.of.server.1
as
a service name.
So prosody config should be:

VirtualHost "domain.of.server.1"
authentication = "anonymous"
ssl = {
key = "/var/lib/prosody/domain.of.server.1.key";
certificate = "/var/lib/prosody/domain.of.server.1.crt";
}

modules_enabled = {
"bosh";
"pubsub";
"s2s";
}

VirtualHost "auth.domain.of.server.1"
authentication = "internal_plain"
admins = { "focus@auth.domain.of.server.1"}

Component "conference.domain.of.server.1" "muc"

Component "jitsi-videobridge.domain.of.server.1"
component_secret = "YOURSECRET1"

Component "focus.domain.of.server.1"
component_secret = "YOURSECRET2"

admins = {"jitsi-videobridge.domain.of.
server.1","jvb2.domain.of.server.1"}

allow_anonymous_s2s = true

component_ports = { 8888 }

component_interface = "ip.of.server.1"

Component "jvb2.domain.of.server.1"
component_secret = "YOURSECRET3"

Jicofo on server1 sip-communicator.properties:
org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
org.jitsi.jicofo.STATS_PUBSUB_NODE= sharedStatsNode

First jvb on server1 sip-communicator.properties:
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.
ip.of.server.1
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

Second jvb on server2 sip-communicator.properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=internal.
ip.of.server.2
(not 127.0.0.1)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

To run jvb on server2 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--subdomain=jvb2 --port=5347 --secret=YOURSECRET3
To run jvb on server1 you need to run:
./jvb.sh --host=ip.of.server.1 --domain=domain.of.server.1
--port=5347 --secret=YOURSECRET1

The default port of prosody is 5347, not as I wrote earlier 3478.

Hope this helps.

Regards
damencho

On Wed, Mar 28, 2018 at 7:59 AM, Damian Minkov < >>>>>>> damencho@damencho.com> wrote:
> Have you tried using port 3478, the default one for connecting xmpp
> components to prosody, port 8888 is for jvb health checking.
>
> On Wed, Mar 28, 2018, 04:48 Trần Hoài Nam <namth4@topica.edu.vn> >>>>>>> wrote:
>>
>> Dear Jitsi Team,
>>
>> I want to ask how to config for multi jitsi-video-bridge instance.
>> Right now, in server 1, I already setup prosody and nginx and
jicofo.
>> My prosody config in server 1 is:
>>
>> VirtualHost "domain.of.server.1"
>>
>> authentication = "anonymous"
>>
>> ssl = {
>>
>> key = "/var/lib/prosody/domain.of.server.1.key";
>>
>> certificate = "/var/lib/prosody/domain.of.server.1.crt";
>>
>> }
>>
>> modules_enabled = {
>>
>> "bosh";
>>
>> "pubsub";
>>
>> "s2s";
>>
>> }
>>
>> VirtualHost "auth.domain.of.server.1"
>>
>> authentication = "internal_plain"
>>
>> admins = { "focus@auth.domain.of.server.1"}
>>
>> Component "conference.domain.of.server.1" "muc"
>>
>> Component "jitsi-videobridge.domain.of.server.1"
>>
>> component_secret = "YOURSECRET1"
>>
>> Component "focus.domain.of.server.1"
>>
>> component_secret = "YOURSECRET2"
>>
>> admins = {"domain.of.server.1","domain.of.server.2"}
>>
>> allow_anonymous_s2s = true
>>
>> component_ports = { 8888 }
>>
>> component_interface = "ip.of.server.2"
>>
>>
>> And in home/user/.sip-communicator/sip.comunicator.properties
file, I
>> already added these lines:
>>
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.
checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.1
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>> org.jitsi.focus.pubsub.ADDRESS=domain.of.server.1
>>
>> org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode
>>
>>
>> In server 2, I download Jitsi-video-bridge, and in
>> home/user/.sip-communicator/sip.comunicator.properties file, I
already added
>> theses lines:
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.
checkReplay=false
>> org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
>>
>> org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=ip.of.server.2
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=true
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
>>
>> org.jitsi.videobridge.PUBSUB_SERVICE=domain.of.server.1
>>
>> org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
>>
>>
>> But when I run this command in Jitsi-video-bridge on server 2:
>>
>> screen ./jvb.sh --hosts=domain.of.server.1
--domain=domain.of.server.1
>> --port=8888 --secret=YOURSECRET1
>>
>>
>> It seems can connected to server 1, but can't get any
information. The log
>> is:
>>
>> org.jitsi.meet.ComponentMain.call().278 java.io.EOFException:
input
>> contained no data, host:domain.of.server.1, port:8888
>>
>>
>> In server 1, I checked the log in prosody, the component can't
not be
>> bounded. The log is:
>>
>> jitsi-videobridge1.domain.of.server.1:component warn Component
not
>> connected, bouncing error for: <iq id='X01u5-819' type='get'
>> to='jitsi-videobridge1.domain.of.server.1'
>> from='focus@auth.domain.of.server.1/focus2936228778827373'>
>>
>>
>> Where do I wrong, thank you so much guys, have a good coding time.
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev