[jitsi-dev] How compile ffmpeg win and mac


#1

Hi all,

I'm trying to rebuild jni ffmpeg to add the way to set some extra AVCodecContext property,
i.e. context->level for H264 profile

I followed src/native/README instructions, but I'm aving problems to compile the lib
in win (mingw) and mac.

which versions of the x264 and ffmpeg I use?

I tried latest snapshot x264, lame-3.98.4, and ffmpeg 0.8.1

Tnx
Davide


#2

which versions of the x264 and ffmpeg I use?

The binaries have been compiled with ffmpeg pulled from the git
repository and checked out from the master branch a few days before
committing them (because it takes a few days to build them for the
three supported platforms, test them and fix bugs in our code caused
by compatibility or modifications which have caused the update).

Since we use ffmpeg as a moving target, we usually take an x264
snapshot from the day of the last commit made to the ffmpeg tree we've
checked out.

As far as lame is concerned, we use the latest (stable) release.

I tried latest snapshot x264, lame-3.98.4, and ffmpeg 0.8.1

Didn't these work? As I noted above, updating ffmpeg is not always
just a question of rebuilding and more often than not we have to
update our source code to resolve compatibility issues.

ยทยทยท

On Mon, Aug 1, 2011 at 3:19 PM, Davide Corda <davide.corda@abbeynet.it> wrote: