[jitsi-dev] handleIQError jitsi-videobridge ejabberd ping timeout


#1

Hello all,

Im trying a new setup with ejabberd, jitsi-videobridge and jicofo., Jitsi-meet
should run on another machine.
ubuntu server 14.04
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b17)

followed instructions: https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

and getting this in jvb.log when starrting the bridge:

Jan 14, 2016 8:41:24 PM org.jitsi.util.Logger info
INFORMATION: RECV: <iq from="domain.tld" to="jitsi-videobridge.domain.tld"
type="error" id="QiBAF-32"><ping xmlns="urn:xmpp:ping"/><error code="501"
type="cancel"><feature-not-implemented xmlns="urn:ietf:params:xml:ns:xmpp-
stanzas"/></error></iq>
Jan 14, 2016 8:41:29 PM net.java.sip.communicator.util.Logger error
SCHWERWIEGEND: Ping timeout for ID: QiBAF-32
Jan 14, 2016 8:41:34 PM org.xmpp.component.AbstractComponent handleIQError
INFORMATION: (serving component 'JitsiVideobridge') IQ stanza of type
<tt>error</tt> received:

ejabberd log shows okay:
[debug] <0.795.0>@ejabberd_receiver:process_data:349 Received XML on stream =
<<"<iq id=\"mh20R-4\" to=\"jitsi-videobridge.domain.tld\" from=\"jitsi-
videobridge.jitsi-videobridge.domain.tld\" type=\"get\"><ping xmlns=
\"urn:xmpp:ping\"></ping></iq>">>

I tried alot around and did searching on the web but can not solve it.

Im having another test machine with prosody. There is no such error.

How can I solve it?
Can someone help?

tia
Stefan


#2

Hi !

ยทยทยท

On Thu, Jan 14, 2016 at 2:54 PM, Stefan Fuhrmann <stefan.fuhrmann@no-panic-systems.de> wrote:

Hello all,

Im trying a new setup with ejabberd, jitsi-videobridge and jicofo., Jitsi-meet
should run on another machine.
ubuntu server 14.04
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b17)

followed instructions: https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

and getting this in jvb.log when starrting the bridge:

Jan 14, 2016 8:41:24 PM org.jitsi.util.Logger info
INFORMATION: RECV: <iq from="domain.tld" to="jitsi-videobridge.domain.tld"
type="error" id="QiBAF-32"><ping xmlns="urn:xmpp:ping"/><error code="501"
type="cancel"><feature-not-implemented xmlns="urn:ietf:params:xml:ns:xmpp-
stanzas"/></error></iq>
Jan 14, 2016 8:41:29 PM net.java.sip.communicator.util.Logger error
SCHWERWIEGEND: Ping timeout for ID: QiBAF-32
Jan 14, 2016 8:41:34 PM org.xmpp.component.AbstractComponent handleIQError
INFORMATION: (serving component 'JitsiVideobridge') IQ stanza of type
<tt>error</tt> received:

ejabberd log shows okay:
[debug] <0.795.0>@ejabberd_receiver:process_data:349 Received XML on stream =
<<"<iq id=\"mh20R-4\" to=\"jitsi-videobridge.domain.tld\" from=\"jitsi-
videobridge.jitsi-videobridge.domain.tld\" type=\"get\"><ping xmlns=
\"urn:xmpp:ping\"></ping></iq>">>

I tried alot around and did searching on the web but can not solve it.

Im having another test machine with prosody. There is no such error.

How can I solve it?
Can someone help?

It seems that XMPP host "domain.tld" does not support pings. You can
disable them in JVB by adding this line to
/etc/jitsi/videobridge/sip-communicator.properties file:

org.jitsi.videobridge.PING_INTERVAL=-1

Regards,
Pawel