[jitsi-dev] H.264 only in jitsi-meet


#1

Is there a simple way to do that?

Thanks,

/Kaiduan


#2

Yes and no. There is a setting you can set in config.js : preferH264, which will prefer H264 if set to true. The problem, however, is that there are some fixes necessary in the JVB in order to make it work. You would lose simulcast too, which can yield a significantly higher bandwidth usage.

Cheers,

···

On Jun 28, 2017, at 21:57, Kaiduan Xie <kaiduanx@gmail.com> wrote:

Is there a simple way to do that?

Thanks,

--
Saúl


#3

Saul,

Thanks for swift response.

Are you referring config.js in /etc/jitsi/meet, right?

If I enable this on the latest Jitsi-meet installed by quick-install, will
it work? I do not mind the loss of simulcast.

Regards,

/Kaiduan

···

On Wed, Jun 28, 2017 at 4:03 PM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Jun 28, 2017, at 21:57, Kaiduan Xie <kaiduanx@gmail.com> wrote:
>
> Is there a simple way to do that?
>
> Thanks,
>

Yes and no. There is a setting you can set in config.js : preferH264,
which will prefer H264 if set to true. The problem, however, is that there
are some fixes necessary in the JVB in order to make it work. You would
lose simulcast too, which can yield a significantly higher bandwidth usage.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Founder of Goodstartsoft
https://www.goodstartsoft.com


#4

Saul,

I enabled preferH264 on my local setup, Jitsi meet showed "Fellow Jitser
video is turned off to save bandwidth", and then "Fellow Jitser is having
connectivity issue". Jitsi-meet runs in the local network.

Is there a configuration in JVB I missed?

Thanks,

/Kaiduan

···

On Wed, Jun 28, 2017 at 4:13 PM, Kaiduan Xie <kaiduanx@gmail.com> wrote:

Saul,

Thanks for swift response.

Are you referring config.js in /etc/jitsi/meet, right?

If I enable this on the latest Jitsi-meet installed by quick-install, will
it work? I do not mind the loss of simulcast.

Regards,

/Kaiduan

On Wed, Jun 28, 2017 at 4:03 PM, Saúl Ibarra Corretgé < > scorretge@atlassian.com> wrote:

> On Jun 28, 2017, at 21:57, Kaiduan Xie <kaiduanx@gmail.com> wrote:
>
> Is there a simple way to do that?
>
> Thanks,
>

Yes and no. There is a setting you can set in config.js : preferH264,
which will prefer H264 if set to true. The problem, however, is that there
are some fixes necessary in the JVB in order to make it work. You would
lose simulcast too, which can yield a significantly higher bandwidth usage.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Founder of Goodstartsoft
https://www.goodstartsoft.com

--
Founder of Goodstartsoft
https://www.goodstartsoft.com


#5

Saul,

I enabled preferH264 on my local setup, Jitsi meet showed "Fellow Jitser video is turned off to save bandwidth", and then "Fellow Jitser is having connectivity issue". Jitsi-meet runs in the local network.

Is there a configuration in JVB I missed?

No, as I mentioned, there are some problems in the JVB and fixes are pending. The loss of simulcast if just an aggravation, but right now the bridge doesn’t let H264 through properly.

Cheers,

···

On Jun 28, 2017, at 22:41, Kaiduan Xie <kaiduanx@gmail.com> wrote:

Thanks,

/Kaiduan

On Wed, Jun 28, 2017 at 4:13 PM, Kaiduan Xie <kaiduanx@gmail.com> wrote:
Saul,

Thanks for swift response.

Are you referring config.js in /etc/jitsi/meet, right?

If I enable this on the latest Jitsi-meet installed by quick-install, will it work? I do not mind the loss of simulcast.

Regards,

/Kaiduan

On Wed, Jun 28, 2017 at 4:03 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:

> On Jun 28, 2017, at 21:57, Kaiduan Xie <kaiduanx@gmail.com> wrote:
>
> Is there a simple way to do that?
>
> Thanks,
>

Yes and no. There is a setting you can set in config.js : preferH264, which will prefer H264 if set to true. The problem, however, is that there are some fixes necessary in the JVB in order to make it work. You would lose simulcast too, which can yield a significantly higher bandwidth usage.

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Founder of Goodstartsoft
https://www.goodstartsoft.com

--
Founder of Goodstartsoft
https://www.goodstartsoft.com
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl


#6

Saul,

Do you have any idea about the ETA for the fixes in JVB?

Thanks,

/Kaiduan

···

On Thu, Jun 29, 2017 at 1:50 AM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Jun 28, 2017, at 22:41, Kaiduan Xie <kaiduanx@gmail.com> wrote:
>
> Saul,
>
> I enabled preferH264 on my local setup, Jitsi meet showed "Fellow Jitser
video is turned off to save bandwidth", and then "Fellow Jitser is having
connectivity issue". Jitsi-meet runs in the local network.
>
> Is there a configuration in JVB I missed?
>

No, as I mentioned, there are some problems in the JVB and fixes are
pending. The loss of simulcast if just an aggravation, but right now the
bridge doesn’t let H264 through properly.

Cheers,

> Thanks,
>
> /Kaiduan
>
> On Wed, Jun 28, 2017 at 4:13 PM, Kaiduan Xie <kaiduanx@gmail.com> wrote:
> Saul,
>
> Thanks for swift response.
>
> Are you referring config.js in /etc/jitsi/meet, right?
>
> If I enable this on the latest Jitsi-meet installed by quick-install,
will it work? I do not mind the loss of simulcast.
>
> Regards,
>
> /Kaiduan
>
> On Wed, Jun 28, 2017 at 4:03 PM, Saúl Ibarra Corretgé < > scorretge@atlassian.com> wrote:
>
> > On Jun 28, 2017, at 21:57, Kaiduan Xie <kaiduanx@gmail.com> wrote:
> >
> > Is there a simple way to do that?
> >
> > Thanks,
> >
>
> Yes and no. There is a setting you can set in config.js : preferH264,
which will prefer H264 if set to true. The problem, however, is that there
are some fixes necessary in the JVB in order to make it work. You would
lose simulcast too, which can yield a significantly higher bandwidth usage.
>
>
> Cheers,
>
> --
> Saúl
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> --
> Founder of Goodstartsoft
> https://www.goodstartsoft.com
>
>
>
> --
> Founder of Goodstartsoft
> https://www.goodstartsoft.com
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Founder of Goodstartsoft
https://www.goodstartsoft.com


#7

Hi Kaiduan, it keeps getting pushed back, but we're hoping to have something by the end of July.

···

On Jun 29, 2017, at 3:12 PM, Kaiduan Xie <kaiduanx@gmail.com> wrote:

Saul,

Do you have any idea about the ETA for the fixes in JVB?

Thanks,

/Kaiduan

On Thu, Jun 29, 2017 at 1:50 AM, Saúl Ibarra Corretgé <scorretge@atlassian.com <mailto:scorretge@atlassian.com>> wrote:

> On Jun 28, 2017, at 22:41, Kaiduan Xie <kaiduanx@gmail.com <mailto:kaiduanx@gmail.com>> wrote:
>
> Saul,
>
> I enabled preferH264 on my local setup, Jitsi meet showed "Fellow Jitser video is turned off to save bandwidth", and then "Fellow Jitser is having connectivity issue". Jitsi-meet runs in the local network.
>
> Is there a configuration in JVB I missed?
>

No, as I mentioned, there are some problems in the JVB and fixes are pending. The loss of simulcast if just an aggravation, but right now the bridge doesn’t let H264 through properly.

Cheers,

> Thanks,
>
> /Kaiduan
>
> On Wed, Jun 28, 2017 at 4:13 PM, Kaiduan Xie <kaiduanx@gmail.com <mailto:kaiduanx@gmail.com>> wrote:
> Saul,
>
> Thanks for swift response.
>
> Are you referring config.js in /etc/jitsi/meet, right?
>
> If I enable this on the latest Jitsi-meet installed by quick-install, will it work? I do not mind the loss of simulcast.
>
> Regards,
>
> /Kaiduan
>
> On Wed, Jun 28, 2017 at 4:03 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com <mailto:scorretge@atlassian.com>> wrote:
>
> > On Jun 28, 2017, at 21:57, Kaiduan Xie <kaiduanx@gmail.com <mailto:kaiduanx@gmail.com>> wrote:
> >
> > Is there a simple way to do that?
> >
> > Thanks,
> >
>
> Yes and no. There is a setting you can set in config.js : preferH264, which will prefer H264 if set to true. The problem, however, is that there are some fixes necessary in the JVB in order to make it work. You would lose simulcast too, which can yield a significantly higher bandwidth usage.
>
>
> Cheers,
>
> --
> Saúl
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org <mailto:dev@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> --
> Founder of Goodstartsoft
> https://www.goodstartsoft.com <https://www.goodstartsoft.com/>
>
>
>
> --
> Founder of Goodstartsoft
> https://www.goodstartsoft.com <https://www.goodstartsoft.com/>
> _______________________________________________
> dev mailing list
> dev@jitsi.org <mailto:dev@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Founder of Goodstartsoft
https://www.goodstartsoft.com <https://www.goodstartsoft.com/>_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev