[jitsi-dev] Gateway timeout with JWT enabled


#1

Hi,

I followed the guide at https://github.com/jitsi/lib-jitsi-meet/blob/master/doc/tokens.md to enable JWT authentication but I can't get it to work. When I join a room the POST request to http-bind timeouts after a while. I'm not even getting the local video stream. Below is the debug output from Prosody

Feb 01 13:48:16 http.server debug Firing event: POST x.y.z.w/http-bind
Feb 01 13:48:16 mod_bosh debug Handling new request table: 0x1352d10: <body rid='3980768250' xmlns='http://jabber.org/protocol/httpbind' to='x.y.z.w' xml:lang='en' wait='60' hold='1' content='text/xml; charset=utf-8' ver='1.6' xmpp:version='1.0' xmlns:xmpp='urn:xmpp:xbosh'/>

···

----------
Feb 01 13:48:16 mod_bosh debug BOSH body open (sid: <none>)
Feb 01 13:48:16 bosh698a5e29-b614-4fcf-ad2f-990e75d8ae0b debug BOSH session created for request from a.b.c.d
Feb 01 13:48:16 mod_bosh info New BOSH session, assigned it sid '698a5e29-b614-4fcf-ad2f-990e75d8ae0b'
Feb 01 13:48:16 mod_bosh debug We have an open request, so sending on that
Feb 01 13:48:16 mod_bosh debug Request destroyed: table: 0x13579a0
Feb 01 13:48:16 bosh698a5e29-b614-4fcf-ad2f-990e75d8ae0b debug BOSH session marked as inactive (for 60s)
Feb 01 13:48:16 mod_bosh debug Session 698a5e29-b614-4fcf-ad2f-990e75d8ae0b has 0 out of 1 requests open
Feb 01 13:48:16 mod_bosh debug and there are 0 things in the send_buffer:
Feb 01 13:48:16 http.server debug Firing event: POST x.y.z.w/http-bind
Feb 01 13:48:16 mod_bosh debug Handling new request table: 0x1491900: <body rid='3980768251' xmlns='http://jabber.org/protocol/httpbind' sid='698a5e29-b614-4fcf-ad2f-990e75d8ae0b'/>
----------
Feb 01 13:48:16 mod_bosh debug BOSH body open (sid: 698a5e29-b614-4fcf-ad2f-990e75d8ae0b)
Feb 01 13:48:16 mod_bosh debug Session 698a5e29-b614-4fcf-ad2f-990e75d8ae0b has 1 out of 1 requests open
Feb 01 13:48:16 mod_bosh debug and there are 0 things in the send_buffer:
Feb 01 13:48:16 mod_bosh debug Have nothing to say, so leaving request unanswered for now
Feb 01 13:48:16 jcp12cbbc0 debug Received[component]: <iq id='23e7C-319' type='get' to='x.y.z.w' from='jitsi-videobridge.x.y.z.w'>
Feb 01 13:48:16 c2s12f5000 debug Received[c2s]: <iq id='6NhnT-502' type='get' to='jitsi-videobridge.x.y.z.w'>
Feb 01 13:48:16 jcp12cbbc0 debug Received[component]: <iq id='6NhnT-502' type='result' to='focus@auth.x.y.z.w/focus768988602212' from='jitsi-videobridge.x.y.z.w'>
Feb 01 13:48:17 jcp11c1af0 debug Received[component]: <iq id='6NhnT-504' type='get' to='x.y.z.w' from='focus.x.y.z.w'>
Feb 01 13:48:17 jcp11c1af0 debug Received[component]: <iq id='6NhnT-505' type='get' to='x.y.z.w' from='focus.x.y.z.w'>

Can someone help me?

BR,
Markus


#2

Replying to this in case someone else has the same problem.

First of all, I installed Jitsi-Meet on Ubuntu 16.04. The issue was Prosody; using the latest trunk (842) did not work. I don't know why it doesn't work but using the oldest Xenial package (prosody-trunk_1nightly635-1~xenial_amd64.deb) works.

BR,
Markus

···

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of markus.kullberg@teliacompany.com
Sent: 1. helmikuuta 2018 16:04
To: dev@jitsi.org
Subject: [jitsi-dev] Gateway timeout with JWT enabled

Hi,

I followed the guide at https://github.com/jitsi/lib-jitsi-meet/blob/master/doc/tokens.md to enable JWT authentication but I can't get it to work. When I join a room the POST request to http-bind timeouts after a while. I'm not even getting the local video stream. Below is the debug output from Prosody

Feb 01 13:48:16 http.server debug Firing event: POST x.y.z.w/http-bind
Feb 01 13:48:16 mod_bosh debug Handling new request table: 0x1352d10: <body rid='3980768250' xmlns='http://jabber.org/protocol/httpbind' to='x.y.z.w' xml:lang='en' wait='60' hold='1' content='text/xml; charset=utf-8' ver='1.6' xmpp:version='1.0' xmlns:xmpp='urn:xmpp:xbosh'/>
----------
Feb 01 13:48:16 mod_bosh debug BOSH body open (sid: <none>)
Feb 01 13:48:16 bosh698a5e29-b614-4fcf-ad2f-990e75d8ae0b debug BOSH session created for request from a.b.c.d
Feb 01 13:48:16 mod_bosh info New BOSH session, assigned it sid '698a5e29-b614-4fcf-ad2f-990e75d8ae0b'
Feb 01 13:48:16 mod_bosh debug We have an open request, so sending on that
Feb 01 13:48:16 mod_bosh debug Request destroyed: table: 0x13579a0
Feb 01 13:48:16 bosh698a5e29-b614-4fcf-ad2f-990e75d8ae0b debug BOSH session marked as inactive (for 60s)
Feb 01 13:48:16 mod_bosh debug Session 698a5e29-b614-4fcf-ad2f-990e75d8ae0b has 0 out of 1 requests open
Feb 01 13:48:16 mod_bosh debug and there are 0 things in the send_buffer:
Feb 01 13:48:16 http.server debug Firing event: POST x.y.z.w/http-bind
Feb 01 13:48:16 mod_bosh debug Handling new request table: 0x1491900: <body rid='3980768251' xmlns='http://jabber.org/protocol/httpbind' sid='698a5e29-b614-4fcf-ad2f-990e75d8ae0b'/>
----------
Feb 01 13:48:16 mod_bosh debug BOSH body open (sid: 698a5e29-b614-4fcf-ad2f-990e75d8ae0b)
Feb 01 13:48:16 mod_bosh debug Session 698a5e29-b614-4fcf-ad2f-990e75d8ae0b has 1 out of 1 requests open
Feb 01 13:48:16 mod_bosh debug and there are 0 things in the send_buffer:
Feb 01 13:48:16 mod_bosh debug Have nothing to say, so leaving request unanswered for now
Feb 01 13:48:16 jcp12cbbc0 debug Received[component]: <iq id='23e7C-319' type='get' to='x.y.z.w' from='jitsi-videobridge.x.y.z.w'>
Feb 01 13:48:16 c2s12f5000 debug Received[c2s]: <iq id='6NhnT-502' type='get' to='jitsi-videobridge.x.y.z.w'>
Feb 01 13:48:16 jcp12cbbc0 debug Received[component]: <iq id='6NhnT-502' type='result' to='focus@auth.x.y.z.w/focus768988602212' from='jitsi-videobridge.x.y.z.w'>
Feb 01 13:48:17 jcp11c1af0 debug Received[component]: <iq id='6NhnT-504' type='get' to='x.y.z.w' from='focus.x.y.z.w'>
Feb 01 13:48:17 jcp11c1af0 debug Received[component]: <iq id='6NhnT-505' type='get' to='x.y.z.w' from='focus.x.y.z.w'>

Can someone help me?

BR,
Markus


#3

Replying to this in case someone else has the same problem.

First of all, I installed Jitsi-Meet on Ubuntu 16.04. The issue was Prosody; using the latest trunk (842) did not work. I don't know why it doesn't work but using the oldest Xenial package (prosody-trunk_1nightly635-1~xenial_amd64.deb) works.

Personally, I use the same version of Prosody as meet.jit.si, which is Prosody trunk nightly build 747 and it works fine.

Regards
Hamza