[jitsi-dev] G722 - unreadable sound in conference call


#1

Hello Lyubomir, Emil, All.

At first, thank you for your great work!

We experience a problem with conference calls in Jitsi with G722 codec.
When a conference call is created on Jitsi client with an external Polycom
335 SIP phone as a peer - only noise can be heard on it.
But if I make single call from that Jitsi client to that Polycom phone
everything works fine.
And also if I replace Jitsi with X-Lite 4 connected to the same backend as
Jitsi and with only G722 enabled and create the same conference call -
sound on the Polycom phone is fine.

I have Wireshark records of non-working conference call with Jitsi and
working conference call with X-Lite. I can provide them via private mail if
needed.

Could somebody narrow me please - what can be wrong?

Thank you in advance.

···

---
We have in more details:
1. Two Jitsi 2.5 clients connected to FreeSWITCH-based backend with only
G722 codec enabled on them.
2. Voice Mail auto-answerer on the backend. It always answers the call and
says: "Please enter your password.... Login incorrect".
3. External SIP phone (Polycom 335) connected to another SIP provider.

What I do:
1. Using one Jitsi client I create a conference call to another Jitsi and
VoiceMail ==> everything works fine, sound is good.

2. Using one Jitsi client I create a conference call to VoiceMail and
Polycom 335 ==> only noise is heard on Polycom 335, voice is unreadable.

3. Using Jitsi client I create a single call to Polycom 335 ==> everything
is fine, sound is good.

4. Using X-Lite 4 client with only G722 codec enabled and connected to the
same backend as previous Jitsi client (with the same credentials) I create
a conference call to VoiceMail and Polycom 335 ==> everything works fine,
sound is good.
---

Best regards,
Mikhail Viktorov


#2

Mikhail Viktorov

Hello Lyubomir, Emil, All.

At first, thank you for your great work!

We experience a problem with conference calls in Jitsi with G722 codec.

When a conference call is created on Jitsi client with an external Polycom
335 SIP phone as a peer - only noise can be heard on it.

But if I make single call from that Jitsi client to that Polycom phone
everything works fine.

And also if I replace Jitsi with X-Lite 4 connected to the same backend as
Jitsi and with only G722 enabled and create the same conference call - sound
on the Polycom phone is fine.

I have Wireshark records of non-working conference call with Jitsi and
working conference call with X-Lite. I can provide them via private mail if
needed.

Could somebody narrow me please - what can be wrong?

Make sure that, when offering SDP, the G722 is offered first and that the
receiver will pick that codec first as well.

Chances are that 1 of them chooses pcma/pcmu first which is narrowband(?),
mixing the 2 in a conference is tricky.

FWIW.

···

From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of