[jitsi-dev] Fwd: Re: Re: [jitsi~svn:9137] Change "proactive notification" to "typing notification"


#1

Hey

Maybe you remember that I told you I disabled the typing notifications,
but receive them despite the setting? Well, no wonder: The setting
behind the checkbox in Options->General->Message is not used anywhere.

OK. Just to be clear, this is not related to your string change, right?

IIRC, that setting was meant to prevent Jitsi from sending typing
notifications. It could have been broken along the way of course and if
so then we should have a look at it.

Well I looked at it and tested it. Its working fine when I disable
typing notifications in Options->General->Message, typing
notifications are not sent.

Its used in impl.gui.main.chat.ChatWritePanel
... void keyTyped(KeyEvent e)
     {
         if (ConfigurationManager.isSendTypingNotifications())

You're right. Maybe I was confused because of the same class name in the
plugins-package vs. the gui.utils-package.

Anyway, this apparently only disables /send/-notifications, but not the
popups that annoyed me. The checkbox label "Enable typing notifications"
should probably be changed to "Enable sending typing notifications" and
an accompanying label saying "To disable receiving typing notifications,
go to Events".

Ingo


#2

На 24.11.11 17:41, Bauersachs Ingo написа:

Hey

Maybe you remember that I told you I disabled the typing notifications,
but receive them despite the setting? Well, no wonder: The setting
behind the checkbox in Options->General->Message is not used anywhere.

OK. Just to be clear, this is not related to your string change, right?

IIRC, that setting was meant to prevent Jitsi from sending typing
notifications. It could have been broken along the way of course and if
so then we should have a look at it.

Well I looked at it and tested it. Its working fine when I disable
typing notifications in Options->General->Message, typing
notifications are not sent.

Its used in impl.gui.main.chat.ChatWritePanel
... void keyTyped(KeyEvent e)
     {
         if (ConfigurationManager.isSendTypingNotifications())

You're right. Maybe I was confused because of the same class name in the
plugins-package vs. the gui.utils-package.

Anyway, this apparently only disables /send/-notifications, but not the
popups that annoyed me. The checkbox label "Enable typing notifications"
should probably be changed to "Enable sending typing notifications"

I'd go for "Tell others when we are writing to them (send chat
activity)" ... with or without the part between the parentheses.

and
an accompanying label saying "To disable receiving typing notifications,
go to Events".

"You can choose to ignore others' chat activity from the "Events" tab."

Personally I am not convinced about that one though and would prefer to
hear that others also feel it is necessary before we add the exta label.

Emil