[jitsi-dev] Fw:problem with jitisi-android


#1

------------------ Original ------------------

···

From: "MAXWELL"<95143848@qq.com>;
Date: Thu, Jun 6, 2013 04:55 PM
To: "contact"<contact@jitsi.org>; "emcho"<emcho@jitsi.org>; "ingo"<ingo@jitsi.org>;

Subject: problem with jitisi-android

hi there,
    i'm fan of jitsi from chinese and have been study it for several days ,now i have troubles about jitsi-android,it is :
    when i answer/creat a video call with jitsi(PC), i can only recieve video from PC but couldn't send video to PC,the local
    video preview block in there and no data upload(i got data in "call info"), it seems that the mediarecorder block in the "LocalSocketThread", because if i set the output path to SD card, local preview works well.
    would you please help me fix it, or some suggestion?
     thanks very much .
                                                                                                                 RAY FROM BEIJING


#2

Hi Ray.

···

On Thu, Jun 6, 2013 at 10:59 AM, MAXWELL <95143848@qq.com> wrote:

------------------ Original ------------------
From: "MAXWELL"<95143848@qq.com>;
Date: Thu, Jun 6, 2013 04:55 PM
To: "contact"<contact@jitsi.org>; "emcho"<emcho@jitsi.org>;
"ingo"<ingo@jitsi.org>;
Subject: problem with jitisi-android

hi there,
    i'm fan of jitsi from chinese and have been study it for several days
,now i have troubles about jitsi-android,it is :
    when i answer/creat a video call with jitsi(PC), i can only recieve
video from PC but couldn't send video to PC,the local
    video preview block in there and no data upload(i got data in "call
info"), it seems that the mediarecorder block in the "LocalSocketThread",
because if i set the output path to SD card, local preview works well.
    would you please help me fix it, or some suggestion?

And when you change change output path to SD card it works then ? Or
only the preview works ?

Thanks for looking into the problem as we had reports about similiar
issue and now we have a clue. I'll take a look on it later.

Regards,
Pawel


#3

After looking at the code I can see that video is captured by settings
media output to filedescriptor which should point to local socket and
from this socket it is streamed to the PC. When you set static var
OUTPUT_FILE it writes the stream to this file instead(so it won't
work). It looks like there's a problem with this descriptor on some
devices. What device do you use and what's the OS version ?

Regards,
Pawel

···

On Thu, Jun 6, 2013 at 2:26 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi Ray.

On Thu, Jun 6, 2013 at 10:59 AM, MAXWELL <95143848@qq.com> wrote:

------------------ Original ------------------
From: "MAXWELL"<95143848@qq.com>;
Date: Thu, Jun 6, 2013 04:55 PM
To: "contact"<contact@jitsi.org>; "emcho"<emcho@jitsi.org>;
"ingo"<ingo@jitsi.org>;
Subject: problem with jitisi-android

hi there,
    i'm fan of jitsi from chinese and have been study it for several days
,now i have troubles about jitsi-android,it is :
    when i answer/creat a video call with jitsi(PC), i can only recieve
video from PC but couldn't send video to PC,the local
    video preview block in there and no data upload(i got data in "call
info"), it seems that the mediarecorder block in the "LocalSocketThread",
because if i set the output path to SD card, local preview works well.
    would you please help me fix it, or some suggestion?

And when you change change output path to SD card it works then ? Or
only the preview works ?

Thanks for looking into the problem as we had reports about similiar
issue and now we have a clue. I'll take a look on it later.

Regards,
Pawel