[jitsi-dev] FW: [jitsi-meet] How to use different auth user with jigasi config (#418)


#1

Hi,

my apologies, I tested around before opening an git issue and it seems like I have changed ACCOUNT_UID in the expection, that it’s the right place to store the auth user. By comparing my Jitsi Desktop configuration with my Jitsi Meet configuration, I overlooked the different variable name. Now it’s working, many thanks.

I just have two other topics open (on Git), maybe you can help me out with them also:

1. Desktop Sharing does not provide me with the dialog on Chrome to install the extension. I registered it in the Chrome App Store and I entered the ID with desktopSharingChromeExtId. However, I found different hints online, stating a parameter chromeExtensionId, which I don’t have. Maybe that’s the reason, why the extension is not recognized. However, the extension is uploaded correctly with the App Store as if I install it manually, Desktop Sharing is working

2. I did not found any instructions on how to integrate Prezi with Jitsi Meet

Regards,
Christian

···

Am 02.12.15 15:22 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,

AUTHORIZATION_NAME is the property that needs to be used. And I'm not
sure how you managed to edit ACCOUNT_UID through the jitsi UI. You
just need to fill there the authorization name field for the sip
account advanced settings.

Regards
damencho

On Wed, Dec 2, 2015 at 4:05 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I
check the Jitsi Meet-Server be successful registered?

Regards,
Christian

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> >> wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,

but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED

FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I

expect, the configuration does not work as because of the missing Auth User

in the above config file.

Regards,

Christian

Von: Дамян Минков <notifications@github.com>

Antworten an: jitsi/jitsi-meet

<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>

Datum: Dienstag, 1. Dezember 2015 16:57

An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>

Cc: Christian Heutger <christian@heutger.net>

Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config

(#418)

Please use our dev mailinglist for questions.

You can install jitsi desktop client, configure it the way so you can use it

with your sip account and then use the relevant account properties from the

sip-communicator.properties file and paste them in the jigasi config.

Reply to this email directly or view it on GitHub.

_______________________________________________

dev mailing list

dev@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#2

Hi,
chromeExtensionId was deprecated, you need to use
desktopSharingChromeExtId. Did you hard refresh your browser,
sometimes old config.js is loaded from cache?
Prezi is supposed to be enabled by default, but there was a bug in the
code, which I just fixed and build should be available any minute now.

Regards
damencho

···

On Wed, Dec 2, 2015 at 5:40 PM, Christian Heutger <christian@heutger.net> wrote:

Hi,

my apologies, I tested around before opening an git issue and it seems like I have changed ACCOUNT_UID in the expection, that it’s the right place to store the auth user. By comparing my Jitsi Desktop configuration with my Jitsi Meet configuration, I overlooked the different variable name. Now it’s working, many thanks.

I just have two other topics open (on Git), maybe you can help me out with them also:

1. Desktop Sharing does not provide me with the dialog on Chrome to install the extension. I registered it in the Chrome App Store and I entered the ID with desktopSharingChromeExtId. However, I found different hints online, stating a parameter chromeExtensionId, which I don’t have. Maybe that’s the reason, why the extension is not recognized. However, the extension is uploaded correctly with the App Store as if I install it manually, Desktop Sharing is working

2. I did not found any instructions on how to integrate Prezi with Jitsi Meet

Regards,
Christian

Am 02.12.15 15:22 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,

AUTHORIZATION_NAME is the property that needs to be used. And I'm not
sure how you managed to edit ACCOUNT_UID through the jitsi UI. You
just need to fill there the authorization name field for the sip
account advanced settings.

Regards
damencho

On Wed, Dec 2, 2015 at 4:05 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I
check the Jitsi Meet-Server be successful registered?

Regards,
Christian

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> >>> wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,

but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED

FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I

expect, the configuration does not work as because of the missing Auth User

in the above config file.

Regards,

Christian

Von: Дамян Минков <notifications@github.com>

Antworten an: jitsi/jitsi-meet

<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>

Datum: Dienstag, 1. Dezember 2015 16:57

An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>

Cc: Christian Heutger <christian@heutger.net>

Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config

(#418)

Please use our dev mailinglist for questions.

You can install jitsi desktop client, configure it the way so you can use it

with your sip account and then use the relevant account properties from the

sip-communicator.properties file and paste them in the jigasi config.

Reply to this email directly or view it on GitHub.

_______________________________________________

dev mailing list

dev@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

I used the new setting and now cleared my cache once again and closed and reopened Chrome completely. However, it’s still not working. You may check https://meet.heutger.net/, the config is as below.

Regarding Prezi, many thanks! Will it be available if doing an apt-get update or do I need to change anything in the config?

Regards,
Christian

/* jshint -W101 */
var config = {
// configLocation: './config.json', // see ./modules/HttpConfigFetch.js
    hosts: {
        domain: 'meet.heutger.net',
        //anonymousdomain: 'guest.example.com',
        // authdomain: 'meet.heutger.net', // defaults to <domain>
        muc: 'conference.meet.heutger.net', // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.meet.heutger.net', // FIXME: use XEP-0030
        //jirecon: 'jirecon.meet.heutger.net',
        call_control: 'callcontrol.meet.heutger.net'
        //focus: 'focus.meet.heutger.net' - defaults to 'focus.meet.heutger.net'
    },
// getroomnode: function (path) { return 'someprefixpossiblybasedonpath'; },
// useStunTurn: true, // use XEP-0215 to fetch STUN and TURN server
// useIPv6: true, // ipv6 support. use at your own risk
    useNicks: false,
    bosh: '//meet.heutger.net/http-bind', // FIXME: use xep-0156 for that
    clientNode: 'http://jitsi.org/jitsimeet', // The name of client node advertised in XEP-0115 'c' stanza
    //focusUserJid: 'focus@auth.meet.heutger.net', // The real JID of focus participant - can be overridden here
    //defaultSipNumber: '', // Default SIP number

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'mkfkfbpdfbejjadkgboflmifmbfdajji',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

    // The ID of the jidesha extension for Firefox. If null, we assume that no
    // extension is required.
    desktopSharingFirefoxExtId: null,
    // Whether desktop sharing should be disabled on Firefox.
    desktopSharingFirefoxDisabled: true,
    // The maximum version of Firefox which requires a jidesha extension.
    // Example: if set to 41, we will require the extension for Firefox versions
    // up to and including 41. On Firefox 42 and higher, we will run without the
    // extension.
    // If set to -1, an extension will be required for all versions of Firefox.
    desktopSharingFirefoxMaxVersionExtRequired: -1,
    // The URL to the Firefox extension for desktop sharing.
    desktopSharingFirefoxExtensionURL: null,

    etherpad_base: 'https://meet.heutger.net/etherpad/p/',

    // Disables ICE/UDP by filtering out local and remote UDP candidates in signalling.
    webrtcIceUdpDisable: false,
    // Disables ICE/TCP by filtering out local and remote TCP candidates in signalling.
    webrtcIceTcpDisable: false,

    openSctp: true, // Toggle to enable/disable SCTP channels
    disableStats: false,
    disableAudioLevels: false,
    channelLastN: -1, // The default value of the channel attribute last-n.
    adaptiveLastN: false,
    adaptiveSimulcast: false,
    enableRecording: false,
    enableWelcomePage: true,
    enableSimulcast: false, // blocks FF support
    logStats: false, // Enable logging of PeerConnection stats via the focus
// requireDisplayName: true,//Forces the participants that doesn't have display name to enter it when they enter the room.
// startAudioMuted: 10, //every participant after the Nth will start audio muted
// startVideoMuted: 10, //every participant after the Nth will start video muted
// defaultLanguage: "en",
// To enable sending statistics to callstats.io you should provide Applicaiton ID and Secret.
// callStatsID: "",//Application ID for callstats.io API
// callStatsSecret: ""//Secret for callstats.io API
    /*noticeMessage: 'Service update is scheduled for 16th March 2015. ' +
    'During that time service will not be available. ' +
    'Apologise for inconvenience.'*/
};

···

Am 04.12.15 17:42 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,
chromeExtensionId was deprecated, you need to use
desktopSharingChromeExtId. Did you hard refresh your browser,
sometimes old config.js is loaded from cache?
Prezi is supposed to be enabled by default, but there was a bug in the
code, which I just fixed and build should be available any minute now.

Regards
damencho

On Wed, Dec 2, 2015 at 5:40 PM, Christian Heutger <christian@heutger.net> wrote:

Hi,

my apologies, I tested around before opening an git issue and it seems like I have changed ACCOUNT_UID in the expection, that it’s the right place to store the auth user. By comparing my Jitsi Desktop configuration with my Jitsi Meet configuration, I overlooked the different variable name. Now it’s working, many thanks.

I just have two other topics open (on Git), maybe you can help me out with them also:

1. Desktop Sharing does not provide me with the dialog on Chrome to install the extension. I registered it in the Chrome App Store and I entered the ID with desktopSharingChromeExtId. However, I found different hints online, stating a parameter chromeExtensionId, which I don’t have. Maybe that’s the reason, why the extension is not recognized. However, the extension is uploaded correctly with the App Store as if I install it manually, Desktop Sharing is working

2. I did not found any instructions on how to integrate Prezi with Jitsi Meet

Regards,
Christian

Am 02.12.15 15:22 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,

AUTHORIZATION_NAME is the property that needs to be used. And I'm not
sure how you managed to edit ACCOUNT_UID through the jitsi UI. You
just need to fill there the authorization name field for the sip
account advanced settings.

Regards
damencho

On Wed, Dec 2, 2015 at 4:05 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I
check the Jitsi Meet-Server be successful registered?

Regards,
Christian

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> >>>> wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,

but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED

FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I

expect, the configuration does not work as because of the missing Auth User

in the above config file.

Regards,

Christian

Von: Дамян Минков <notifications@github.com>

Antworten an: jitsi/jitsi-meet

<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>

Datum: Dienstag, 1. Dezember 2015 16:57

An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>

Cc: Christian Heutger <christian@heutger.net>

Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config

(#418)

Please use our dev mailinglist for questions.

You can install jitsi desktop client, configure it the way so you can use it

with your sip account and then use the relevant account properties from the

sip-communicator.properties file and paste them in the jigasi config.

Reply to this email directly or view it on GitHub.

_______________________________________________

dev mailing list

dev@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi,

just update of the package will be enough. About DS, did you change
the url matching in manifest.json?

Regards
damencho

···

On Fri, Dec 4, 2015 at 10:53 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

I used the new setting and now cleared my cache once again and closed and reopened Chrome completely. However, it’s still not working. You may check https://meet.heutger.net/, the config is as below.

Regarding Prezi, many thanks! Will it be available if doing an apt-get update or do I need to change anything in the config?

Regards,
Christian

/* jshint -W101 */
var config = {
// configLocation: './config.json', // see ./modules/HttpConfigFetch.js
    hosts: {
        domain: 'meet.heutger.net',
        //anonymousdomain: 'guest.example.com',
        // authdomain: 'meet.heutger.net', // defaults to <domain>
        muc: 'conference.meet.heutger.net', // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.meet.heutger.net', // FIXME: use XEP-0030
        //jirecon: 'jirecon.meet.heutger.net',
        call_control: 'callcontrol.meet.heutger.net'
        //focus: 'focus.meet.heutger.net' - defaults to 'focus.meet.heutger.net'
    },
// getroomnode: function (path) { return 'someprefixpossiblybasedonpath'; },
// useStunTurn: true, // use XEP-0215 to fetch STUN and TURN server
// useIPv6: true, // ipv6 support. use at your own risk
    useNicks: false,
    bosh: '//meet.heutger.net/http-bind', // FIXME: use xep-0156 for that
    clientNode: 'http://jitsi.org/jitsimeet', // The name of client node advertised in XEP-0115 'c' stanza
    //focusUserJid: 'focus@auth.meet.heutger.net', // The real JID of focus participant - can be overridden here
    //defaultSipNumber: '', // Default SIP number

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'mkfkfbpdfbejjadkgboflmifmbfdajji',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

    // The ID of the jidesha extension for Firefox. If null, we assume that no
    // extension is required.
    desktopSharingFirefoxExtId: null,
    // Whether desktop sharing should be disabled on Firefox.
    desktopSharingFirefoxDisabled: true,
    // The maximum version of Firefox which requires a jidesha extension.
    // Example: if set to 41, we will require the extension for Firefox versions
    // up to and including 41. On Firefox 42 and higher, we will run without the
    // extension.
    // If set to -1, an extension will be required for all versions of Firefox.
    desktopSharingFirefoxMaxVersionExtRequired: -1,
    // The URL to the Firefox extension for desktop sharing.
    desktopSharingFirefoxExtensionURL: null,

    etherpad_base: 'https://meet.heutger.net/etherpad/p/',

    // Disables ICE/UDP by filtering out local and remote UDP candidates in signalling.
    webrtcIceUdpDisable: false,
    // Disables ICE/TCP by filtering out local and remote TCP candidates in signalling.
    webrtcIceTcpDisable: false,

    openSctp: true, // Toggle to enable/disable SCTP channels
    disableStats: false,
    disableAudioLevels: false,
    channelLastN: -1, // The default value of the channel attribute last-n.
    adaptiveLastN: false,
    adaptiveSimulcast: false,
    enableRecording: false,
    enableWelcomePage: true,
    enableSimulcast: false, // blocks FF support
    logStats: false, // Enable logging of PeerConnection stats via the focus
// requireDisplayName: true,//Forces the participants that doesn't have display name to enter it when they enter the room.
// startAudioMuted: 10, //every participant after the Nth will start audio muted
// startVideoMuted: 10, //every participant after the Nth will start video muted
// defaultLanguage: "en",
// To enable sending statistics to callstats.io you should provide Applicaiton ID and Secret.
// callStatsID: "",//Application ID for callstats.io API
// callStatsSecret: ""//Secret for callstats.io API
    /*noticeMessage: 'Service update is scheduled for 16th March 2015. ' +
    'During that time service will not be available. ' +
    'Apologise for inconvenience.'*/
};

Am 04.12.15 17:42 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,
chromeExtensionId was deprecated, you need to use
desktopSharingChromeExtId. Did you hard refresh your browser,
sometimes old config.js is loaded from cache?
Prezi is supposed to be enabled by default, but there was a bug in the
code, which I just fixed and build should be available any minute now.

Regards
damencho

On Wed, Dec 2, 2015 at 5:40 PM, Christian Heutger <christian@heutger.net> wrote:

Hi,

my apologies, I tested around before opening an git issue and it seems like I have changed ACCOUNT_UID in the expection, that it’s the right place to store the auth user. By comparing my Jitsi Desktop configuration with my Jitsi Meet configuration, I overlooked the different variable name. Now it’s working, many thanks.

I just have two other topics open (on Git), maybe you can help me out with them also:

1. Desktop Sharing does not provide me with the dialog on Chrome to install the extension. I registered it in the Chrome App Store and I entered the ID with desktopSharingChromeExtId. However, I found different hints online, stating a parameter chromeExtensionId, which I don’t have. Maybe that’s the reason, why the extension is not recognized. However, the extension is uploaded correctly with the App Store as if I install it manually, Desktop Sharing is working

2. I did not found any instructions on how to integrate Prezi with Jitsi Meet

Regards,
Christian

Am 02.12.15 15:22 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,

AUTHORIZATION_NAME is the property that needs to be used. And I'm not
sure how you managed to edit ACCOUNT_UID through the jitsi UI. You
just need to fill there the authorization name field for the sip
account advanced settings.

Regards
damencho

On Wed, Dec 2, 2015 at 4:05 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I
check the Jitsi Meet-Server be successful registered?

Regards,
Christian

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> >>>>> wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,

but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED

FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I

expect, the configuration does not work as because of the missing Auth User

in the above config file.

Regards,

Christian

Von: Дамян Минков <notifications@github.com>

Antworten an: jitsi/jitsi-meet

<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>

Datum: Dienstag, 1. Dezember 2015 16:57

An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>

Cc: Christian Heutger <christian@heutger.net>

Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config

(#418)

Please use our dev mailinglist for questions.

You can install jitsi desktop client, configure it the way so you can use it

with your sip account and then use the relevant account properties from the

sip-communicator.properties file and paste them in the jigasi config.

Reply to this email directly or view it on GitHub.

_______________________________________________

dev mailing list

dev@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

you mean the url in the manifest.json of the chrome extension? Yes, I did. If you manually install https://chrome.google.com/webstore/detail/jitsi-desktop-streamer/mkfkfbpdfbejjadkgboflmifmbfdajji?hl=de desktop sharing also works (with any other extension it doesn’t), so I expect, I did everything right. Just the dialog if clicking desktop sharing without the extension installed, which should invoke the installation process, does not work.

Regards,
Christian

···

Am 04.12.15 18:06 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,

just update of the package will be enough. About DS, did you change
the url matching in manifest.json?

Regards
damencho

On Fri, Dec 4, 2015 at 10:53 AM, Christian Heutger ><christian@heutger.net> wrote:

Hi,

I used the new setting and now cleared my cache once again and closed and reopened Chrome completely. However, it’s still not working. You may check https://meet.heutger.net/, the config is as below.

Regarding Prezi, many thanks! Will it be available if doing an apt-get update or do I need to change anything in the config?

Regards,
Christian

/* jshint -W101 */
var config = {
// configLocation: './config.json', // see ./modules/HttpConfigFetch.js
    hosts: {
        domain: 'meet.heutger.net',
        //anonymousdomain: 'guest.example.com',
        // authdomain: 'meet.heutger.net', // defaults to <domain>
        muc: 'conference.meet.heutger.net', // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.meet.heutger.net', // FIXME: use XEP-0030
        //jirecon: 'jirecon.meet.heutger.net',
        call_control: 'callcontrol.meet.heutger.net'
        //focus: 'focus.meet.heutger.net' - defaults to 'focus.meet.heutger.net'
    },
// getroomnode: function (path) { return 'someprefixpossiblybasedonpath'; },
// useStunTurn: true, // use XEP-0215 to fetch STUN and TURN server
// useIPv6: true, // ipv6 support. use at your own risk
    useNicks: false,
    bosh: '//meet.heutger.net/http-bind', // FIXME: use xep-0156 for that
    clientNode: 'http://jitsi.org/jitsimeet', // The name of client node advertised in XEP-0115 'c' stanza
    //focusUserJid: 'focus@auth.meet.heutger.net', // The real JID of focus participant - can be overridden here
    //defaultSipNumber: '', // Default SIP number

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'mkfkfbpdfbejjadkgboflmifmbfdajji',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

    // The ID of the jidesha extension for Firefox. If null, we assume that no
    // extension is required.
    desktopSharingFirefoxExtId: null,
    // Whether desktop sharing should be disabled on Firefox.
    desktopSharingFirefoxDisabled: true,
    // The maximum version of Firefox which requires a jidesha extension.
    // Example: if set to 41, we will require the extension for Firefox versions
    // up to and including 41. On Firefox 42 and higher, we will run without the
    // extension.
    // If set to -1, an extension will be required for all versions of Firefox.
    desktopSharingFirefoxMaxVersionExtRequired: -1,
    // The URL to the Firefox extension for desktop sharing.
    desktopSharingFirefoxExtensionURL: null,

    etherpad_base: 'https://meet.heutger.net/etherpad/p/',

    // Disables ICE/UDP by filtering out local and remote UDP candidates in signalling.
    webrtcIceUdpDisable: false,
    // Disables ICE/TCP by filtering out local and remote TCP candidates in signalling.
    webrtcIceTcpDisable: false,

    openSctp: true, // Toggle to enable/disable SCTP channels
    disableStats: false,
    disableAudioLevels: false,
    channelLastN: -1, // The default value of the channel attribute last-n.
    adaptiveLastN: false,
    adaptiveSimulcast: false,
    enableRecording: false,
    enableWelcomePage: true,
    enableSimulcast: false, // blocks FF support
    logStats: false, // Enable logging of PeerConnection stats via the focus
// requireDisplayName: true,//Forces the participants that doesn't have display name to enter it when they enter the room.
// startAudioMuted: 10, //every participant after the Nth will start audio muted
// startVideoMuted: 10, //every participant after the Nth will start video muted
// defaultLanguage: "en",
// To enable sending statistics to callstats.io you should provide Applicaiton ID and Secret.
// callStatsID: "",//Application ID for callstats.io API
// callStatsSecret: ""//Secret for callstats.io API
    /*noticeMessage: 'Service update is scheduled for 16th March 2015. ' +
    'During that time service will not be available. ' +
    'Apologise for inconvenience.'*/
};

Am 04.12.15 17:42 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,
chromeExtensionId was deprecated, you need to use
desktopSharingChromeExtId. Did you hard refresh your browser,
sometimes old config.js is loaded from cache?
Prezi is supposed to be enabled by default, but there was a bug in the
code, which I just fixed and build should be available any minute now.

Regards
damencho

On Wed, Dec 2, 2015 at 5:40 PM, Christian Heutger <christian@heutger.net> wrote:

Hi,

my apologies, I tested around before opening an git issue and it seems like I have changed ACCOUNT_UID in the expection, that it’s the right place to store the auth user. By comparing my Jitsi Desktop configuration with my Jitsi Meet configuration, I overlooked the different variable name. Now it’s working, many thanks.

I just have two other topics open (on Git), maybe you can help me out with them also:

1. Desktop Sharing does not provide me with the dialog on Chrome to install the extension. I registered it in the Chrome App Store and I entered the ID with desktopSharingChromeExtId. However, I found different hints online, stating a parameter chromeExtensionId, which I don’t have. Maybe that’s the reason, why the extension is not recognized. However, the extension is uploaded correctly with the App Store as if I install it manually, Desktop Sharing is working

2. I did not found any instructions on how to integrate Prezi with Jitsi Meet

Regards,
Christian

Am 02.12.15 15:22 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,

AUTHORIZATION_NAME is the property that needs to be used. And I'm not
sure how you managed to edit ACCOUNT_UID through the jitsi UI. You
just need to fill there the authorization name field for the sip
account advanced settings.

Regards
damencho

On Wed, Dec 2, 2015 at 4:05 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I
check the Jitsi Meet-Server be successful registered?

Regards,
Christian

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> >>>>>> wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,

but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED

FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I

expect, the configuration does not work as because of the missing Auth User

in the above config file.

Regards,

Christian

Von: Дамян Минков <notifications@github.com>

Antworten an: jitsi/jitsi-meet

<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>

Datum: Dienstag, 1. Dezember 2015 16:57

An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>

Cc: Christian Heutger <christian@heutger.net>

Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config

(#418)

Please use our dev mailinglist for questions.

You can install jitsi desktop client, configure it the way so you can use it

with your sip account and then use the relevant account properties from the

sip-communicator.properties file and paste them in the jigasi config.

Reply to this email directly or view it on GitHub.

_______________________________________________

dev mailing list

dev@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

It fails with "Inline installs can only be initiated for Chrome Web Store items that have one or more verified sites.". I don't know how all this works really, but googling suggests this, which seems relevant:
http://stackoverflow.com/questions/25920728/how-to-specify-verified-site-to-a-chrome-app

Boris

···

On 04/12/15 11:14, Christian Heutger wrote:

Hi,

you mean the url in the manifest.json of the chrome extension? Yes, I
did. If you manually install
https://chrome.google.com/webstore/detail/jitsi-desktop-streamer/mkfkfbpdfbejjadkgboflmifmbfdajji?hl=de
desktop sharing also works (with any other extension it doesn’t), so
I expect, I did everything right. Just the dialog if clicking desktop
sharing without the extension installed, which should invoke the
installation process, does not work.


#7

Hi Boris,

that’s it! Great! Many thanks!

Regards,
Christian

···

Am 04.12.15 18:52 schrieb "dev im Auftrag von Boris Grozev" <dev-bounces@jitsi.org im Auftrag von boris@jitsi.org>:

On 04/12/15 11:14, Christian Heutger wrote:

Hi,

you mean the url in the manifest.json of the chrome extension? Yes, I
did. If you manually install
https://chrome.google.com/webstore/detail/jitsi-desktop-streamer/mkfkfbpdfbejjadkgboflmifmbfdajji?hl=de
desktop sharing also works (with any other extension it doesn’t), so
I expect, I did everything right. Just the dialog if clicking desktop
sharing without the extension installed, which should invoke the
installation process, does not work.

It fails with "Inline installs can only be initiated for Chrome Web
Store items that have one or more verified sites.". I don't know how all
this works really, but googling suggests this, which seems relevant:
http://stackoverflow.com/questions/25920728/how-to-specify-verified-site-to-a-chrome-app

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev