[jitsi-dev] FW: [jitsi-meet] How to use different auth user with jigasi config (#418)


#1

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine, but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I expect, the configuration does not work as because of the missing Auth User in the above config file.

Regards,
Christian

···

Von: Дамян Минков <notifications@github.com<mailto:notifications@github.com>>
Antworten an: jitsi/jitsi-meet <reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com<mailto:reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>>
Datum: Dienstag, 1. Dezember 2015 16:57
An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com<mailto:jitsi-meet@noreply.github.com>>
Cc: Christian Heutger <christian@heutger.net<mailto:christian@heutger.net>>
Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config (#418)

Please use our dev mailinglist for questions.
You can install jitsi desktop client, configure it the way so you can use it with your sip account and then use the relevant account properties from the sip-communicator.properties file and paste them in the jigasi config.


Reply to this email directly or view it on GitHub<https://github.com/jitsi/jitsi-meet/issues/418#issuecomment-161011295>.


#2

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

···

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,
but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED
FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I
expect, the configuration does not work as because of the missing Auth User
in the above config file.

Regards,
Christian

Von: Дамян Минков <notifications@github.com>
Antworten an: jitsi/jitsi-meet
<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>
Datum: Dienstag, 1. Dezember 2015 16:57
An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>
Cc: Christian Heutger <christian@heutger.net>
Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config
(#418)

Please use our dev mailinglist for questions.
You can install jitsi desktop client, configure it the way so you can use it
with your sip account and then use the relevant account properties from the
sip-communicator.properties file and paste them in the jigasi config.


Reply to this email directly or view it on GitHub.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I check the Jitsi Meet-Server be successful registered?

Regards,
Christian

···

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org<mailto:damencho@jitsi.org>>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net<mailto:christian@heutger.net>> wrote:
Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,
but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED
FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com<http://getonsip.com>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com<mailto:net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com<mailto:JIGASI_SIPUSER=heutger@getonsip.com>

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I
expect, the configuration does not work as because of the missing Auth User
in the above config file.

Regards,
Christian

Von: Дамян Минков <notifications@github.com<mailto:notifications@github.com>>
Antworten an: jitsi/jitsi-meet
<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com<mailto:reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>>
Datum: Dienstag, 1. Dezember 2015 16:57
An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com<mailto:jitsi-meet@noreply.github.com>>
Cc: Christian Heutger <christian@heutger.net<mailto:christian@heutger.net>>
Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config
(#418)

Please use our dev mailinglist for questions.
You can install jitsi desktop client, configure it the way so you can use it
with your sip account and then use the relevant account properties from the
sip-communicator.properties file and paste them in the jigasi config.


Reply to this email directly or view it on GitHub.

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi,

AUTHORIZATION_NAME is the property that needs to be used. And I'm not
sure how you managed to edit ACCOUNT_UID through the jitsi UI. You
just need to fill there the authorization name field for the sip
account advanced settings.

Regards
damencho

···

On Wed, Dec 2, 2015 at 4:05 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I
check the Jitsi Meet-Server be successful registered?

Regards,
Christian

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> > wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,

but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED

FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I

expect, the configuration does not work as because of the missing Auth User

in the above config file.

Regards,

Christian

Von: Дамян Минков <notifications@github.com>

Antworten an: jitsi/jitsi-meet

<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>

Datum: Dienstag, 1. Dezember 2015 16:57

An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>

Cc: Christian Heutger <christian@heutger.net>

Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config

(#418)

Please use our dev mailinglist for questions.

You can install jitsi desktop client, configure it the way so you can use it

with your sip account and then use the relevant account properties from the

sip-communicator.properties file and paste them in the jigasi config.

Reply to this email directly or view it on GitHub.

_______________________________________________

dev mailing list

dev@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

my apologies, I tested around before opening an git issue and it seems like I have changed ACCOUNT_UID in the expection, that it’s the right place to store the auth user. By comparing my Jitsi Desktop configuration with my Jitsi Meet configuration, I overlooked the different variable name. Now it’s working, many thanks.

I just have two other topics open (on Git), maybe you can help me out with them also:

2. I did not found any instructions on how to integrate Prezi with Jitsi Meet

···

Am 02.12.15 15:22 schrieb "dev im Auftrag von Damian Minkov" <dev-bounces@jitsi.org im Auftrag von damencho@jitsi.org>:

Hi,

AUTHORIZATION_NAME is the property that needs to be used. And I'm not
sure how you managed to edit ACCOUNT_UID through the jitsi UI. You
just need to fill there the authorization name field for the sip
account advanced settings.

Regards
damencho

On Wed, Dec 2, 2015 at 4:05 AM, Christian Heutger <christian@heutger.net> wrote:

Hi,

here is the different auth user:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

With Jitsi (desktop version) this details seem to work, however, how can I
check the Jitsi Meet-Server be successful registered?

Regards,
Christian

Am 02.12.2015 um 02:46 schrieb Damian Minkov <damencho@jitsi.org>:

Hi,

the file /etc/jitsi/jigasi/config is used when configuring or
re-configuring. What is used for registering by jigasi is the
sip-communicator.properties file. That file is generated using config
values when installing.
I also don't see in your sip-communicator.properties AuthUser. Is it
working when you start jitsi using those account properties, is it
registered?

Regards
damencho

On Tue, Dec 1, 2015 at 4:28 PM, Christian Heutger <christian@heutger.net> >> wrote:

Hi,

sorry, but that’s not working. The sip-communicator.properties file is fine,

but there is also a config file, and this one seems to be the problem:

/etc/jitsi/jigasi/sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:getonsip_heutger

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REMOVED

FOR SECURITY PURPOSES

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=heutger@getonsip.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

/etc/jitsi/jigasi/config:

JIGASI_SIPUSER=heutger@getonsip.com

JIGASI_SIPPWD=REMOVED FOR SECURITY PURPOSES

JIGASI_SECRET=GI6mECrZ

As Jitsi Meet seems still to initialize connection but doesn’t dial, I

expect, the configuration does not work as because of the missing Auth User

in the above config file.

Regards,

Christian

Von: Дамян Минков <notifications@github.com>

Antworten an: jitsi/jitsi-meet

<reply+00067d3f30f676b10346da2170c70df67dc93d6af3ba918792cf000000011275857992a169ce07224220@reply.github.com>

Datum: Dienstag, 1. Dezember 2015 16:57

An: jitsi/jitsi-meet <jitsi-meet@noreply.github.com>

Cc: Christian Heutger <christian@heutger.net>

Betreff: Re: [jitsi-meet] How to use different auth user with jigasi config

(#418)

Please use our dev mailinglist for questions.

You can install jitsi desktop client, configure it the way so you can use it

with your sip account and then use the relevant account properties from the

sip-communicator.properties file and paste them in the jigasi config.

Reply to this email directly or view it on GitHub.

_______________________________________________

dev mailing list

dev@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev