[jitsi-dev] From within Eclipse: Non-existing property SYSTEM_BUNDLES causes NPE when loading pluginmanager.jar


#1

Hi,

Recently I started getting NPE's when starting Jitsi from within
Eclipse. This is caused by a property not being available in the jitsi
properties file (in my case "~/.jitsi/sip-communicator.properties").
The property: net.java.sip.communicator.plugin.pluginmanager.SYSTEM_BUNDLES

I found the property in lib/jitsi-defaults.properties however (on my
machine) it never gets copied into the standard jitsi properties file.
Closing jitsi and manually writing the property to
sip-communicator.properties fixes this problem. (Closing is required
since Jitsi seems to rewrite the file on shutdown.)

Stack trace:
ERROR: Bundle net.java.sip.communicator.plugin.pluginmanager [38] Error
starting reference:file:sc-bundles/pluginmanager.jar
(org.osgi.framework.BundleException: Activator start error in bundle
net.java.sip.communicator.plugin.pluginmanager
[38].)java.lang.NullPointerException
    at
net.java.sip.communicator.plugin.pluginmanager.PluginManagerActivator.start(PluginManagerActivator.java:86)
    at
org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:629)
    at org.apache.felix.framework.Felix.activateBundle(Felix.java:1904)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:1822)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
    at
org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
    at java.lang.Thread.run(Thread.java:722)

I can reproduce this with:
1. delete or move ~/.jitsi
2. start jitsi from Eclipse in my case

This problem does not occur when running Jitsi via 'ant run', for
example, so it might be related to the IDE configuration.
I have followed https://jitsi.org/Documentation/ConfigureEclipseNew to
configure my Eclipse 4.3 IDE with the exception that I did not set the
path variable, but instead configured

Does anyone know how to fix this?

Thanks,
Danny


#2

Hey

You need to add the lib directory to the classpath of the run-configuration.

Guess I need to more or less rewrite that howto-page these days...

Ingo

From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of

Danny

van Heumen
Sent: Sonntag, 12. Januar 2014 22:21
To: Jitsi Developers
Subject: [jitsi-dev] From within Eclipse: Non-existing property
SYSTEM_BUNDLES causes NPE when loading pluginmanager.jar
Hi,

Recently I started getting NPE's when starting Jitsi from within
Eclipse. This is caused by a property not being available in the jitsi
properties file (in my case "~/.jitsi/sip-communicator.properties").
The property:

net.java.sip.communicator.plugin.pluginmanager.SYSTEM_BUNDLES

I found the property in lib/jitsi-defaults.properties however (on my
machine) it never gets copied into the standard jitsi properties file.
Closing jitsi and manually writing the property to
sip-communicator.properties fixes this problem. (Closing is required
since Jitsi seems to rewrite the file on shutdown.)

Stack trace: ERROR: Bundle
net.java.sip.communicator.plugin.pluginmanager [38] Error starting
reference:file:sc-bundles/pluginmanager.jar
(org.osgi.framework.BundleException: Activator start error in bundle
net.java.sip.communicator.plugin.pluginmanager
[38].)java.lang.NullPointerException
    at

net.java.sip.communicator.plugin.pluginmanager.PluginManagerActivator.start(
P

luginManagerActivator.java:86)
    at

org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.jav
a

···

-----Original Message-----
:629)
    at org.apache.felix.framework.Felix.activateBundle(Felix.java:1904)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:1822) at
    org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
     at
    org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266
    ) at java.lang.Thread.run(Thread.java:722)
I can reproduce this with:
1. delete or move ~/.jitsi
2. start jitsi from Eclipse in my case

This problem does not occur when running Jitsi via 'ant run', for
example, so it might be related to the IDE configuration.
I have followed https://jitsi.org/Documentation/ConfigureEclipseNew to
configure my Eclipse 4.3 IDE with the exception that I did not set the
path variable, but instead configured

Does anyone know how to fix this?

Thanks,
Danny

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hey Ingo,

Right, that does the trick. Thanks!

Danny

···

On 01/12/2014 10:25 PM, Ingo Bauersachs wrote:

Hey

You need to add the lib directory to the classpath of the run-configuration.

Guess I need to more or less rewrite that howto-page these days...

Ingo

-----Original Message-----
From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of

Danny

van Heumen
Sent: Sonntag, 12. Januar 2014 22:21
To: Jitsi Developers
Subject: [jitsi-dev] From within Eclipse: Non-existing property
SYSTEM_BUNDLES causes NPE when loading pluginmanager.jar
Hi,

Recently I started getting NPE's when starting Jitsi from within
Eclipse. This is caused by a property not being available in the jitsi
properties file (in my case "~/.jitsi/sip-communicator.properties").
The property:

net.java.sip.communicator.plugin.pluginmanager.SYSTEM_BUNDLES

I found the property in lib/jitsi-defaults.properties however (on my
machine) it never gets copied into the standard jitsi properties file.
Closing jitsi and manually writing the property to
sip-communicator.properties fixes this problem. (Closing is required
since Jitsi seems to rewrite the file on shutdown.)

Stack trace: ERROR: Bundle
net.java.sip.communicator.plugin.pluginmanager [38] Error starting
reference:file:sc-bundles/pluginmanager.jar
(org.osgi.framework.BundleException: Activator start error in bundle
net.java.sip.communicator.plugin.pluginmanager
[38].)java.lang.NullPointerException
    at

net.java.sip.communicator.plugin.pluginmanager.PluginManagerActivator.start(
P

luginManagerActivator.java:86)
    at

org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.jav
a

:629)
    at org.apache.felix.framework.Felix.activateBundle(Felix.java:1904)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:1822) at
    org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
     at
    org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266
    ) at java.lang.Thread.run(Thread.java:722)
I can reproduce this with:
1. delete or move ~/.jitsi
2. start jitsi from Eclipse in my case

This problem does not occur when running Jitsi via 'ant run', for
example, so it might be related to the IDE configuration.
I have followed https://jitsi.org/Documentation/ConfigureEclipseNew to
configure my Eclipse 4.3 IDE with the exception that I did not set the
path variable, but instead configured

Does anyone know how to fix this?

Thanks,
Danny

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev