[jitsi-dev] Firefox no audio output selector on jitsi meet unstable


#1

Hi all,

I thought I'd start another thread since the last one was mostly dedicated
to jigasi and jitsi-meet integration problems
<http://lists.jitsi.org/pipermail/dev/2017-April/032539.html> and was
drifting off topic.

This new thread is to report some of the bugs/issues I have found with a
clean install of latest unstable debian packages.

The most obvious one is that Firefox audio seems to be broken lately in
that there's no way to select Audio output anymore, so it defaults to the
system speakers even though it sees the plantronics headset's mic and uses
it without issues.

I tried this experiment with my own installation and also yours at
beta.meet.jit.si, with Firefox (52.0.2) using both Linux and Windows. All
showed the same issue as seen in the screenshot and audio comes out only
through the PC speakers.

Also, I did enable p2p in the config and it seems to be working fine
(however, when I enable backToP2PDelay: 5 in the config I get black screen
and errors in the console about missing config).

I hope this feedback help.

I'll keep posting any issues/bugs I find in unstable.

Cheers,
Peter


#2

I don't believe this is actually supported by Firefox actually.

···

On Sun, 9 Apr 2017 at 09:06, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi all,

I thought I'd start another thread since the last one was mostly
dedicated to jigasi and jitsi-meet integration problems
<http://lists.jitsi.org/pipermail/dev/2017-April/032539.html> and was
drifting off topic.

This new thread is to report some of the bugs/issues I have found with a
clean install of latest unstable debian packages.

The most obvious one is that Firefox audio seems to be broken lately in
that there's no way to select Audio output anymore, so it defaults to the
system speakers even though it sees the plantronics headset's mic and uses
it without issues.

I tried this experiment with my own installation and also yours at
beta.meet.jit.si, with Firefox (52.0.2) using both Linux and Windows. All
showed the same issue as seen in the screenshot and audio comes out only
through the PC speakers.

Also, I did enable p2p in the config and it seems to be working fine
(however, when I enable backToP2PDelay: 5 in the config I get black
screen and errors in the console about missing config).

I hope this feedback help.

I'll keep posting any issues/bugs I find in unstable.

Cheers,
Peter


_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
sent from my mobile


#3

Hi Emil,

Good to hear from you.

I remember that in the past I could use ffox with my headset and jitsi meet
with no problems.
Now audio comes out the speaker and there's no way to force audio out of
the headset. I have to switch to Chrome.
You're saying that behavior from Mozilla is on purpose? How do you guys use
USB headsets with Ffox and jitsi meet then?

Cheers,
Peter

···

On Sun, Apr 9, 2017 at 3:40 PM, Emil Ivov <emcho@jitsi.org> wrote:

I don't believe this is actually supported by Firefox actually.

On Sun, 9 Apr 2017 at 09:06, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi all,

I thought I'd start another thread since the last one was mostly
dedicated to jigasi and jitsi-meet integration problems
<http://lists.jitsi.org/pipermail/dev/2017-April/032539.html> and was
drifting off topic.

This new thread is to report some of the bugs/issues I have found with a
clean install of latest unstable debian packages.

The most obvious one is that Firefox audio seems to be broken lately in
that there's no way to select Audio output anymore, so it defaults to the
system speakers even though it sees the plantronics headset's mic and uses
it without issues.

I tried this experiment with my own installation and also yours at
beta.meet.jit.si, with Firefox (52.0.2) using both Linux and Windows.
All showed the same issue as seen in the screenshot and audio comes out
only through the PC speakers.

Also, I did enable p2p in the config and it seems to be working fine
(however, when I enable backToP2PDelay: 5 in the config I get black
screen and errors in the console about missing config).

I hope this feedback help.

I'll keep posting any issues/bugs I find in unstable.

Cheers,
Peter


_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
sent from my mobile

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi again,

I just tried using my USB headset with Ffox on meet.jit.si as well as
beta.meet.jit.si and in both cases audio only comes out through the default
speakers and not through the headset.
This has to be a bug no?
I may be remembering incorrectly, but I'm pretty sure I've used ffox before
on meet.jit.si with a USB headset without any issues.

Can anyone else confirm this behavior?

Cheers,
Peter

···

On Sun, Apr 9, 2017 at 3:04 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Hi all,

I thought I'd start another thread since the last one was mostly
dedicated to jigasi and jitsi-meet integration problems
<http://lists.jitsi.org/pipermail/dev/2017-April/032539.html> and was
drifting off topic.

This new thread is to report some of the bugs/issues I have found with a
clean install of latest unstable debian packages.

The most obvious one is that Firefox audio seems to be broken lately in
that there's no way to select Audio output anymore, so it defaults to the
system speakers even though it sees the plantronics headset's mic and uses
it without issues.

I tried this experiment with my own installation and also yours at
beta.meet.jit.si, with Firefox (52.0.2) using both Linux and Windows. All
showed the same issue as seen in the screenshot and audio comes out only
through the PC speakers.

Also, I did enable p2p in the config and it seems to be working fine
(however, when I enable backToP2PDelay: 5 in the config I get black
screen and errors in the console about missing config).

I hope this feedback help.

I'll keep posting any issues/bugs I find in unstable.

Cheers,
Peter


#5

Hi Roy,

Thanks for the confirmation. You're tight. Indeed it does work with Firefox
as long as I configure the default audio output in Ubuntu/Mint to come out
the USB headset.

As for the mobile app, no it still doesn't work when authentication is
turned on on the server, even if they're just joining as guests.

I hope this is being worked on by the Jitsi team but honestly I'm not sure.

Cheers,
Peter

···

On Wed, Apr 12, 2017 at 6:37 PM, <royblog@comcast.net> wrote:

Peter,

Tested Firefox with bluetooth headset. In both cases meet.jit.si &
beta.meet, headset was detected, ver 52 on MAC; pic below.
Audio worked fine with both.

Have you done any more testing of mobile app with authentication? Assume
users are able to join if setup as guest?
On Tue, Feb 14, 2017 at 10:04 AM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> So this means that you can't have authentication and the iOS app
> simultaneously?

We will get to authentication in the mobile apps eventually, it's not
supported at the time of this writing.

------------------------------
*From: *"Peter Villeneuve" <petervnv1@gmail.com>
*To: *"Jitsi Developers" <dev@jitsi.org>
*Sent: *Monday, April 10, 2017 10:46:54 AM
*Subject: *Re: [jitsi-dev] Firefox no audio output selector on jitsi
meet unstable

Hi again,

I just tried using my USB headset with Ffox on meet.jit.si as well as
beta.meet.jit.si and in both cases audio only comes out through the
default speakers and not through the headset.
This has to be a bug no?
I may be remembering incorrectly, but I'm pretty sure I've used ffox
before on meet.jit.si with a USB headset without any issues.

Can anyone else confirm this behavior?

Cheers,
Peter

On Sun, Apr 9, 2017 at 3:04 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

Hi all,

I thought I'd start another thread since the last one was mostly
dedicated to jigasi and jitsi-meet integration problems
<http://lists.jitsi.org/pipermail/dev/2017-April/032539.html> and was
drifting off topic.

This new thread is to report some of the bugs/issues I have found with a
clean install of latest unstable debian packages.

The most obvious one is that Firefox audio seems to be broken lately in
that there's no way to select Audio output anymore, so it defaults to the
system speakers even though it sees the plantronics headset's mic and uses
it without issues.

I tried this experiment with my own installation and also yours at
beta.meet.jit.si, with Firefox (52.0.2) using both Linux and Windows.
All showed the same issue as seen in the screenshot and audio comes out
only through the PC speakers.

Also, I did enable p2p in the config and it seems to be working fine
(however, when I enable backToP2PDelay: 5 in the config I get black
screen and errors in the console about missing config).

I hope this feedback help.

I'll keep posting any issues/bugs I find in unstable.

Cheers,
Peter

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev