[jitsi-dev] firefox bugs in jitsi-meet unstable


#1

Hi all,

Just installed latest debian packages from unstable, and I have noticed it
is not playing well with latest firefox.

I'm using Firefox 49 on Ubuntu 16.04, and there's no Audio Output menu in
Settings (it is there when using Chrome).

Also, when trying to stream desktop I get the Permission Denied: Failed to
install desktop sharing extension" message.

I have config.js setup so it shouldn't need an extension for firefox:

desktopSharingFirefoxExtId: "",
    // Whether desktop sharing should be disabled on Firefox.
    desktopSharingFirefoxDisabled: false,
    // The maximum version of Firefox which requires a jidesha extension.
    // Example: if set to 41, we will require the extension for Firefox
versions
    // up to and including 41. On Firefox 42 and higher, we will run
without the
    // extension.
    // If set to -1, an extension will be required for all versions of
Firefox.
    desktopSharingFirefoxMaxVersionExtRequired: 0,
    // The URL to the Firefox extension for desktop sharing.
    desktopSharingFirefoxExtensionURL: '',

And this is the Firefox console:

[modules/xmpp/ChatRoom.js] <i.prototype.onPresence>: (TIME) MUC joined:
2407.98(unknown)
hover in 4144bb36app.bundle.min.js:40:29106
not well-formed(unknown)
My role changed, new role: moderatorapp.bundle.min.js:37:18115
[modules/RTC/RTCUtils.js] <Y.getUserMediaWithConstraints>: Get media
constraints Object { audio: false, video: Object }(unknown)
[modules/RTC/RTCUtils.js] <Y.getUserMediaWithConstraints/<>: Failed to get
access to local media. Error MediaStreamError { name: "NotAllowedError",
message: "The request is not allowed by the u…", constraint: "", stack: ""
} Object { audio: false, video: Object }(unknown)
[modules/RTC/RTCUtils.js] <y/<>: failed to obtain desktop stream - stop
gum.general: The request is not allowed by the user agent or the platform
in the current context.
Stack trace:
t@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:1:28510
Y.getUserMediaWithConstraints/<@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28291
p@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:22842
f/</<@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:23030
f/<@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:22899
Y.getUserMediaWithConstraints@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28131
o@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:24:547
A.obtainScreenOnFirefox@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:24:5045
y@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:23586
Y.obtainAudioAndVideoPermissions/<@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28950
_@https://meet.my.domain/libs/app.bundle.min.js?v=1403:42:12814
Y.obtainAudioAndVideoPermissions@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28506
a.obtainAudioAndVideoPermissions@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:5638
U.createLocalTracks@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:1:2435
h@https://meet.my.domain/libs/app.bundle.min.js?v=1403:37:4792
t.default.toggleScreenSharing@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:37:15902
i.prototype.emit@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:14:27975
p.toolbar_button_desktopsharing@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:15:2291
h.init/</<@https://meet.my.domain/libs/app.bundle.min.js?v=1403:15:7760
ae.event.dispatch@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:88:14740
ae.event.add/m.handle@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:88:11520
lib-jitsi-meet.min.js:22:6237

failed to create local tracks Array [ "desktop" ] gum.general: The request
is not allowed by the user agent or the platform in the current context.
Stack trace:
t@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:1:28510
Y.getUserMediaWithConstraints/<@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28291
p@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:22842
f/</<@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:23030
f/<@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:22899
Y.getUserMediaWithConstraints@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28131
o@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:24:547
A.obtainScreenOnFirefox@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:24:5045
y@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:23586
Y.obtainAudioAndVideoPermissions/<@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28950
_@https://meet.my.domain/libs/app.bundle.min.js?v=1403:42:12814
Y.obtainAudioAndVideoPermissions@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28506
a.obtainAudioAndVideoPermissions@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:5638
U.createLocalTracks@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:1:2435
h@https://meet.my.domain/libs/app.bundle.min.js?v=1403:37:4792
t.default.toggleScreenSharing@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:37:15902
i.prototype.emit@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:14:27975
p.toolbar_button_desktopsharing@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:15:2291
h.init/</<@https://meet.my.domain/libs/app.bundle.min.js?v=1403:15:7760
ae.event.dispatch@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:88:14740
ae.event.add/m.handle@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:88:11520
app.bundle.min.js:37:5413

[modules/RTC/RTCUtils.js] <Y.getUserMediaWithConstraints>: Get media
constraints Object { audio: false, video: Object }(unknown)
failed to share local desktop gum.general: The request is not allowed by
the user agent or the platform in the current context.
Stack trace:
t@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:1:28510
Y.getUserMediaWithConstraints/<@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28291
p@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:22842
f/</<@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:23030
f/<@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:22899
Y.getUserMediaWithConstraints@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28131
o@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:24:547
A.obtainScreenOnFirefox@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:24:5045
y@https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:23586
Y.obtainAudioAndVideoPermissions/<@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28950
_@https://meet.my.domain/libs/app.bundle.min.js?v=1403:42:12814
Y.obtainAudioAndVideoPermissions@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:28506
a.obtainAudioAndVideoPermissions@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:2:5638
U.createLocalTracks@
https://meet.my.domain/libs/lib-jitsi-meet.min.js?v=1403:1:2435
h@https://meet.my.domain/libs/app.bundle.min.js?v=1403:37:4792
t.default.toggleScreenSharing@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:37:15902
i.prototype.emit@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:14:27975
p.toolbar_button_desktopsharing@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:15:2291
h.init/</<@https://meet.my.domain/libs/app.bundle.min.js?v=1403:15:7760
ae.event.dispatch@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:88:14740
ae.event.add/m.handle@
https://meet.my.domain/libs/app.bundle.min.js?v=1403:88:11520
app.bundle.min.js:37:16654

Cheers,
Peter


#2

Screensharing will not work without an extension unless you whitelist your domain manually. It looks like if you try to do this we show the wrong error message (it should just say that screensharing is not allowed or something like this).

Regards,
Boris

···

On 26/10/16 10:02, Peter Villeneuve wrote:

Hi all,

Just installed latest debian packages from unstable, and I have noticed
it is not playing well with latest firefox.

I'm using Firefox 49 on Ubuntu 16.04, and there's no Audio Output menu
in Settings (it is there when using Chrome).

Also, when trying to stream desktop I get the Permission Denied: Failed
to install desktop sharing extension" message.

I have config.js setup so it shouldn't need an extension for firefox:

desktopSharingFirefoxExtId: "",
    // Whether desktop sharing should be disabled on Firefox.
    desktopSharingFirefoxDisabled: false,
    // The maximum version of Firefox which requires a jidesha extension.
    // Example: if set to 41, we will require the extension for Firefox
versions
    // up to and including 41. On Firefox 42 and higher, we will run
without the
    // extension.
    // If set to -1, an extension will be required for all versions of
Firefox.
    desktopSharingFirefoxMaxVersionExtRequired: 0,
    // The URL to the Firefox extension for desktop sharing.
    desktopSharingFirefoxExtensionURL: '',