[jitsi-dev] ffmpeg


#1

Hello all

I have a project with jitsi, to add stream authentication using x264, that
needs me to compile ffmpeg. however i have followed all steps mentioned on
the readme file and still can not compile ffmpeg. i get the following error:

Class org.apache.tools.ant.taskdefs.LogStreamHandler loaded from parent
loader (
parentFirst)
Execute:Java13CommandLauncher: Executing 'gcc' with arguments:
'-LC:\Users\sergio\git\ffmpeg/libavformat'
'-LC:\Users\sergio\git\ffmpeg/libavcodec'
'-LC:\Users\sergio\git\ffmpeg/libavutil'
'-LC:\Users\sergio\git\ffmpeg/libavfilter'
'-LC:\Users\sergio\git\ffmpeg/libswscale'
'-LC:\Users\sergio\git\x264'
'-LC:\Users\sergio\workspace\lame/libmp3lame'
'-LC:\Users\sergio\workspace\lame/libmp3lame/.libs'
'-m32'
'-arch'
'i386'
'-Wl,-ojnffmpeg.dll'
'-Wl,--kill-at'
'-shared'
'-o'
'libjnffmpeg.so'
'..\..\..\src\native\native_obj\net_java_sip_communicator_impl_neomedia_codec_FF
mpeg.o'
'-lavformat'
'-lavcodec'
'-lavfilter'
'-lavutil'
'-lswscale'
'-lx264'
'-lmp3lame'

The ' characters around the executable and arguments are
not part of the command.
       [cc] gcc: error: i386: No such file or directory
       [cc] gcc: error: unrecognized option '-arch'

BUILD FAILED
C:\Users\sergio\workspace\sip-communicator\src\native\build.xml:289: gcc
failed
with return code 1

Some help would be really appreciated.
I have compiled jitsi with out ffmpeg and it work ok.

best regards

Sérgio


#2

Hi Sergio,

Thanks for your report.

A fix is commited in SVN revision 9509.

Best regards,

···

--
Seb

Le 05/04/12 00:45, Sergio Henriques a �crit :

Hello all

I have a project with jitsi, to add stream authentication using x264, that needs me to compile ffmpeg. however i have followed all steps mentioned on the readme file and still can not compile ffmpeg. i get the following error:

Class org.apache.tools.ant.taskdefs.LogStreamHandler loaded from parent loader (
parentFirst)
Execute:Java13CommandLauncher: Executing 'gcc' with arguments:
'-LC:\Users\sergio\git\ffmpeg/libavformat'
'-LC:\Users\sergio\git\ffmpeg/libavcodec'
'-LC:\Users\sergio\git\ffmpeg/libavutil'
'-LC:\Users\sergio\git\ffmpeg/libavfilter'
'-LC:\Users\sergio\git\ffmpeg/libswscale'
'-LC:\Users\sergio\git\x264'
'-LC:\Users\sergio\workspace\lame/libmp3lame'
'-LC:\Users\sergio\workspace\lame/libmp3lame/.libs'
'-m32'
'-arch'
'i386'
'-Wl,-ojnffmpeg.dll'
'-Wl,--kill-at'
'-shared'
'-o'
'libjnffmpeg.so'
'..\..\..\src\native\native_obj\net_java_sip_communicator_impl_neomedia_codec_FF
mpeg.o'
'-lavformat'
'-lavcodec'
'-lavfilter'
'-lavutil'
'-lswscale'
'-lx264'
'-lmp3lame'

The ' characters around the executable and arguments are
not part of the command.
       [cc] gcc: error: i386: No such file or directory
       [cc] gcc: error: unrecognized option '-arch'

BUILD FAILED
C:\Users\sergio\workspace\sip-communicator\src\native\build.xml:289: gcc failed
with return code 1

Some help would be really appreciated.
I have compiled jitsi with out ffmpeg and it work ok.

best regards

S�rgio