[jitsi-dev] Fail to share my screen


#1

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I try to
share my screen in a room, my screen become black with an alert saying
"failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my screen.
The problem is that Jitsi never asks me to install the needed extension
when I try to share my screen, it just tells me the previous error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me to
install the extension.

Does someone have an idea why I'm not asked to install an extension to
share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy


#2

Hi,

You need to create your own extension for screen sharing and then put the
hex code in the config file. The hex code already present there is only for
meet.jit.si

Follow : https://github.com/jitsi/jidesha

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

···

On Thu, Jun 9, 2016 at 1:00 PM, Jimmy Kasprzak <jimmyk.dsi@gmail.com> wrote:

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I try
to share my screen in a room, my screen become black with an alert saying
"failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my
screen. The problem is that Jitsi never asks me to install the needed
extension when I try to share my screen, it just tells me the previous
error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me to
install the extension.

Does someone have an idea why I'm not asked to install an extension to
share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Thanks for the answer, basically if I use the external api available at
meet.jit.si I would not have this problem anymore ? (My local instance is
just for test purposes).

Jimmy

···

2016-06-09 9:39 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Hi,

You need to create your own extension for screen sharing and then put the
hex code in the config file. The hex code already present there is only for
meet.jit.si

Follow : https://github.com/jitsi/jidesha

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

On Thu, Jun 9, 2016 at 1:00 PM, Jimmy Kasprzak <jimmyk.dsi@gmail.com> > wrote:

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I try
to share my screen in a room, my screen become black with an alert saying
"failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my
screen. The problem is that Jitsi never asks me to install the needed
extension when I try to share my screen, it just tells me the previous
error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me to
install the extension.

Does someone have an idea why I'm not asked to install an extension to
share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Yes. Correct

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

···

On 09-Jun-2016 1:38 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

Thanks for the answer, basically if I use the external api available at
meet.jit.si I would not have this problem anymore ? (My local instance is
just for test purposes).

Jimmy

2016-06-09 9:39 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Hi,

You need to create your own extension for screen sharing and then put the
hex code in the config file. The hex code already present there is only for
meet.jit.si

Follow : https://github.com/jitsi/jidesha

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

On Thu, Jun 9, 2016 at 1:00 PM, Jimmy Kasprzak <jimmyk.dsi@gmail.com> >> wrote:

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I try
to share my screen in a room, my screen become black with an alert saying
"failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my
screen. The problem is that Jitsi never asks me to install the needed
extension when I try to share my screen, it just tells me the previous
error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me to
install the extension.

Does someone have an idea why I'm not asked to install an extension to
share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

It also means that I can not share my screen with any web navigator ? I
tested Google Chrome, Mozilla Firefox and it worked, but with Safari even
at meet.jit.si it tells me that it was not able to install the needed
extension.

Jimmy

···

2016-06-09 10:09 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Yes. Correct

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com
On 09-Jun-2016 1:38 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

Thanks for the answer, basically if I use the external api available at
meet.jit.si I would not have this problem anymore ? (My local instance
is just for test purposes).

Jimmy

2016-06-09 9:39 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Hi,

You need to create your own extension for screen sharing and then put
the hex code in the config file. The hex code already present there is only
for meet.jit.si

Follow : https://github.com/jitsi/jidesha

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

On Thu, Jun 9, 2016 at 1:00 PM, Jimmy Kasprzak <jimmyk.dsi@gmail.com> >>> wrote:

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I
try to share my screen in a room, my screen become black with an alert
saying "failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my
screen. The problem is that Jitsi never asks me to install the needed
extension when I try to share my screen, it just tells me the previous
error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me to
install the extension.

Does someone have an idea why I'm not asked to install an extension to
share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

With Safari, you need to install the Temasys Plugin, that is created in
collaboration with Skylink. That particular plugin would only work for
meet.jit.si, and if you need a plugin for you, then that would be paid. It
is free for Chrome & Firefox, but not for Safari and IE.

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

···

On 09-Jun-2016 1:55 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

It also means that I can not share my screen with any web navigator ? I
tested Google Chrome, Mozilla Firefox and it worked, but with Safari even
at meet.jit.si it tells me that it was not able to install the needed
extension.

Jimmy

2016-06-09 10:09 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Yes. Correct

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com
On 09-Jun-2016 1:38 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

Thanks for the answer, basically if I use the external api available at
meet.jit.si I would not have this problem anymore ? (My local instance
is just for test purposes).

Jimmy

2016-06-09 9:39 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Hi,

You need to create your own extension for screen sharing and then put
the hex code in the config file. The hex code already present there is only
for meet.jit.si

Follow : https://github.com/jitsi/jidesha

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

On Thu, Jun 9, 2016 at 1:00 PM, Jimmy Kasprzak <jimmyk.dsi@gmail.com> >>>> wrote:

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I
try to share my screen in a room, my screen become black with an alert
saying "failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my
screen. The problem is that Jitsi never asks me to install the needed
extension when I try to share my screen, it just tells me the previous
error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me to
install the extension.

Does someone have an idea why I'm not asked to install an extension to
share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Well I installed the plugin but my screen sharing still fails with an error
"failed to install desktop sharing extension". It's really strange because
when i clicked in the screen sharing button, it shows me a list of all my
windows to chose which one to show, and when I select one of them and click
ok I can see the chosen window displayed for a few seconds before crashing.

Jimmy

···

2016-06-09 10:50 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

With Safari, you need to install the Temasys Plugin, that is created in
collaboration with Skylink. That particular plugin would only work for
meet.jit.si, and if you need a plugin for you, then that would be paid.
It is free for Chrome & Firefox, but not for Safari and IE.

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com
On 09-Jun-2016 1:55 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

It also means that I can not share my screen with any web navigator ? I
tested Google Chrome, Mozilla Firefox and it worked, but with Safari even
at meet.jit.si it tells me that it was not able to install the needed
extension.

Jimmy

2016-06-09 10:09 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Yes. Correct

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com
On 09-Jun-2016 1:38 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

Thanks for the answer, basically if I use the external api available at
meet.jit.si I would not have this problem anymore ? (My local instance
is just for test purposes).

Jimmy

2016-06-09 9:39 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Hi,

You need to create your own extension for screen sharing and then put
the hex code in the config file. The hex code already present there is only
for meet.jit.si

Follow : https://github.com/jitsi/jidesha

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

On Thu, Jun 9, 2016 at 1:00 PM, Jimmy Kasprzak <jimmyk.dsi@gmail.com> >>>>> wrote:

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I
try to share my screen in a room, my screen become black with an alert
saying "failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my
screen. The problem is that Jitsi never asks me to install the needed
extension when I try to share my screen, it just tells me the previous
error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me
to install the extension.

Does someone have an idea why I'm not asked to install an extension
to share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Furthermore, I just realized that if I stop the screen sharing and click on
it again (without refreshing the page), it works then.

Jimmy

···

2016-06-09 11:42 GMT+02:00 Jimmy Kasprzak <jimmyk.dsi@gmail.com>:

Well I installed the plugin but my screen sharing still fails with an
error "failed to install desktop sharing extension". It's really strange
because when i clicked in the screen sharing button, it shows me a list of
all my windows to chose which one to show, and when I select one of them
and click ok I can see the chosen window displayed for a few seconds before
crashing.

Jimmy

2016-06-09 10:50 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

With Safari, you need to install the Temasys Plugin, that is created in
collaboration with Skylink. That particular plugin would only work for
meet.jit.si, and if you need a plugin for you, then that would be paid.
It is free for Chrome & Firefox, but not for Safari and IE.

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com
On 09-Jun-2016 1:55 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

It also means that I can not share my screen with any web navigator ? I
tested Google Chrome, Mozilla Firefox and it worked, but with Safari even
at meet.jit.si it tells me that it was not able to install the needed
extension.

Jimmy

2016-06-09 10:09 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Yes. Correct

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com
On 09-Jun-2016 1:38 pm, "Jimmy Kasprzak" <jimmyk.dsi@gmail.com> wrote:

Thanks for the answer, basically if I use the external api available
at meet.jit.si I would not have this problem anymore ? (My local
instance is just for test purposes).

Jimmy

2016-06-09 9:39 GMT+02:00 Ankit Arora <ankit.arora@tothenew.com>:

Hi,

You need to create your own extension for screen sharing and then put
the hex code in the config file. The hex code already present there is only
for meet.jit.si

Follow : https://github.com/jitsi/jidesha

Best Regards,
Ankit Arora
Tech Lead - Technology
TO THE NEW Digital
M: +91 7042461884
www.tothenew.com

On Thu, Jun 9, 2016 at 1:00 PM, Jimmy Kasprzak <jimmyk.dsi@gmail.com> >>>>>> wrote:

Hi everyone,

I have a little problem with my local instance of Jitsi : whenever I
try to share my screen in a room, my screen become black with an alert
saying "failed to install the extension for screen sharing".

In my developer console, I got the following errors :

conference.js:172 failed to create local tracks desktop
gum.chrome_extension_installation_error

conference.js:684 failed to share local desktop
gum.chrome_extension_installation_error

So basically, Jitsi didn't find the extension it needed to share my
screen. The problem is that Jitsi never asks me to install the needed
extension when I try to share my screen, it just tells me the previous
error.
I tried the same thing with the Jitsi instance we can use here : "
https://meet.jit.si/" and when I try to share my screen it asks me
to install the extension.

Does someone have an idea why I'm not asked to install an extension
to share my screen in my local instance of Jitsi ?

Thanks in advance

Jimmy

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev