[jitsi-dev] error starting from jar


#1

i'm trying to start the bridge from the built jitsi-videobridge.jar (built
with target 'jar' after following the instructions in build.xml), but i'm
running into an error. i successfully built the jar (as far as i can
tell), but when trying to run jvb.sh, i get:

$ ./jvb.sh --apis=rest
Exception in thread "main" java.lang.NoClassDefFoundError:
org/jitsi/meet/OSGiBundleConfig
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Class.java:2693)
        at java.lang.Class.privateGetMethodRecursive(Class.java:3040)
        at java.lang.Class.getMethod0(Class.java:3010)
        at java.lang.Class.getMethod(Class.java:1776)
        at
sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
        at
sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
Caused by: java.lang.ClassNotFoundException: org.jitsi.meet.OSGiBundleConfig
        at java.net.URLClassLoader$1.run(URLClassLoader.java:372)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:360)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 7 more

is there a step i'm missing?


#2

sorry, nevermind...it looks like the osgi packages are having trouble
getting pulled down from maven (or something? complaining that "POM for
'org.osgi:org.osgi.core:pom:4.3.1:compile' is invalid"), i'll try and get
that sorted.

···

On Fri, Jan 15, 2016 at 1:42 PM, Brian Baldino <brian@highfive.com> wrote:

i'm trying to start the bridge from the built jitsi-videobridge.jar (built
with target 'jar' after following the instructions in build.xml), but i'm
running into an error. i successfully built the jar (as far as i can
tell), but when trying to run jvb.sh, i get:

$ ./jvb.sh --apis=rest
Exception in thread "main" java.lang.NoClassDefFoundError:
org/jitsi/meet/OSGiBundleConfig
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Class.java:2693)
        at java.lang.Class.privateGetMethodRecursive(Class.java:3040)
        at java.lang.Class.getMethod0(Class.java:3010)
        at java.lang.Class.getMethod(Class.java:1776)
        at
sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
        at
sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
Caused by: java.lang.ClassNotFoundException:
org.jitsi.meet.OSGiBundleConfig
        at java.net.URLClassLoader$1.run(URLClassLoader.java:372)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:360)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 7 more

is there a step i'm missing?