[jitsi-dev] Error after developing Jitsi to work with OTC.


#1

Hello and welcome every one,
I'm working on a project to deploy Jitsi to on OTC/open thine client here
http://www.openthinclient.org/
and after deploying the package on the OTC Client i can run Jitsi only as a
root but when running the package as
a non-root user i'm receiving this error message...

Java.lang.Exception:unable to lock bundle cache:java.io.IOException:invlaid
argument at org.apache.Fleix.Framework.Cache.BundleCache.

so the question now why i'm receiving this error when i run the app as a
non-root user and how to fix it...help plz...and thanks in advance...


#2

Hey Mahmoud,

Sounds like it could be a permissions problem. Try deleting and
reinstalling Jitsi. Make sure you also remove the user profile
directory:

https://jitsi.org/Documentation/FAQ#jitsi-home

···

On Mon, Feb 17, 2014 at 10:53 PM, Mahmoud Ramadan Ali <cisco.and.more.blog@gmail.com> wrote:

Hello and welcome every one,
I'm working on a project to deploy Jitsi to on OTC/open thine client here
http://www.openthinclient.org/
and after deploying the package on the OTC Client i can run Jitsi only as a
root but when running the package as
a non-root user i'm receiving this error message...

Java.lang.Exception:unable to lock bundle cache:java.io.IOException:invlaid
argument at org.apache.Fleix.Framework.Cache.BundleCache.

so the question now why i'm receiving this error when i run the app as a
non-root user and how to fix it...help plz...and thanks in advance...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org


#3

i have configured chmod 777 -R for the directory holding the jitsi unpacked
files ..the root can run it on the OTC Client but the non root user
can't...but what do u mean by removing the user profile ? also do u think
the issue could be because of i need to setup http://bundler.io/ or what ?

···

On Tue, Feb 18, 2014 at 12:02 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Mahmoud,

Sounds like it could be a permissions problem. Try deleting and
reinstalling Jitsi. Make sure you also remove the user profile
directory:

https://jitsi.org/Documentation/FAQ#jitsi-home

On Mon, Feb 17, 2014 at 10:53 PM, Mahmoud Ramadan Ali > <cisco.and.more.blog@gmail.com> wrote:
> Hello and welcome every one,
> I'm working on a project to deploy Jitsi to on OTC/open thine client here
> http://www.openthinclient.org/
> and after deploying the package on the OTC Client i can run Jitsi only
as a
> root but when running the package as
> a non-root user i'm receiving this error message...
>
> Java.lang.Exception:unable to lock bundle
cache:java.io.IOException:invlaid
> argument at org.apache.Fleix.Framework.Cache.BundleCache.
>
> so the question now why i'm receiving this error when i run the app as a
> non-root user and how to fix it...help plz...and thanks in advance...
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Ok i have an idea that might be useful...how can i modify the Jitsi
script/executable to run automatically as root....?
Here is my Jitsi executable file

#!/bin/bash

# Get architecture
ARCH=`uname -m | sed -e s/x86_64/64/ -e s/i.86/32/`

# Additionnal JVM arguments
CLIENTARGS=""

if [ $ARCH -eq 32 ]
then
    CLIENTARGS="-client -Xmx256m"
fi

show_splash=true
for arg in "$@" ; do
  if [ "$arg" = "--splash=no" ] ; then
    show_splash=false
  elif [ "$arg" = "--splash=yes" ] ; then
    show_splash=true
  fi
done

SPLASH_ARG=""
if $show_splash ; then
    SPLASH_ARG="-splash:splash.gif"
fi

javabin=`which java`

SCDIR=/opt/jitsi05/usr/bin/jitsi
LIBPATH=$SCDIR/lib
CLASSPATH=$LIBPATH/felix.jar:$SCDIR/sc-bundles/sc-launcher.jar:$SCDIR/sc-bundles/util.jar:$LIBPATH
FELIX_CONFIG=$LIBPATH/felix.client.run.properties
LOG_CONFIG=$LIBPATH/logging.properties
COMMAND="$javabin $CLIENTARGS -classpath $CLASSPATH
-Djna.library.path=$SCDIR/lib/native
-Dfelix.config.properties=file:$FELIX_CONFIG
-Djava.util.logging.config.file=$LOG_CONFIG $SPLASH_ARG
-Dnet.java.sip.communicator.SC_HOME_DIR_NAME=.jitsi
net.java.sip.communicator.launcher.SIPCommunicator"

# set add LIBPATH to LD_LIBRARY_PATH for any sc natives (e.g. jmf .so's)
export
LD_LIBRARY_PATH="${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}$SCDIR/lib/native"

cd $SCDIR

exec $COMMAND $*

i'm waiting ur reply and thanks in advance...

···

On Tue, Feb 18, 2014 at 2:04 PM, Mahmoud Ramadan Ali < cisco.and.more.blog@gmail.com> wrote:

i have configured chmod 777 -R for the directory holding the jitsi
unpacked files ..the root can run it on the OTC Client but the non root
user can't...but what do u mean by removing the user profile ? also do u
think the issue could be because of i need to setup http://bundler.io/ or
what ?

On Tue, Feb 18, 2014 at 12:02 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Mahmoud,

Sounds like it could be a permissions problem. Try deleting and
reinstalling Jitsi. Make sure you also remove the user profile
directory:

https://jitsi.org/Documentation/FAQ#jitsi-home

On Mon, Feb 17, 2014 at 10:53 PM, Mahmoud Ramadan Ali >> <cisco.and.more.blog@gmail.com> wrote:
> Hello and welcome every one,
> I'm working on a project to deploy Jitsi to on OTC/open thine client
here
> http://www.openthinclient.org/
> and after deploying the package on the OTC Client i can run Jitsi only
as a
> root but when running the package as
> a non-root user i'm receiving this error message...
>
> Java.lang.Exception:unable to lock bundle
cache:java.io.IOException:invlaid
> argument at org.apache.Fleix.Framework.Cache.BundleCache.
>
> so the question now why i'm receiving this error when i run the app as a
> non-root user and how to fix it...help plz...and thanks in advance...
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

This shouldn't be necessary. Have you checked the permissions for the
.jitsi directory?

Regards,
Boris

···

On 20/02/14 10:51, Mahmoud Ramadan Ali wrote:

Ok i have an idea that might be useful...how can i modify the Jitsi
script/executable to run automatically as root....?


#6

I'm using the chmod 777 -R command on the parent directory that is holding
the package files...on the otc client i can run jitsi only as root
but when trying to run it as a non-root user i see a fast splash screen
and the package does not run...also here is the permissions on the otc
client

ls -l jitsi06
drwxrwxrwx 2 root root 22 2014-02-20 10:44 bin
drwxrwxrwx 8 root root 76 2014-02-20 10:44 share
drwxrwxrwx 2 root root 80 2014-02-20 10:44 tcos

so what i am missing to run the package as a non root user ?

···

On Thu, Feb 20, 2014 at 1:00 PM, Boris Grozev <boris@jitsi.org> wrote:

On 20/02/14 10:51, Mahmoud Ramadan Ali wrote:
> Ok i have an idea that might be useful...how can i modify the Jitsi
> script/executable to run automatically as root....?

This shouldn't be necessary. Have you checked the permissions for the
.jitsi directory?

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

also here is the full error...this might help u to figure out what is
causing this issue...

<img src=’/uploads/jitsi/original/2X/0/0bd167a75c3d11ac69abb0c754b10bd397f944fb.png’ width=‘647’ height=‘214’>

i'm waiting ur reply..and thanks in advance.....

···

On Thu, Feb 20, 2014 at 1:20 PM, Mahmoud Ramadan Ali < cisco.and.more.blog@gmail.com> wrote:

I'm using the chmod 777 -R command on the parent directory that is holding
the package files...on the otc client i can run jitsi only as root
but when trying to run it as a non-root user i see a fast splash screen
and the package does not run...also here is the permissions on the otc
client

ls -l jitsi06
drwxrwxrwx 2 root root 22 2014-02-20 10:44 bin
drwxrwxrwx 8 root root 76 2014-02-20 10:44 share
drwxrwxrwx 2 root root 80 2014-02-20 10:44 tcos

so what i am missing to run the package as a non root user ?

On Thu, Feb 20, 2014 at 1:00 PM, Boris Grozev <boris@jitsi.org> wrote:

On 20/02/14 10:51, Mahmoud Ramadan Ali wrote:
> Ok i have an idea that might be useful...how can i modify the Jitsi
> script/executable to run automatically as root....?

This shouldn't be necessary. Have you checked the permissions for the
.jitsi directory?

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

  I'm using the chmod 777 -R command on the parent directory that is
holding the package files...on the otc client i can run jitsi only as root

  but when trying to run it as a non-root user i see a fast splash
screen and the package does not run...also here is the permissions on
the otc client

How did you install Jitsi on that platform? It seems to me that you use a
customized installation.

By default Jitsi places it's configuration under ~/.jitsi. All you need for
permissions there is 600 (that is read/write for the user). If Jitsi tries
to write somewhere outside of this directory (and it seems like that), then
it fails to set its defaults. The image you posted shows failures from
Felix, so it seems it cannot find its configuration file and the properties
referenced therein (lib/felix.client.run.properties).

And don't hijack other threads, or nobody will help you!

Ingo


#9

Hello Bauersachs ,
Thank u for the reply...yes i did a custom installation to a custom
path/directory to develop this in OTC/openthinclient and the
felix.client.run.properties file is located in the
*/opt/jitsi06/share/jitsi/lib
path so what variables and what file i need to modify to change the
defaults to fix this issue and point to the configuration file for Fleix to
use it....*i'm waiting ur reply and thanks in advance...

···

On Thu, Feb 20, 2014 at 1:36 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> I'm using the chmod 777 -R command on the parent directory that is
> holding the package files...on the otc client i can run jitsi only as
root
>
> but when trying to run it as a non-root user i see a fast splash
> screen and the package does not run...also here is the permissions on
> the otc client

How did you install Jitsi on that platform? It seems to me that you use a
customized installation.

By default Jitsi places it's configuration under ~/.jitsi. All you need for
permissions there is 600 (that is read/write for the user). If Jitsi tries
to write somewhere outside of this directory (and it seems like that), then
it fails to set its defaults. The image you posted shows failures from
Felix, so it seems it cannot find its configuration file and the properties
referenced therein (lib/felix.client.run.properties).

And don't hijack other threads, or nobody will help you!

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Thank u for the reply...yes i did a custom installation to a custom
path/directory to develop this in OTC/openthinclient and the
felix.client.run.properties file is located in the
/opt/jitsi06/share/jitsi/lib path so what variables and what file i need
to modify to change the defaults to fix this issue and point to the
configuration file for Fleix to use it....i'm waiting ur reply and
thanks in advance...

/opt/jitsi06/share/jitsi/lib and the files therein need to be on the
classpath. Adapt the launcher script accordingly.

Ingo


#11

hello friend...i have changed the SCDIR variable in the executable
file...the SCDIR that is holding the bin and share directories is jitsi06
and it is located in the /opt directory so the full bath i have configured
in the script is
/opt/jitsi06/share/jitsi and inside this directory lib and sc-bundles and
splash.gif and the executable file can see all the files and directories in
the SCDIR since it has the variable value set...on the client i can run the
package as root but when executing the executable as non root user i see
the fast splash screen and it disapear immediately and get the error in the
image i posted before also
i have configured the chmod -R 777 on the parent directory to enable anyone
to run the app so what is causing this error message and how to fix it...

....................................................
#!/bin/bash

# Get architecture
ARCH=`uname -m | sed -e s/x86_64/64/ -e s/i.86/32/`

# Additionnal JVM arguments
CLIENTARGS=""

if [ $ARCH -eq 32 ]
then
    CLIENTARGS="-client -Xmx256m"
fi

show_splash=true
for arg in "$@" ; do
  if [ "$arg" = "--splash=no" ] ; then
    show_splash=false
  elif [ "$arg" = "--splash=yes" ] ; then
    show_splash=true
  fi
done

SPLASH_ARG=""
if $show_splash ; then
    SPLASH_ARG="-splash:splash.gif"
fi

javabin=`which java`

SCDIR=/opt/jitsi06/share/jitsi
LIBPATH=$SCDIR/lib
CLASSPATH=$LIBPATH/felix.jar:$SCDIR/sc-bundles/sc-launcher.jar:$SCDIR/sc-bundles/util.jar:$LIBPATH
FELIX_CONFIG=$LIBPATH/felix.client.run.properties
LOG_CONFIG=$LIBPATH/logging.properties
COMMAND="$javabin $CLIENTARGS -classpath $CLASSPATH
-Djna.library.path=$SCDIR/lib/native
-Dfelix.config.properties=file:$FELIX_CONFIG
-Djava.util.logging.config.file=$LOG_CONFIG $SPLASH_ARG
-Dnet.java.sip.communicator.SC_HOME_DIR_NAME=.jitsi
net.java.sip.communicator.launcher.SIPCommunicator"

# set add LIBPATH to LD_LIBRARY_PATH for any sc natives (e.g. jmf .so's)
export
LD_LIBRARY_PATH="${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}$SCDIR/lib/native"

cd $SCDIR

exec $COMMAND $*
..................................................................

···

On Thu, Feb 20, 2014 at 7:14 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> Thank u for the reply...yes i did a custom installation to a custom
> path/directory to develop this in OTC/openthinclient and the
> felix.client.run.properties file is located in the
> /opt/jitsi06/share/jitsi/lib path so what variables and what file i need
> to modify to change the defaults to fix this issue and point to the
> configuration file for Fleix to use it....i'm waiting ur reply and
> thanks in advance...

/opt/jitsi06/share/jitsi/lib and the files therein need to be on the
classpath. Adapt the launcher script accordingly.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev