[jitsi-dev] Easycam works only with LD_PRELOAD on Ubuntu/Debian


#1

Hi,

Hi Jitsi devs,

my webcam (Typhoon EasyCam) is now succesfully working with the newest
nightly build (jitsi_2.3.4849-1_i386.deb), but only by using the
following LD_PRELOAD (in the console) [1]:

$ LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so jitsi

Can solve this in Jitsi itself or shell I report it to the Debian bug
tracker?

My system: Ubuntu 12.04.3 LTS (Precise)
With the current Debian sid/unstable version (2.3.4687.9786-1), there
was only a black screen in the preview window, as mentioned in [2].

Ok we will consider this option.

By the way:

* https://jitsi.org/Documentation/ReportingBugs -> Jitsi instead of SIP
Communicator

Thanks, fixed.

* Update https://jitsi.org/Main/DebianRepository and link to
http://packages.debian.org/sid/jitsi (The version in the Jitsi
repository is older than the one in Debian.)

We have a stable line and nightly builds. The Debian repository has
different release cycle, as it takes a bit longer to submit a package and
we try to do our best there. So the links you mention are correct.

Regards
damencho

···

On Thu, Oct 3, 2013 at 5:08 PM, Dominik K. <d.k@quantentunnel.de> wrote:

Maybe the v4l-info output is also good to have:

### v4l2 device info [/dev/video0] ###
general info
    VIDIOC_QUERYCAP
        driver : "sonixb"
        card : "USB camera"
        bus_info : "usb-0000:00:1d.1-1"
        version : 3.2.50
        capabilities : 0x5000001
[VIDEO_CAPTURE,READWRITE,STREAMING]

standards

inputs
    VIDIOC_ENUMINPUT(0)
        index : 0
        name : "sonixb"
        type : CAMERA
        audioset : 0
        tuner : 0
        std : 0x0 []
        status : 0x0 []

video capture
    VIDIOC_ENUM_FMT(0,VIDEO_CAPTURE)
        index : 0
        type : VIDEO_CAPTURE
        flags : 0
        description : "S910"
        pixelformat : 0x30313953 [S910]
    VIDIOC_ENUM_FMT(1,VIDEO_CAPTURE)
        index : 1
        type : VIDEO_CAPTURE
        flags : 0
        description : "BA81"
        pixelformat : 0x31384142 [BA81]
    VIDIOC_G_FMT(VIDEO_CAPTURE)
        type : VIDEO_CAPTURE
        fmt.pix.width : 640
        fmt.pix.height : 480
        fmt.pix.pixelformat : 0x30313953 [S910]
        fmt.pix.field : NONE
        fmt.pix.bytesperline : 640
        fmt.pix.sizeimage : 384000
        fmt.pix.colorspace : SRGB
        fmt.pix.priv : 0

controls
    VIDIOC_QUERYCTRL(BASE+0)
        id : 9963776
        type : INTEGER
        name : "Brightness"
        minimum : 0
        maximum : 255
        step : 1
        default_value : 127
        flags : 0
    VIDIOC_QUERYCTRL(BASE+17)
        id : 9963793
        type : INTEGER
        name : "Exposure"
        minimum : 0
        maximum : 1023
        step : 1
        default_value : 66
        flags : 16
    VIDIOC_QUERYCTRL(BASE+18)
        id : 9963794
        type : BOOLEAN
        name : "Automatic Gain (and Exposure)"
        minimum : 0
        maximum : 1
        step : 1
        default_value : 1
        flags : 8
    VIDIOC_QUERYCTRL(BASE+19)
        id : 9963795
        type : INTEGER
        name : "Gain"
        minimum : 0
        maximum : 255
        step : 1
        default_value : 127
        flags : 16

Regards,

Dominik

[1] "[jitsi-dev] Re: Jitsi doesn't catch web cameras on OpenSuSE
Linux", Date: Wed, 30 May 2012 16:06:03 +0300 ->
https://java.net/projects/jitsi/lists/dev/archive/2012-05/message/128
[2] "[jitsi-dev] Re: [jitsi-users] No webcam picture in Jitsi", Date:
Fri, 8 Mar 2013 02:57:59 -0800 (PST) ->
https://java.net/projects/jitsi/lists/dev/archive/2013-03/message/121

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#2

Hi, thanks for mentioning:

> $ LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so jitsi

It's a VERY simple solution for a problem we are having for years.

> Can solve this in Jitsi itself or shell I report it to the Debian bug
> tracker?

Ok we will consider this option.

Any news on this?
With jitsi 2.5.5065 on xubuntu 13.10 there is still the same problem with
<no device> in the video section, using a LogiLink or a MS-Tech webcam. But
with starting jitsi like above, both cameras are showing up and are able to
preview. Any chance this line is going to make it into the normal jitsi
starting process, so I don't have to use a special script for starting jitsi?

Thanks for Your concern,
groovE