[jitsi-dev] DTMF tones not working with Pulse Audio


#1

Hi,

       I'm not able to send DTMF tones when using Pulse Audio audio system. I hear the DTMF tones being dialed but my service provider indicates no tone was received.

     Tones are sent correctly when using PortAudio.

     By default I use Auto DTMF tone setting but also tried SIP Info and does not work as well. Also tried to increase DTMF time to 120.

    Did anyone had such problem ?

     Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

     Regards,

         Adelino.


#2

Hey Adelino,

     Hi,

       I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

     Tones are sent correctly when using PortAudio.

     By default I use Auto DTMF tone setting but also tried SIP Info and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

···

On 06.05.13, 03:16, Adelino Rocha wrote:

    Did anyone had such problem ?

     Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

     Regards,

         Adelino.

--
https://jitsi.org


#3

Hi Emil,

         ok, I will check the traffic packets. Please be aware that my aim is to use RTP/RFC 4733. I just referred SIP Info as test option.

      I still think this is a problem in Jitsi and note on remote server because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with Port Audio.

  Regards,

          Adelino

···

On 05/07/2013 04:44 PM, Emil Ivov wrote:

Hey Adelino,

On 06.05.13, 03:16, Adelino Rocha wrote:

      Hi,

        I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

      Tones are sent correctly when using PortAudio.

      By default I use Auto DTMF tone setting but also tried SIP Info and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

     Did anyone had such problem ?

      Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

      Regards,

          Adelino.


#4

Hey Adelino,

--sent from my mobile

Hi Emil,

        ok, I will check the traffic packets. Please be aware that my aim

is to use RTP/RFC 4733. I just referred SIP Info as test option.

     I still think this is a problem in Jitsi and note on remote server

because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine
with Port Audio.

Could you please have a look at the rtp traffic and see if the packets are
actually being sent?

Thanks,
Emil

Regards,

         Adelino

Hey Adelino,

      Hi,

        I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

      Tones are sent correctly when using PortAudio.

      By default I use Auto DTMF tone setting but also tried SIP Info

and

···

On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com> wrote:

On 05/07/2013 04:44 PM, Emil Ivov wrote:

On 06.05.13, 03:16, Adelino Rocha wrote:

does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

     Did anyone had such problem ?

      Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

      Regards,

          Adelino.


#5

Hi Emil,

         here are some files with RTP net. traffic. Each for a different scenario.

     Regards,

         Adelino.

DTMF_issue_net_packets.tar.gz (1.54 MB)

···

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com > <mailto:aderocha1a@gmail.com>> wrote:
>
> Hi Emil,
>
> ok, I will check the traffic packets. Please be aware that my aim is to use RTP/RFC 4733. I just referred SIP Info as test option.
>
> I still think this is a problem in Jitsi and note on remote server because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with Port Audio.

Could you please have a look at the rtp traffic and see if the packets are actually being sent?

Thanks,
Emil
>
> Regards,
>
> Adelino
>
> On 05/07/2013 04:44 PM, Emil Ivov wrote:
>>
>> Hey Adelino,
>>
>> On 06.05.13, 03:16, Adelino Rocha wrote:
>>>
>>> Hi,
>>>
>>> I'm not able to send DTMF tones when using Pulse Audio audio
>>> system. I hear the DTMF tones being dialed but my service provider
>>> indicates no tone was received.
>>>
>>> Tones are sent correctly when using PortAudio.
>>>
>>> By default I use Auto DTMF tone setting but also tried SIP Info and
>>> does not work as well. Also tried to increase DTMF time to 120.
>>
>> It is unlikely that the audio system would have any impact whatsoever on
>> non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
>> are completely independent.
>>
>> Have you tried looking at the traffic? Could this be related to your
>> server-side?
>>
>> Cheers,
>> Emil
>>>
>>> Did anyone had such problem ?
>>>
>>> Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.
>>>
>>> Regards,
>>>
>>> Adelino.
>>>
>


#6

Hi Emil,

         did you had the opportunity to analyze those dumps I sent ?

          Some of the strange things I found is that RTP packets for DTMF seems to be sent only when having "telephone-event" codec enabled even when configuring it to send exclusively RTP/RFC 4733.

     I also sent the dump created by linphone (that works fine for same provider). I noticed that DTMF packets are a bit bigger, don't know if this has any importance in this case.

     Regards,

         Adelino.

DTMF_issue_net_packets.tar.gz (1.54 MB)

···

On 05/09/2013 02:02 AM, Adelino Rocha wrote:

    Hi Emil,

        here are some files with RTP net. traffic. Each for a different scenario.

    Regards,

        Adelino.

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com >> <mailto:aderocha1a@gmail.com>> wrote:
>
> Hi Emil,
>
> ok, I will check the traffic packets. Please be aware that my aim is to use RTP/RFC 4733. I just referred SIP Info as test option.
>
> I still think this is a problem in Jitsi and note on remote server because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with Port Audio.

Could you please have a look at the rtp traffic and see if the packets are actually being sent?

Thanks,
Emil
>
> Regards,
>
> Adelino
>
> On 05/07/2013 04:44 PM, Emil Ivov wrote:
>>
>> Hey Adelino,
>>
>> On 06.05.13, 03:16, Adelino Rocha wrote:
>>>
>>> Hi,
>>>
>>> I'm not able to send DTMF tones when using Pulse Audio audio
>>> system. I hear the DTMF tones being dialed but my service provider
>>> indicates no tone was received.
>>>
>>> Tones are sent correctly when using PortAudio.
>>>
>>> By default I use Auto DTMF tone setting but also tried SIP Info and
>>> does not work as well. Also tried to increase DTMF time to 120.
>>
>> It is unlikely that the audio system would have any impact whatsoever on
>> non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
>> are completely independent.
>>
>> Have you tried looking at the traffic? Could this be related to your
>> server-side?
>>
>> Cheers,
>> Emil
>>>
>>> Did anyone had such problem ?
>>>
>>> Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.
>>>
>>> Regards,
>>>
>>> Adelino.
>>>
>


#7

Hey Adelino,

    Hi Emil,

        did you had the opportunity to analyze those dumps I sent ?

         Some of the strange things I found is that RTP packets for DTMF
seems to be sent only when having "telephone-event" codec enabled even when
configuring it to send exclusively RTP/RFC 4733.

That's actually not strange at all! The "telephone-event" payload _is_
the one that's used to transport 4733 dtmf events. If you have been
turning it off then lack of 4733 DTMF is to be expected.

Hope this helps,
Emil

···

On Sat, May 18, 2013 at 12:21 PM, Adelino Rocha <aderocha1a@gmail.com> wrote:

    I also sent the dump created by linphone (that works fine for same
provider). I noticed that DTMF packets are a bit bigger, don't know if this
has any importance in this case.

    Regards,

        Adelino.

On 05/09/2013 02:02 AM, Adelino Rocha wrote:

    Hi Emil,

        here are some files with RTP net. traffic. Each for a different
scenario.

    Regards,

        Adelino.

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com> wrote:

Hi Emil,

        ok, I will check the traffic packets. Please be aware that my aim
is to use RTP/RFC 4733. I just referred SIP Info as test option.

     I still think this is a problem in Jitsi and note on remote server
because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with
Port Audio.

Could you please have a look at the rtp traffic and see if the packets are
actually being sent?

Thanks,
Emil

Regards,

         Adelino

On 05/07/2013 04:44 PM, Emil Ivov wrote:

Hey Adelino,

On 06.05.13, 03:16, Adelino Rocha wrote:

      Hi,

        I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

      Tones are sent correctly when using PortAudio.

      By default I use Auto DTMF tone setting but also tried SIP Info
and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

     Did anyone had such problem ?

      Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

      Regards,

          Adelino.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#8

Hi Adelino,

do you know which dtmf method is supported by your provider?
If you want to use rfc4733 dtmf tones, you need to have telephone-event enabled.
We made some changes, could you please test with latest build (4734 or
4735) using rfc4733 and "telephone-event" enabled and if you have
changed the minimum tone duration, make sure it has at least value of
100. When using rfc4733 the audio system has nothing to do with
sending dtmf tones.

Regards
damencho

···

On Sat, May 18, 2013 at 12:30 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Adelino,

On Sat, May 18, 2013 at 12:21 PM, Adelino Rocha <aderocha1a@gmail.com> wrote:

    Hi Emil,

        did you had the opportunity to analyze those dumps I sent ?

         Some of the strange things I found is that RTP packets for DTMF
seems to be sent only when having "telephone-event" codec enabled even when
configuring it to send exclusively RTP/RFC 4733.

That's actually not strange at all! The "telephone-event" payload _is_
the one that's used to transport 4733 dtmf events. If you have been
turning it off then lack of 4733 DTMF is to be expected.

Hope this helps,
Emil

    I also sent the dump created by linphone (that works fine for same
provider). I noticed that DTMF packets are a bit bigger, don't know if this
has any importance in this case.

    Regards,

        Adelino.

On 05/09/2013 02:02 AM, Adelino Rocha wrote:

    Hi Emil,

        here are some files with RTP net. traffic. Each for a different
scenario.

    Regards,

        Adelino.

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com> wrote:

Hi Emil,

        ok, I will check the traffic packets. Please be aware that my aim
is to use RTP/RFC 4733. I just referred SIP Info as test option.

     I still think this is a problem in Jitsi and note on remote server
because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with
Port Audio.

Could you please have a look at the rtp traffic and see if the packets are
actually being sent?

Thanks,
Emil

Regards,

         Adelino

On 05/07/2013 04:44 PM, Emil Ivov wrote:

Hey Adelino,

On 06.05.13, 03:16, Adelino Rocha wrote:

      Hi,

        I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

      Tones are sent correctly when using PortAudio.

      By default I use Auto DTMF tone setting but also tried SIP Info
and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

     Did anyone had such problem ?

      Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

      Regards,

          Adelino.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Hi Damian,

         thanks a lot for your attention to this issue.

         I tested several configurations including the one you suggested:

         - RFC4733
         - telephone-event ON
         - 100 ms and 120 ms for DTMF duration

     But unfortunately doesn't work.

     I was able to conclude that my company SIP provider is using INBAND method:

     Only configuration I was able to make it work is this:

         - PortAudio sound system (with PulseAudio doesn't work)
         - INBAND DTMF (AUTO also work, but certainly INBAND is used in the back)
         - telephone-event OFF

     Be aware that in this working configuration if I enable telephone-event it no longer works. May the telephone-event codec be the problem ?

     As I referred before, I have no problem to use PortAudio but for some reason it causes a big delay (> 5 sec) on input sound (mic).

     Regards,

         Adelino.

···

On 07/12/2013 03:11 PM, Damian Minkov wrote:

Hi Adelino,

do you know which dtmf method is supported by your provider?
If you want to use rfc4733 dtmf tones, you need to have telephone-event enabled.
We made some changes, could you please test with latest build (4734 or
4735) using rfc4733 and "telephone-event" enabled and if you have
changed the minimum tone duration, make sure it has at least value of
100. When using rfc4733 the audio system has nothing to do with
sending dtmf tones.

Regards
damencho

On Sat, May 18, 2013 at 12:30 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Adelino,

On Sat, May 18, 2013 at 12:21 PM, Adelino Rocha <aderocha1a@gmail.com> wrote:

     Hi Emil,

         did you had the opportunity to analyze those dumps I sent ?

          Some of the strange things I found is that RTP packets for DTMF
seems to be sent only when having "telephone-event" codec enabled even when
configuring it to send exclusively RTP/RFC 4733.

That's actually not strange at all! The "telephone-event" payload _is_
the one that's used to transport 4733 dtmf events. If you have been
turning it off then lack of 4733 DTMF is to be expected.

Hope this helps,
Emil

     I also sent the dump created by linphone (that works fine for same
provider). I noticed that DTMF packets are a bit bigger, don't know if this
has any importance in this case.

     Regards,

         Adelino.

On 05/09/2013 02:02 AM, Adelino Rocha wrote:

     Hi Emil,

         here are some files with RTP net. traffic. Each for a different
scenario.

     Regards,

         Adelino.

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com> wrote:

Hi Emil,

         ok, I will check the traffic packets. Please be aware that my aim
is to use RTP/RFC 4733. I just referred SIP Info as test option.

      I still think this is a problem in Jitsi and note on remote server
because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with
Port Audio.

Could you please have a look at the rtp traffic and see if the packets are
actually being sent?

Thanks,
Emil

  Regards,

          Adelino

On 05/07/2013 04:44 PM, Emil Ivov wrote:

Hey Adelino,

On 06.05.13, 03:16, Adelino Rocha wrote:

       Hi,

         I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

       Tones are sent correctly when using PortAudio.

       By default I use Auto DTMF tone setting but also tried SIP Info
and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

      Did anyone had such problem ?

       Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

       Regards,

           Adelino.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hey Adelino,

      Hi Damian,

          thanks a lot for your attention to this issue.

          I tested several configurations including the one you suggested:

          - RFC4733
          - telephone-event ON
          - 100 ms and 120 ms for DTMF duration

      But unfortunately doesn't work.

      I was able to conclude that my company SIP provider is using INBAND
method:

This could be. Or it could be that it really doesn't support anything and it just leaves it to the end system to detect tones in the audio stream.

      Only configuration I was able to make it work is this:

          - PortAudio sound system (with PulseAudio doesn't work)
          - INBAND DTMF (AUTO also work, but certainly INBAND is used in
the back)
          - telephone-event OFF

      Be aware that in this working configuration if I enable
telephone-event it no longer works.

OK. This means that it probably does support RFC 4733 but it just doesn't like the packets we send.

May the telephone-event codec be the problem ?

Possibly. Note that "codec" is a bit of an exaggeration here. An RFC 4733 packets just says: key N pressed. There's not really a lot that could go wrong.

      As I referred before, I have no problem to use PortAudio but for
some reason it causes a big delay (> 5 sec) on input sound (mic).

There could be a problem with the DTMF injection and pulse audio. We did some changes on our mixer recently. Lyubo, do you think they could be related?

Cheers,
Emil

···

On 13.07.13, 01:59, Adelino Rocha wrote:

      Regards,

          Adelino.

On 07/12/2013 03:11 PM, Damian Minkov wrote:

Hi Adelino,

do you know which dtmf method is supported by your provider?
If you want to use rfc4733 dtmf tones, you need to have telephone-event enabled.
We made some changes, could you please test with latest build (4734 or
4735) using rfc4733 and "telephone-event" enabled and if you have
changed the minimum tone duration, make sure it has at least value of
100. When using rfc4733 the audio system has nothing to do with
sending dtmf tones.

Regards
damencho

On Sat, May 18, 2013 at 12:30 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Adelino,

On Sat, May 18, 2013 at 12:21 PM, Adelino Rocha <aderocha1a@gmail.com> wrote:

      Hi Emil,

          did you had the opportunity to analyze those dumps I sent ?

           Some of the strange things I found is that RTP packets for DTMF
seems to be sent only when having "telephone-event" codec enabled even when
configuring it to send exclusively RTP/RFC 4733.

That's actually not strange at all! The "telephone-event" payload _is_
the one that's used to transport 4733 dtmf events. If you have been
turning it off then lack of 4733 DTMF is to be expected.

Hope this helps,
Emil

      I also sent the dump created by linphone (that works fine for same
provider). I noticed that DTMF packets are a bit bigger, don't know if this
has any importance in this case.

      Regards,

          Adelino.

On 05/09/2013 02:02 AM, Adelino Rocha wrote:

      Hi Emil,

          here are some files with RTP net. traffic. Each for a different
scenario.

      Regards,

          Adelino.

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com> wrote:

Hi Emil,

          ok, I will check the traffic packets. Please be aware that my aim
is to use RTP/RFC 4733. I just referred SIP Info as test option.

       I still think this is a problem in Jitsi and note on remote server
because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with
Port Audio.

Could you please have a look at the rtp traffic and see if the packets are
actually being sent?

Thanks,
Emil

   Regards,

           Adelino

On 05/07/2013 04:44 PM, Emil Ivov wrote:

Hey Adelino,

On 06.05.13, 03:16, Adelino Rocha wrote:

        Hi,

          I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

        Tones are sent correctly when using PortAudio.

        By default I use Auto DTMF tone setting but also tried SIP Info
and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

       Did anyone had such problem ?

        Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

        Regards,

            Adelino.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org


#11

Hi Emil,

     Regarding your comment:/
/

    /There could be a problem with the DTMF injection and pulse audio.
    We did some changes on our mixer recently. Lyubo, do you think they
    could be related? /

      Just to say that this is not a recent problem. I have been trying Jitsi since version 1.1 with which everything was working fine with PortAudio until I upgraded to Fedora 18.

     Then I have been trying versions 2.2 and 2.3 and DTMFs never worked properly for me since then.

     Regards,

         Adelino.

···

On 07/13/2013 06:30 PM, Emil Ivov wrote:

Hey Adelino,

On 13.07.13, 01:59, Adelino Rocha wrote:

      Hi Damian,

          thanks a lot for your attention to this issue.

          I tested several configurations including the one you suggested:

          - RFC4733
          - telephone-event ON
          - 100 ms and 120 ms for DTMF duration

      But unfortunately doesn't work.

      I was able to conclude that my company SIP provider is using INBAND
method:

This could be. Or it could be that it really doesn't support anything and it just leaves it to the end system to detect tones in the audio stream.

      Only configuration I was able to make it work is this:

          - PortAudio sound system (with PulseAudio doesn't work)
          - INBAND DTMF (AUTO also work, but certainly INBAND is used in
the back)
          - telephone-event OFF

      Be aware that in this working configuration if I enable
telephone-event it no longer works.

OK. This means that it probably does support RFC 4733 but it just doesn't like the packets we send.

May the telephone-event codec be the problem ?

Possibly. Note that "codec" is a bit of an exaggeration here. An RFC 4733 packets just says: key N pressed. There's not really a lot that could go wrong.

      As I referred before, I have no problem to use PortAudio but for
some reason it causes a big delay (> 5 sec) on input sound (mic).

There could be a problem with the DTMF injection and pulse audio. We did some changes on our mixer recently. Lyubo, do you think they could be related?

Cheers,
Emil

      Regards,

          Adelino.

On 07/12/2013 03:11 PM, Damian Minkov wrote:

Hi Adelino,

do you know which dtmf method is supported by your provider?
If you want to use rfc4733 dtmf tones, you need to have telephone-event enabled.
We made some changes, could you please test with latest build (4734 or
4735) using rfc4733 and "telephone-event" enabled and if you have
changed the minimum tone duration, make sure it has at least value of
100. When using rfc4733 the audio system has nothing to do with
sending dtmf tones.

Regards
damencho

On Sat, May 18, 2013 at 12:30 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Adelino,

On Sat, May 18, 2013 at 12:21 PM, Adelino Rocha >>>> <aderocha1a@gmail.com> wrote:

      Hi Emil,

          did you had the opportunity to analyze those dumps I sent ?

           Some of the strange things I found is that RTP packets for DTMF
seems to be sent only when having "telephone-event" codec enabled even when
configuring it to send exclusively RTP/RFC 4733.

That's actually not strange at all! The "telephone-event" payload _is_
the one that's used to transport 4733 dtmf events. If you have been
turning it off then lack of 4733 DTMF is to be expected.

Hope this helps,
Emil

      I also sent the dump created by linphone (that works fine for same
provider). I noticed that DTMF packets are a bit bigger, don't know if this
has any importance in this case.

      Regards,

          Adelino.

On 05/09/2013 02:02 AM, Adelino Rocha wrote:

      Hi Emil,

          here are some files with RTP net. traffic. Each for a different
scenario.

      Regards,

          Adelino.

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com> >>>>> wrote:

Hi Emil,

          ok, I will check the traffic packets. Please be aware that my aim
is to use RTP/RFC 4733. I just referred SIP Info as test option.

       I still think this is a problem in Jitsi and note on remote server
because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with
Port Audio.

Could you please have a look at the rtp traffic and see if the packets are
actually being sent?

Thanks,
Emil

   Regards,

           Adelino

On 05/07/2013 04:44 PM, Emil Ivov wrote:

Hey Adelino,

On 06.05.13, 03:16, Adelino Rocha wrote:

        Hi,

          I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

        Tones are sent correctly when using PortAudio.

        By default I use Auto DTMF tone setting but also tried SIP Info
and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

       Did anyone had such problem ?

        Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

        Regards,

            Adelino.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Hi,

         just to let you know that DTMFs now work fine with PulseAudio after fix described in attached e-mail.

     Regards & Thanks,

         Adelino.

···

On 07/13/2013 06:30 PM, Emil Ivov wrote:

Hey Adelino,

On 13.07.13, 01:59, Adelino Rocha wrote:

      Hi Damian,

          thanks a lot for your attention to this issue.

          I tested several configurations including the one you suggested:

          - RFC4733
          - telephone-event ON
          - 100 ms and 120 ms for DTMF duration

      But unfortunately doesn't work.

      I was able to conclude that my company SIP provider is using INBAND
method:

This could be. Or it could be that it really doesn't support anything and it just leaves it to the end system to detect tones in the audio stream.

      Only configuration I was able to make it work is this:

          - PortAudio sound system (with PulseAudio doesn't work)
          - INBAND DTMF (AUTO also work, but certainly INBAND is used in
the back)
          - telephone-event OFF

      Be aware that in this working configuration if I enable
telephone-event it no longer works.

OK. This means that it probably does support RFC 4733 but it just doesn't like the packets we send.

May the telephone-event codec be the problem ?

Possibly. Note that "codec" is a bit of an exaggeration here. An RFC 4733 packets just says: key N pressed. There's not really a lot that could go wrong.

      As I referred before, I have no problem to use PortAudio but for
some reason it causes a big delay (> 5 sec) on input sound (mic).

There could be a problem with the DTMF injection and pulse audio. We did some changes on our mixer recently. Lyubo, do you think they could be related?

Cheers,
Emil

      Regards,

          Adelino.

On 07/12/2013 03:11 PM, Damian Minkov wrote:

Hi Adelino,

do you know which dtmf method is supported by your provider?
If you want to use rfc4733 dtmf tones, you need to have telephone-event enabled.
We made some changes, could you please test with latest build (4734 or
4735) using rfc4733 and "telephone-event" enabled and if you have
changed the minimum tone duration, make sure it has at least value of
100. When using rfc4733 the audio system has nothing to do with
sending dtmf tones.

Regards
damencho

On Sat, May 18, 2013 at 12:30 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Adelino,

On Sat, May 18, 2013 at 12:21 PM, Adelino Rocha >>>> <aderocha1a@gmail.com> wrote:

      Hi Emil,

          did you had the opportunity to analyze those dumps I sent ?

           Some of the strange things I found is that RTP packets for DTMF
seems to be sent only when having "telephone-event" codec enabled even when
configuring it to send exclusively RTP/RFC 4733.

That's actually not strange at all! The "telephone-event" payload _is_
the one that's used to transport 4733 dtmf events. If you have been
turning it off then lack of 4733 DTMF is to be expected.

Hope this helps,
Emil

      I also sent the dump created by linphone (that works fine for same
provider). I noticed that DTMF packets are a bit bigger, don't know if this
has any importance in this case.

      Regards,

          Adelino.

On 05/09/2013 02:02 AM, Adelino Rocha wrote:

      Hi Emil,

          here are some files with RTP net. traffic. Each for a different
scenario.

      Regards,

          Adelino.

On 05/08/2013 06:53 AM, Emil Ivov wrote:

Hey Adelino,

--sent from my mobile
On May 7, 2013 11:43 PM, "Adelino Rocha" <aderocha1a@gmail.com> >>>>> wrote:

Hi Emil,

          ok, I will check the traffic packets. Please be aware that my aim
is to use RTP/RFC 4733. I just referred SIP Info as test option.

       I still think this is a problem in Jitsi and note on remote server
because RTP/RFC 4733 DTMF does not work with Pulse Audio but works fine with
Port Audio.

Could you please have a look at the rtp traffic and see if the packets are
actually being sent?

Thanks,
Emil

   Regards,

           Adelino

On 05/07/2013 04:44 PM, Emil Ivov wrote:

Hey Adelino,

On 06.05.13, 03:16, Adelino Rocha wrote:

        Hi,

          I'm not able to send DTMF tones when using Pulse Audio audio
system. I hear the DTMF tones being dialed but my service provider
indicates no tone was received.

        Tones are sent correctly when using PortAudio.

        By default I use Auto DTMF tone setting but also tried SIP Info
and
does not work as well. Also tried to increase DTMF time to 120.

It is unlikely that the audio system would have any impact whatsoever on
non-inband DTMF sending methods. That is, both RTP/RFC 4733 and SIP INFO
are completely independent.

Have you tried looking at the traffic? Could this be related to your
server-side?

Cheers,
Emil

       Did anyone had such problem ?

        Jitsi version is jitsi-2.3-4612.9630.x86_64 on a Fedora 18 x86_64.

        Regards,

            Adelino.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev