[jitsi-dev] Discarding a mapping harvester


#1

Hi everybody
My jitsi-meet is at home behind a nat (IP local: 192.168.1.2 and IP public: XXXXXX.ddns.net). Here's my /etc/jitsi/videobridge/sip-communicator.properties :
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXX.ddns.net <mailto:org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXX.ddns.net>/.*org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=192.168.1.2org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=XXXXXX.ddns.net
When I restart jitsi-videobridge, the jvb.log returns this line:JVB 2018-05-30 15:41:52.648 INFOS: [15] org.ice4j.ice.harvest.MappingCandidateHarvesters.maybeAdd() Discarding a mapping harvester: org.ice4j.ice.harvest.MappingCandidateHarvester, face=/192.168.1.2, mask=XXXXXX.ddns.net/192.168.1.2
Is that normal ?
Thanks for help
Yann

···

--
Envoi sécurisé avec Tutanota. Obtenez votre adresse email chiffrée aujourd'hui!


#2

Hi
I think I've found what could be wrong:I'm using apache2 and I've a https site on my server with certbots certificates. I use them for my jitsi site in the apache2 config but I didn't direct prosody (I use the 0.9) to use them. So I copied them in /etc/prosody/certs:# cp /etc/letsencrypt/live/XXXXXX.ddns.net/*.pem /etc/prosody/certs/
and I provide the following config under the VirtualHost:VirtualHost "auth.XXXXXX.ddns.net" ssl = { key = "/etc/prosody/certs/fullchain.pem"; certificate = "/etc/prosody/certs/privkey.pem"; }But when I restart prosody, I 've this:certmanager: SSL/TLS: Failed to load '/etc/prosody/certs/fullchain.pem': Reason: no start line (for auth.XXXXXX.ddns.net etc/prosody/certs/fullchain.pem': Reason: no start line (for auth.XXXXXX.ddns.net)

What could I do to solve this ?
Thanks for your answer, and sorry for my english...
Yann

···

--
Envoi sécurisé avec Tutanota. Obtenez votre adresse email chiffrée aujourd'hui!
https://tutanota.com

30. Mai 2018 15:48 de yannick.rousseau@tutanota.com <mailto:yannick.rousseau@tutanota.com>:

Hi everybody
My jitsi-meet is at home behind a nat (IP local: 192.168.1.2 and IP public: XXXXXX.ddns.net). Here's my /etc/jitsi/videobridge/sip-communicator.properties :
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXX.ddns.net <mailto:org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXX.ddns.net>> /.*> org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=192.168.1.2> org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=XXXXXX.ddns.net
When I restart jitsi-videobridge, the jvb.log returns this line:> JVB 2018-05-30 15:41:52.648 INFOS: [15] org.ice4j.ice.harvest.MappingCandidateHarvesters.maybeAdd() Discarding a mapping harvester: org.ice4j.ice.harvest.MappingCandidateHarvester, face=/192.168.1.2, mask=XXXXXX.ddns.net/192.168.1.2
Is that normal ?
Thanks for help
Yann
--
Envoi sécurisé avec Tutanota. Obtenez votre adresse email chiffrée aujourd'hui!
https://tutanota.com


#3

Hi again,

I just saw this email (after asking whether you had set those props),
so I'm not sure about that part:
NAT_HARVESTER_PUBLIC_ADDRESS=XXXXXX.ddns.net, not sure will it work
with a DNS, we normally put there the IP address.

Regards
damencho

···

On Thu, May 31, 2018 at 4:14 PM <yannick.rousseau@tutanota.com> wrote:

Hi everybody

My jitsi-meet is at home behind a nat (IP local: 192.168.1.2 and IP public: XXXXXX.ddns.net). Here's my /etc/jitsi/videobridge/sip-communicator.properties :

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXX.ddns.net/.*
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=192.168.1.2
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=XXXXXX.ddns.net

When I restart jitsi-videobridge, the jvb.log returns this line:
JVB 2018-05-30 15:41:52.648 INFOS: [15] org.ice4j.ice.harvest.MappingCandidateHarvesters.maybeAdd() Discarding a mapping harvester: org.ice4j.ice.harvest.MappingCandidateHarvester, face=/192.168.1.2, mask=XXXXXX.ddns.net/192.168.1.2

Is that normal ?

Thanks for help

Yann

--
Envoi sécurisé avec Tutanota. Obtenez votre adresse email chiffrée aujourd'hui!
https://tutanota.com
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Ok, I've solved the prosody letsencrypt certificate problem: I did
VirtualHost "auth.XXXXXX.ddns.net <http://auth.XXXXXX.ddns.net>"
ssl = {
key = "/etc/prosody/certs/fullchain.pem";
certificate = "/etc/prosody/certs/privkey.pem";
}

instead of
VirtualHost "auth.XXXXXX.ddns.net <http://auth.XXXXXX.ddns.net>"
ssl = {
key = "/etc/prosody/certs/privkey.pem";
certificate = "/etc/prosody/certs/fullchain.pem";
}
No more error now.
I will run test tomorrow.

···

--
Envoi sécurisé avec Tutanota. Obtenez votre adresse email chiffrée aujourd'hui!
https://tutanota.com

30. Mai 2018 17:46 de yannick.rousseau@tutanota.com <mailto:yannick.rousseau@tutanota.com>:

Hi
I think I've found what could be wrong:> I'm using apache2 and I've a https site on my server with certbots certificates. I use them for my jitsi site in the apache2 config but I didn't direct prosody (I use the 0.9) to use them. > So I copied them in /etc/prosody/certs:> # cp /etc/letsencrypt/live/XXXXXX.ddns.net/*.pem /etc/prosody/certs/
and I provide the following config under the VirtualHost:> VirtualHost "auth.XXXXXX.ddns.net"> ssl = {> key = "/etc/prosody/certs/fullchain.pem";> certificate = "/etc/prosody/certs/privkey.pem";> }> But when I restart prosody, I 've this:> certmanager: SSL/TLS: Failed to load '/etc/prosody/certs/fullchain.pem': Reason: no start line (for auth.XXXXXX.ddns.net etc/prosody/certs/fullchain.pem': Reason: no start line (for auth.XXXXXX.ddns.net)

What could I do to solve this ?
Thanks for your answer, and sorry for my english...
Yann
--
Envoi sécurisé avec Tutanota. Obtenez votre adresse email chiffrée aujourd'hui!
https://tutanota.com

30. Mai 2018 15:48 de > yannick.rousseau@tutanota.com <mailto:yannick.rousseau@tutanota.com>> :

Hi everybody
My jitsi-meet is at home behind a nat (IP local: 192.168.1.2 and IP public: XXXXXX.ddns.net). Here's my /etc/jitsi/videobridge/sip-communicator.properties :
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXX.ddns.net <mailto:org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXX.ddns.net>>> /.*>> org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=192.168.1.2>> org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=XXXXXX.ddns.net
When I restart jitsi-videobridge, the jvb.log returns this line:>> JVB 2018-05-30 15:41:52.648 INFOS: [15] org.ice4j.ice.harvest.MappingCandidateHarvesters.maybeAdd() Discarding a mapping harvester: org.ice4j.ice.harvest.MappingCandidateHarvester, face=/192.168.1.2, mask=XXXXXX.ddns.net/192.168.1.2
Is that normal ?
Thanks for help
Yann
--
Envoi sécurisé avec Tutanota. Obtenez votre adresse email chiffrée aujourd'hui!
https://tutanota.com


#5

sorry for my english...

?? Speaking as a native (British) English speaker, it wasn't until I got to
this line, that I had any clue you might not be a native English speaker.