[jitsi-dev] dev Digest, Vol 24, Issue 54


#1

Thanks Boris,
ands here captured if host parameter change to 'hosts' :

59:54.707 SEVERE: [1] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[main,5,main] and message was:
java.io.EOFException: input contained no data
org.xmpp.component.ComponentException: java.io.EOFException: input
contained no data
at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)
at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
at org.jitsi.videobridge.Main.main(Main.java:273)
Caused by: java.io.EOFException: input contained no data
at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:3003)
at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)
at org.xmlpull.mxp1.MXParser.parseProlog(MXParser.java:1410)
at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1395)
at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)
at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:191)
... 3 more

Regards

···

On Sat, Mar 21, 2015 at 5:55 AM, <dev-request@jitsi.org> wrote:

Send dev mailing list submissions to
        dev@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.jitsi.org/mailman/listinfo/dev
or, via email, send a message with subject or body 'help' to
        dev-request@jitsi.org

You can reach the person managing the list at
        dev-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of dev digest..."

Today's Topics:

   1. Re: Jitmeet: authenticated room persists after moderator
      leaves. (Paweł Domas)
   2. Re: dev Digest, Vol 24, Issue 48 (Boris Grozev)
   3. Re: dev Digest, Vol 24, Issue 48 (alandalus)

----------------------------------------------------------------------

Message: 1
Date: Fri, 20 Mar 2015 15:54:16 +0100
From: Paweł Domas <pawel.domas@jitsi.org>
To: Jitsi Developers <dev@jitsi.org>
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after
        moderator leaves.
Message-ID:
        <CAME7wR4Vy=
HHntknhXedyaWTDHbduHRCmm+nToOAbBaSJ_xRHA@mail.gmail.com>
Content-Type: text/plain; charset=UTF-8

Hi John,

On Wed, Mar 18, 2015 at 10:56 PM, John Lightfoot <john@vizhn.com> wrote:
> I found the fix. The documentation for XMPP authentication indicates
> jicofo should be started with the
> "-Dorg.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com" command line
> option. Instead, "org.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com
"
> should be added to this file:
> /usr/share/jicofo/.sip-communicator/sip-communicator.properties.

The readme is now updated. Sorry for having this unclear.

Regards,
Pawel

------------------------------

Message: 2
Date: Fri, 20 Mar 2015 08:25:10 -0700
From: Boris Grozev <boris@jitsi.org>
To: Jitsi Developers <dev@jitsi.org>, Damian Minkov
        <damencho@jitsi.org>
Subject: Re: [jitsi-dev] dev Digest, Vol 24, Issue 48
Message-ID: <550C3BD6.7000408@jitsi.org>
Content-Type: text/plain; charset=utf-8; format=flowed

On 20/03/15 07:23, alandalus wrote:
> Damencho, the password here which you mean?
>
> ejabberd.yml:
> * port: 5347*
> * module: ejabberd_service*
> * host: "jitsi-videobridge.localhost"*

Our doc[1] uses "hosts" and not "host", not sure if this has any effect.

Boris

[1] https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

------------------------------

Message: 3
Date: Sat, 21 Mar 2015 05:47:52 +0700
From: alandalus <bayu.in9@gmail.com>
To: Damian Minkov <damencho@jitsi.org>
Cc: Jitsi Developers <dev@jitsi.org>
Subject: Re: [jitsi-dev] dev Digest, Vol 24, Issue 48
Message-ID:
        <CAACamy7tTfPwXAP0FqGM_fhHwwsFY6zyGeNWT2roo=
pFagDpQg@mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Dear ,

What the meaning 'terminated normal' ?

user root execute jvb.sh ,
why the script states xmpp.component being not-authorized communicate to
videobridge, while ejabberd states accept connection ?

does ejabberd wrong configured, so videobridge block installation ? CMIIW..

thank in advance,
best regards,

On Fri, Mar 20, 2015 at 9:37 PM, alandalus <bayu.in9@gmail.com> wrote:

> Captured on ejabberd log:
>
> 2015-03-20 21:33:38.430 [info] <0.469.0>@ejabberd_listener:accept:309
> (#Port<0.3637>) Accepted connection 127.0.0.1:36645 -> 127.0.0.1:5347
> 2015-03-20 21:33:38.431 [info] <0.494.0>@ejabberd_service:init:121
> ({socket_state,gen_tcp,#Port<0.3637>,<0.493.0>}) External service
connected
> 2015-03-20 21:33:38.439 [debug]
> <0.493.0>@ejabberd_receiver:process_data:343 Received XML on stream =
> <<"<stream:stream xmlns=\"jabber:component:accept\" xmlns:stream=\"
> http://etherx.jabber.org/streams&quot; allowMultiple=\"true\"
> to=\"jitsi-videobridge.localhost\">">>
> 2015-03-20 21:33:38.460 [debug]
> <0.493.0>@ejabberd_receiver:process_data:343 Received XML on stream =
> <<"<handshake>724b058a910ad46e816da4e4f6b81bc877b9de66</handshake>">>
> 2015-03-20 21:33:38.460 [info] <0.494.0>@ejabberd_service:terminate:343
> terminated: normal
>
>
> handshake ? terminated/not authorized ?
>
>
> Best Regards,
>
> On Fri, Mar 20, 2015 at 9:30 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>
>> Yes, this password. Seems fine in the example you sent. Check the logs
>> of ejabberd why it cannot authenticate the videobridge.
>>
>> On Fri, Mar 20, 2015 at 4:23 PM, alandalus <bayu.in9@gmail.com> wrote:
>> > Damencho, the password here which you mean?
>> >
>> > ejabberd.yml:
>> > port: 5347
>> > module: ejabberd_service
>> > host: "jitsi-videobridge.localhost"
>> > password: "securepass"
>> >
>> > and i run this command:
>> >
>> > ./jvb.sh --host=localhost --domain=localhost --port=5347
>> > --secret=securepass
>> >
>> > still got the same messages:
>> > 20:29.299 SEVERE: [1] util.UtilActivator.uncaughtException().108 An
>> uncaught
>> > exception occurred in thread=Thread[main,5,main] and message was:
>> > not-authorized
>> > org.xmpp.component.ComponentException: not-authorized
>> > at
>> >
>>
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
>> > at
>> >
>>
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
>> > at
>> >
>>
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
>> > at org.jitsi.videobridge.Main.main(Main.java:273)
>> >
>> > What the password related to others module or just easy create
password
>> we
>> > can put on YML file ?
>> >
>> >
>> > Best Regards,
>> >
>> > On Fri, Mar 20, 2015 at 8:20 PM, Damian Minkov <damencho@jitsi.org> > >> wrote:
>> >>
>> >> Make sure the password used by jitsi-videobridge and the password for
>> >> the ejabberd component match.
>> >>
>> >> On Fri, Mar 20, 2015 at 3:17 PM, alandalus <bayu.in9@gmail.com> > wrote:
>> >> > Thank you Damencho,
>> >> >
>> >> > the installation still failure due to message was not authorized,
as
>> >> > captured below :
>> >> >
>> >> > 46:15.352 SEVERE: [1] util.UtilActivator.uncaughtException().108 An
>> >> > uncaught
>> >> > exception occurred in thread=Thread[main,5,main] and message was:
>> >> > not-authorized
>> >> > org.xmpp.component.ComponentException: not-authorized
>> >> > at
>> >> >
>> >> >
>>
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
>> >> > at
>> >> >
>> >> >
>>
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
>> >> > at
>> >> >
>> >> >
>>
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
>> >> > at org.jitsi.videobridge.Main.main(Main.java:273)
>> >> >
>> >> >
>> >> > Best Regards,
>> >> >
>> >> > On Fri, Mar 20, 2015 at 6:05 PM, Damian Minkov <damencho@jitsi.org > > > >> >> > wrote:
>> >> >>
>> >> >> Hi,
>> >> >>
>> >> >>
>> >> >> On Fri, Mar 20, 2015 at 12:54 PM, alandalus <bayu.in9@gmail.com> > >> wrote:
>> >> >> > Dear Damencho,
>> >> >> >
>> >> >> >
>> >> >> > I use the same server localhost xmpp-server and videobridge,
here
>> the
>> >> >> > listen
>> >> >> > port 5275 xmpp status :
>> >> >> > tcp 0 0 0.0.0.0:5222 0.0.0.0:*
>> >> >> > LISTEN
>> >> >> > 3657/beam.smp
>> >> >> > tcp 0 0 0.0.0.0:5269 0.0.0.0:*
>> >> >> > LISTEN
>> >> >> > 3657/beam.smp
>> >> >> > tcp 0 0 0.0.0.0:5275 0.0.0.0:*
>> >> >> > LISTEN
>> >> >> > 3657/beam.smp
>> >> >> > tcp 0 0 0.0.0.0:46524 0.0.0.0:*
>> >> >> > LISTEN
>> >> >> > 3657/beam.smp
>> >> >> > tcp 0 0 0.0.0.0:5280 0.0.0.0:*
>> >> >> > LISTEN
>> >> >> > 3657/beam.smp
>> >> >> >
>> >> >> >
>> >> >> >>> and does captured ejabberd status here normal?
>> >> >> > #./ejabberdctl status
>> >> >> > The node ejabberd@localhost is started with status: started
>> >> >> > ejabberd 15.02 is running in that node
>> >> >> >
>> >> >> >
>> >> >> >>> edit ejabberd.yml for videobridge:
>> >> >> > port: 5275
>> >> >> > module: ejabberd_service
>> >> >> > hosts: localhost
>> >> >> > password: password
>> >> >> >
>> >> >> >
>> >> >> >>> Here after I copy slf4 jar file to the library videobridge:
>> >> >> > root@server#./jvb.sh --secret='ejabberdpass' --domain=localhost
>> >> >> > --port=5275
>> >> >> >
>> >> >> > SLF4J: Detected both log4j-over-slf4j.jar AND slf4j-log4j12.jar
on
>> >> >> > the
>> >> >> > class
>> >> >> > path, preempting StackOverflowError.
>> >> >>
>> >> >> Seems you are using a modified version of jitsi-videobridge,
please
>> >> >> update to latest one and remove the log4j-over-slf4j.jar.
>> >> >>
>> >> >> Here is how default start command look like:
>> >> >> jvb.sh --host=localhost --domain=my_domain--port=5347
>> >> >>
>> >> >> But as you have shown, your ejabberd is not listening on the
>> localhost
>> >> >> try using the --host parameter and add the ip of the server there.
>> >> >>
>> >> >> Regards
>> >> >> damencho
>> >> >>
>> >> >>
>> >> >> > SLF4J: See also
>> http://www.slf4j.org/codes.html#log4jDelegationLoop
>> >> >> > for
>> >> >> > more
>> >> >> > details.
>> >> >> > 15:39:46.649 SEVERE: [1]
>> util.UtilActivator.uncaughtException().108
>> >> >> > An
>> >> >> > uncaught exception occurred in thread=Thread[main,5,main] and
>> message
>> >> >> > was:
>> >> >> > null
>> >> >> > java.lang.ExceptionInInitializerError
>> >> >> > at
>> org.apache.log4j.LogManager.getLogger(LogManager.java:45)
>> >> >> > at
>> >> >> >
>> >> >> >
>> org.slf4j.impl.Log4jLoggerFactory.getLogger(Log4jLoggerFactory.java:64)
>> >> >> > at
>> org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:285)
>> >> >> > at
>> org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:305)
>> >> >> > at
>> >> >> >
>> >> >> >
>> >> >> >
>>
org.jivesoftware.whack.ExternalComponentManager.<clinit>(ExternalComponentManager.java:49)
>> >> >> > at org.jitsi.videobridge.Main.main(Main.java:263)
>> >> >> > Caused by: java.lang.IllegalStateException: Detected both
>> >> >> > log4j-over-slf4j.jar AND slf4j-log4j12.jar on the class path,
>> >> >> > preempting
>> >> >> > StackOverflowError. See also
>> >> >> > http://www.slf4j.org/codes.html#log4jDelegationLoop for more
>> details.
>> >> >> > at
>> >> >> >
>> >> >> >
>> org.apache.log4j.Log4jLoggerFactory.<clinit>(Log4jLoggerFactory.java:51)
>> >> >> > ... 6 more
>> >> >> >
>> >> >> >
>> >> >> > We still cannot successfully install videobridge on
>> >> >> > xmpp-server/ejabberd.
>> >> >> > Please advice, what should be my configuration file ?
>> >> >> >
>> >> >> >
>> >> >> > Best Regards,
>> >> >> >
>> >> >> >
>> >> >> >> ------------------------------
>> >> >> >>
>> >> >> >> Message: 3
>> >> >> >> Date: Fri, 20 Mar 2015 11:36:23 +0700
>> >> >> >> From: alandalus <bayu.in9@gmail.com>
>> >> >> >> To: Jitsi Developers <dev@jitsi.org>
>> >> >> >> Subject: [jitsi-dev] exception installer jitsi-videobridge on
>> linux
>> >> >> >> Message-ID:
>> >> >> >>
>> >> >> >> <
>> CAACamy5tOLsnvO9VxT0pqM67s1LFuxAqHMGNnGowyo2sTS1gAg@mail.gmail.com>
>> >> >> >> Content-Type: text/plain; charset="utf-8"
>> >> >> >>
>> >> >> >> Dear Jitsi Videobridge Developers,
>> >> >> >>
>> >> >> >> We face exception during installation jitsi videobridge,
>> >> >> >>
>> >> >> >> SLF4J: Failed to load class
"org.slf4j.impl.StaticLoggerBinder".
>> >> >> >> SLF4J: Defaulting to no-operation (NOP) logger implementation
>> >> >> >> SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder
>> for
>> >> >> >> further
>> >> >> >> details.
>> >> >> >> 03:16:44.628 SEVERE: [1]
>> util.UtilActivator.uncaughtException().108
>> >> >> >> An
>> >> >> >> uncaught exception occurred in thread=Thread[main,5,main] and
>> >> >> >> message
>> >> >> >> was:
>> >> >> >> java.net.ConnectException: Connection refused
>> >> >> >>
>> >> >> >> We have slf4j library , but this not solve solution.
>> >> >> >>
>> >> >> >> Please help how to solve this problem.
>> >> >> >>
>> >> >> >> Thanks in advance,
>> >> >> >> Best Regards
>> >> >> >> -------------- next part --------------
>> >> >> >> An HTML attachment was scrubbed...
>> >> >> >> URL:
>> >> >> >>
>> >> >> >>
>> >> >> >> <
>>
http://lists.jitsi.org/pipermail/dev/attachments/20150320/62f52e12/attachment-0001.html
>> >
>> >> >> >>
>> >> >> >> ------------------------------
>> >> >> >>
>> >> >> >> Message: 4
>> >> >> >> Date: Fri, 20 Mar 2015 07:51:35 +0300
>> >> >> >> From: admin@medicine-prof.com
>> >> >> >> To: Jitsi Developers <dev@jitsi.org>
>> >> >> >> Subject: Re: [jitsi-dev] exception installer jitsi-videobridge
on
>> >> >> >> linux
>> >> >> >> Message-ID: <1425951426827095@web4h.yandex.ru>
>> >> >> >> Content-Type: text/plain
>> >> >> >>
>> >> >> >> hi,
>> >> >> >> i had the same error. find needed library on the link and copy
>> it in
>> >> >> >> the
>> >> >> >> video bridge library.
>> >> >> >> it helped me.
>> >> >> >>
>> >> >> >> 20.03.2015, 07:37, "alandalus" <bayu.in9@gmail.com>:
>> >> >> >> > Dear Jitsi Videobridge Developers,
>> >> >> >> >
>> >> >> >> > We face exception during installation jitsi videobridge,
>> >> >> >> >
>> >> >> >> > SLF4J: Failed to load class
>> "org.slf4j.impl.StaticLoggerBinder".
>> >> >> >> > SLF4J: Defaulting to no-operation (NOP) logger implementation
>> >> >> >> > SLF4J: See
http://www.slf4j.org/codes.html#StaticLoggerBinder
>> for
>> >> >> >> > further details.
>> >> >> >> > 03:16:44.628 SEVERE: [1]
>> >> >> >> > util.UtilActivator.uncaughtException().108
>> >> >> >> > An
>> >> >> >> > uncaught exception occurred in thread=Thread[main,5,main] and
>> >> >> >> > message
>> >> >> >> > was:
>> >> >> >> > java.net.ConnectException: Connection refused
>> >> >> >> >
>> >> >> >> > We have slf4j library , but this not solve solution.
>> >> >> >> >
>> >> >> >> > Please help how to solve this problem.
>> >> >> >> >
>> >> >> >> > Thanks in advance,
>> >> >> >> > Best Regards
>> >> >> >> > ,
>> >> >> >> >
>> >> >> >> > _______________________________________________
>> >> >> >> > dev mailing list
>> >> >> >> > dev@jitsi.org
>> >> >> >> > Unsubscribe instructions and other list options:
>> >> >> >> > http://lists.jitsi.org/mailman/listinfo/dev
>> >> >> >>
>> >> >> >>
>> >> >> >>
>> >> >> >> ------------------------------
>> >> >> >> ------------------------------
>> >> >> >>
>> >> >> >> Message: 6
>> >> >> >> Date: Fri, 20 Mar 2015 08:47:32 +0200
>> >> >> >> From: Damian Minkov <damencho@jitsi.org>
>> >> >> >> To: Jitsi Developers <dev@jitsi.org>
>> >> >> >> Subject: Re: [jitsi-dev] exception installer jitsi-videobridge
on
>> >> >> >> linux
>> >> >> >> Message-ID:
>> >> >> >>
>> >> >> >> <CAE07f0Kan_ZaN3CtAwH=
>> j1fVJML7G3UfzcHSK96Xp5DWOTovYw@mail.gmail.com>
>> >> >> >> Content-Type: text/plain; charset=UTF-8
>> >> >> >>
>> >> >> >> Hi,
>> >> >> >>
>> >> >> >> The SLF4J lib prints are harmless. You have a problem with the
>> >> >> >> component port on prosody, it is not listening to the interface
>> >> >> >> where
>> >> >> >> jitsi-videobridge is trying to reach it, or there is a firewall
>> or
>> >> >> >> it
>> >> >> >> is just not open. Or at least this is what I can think of
>> looking at
>> >> >> >> the log snippet in your mail.
>> >> >> >>
>> >> >> >> Regards
>> >> >> >> damencho
>> >> >> >>
>> >> >> >>
>> >> >> >> On Fri, Mar 20, 2015 at 6:36 AM, alandalus <bayu.in9@gmail.com > > > >> >> >> >> wrote:
>> >> >> >> > Dear Jitsi Videobridge Developers,
>> >> >> >> >
>> >> >> >> > We face exception during installation jitsi videobridge,
>> >> >> >> >
>> >> >> >> > SLF4J: Failed to load class
>> "org.slf4j.impl.StaticLoggerBinder".
>> >> >> >> > SLF4J: Defaulting to no-operation (NOP) logger implementation
>> >> >> >> > SLF4J: See
http://www.slf4j.org/codes.html#StaticLoggerBinder
>> for
>> >> >> >> > further
>> >> >> >> > details.
>> >> >> >> > 03:16:44.628 SEVERE: [1]
>> >> >> >> > util.UtilActivator.uncaughtException().108
>> >> >> >> > An
>> >> >> >> > uncaught exception occurred in thread=Thread[main,5,main] and
>> >> >> >> > message
>> >> >> >> > was:
>> >> >> >> > java.net.ConnectException: Connection refused
>> >> >> >> >
>> >> >> >> > We have slf4j library , but this not solve solution.
>> >> >> >> >
>> >> >> >> > Please help how to solve this problem.
>> >> >> >> >
>> >> >> >> > Thanks in advance,
>> >> >> >> > Best Regards
>> >> >> >> >
>> >> >> >> > _______________________________________________
>> >> >> >> > dev mailing list
>> >> >> >> > dev@jitsi.org
>> >> >> >> > Unsubscribe instructions and other list options:
>> >> >> >> > http://lists.jitsi.org/mailman/listinfo/dev
>> >> >> >>
>> >> >> >>
>> >> >> >>
>> >> >> >> ------------------------------
>> >> >> >>
>> >> >> >> Subject: Digest Footer
>> >> >> >>
>> >> >> >> _______________________________________________
>> >> >> >> dev mailing list
>> >> >> >> dev@jitsi.org
>> >> >> >> http://lists.jitsi.org/mailman/listinfo/dev
>> >> >> >>
>> >> >> >>
>> >> >> >> ------------------------------
>> >> >> >>
>> >> >> >> End of dev Digest, Vol 24, Issue 48
>> >> >> >> ***********************************
>> >> >> >
>> >> >> >
>> >> >
>> >> >
>> >
>> >
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <
http://lists.jitsi.org/pipermail/dev/attachments/20150321/884b8ad6/attachment.html
>

------------------------------

Subject: Digest Footer

_______________________________________________
dev mailing list
dev@jitsi.org
http://lists.jitsi.org/mailman/listinfo/dev

------------------------------

End of dev Digest, Vol 24, Issue 54
***********************************


#2

I just noticed that you were also missing a ":" after the hostname in the snipped you pasted. Look at the doc and make sure you have the syntax exactly right.

Boris

···

On 20/03/15 22:38, alandalus wrote:

Thanks Boris,
ands here captured if host parameter change to 'hosts' :