[jitsi-dev] Delay before I can talk


#1

There is a 2 to 5 seconds long delay before the other person hears me
when a SIP (ippi) conversation starts. I call : it's ringing, the other
person picks up the line and says "hello ?.... helloooo ?... ???". I am
trying to answer but the person can't hear me. The jitsi (French) status
is "connexion...". Then, after these 2 to 5 seconds, Jitsi eventually
displays I am "connected" and the person can hear me. It happens every
time. It also happens when I am called by someone : once I pick up the
line, the other person can talk and I can hear her but she does not hear
me until Jitsi says we are "connected" and this takes an eternity
(sounds like...).

I don't have this issue using other softphones (twinkle) on the same SIP
account. I even think this never happened when I first was using Jitsi.
Then a package upgrade introduced this issue. I tried tweaking some
jitsi parameters but with no success.

Is this a bug ? Should I report it as such ? How to report + document it ?

Thanks

···

--
Jean Millerat
Wecena, rendre vos informaticiens fiers d'am�liorer le monde
Jean.Millerat@wecena.com +33 1 77 455 344 Jean.Millerat@gmail.com


#2

We noticed it too. The delay before the voice channel opens might be OK on XMPP where both sides are ob Jitsi most of the cases anyway, it is not when we use Jitsi as a SIP telefone:

The other side picks up - cannot hear me - thinks noone is there and hangs up. I then have no way to cope with it - like sending an instant message...

So the issue should be dealt with. Should I open an Jira task?

Greetings
Conrad

···

-------

- Original-Nachricht --------

Datum: Tue, 13 Sep 2011 17:49:05 +0200
Von: Jean Millerat <Jean.Millerat@wecena.com>
An: dev@jitsi.java.net
Betreff: [jitsi-dev] Delay before I can talk

There is a 2 to 5 seconds long delay before the other person hears me
when a SIP (ippi) conversation starts. I call : it's ringing, the other
person picks up the line and says "hello ?.... helloooo ?... ???". I am
trying to answer but the person can't hear me. The jitsi (French) status
is "connexion...". Then, after these 2 to 5 seconds, Jitsi eventually
displays I am "connected" and the person can hear me. It happens every
time. It also happens when I am called by someone : once I pick up the
line, the other person can talk and I can hear her but she does not hear
me until Jitsi says we are "connected" and this takes an eternity
(sounds like...).

I don't have this issue using other softphones (twinkle) on the same SIP
account. I even think this never happened when I first was using Jitsi.
Then a package upgrade introduced this issue. I tried tweaking some
jitsi parameters but with no success.

Is this a bug ? Should I report it as such ? How to report + document it ?

Thanks

--
Jean Millerat
Wecena, rendre vos informaticiens fiers d'améliorer le monde
Jean.Millerat@wecena.com +33 1 77 455 344 Jean.Millerat@gmail.com


#3

Yes, buddy, please do ! :slight_smile:

Thanks

···

Le 18/09/2011 13:49, Conrad Beckert a écrit :

We noticed it too. The delay before the voice channel opens might be
OK on XMPP where both sides are ob Jitsi most of the cases anyway, it
is not when we use Jitsi as a SIP telefone:

The other side picks up - cannot hear me - thinks noone is there and
hangs up. I then have no way to cope with it - like sending an
instant message...

So the issue should be dealt with. Should I open an Jira task?

--
Jean Millerat
Wecena, rendre vos informaticiens fiers d'améliorer le monde
Jean.Millerat@wecena.com +33 1 77 455 344 Jean.Millerat@gmail.com


#4

I couldn't find anything about this issue in JIRA. Do we have a JIRA
task number yet?
kel

···

On Mon, Sep 19, 2011 at 9:48 PM, Emil Ivov <emcho@jitsi.org> wrote:

Folks,

The point of asking the "should I open a JIRA ticket" question is to get an answer from a developer :).

Please keep that in mind.

We'll have a look at the delay one of these days.

Cheers,
Emil

--sent from my mobile

On 18 sept. 2011, at 21:04, Jean Millerat <Jean.Millerat@wecena.com> wrote:

Le 18/09/2011 13:49, Conrad Beckert a écrit :

We noticed it too. The delay before the voice channel opens might be
OK on XMPP where both sides are ob Jitsi most of the cases anyway, it
is not when we use Jitsi as a SIP telefone:

The other side picks up - cannot hear me - thinks noone is there and
hangs up. I then have no way to cope with it - like sending an
instant message...

So the issue should be dealt with. Should I open an Jira task?

Yes, buddy, please do ! :slight_smile:


#5

I've seen this issue on the Mac as well. The initial call tends to linger the most, but subsequent calls subside. I've seen the issue come up on machines that are running lots of processes. With logging turned on to INFO Jitsi analyzes the packet stream and writes details about the health of the network. That may cause a delay, but I"m not certain.

Oren

···

On Dec 29, 2011, at 3:46 PM, Emil Ivov wrote:

Could you please describe your symptoms? OS, server, protocol? How long is the delay you get? How do other applications behave in the exact same environment?

Note that a delay of up to a second is normal for SIP. Up to several seconds are to be expected for XMPP.

We have had reports for longer delays with SIP (for linux if I am not mistaken) but haven't been able to reproduce them. Of course patches are always welcome.

Emil

--sent from my mobile

On 29 déc. 2011, at 22:28, Kelvin Chan <kelvin.chan@positronics.com> wrote:

On Mon, Sep 19, 2011 at 9:48 PM, Emil Ivov <emcho@jitsi.org> wrote:

Folks,

The point of asking the "should I open a JIRA ticket" question is to get an answer from a developer :).

Please keep that in mind.

We'll have a look at the delay one of these days.

Cheers,
Emil

--sent from my mobile

On 18 sept. 2011, at 21:04, Jean Millerat <Jean.Millerat@wecena.com> wrote:

Le 18/09/2011 13:49, Conrad Beckert a écrit :

We noticed it too. The delay before the voice channel opens might be
OK on XMPP where both sides are ob Jitsi most of the cases anyway, it
is not when we use Jitsi as a SIP telefone:

The other side picks up - cannot hear me - thinks noone is there and
hangs up. I then have no way to cope with it - like sending an
instant message...

So the issue should be dealt with. Should I open an Jira task?

Yes, buddy, please do ! :slight_smile:

I couldn't find anything about this issue in JIRA. Do we have a JIRA
task number yet?
kel


#6

Out of curiousity, why? Where is the delay happening?

Regards,
Matthew

···

On 29 December 2011 20:46, Emil Ivov <emcho@jitsi.org> wrote:

Could you please describe your symptoms? OS, server, protocol? How long is the delay you get? How do other applications behave in the exact same environment?

Note that a delay of up to a second is normal for SIP. Up to several seconds are to be expected for XMPP.


#7

As discussed before, I created a Jira ticket for this issue :

http://java.net/jira/browse/JITSI-1003

···

Le 29/12/2011 21:46, Emil Ivov a écrit :

We have had reports for longer delays with SIP (for linux if I am not mistaken) but haven't been able to reproduce them. Of course patches are always welcome.

--
Jean Millerat
Wecena, rendre vos informaticiens fiers d'améliorer le monde
Jean.Millerat@wecena.com +33 1 77 455 344 Jean.Millerat@gmail.com


#8

You asked me to create it in this email :

http://permalink.gmane.org/gmane.comp.voip.sip-communicator.devel/11821

···

Le 30/12/2011 06:51, Emil Ivov a écrit :

Folks, I totally relize that having to discuss stuff on the mailing
list and wait for an invitation to log it on the tracker is a lot
less convinient than just dumping it there.

--
Jean Millerat
Wecena, rendre vos informaticiens fiers d'améliorer le monde
Jean.Millerat@wecena.com +33 1 77 455 344 Jean.Millerat@gmail.com


#9

s/asked/authorized/ :slight_smile:

···

Le 30/12/2011 11:36, Jean Millerat a écrit :

You asked me to create it in this email :

--
Jean Millerat
Wecena, rendre vos informaticiens fiers d'améliorer le monde
Jean.Millerat@wecena.com +33 1 77 455 344 Jean.Millerat@gmail.com