[jitsi-dev] defaults.properties


#1

Good Afternoon Developers,

I was wondering how to compile or change the setting in defaults.properties
if I am using an rpm? Thank you very much for your help.

Thanks,

Leo


#2

hello.

not sure if this is a bug, neither am i sure if this is the right section to post, so sorry if this is the wrong channel.
i made a call jitsi<->jitsi using the sip.sflphone.org sip-service. the call didn't get encrypted. i guess this should not be the case. iptel.org is working fine with encryption, although it is not a very reliable service (login does only work sporadically).

jitsi version is 1.0-beta1-nightly.build.3689. how can i provide more info to fix this and get calls encrypted via sip.sflphone.org?

cheers,
tika


#3

Hi Leonid,

A quick and "hackish" way to do :
- Open the file /usr/lib/jitsi/sc-bundles/defaultresources.jar _with_ vim;
- point the cursors to the line "resources/config/defaults.properties" and hit enter;
- Modify the property you want and save the file;
- Save the jar;
- Launch Jitsi.

Another way less hackish:
- cd /usr/lib/jitsi/sc-bundles/
- mkdir mod
- cd mod
- jar xvf ../defaultresources.jar
- edit the file resources/config/defaults.properties and modify the properties you want
- jar cvfm ./defaultresources.jar META-INF/MANIFEST.MF -C ./ ./
- cd ../
- mv defaultresources.jar defaultresources.jar.old (just in case)
- cp mod/defaultresources.jar defaultresources.jar
- Launch Jitsi.

The problem is if you update Jitsi after (with rpm), the changes will be overwritten...

Regards,

···

--
Seb

Le 17/10/11 21:34, Leonid Nayer a �crit :

Good Afternoon Developers,
I was wondering how to compile or change the setting in defaults.properties if I am using an rpm? Thank you very much for your help.
Thanks,
Leo


#4

Hi Seb,

Thank you very much for your help. Do you know of any easy way to increase
the size of the buttons to make them touch friendly or where should I look
in to do that in the code. Thanks.

Leo

···

On Thu, Oct 20, 2011 at 8:51 AM, Sebastien Vincent <seb@jitsi.org> wrote:

Hi Leonid,

A quick and "hackish" way to do :
- Open the file /usr/lib/jitsi/sc-bundles/**defaultresources.jar _with_
vim;
- point the cursors to the line "resources/config/defaults.**properties"
and hit enter;
- Modify the property you want and save the file;
- Save the jar;
- Launch Jitsi.

Another way less hackish:
- cd /usr/lib/jitsi/sc-bundles/
- mkdir mod
- cd mod
- jar xvf ../defaultresources.jar
- edit the file resources/config/defaults.**properties and modify the
properties you want
- jar cvfm ./defaultresources.jar META-INF/MANIFEST.MF -C ./ ./
- cd ../
- mv defaultresources.jar defaultresources.jar.old (just in case)
- cp mod/defaultresources.jar defaultresources.jar
- Launch Jitsi.

The problem is if you update Jitsi after (with rpm), the changes will be
overwritten...

Regards,
--
Seb

Le 17/10/11 21:34, Leonid Nayer a écrit :

Good Afternoon Developers,

I was wondering how to compile or change the setting in
defaults.properties if I am using an rpm? Thank you very much for your help.
Thanks,
Leo


#5

Yup, code would.be the only way

-- sent from my mobile

···

On Oct 20, 2011 10:03 PM, "Leonid Nayer" <lnayer@gmail.com> wrote:

Hi Seb,

Thank you very much for your help. Do you know of any easy way to increase
the size of the buttons to make them touch friendly or where should I look
in to do that in the code. Thanks.

Leo

On Thu, Oct 20, 2011 at 8:51 AM, Sebastien Vincent <seb@jitsi.org> wrote:

Hi Leonid,

A quick and "hackish" way to do :
- Open the file /usr/lib/jitsi/sc-bundles/**defaultresources.jar _with_
vim;
- point the cursors to the line "resources/config/defaults.**properties"
and hit enter;
- Modify the property you want and save the file;
- Save the jar;
- Launch Jitsi.

Another way less hackish:
- cd /usr/lib/jitsi/sc-bundles/
- mkdir mod
- cd mod
- jar xvf ../defaultresources.jar
- edit the file resources/config/defaults.**properties and modify the
properties you want
- jar cvfm ./defaultresources.jar META-INF/MANIFEST.MF -C ./ ./
- cd ../
- mv defaultresources.jar defaultresources.jar.old (just in case)
- cp mod/defaultresources.jar defaultresources.jar
- Launch Jitsi.

The problem is if you update Jitsi after (with rpm), the changes will be
overwritten...

Regards,
--
Seb

Le 17/10/11 21:34, Leonid Nayer a écrit :

Good Afternoon Developers,

I was wondering how to compile or change the setting in
defaults.properties if I am using an rpm? Thank you very much for your help.
Thanks,
Leo


#6

Thanks Emil for the reply. Is there a way to add that as a feature? I been
trying to play around with the code a little bit and also inlarged the
images.

Thanks,

Leo

···

On Thu, Oct 20, 2011 at 4:09 PM, Emil Ivov <emcho@jitsi.org> wrote:

Yup, code would.be the only way

-- sent from my mobile
  On Oct 20, 2011 10:03 PM, "Leonid Nayer" <lnayer@gmail.com> wrote:

Hi Seb,

Thank you very much for your help. Do you know of any easy way to increase
the size of the buttons to make them touch friendly or where should I look
in to do that in the code. Thanks.

Leo

On Thu, Oct 20, 2011 at 8:51 AM, Sebastien Vincent <seb@jitsi.org> wrote:

Hi Leonid,

A quick and "hackish" way to do :
- Open the file /usr/lib/jitsi/sc-bundles/**defaultresources.jar _with_
vim;
- point the cursors to the line "resources/config/defaults.**properties"
and hit enter;
- Modify the property you want and save the file;
- Save the jar;
- Launch Jitsi.

Another way less hackish:
- cd /usr/lib/jitsi/sc-bundles/
- mkdir mod
- cd mod
- jar xvf ../defaultresources.jar
- edit the file resources/config/defaults.**properties and modify the
properties you want
- jar cvfm ./defaultresources.jar META-INF/MANIFEST.MF -C ./ ./
- cd ../
- mv defaultresources.jar defaultresources.jar.old (just in case)
- cp mod/defaultresources.jar defaultresources.jar
- Launch Jitsi.

The problem is if you update Jitsi after (with rpm), the changes will be
overwritten...

Regards,
--
Seb

Le 17/10/11 21:34, Leonid Nayer a écrit :

Good Afternoon Developers,

I was wondering how to compile or change the setting in
defaults.properties if I am using an rpm? Thank you very much for your help.
Thanks,
Leo