[jitsi-dev] Debug level logging


#1

Hi all,

I have a very simple question: how can I enable the DEBUG level logging? In
my plugin all of the logger.debug("string") messages just do not show up
despite the fact of setting the ConsoleHandler level to FINEST in
lib/logging.properties. What am I missing?

Regards,
Alex


#2

Hi,

as you have changed the console level, you must change and the level
for your package.

Cheers
damencho

···

On Mon, Sep 24, 2012 at 4:08 PM, Alexander Fedulov <ijustwanttoregister@googlemail.com> wrote:

Hi all,

I have a very simple question: how can I enable the DEBUG level logging? In
my plugin all of the logger.debug("string") messages just do not show up
despite the fact of setting the ConsoleHandler level to FINEST in
lib/logging.properties. What am I missing?

Regards,
Alex


#3

Hi Damian,

If I set both handler and package levels to FINE or FINEST I get the debug
messages, however, there is so much noise produced by the other bundles,
that it renders logging pretty useless. I trust that native Jitsi modules
work fine - I do not want to see the finest details of their activities -
INFO level works for me. I want, however, to see the DEBUG messages from my
own plugin, which I currently test. Setting the ConsoleHandler level to
INFO and package level to FINEST does not work. I know, that this would not
be a problem if log4j would be used. The question is: is that achievable
using Jitsi's logging mechanisms?

Regards,
Alex

···

2012/9/24 Damian Minkov <damencho@jitsi.org>

Hi,

as you have changed the console level, you must change and the level
for your package.

Cheers
damencho

On Mon, Sep 24, 2012 at 4:08 PM, Alexander Fedulov > <ijustwanttoregister@googlemail.com> wrote:
> Hi all,
>
> I have a very simple question: how can I enable the DEBUG level logging?
In
> my plugin all of the logger.debug("string") messages just do not show up
> despite the fact of setting the ConsoleHandler level to FINEST in
> lib/logging.properties. What am I missing?
>
> Regards,
> Alex


#4

Hi again,

if your messages are with level FINE (this is the case with
logger.debug) and are in package my.package.
In order to see only your messages with FINE, you need to put the
logging level of the console handler to FINE, in order to see any fine
messages. Setting default level to INFO ('.level= INFO') so you don't
see any other FINE messages(from jitsi bundles) and of course setting
'my.package.level = FINE' to enable FINE messages only for your
package.
This should do the trick, this was what I meant in my previous mail.
Hope this helps.

Regards
damencho

···

On Mon, Sep 24, 2012 at 4:58 PM, Alexander Fedulov <ijustwanttoregister@googlemail.com> wrote:

Hi Damian,

If I set both handler and package levels to FINE or FINEST I get the debug
messages, however, there is so much noise produced by the other bundles,
that it renders logging pretty useless. I trust that native Jitsi modules
work fine - I do not want to see the finest details of their activities -
INFO level works for me. I want, however, to see the DEBUG messages from my
own plugin, which I currently test. Setting the ConsoleHandler level to INFO
and package level to FINEST does not work. I know, that this would not be a
problem if log4j would be used. The question is: is that achievable using
Jitsi's logging mechanisms?

Regards,
Alex

2012/9/24 Damian Minkov <damencho@jitsi.org>

Hi,

as you have changed the console level, you must change and the level
for your package.

Cheers
damencho

On Mon, Sep 24, 2012 at 4:08 PM, Alexander Fedulov >> <ijustwanttoregister@googlemail.com> wrote:
> Hi all,
>
> I have a very simple question: how can I enable the DEBUG level logging?
> In
> my plugin all of the logger.debug("string") messages just do not show up
> despite the fact of setting the ConsoleHandler level to FINEST in
> lib/logging.properties. What am I missing?
>
> Regards,
> Alex


#5

Hi Damian,

thank you! This answers my question.

Regards,
Alex

···

2012/9/24 Damian Minkov <damencho@jitsi.org>

Hi again,

if your messages are with level FINE (this is the case with
logger.debug) and are in package my.package.
In order to see only your messages with FINE, you need to put the
logging level of the console handler to FINE, in order to see any fine
messages. Setting default level to INFO ('.level= INFO') so you don't
see any other FINE messages(from jitsi bundles) and of course setting
'my.package.level = FINE' to enable FINE messages only for your
package.
This should do the trick, this was what I meant in my previous mail.
Hope this helps.

Regards
damencho

On Mon, Sep 24, 2012 at 4:58 PM, Alexander Fedulov > <ijustwanttoregister@googlemail.com> wrote:
> Hi Damian,
>
> If I set both handler and package levels to FINE or FINEST I get the
debug
> messages, however, there is so much noise produced by the other bundles,
> that it renders logging pretty useless. I trust that native Jitsi modules
> work fine - I do not want to see the finest details of their activities -
> INFO level works for me. I want, however, to see the DEBUG messages from
my
> own plugin, which I currently test. Setting the ConsoleHandler level to
INFO
> and package level to FINEST does not work. I know, that this would not
be a
> problem if log4j would be used. The question is: is that achievable using
> Jitsi's logging mechanisms?
>
> Regards,
> Alex
>
>
> 2012/9/24 Damian Minkov <damencho@jitsi.org>
>>
>> Hi,
>>
>> as you have changed the console level, you must change and the level
>> for your package.
>>
>> Cheers
>> damencho
>>
>> On Mon, Sep 24, 2012 at 4:08 PM, Alexander Fedulov > >> <ijustwanttoregister@googlemail.com> wrote:
>> > Hi all,
>> >
>> > I have a very simple question: how can I enable the DEBUG level
logging?
>> > In
>> > my plugin all of the logger.debug("string") messages just do not show
up
>> > despite the fact of setting the ConsoleHandler level to FINEST in
>> > lib/logging.properties. What am I missing?
>> >
>> > Regards,
>> > Alex
>
>