[jitsi-dev] Damencho's response to request for help with setup via Digest, Vol 45, Issue 22


#1

Thanks,@ damencho@jitsi.org

However, nothing shows up even if I boot back into windows and/or serve
index.html securely via chrome browser addon (its called 'Web Server for
Chrome')
at 127.0.0.1:8080 / 127.0.01:8887.

I get the same errors as before.

Should I set it it to another port number? Do I need something like
adapter.js or some other javascript to interoperate the components?

<https://www.dropbox.com/s/kegaud98grsjvr4/jitsi-meet.tar.gz?dl=0>
My entire compile is g-zipped and drop-boxed here
<https://www.dropbox.com/s/kegaud98grsjvr4/jitsi-meet.tar.gz?dl=0>,for
anybody interested in poking around.Also attached, a screenshot of
index.html via secure localhost.

Best Regards,
MKR

PS: I'm not looking for free code- I'm just looking for a way to make this
work - and hopefully learn something! Thanks for any help/pointers!

···

-----------------------------------------------------------------------------------------------------------------

On Wed, Dec 7, 2016 at 9:34 PM, <dev-request@jitsi.org> wrote:

Send dev mailing list submissions to
        dev@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.jitsi.org/mailman/listinfo/dev
or, via email, send a message with subject or body 'help' to
        dev-request@jitsi.org

You can reach the person managing the list at
        dev-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of dev digest..."

Today's Topics:

   1. Re: Jitsi Set Up - Guidance Request (Damian Minkov)

----------------------------------------------------------------------

Message: 1
Date: Wed, 7 Dec 2016 09:59:49 -0600
From: Damian Minkov <damencho@jitsi.org>
To: Jitsi Developers <dev@jitsi.org>
Subject: Re: [jitsi-dev] Jitsi Set Up - Guidance Request
Message-ID:
        <CAE07f0LzmkM2FkE9zfiDp+7WHY-q-d+z2uTfRaTdCs6yAH1N3w@mail.
gmail.com>
Content-Type: text/plain; charset="utf-8"

Hi,

The first thing I notice in the screenshot is that you are opening the
index.html from your local PC (file://...) you need to open it from your
webserver, https://jitmeet.example.com, and it should be https not http.
I have the impression you are installing using the manual install
instructions, it is a complicated process and not recommended anyway,
especially for starters. We recommend installing the packages on
debian/ubuntu server.

Regards
damencho

On Wed, Dec 7, 2016 at 6:14 AM, mkr <info.steppenwolf@gmail.com> wrote:

> [image: Inline image 1]
>
> Thanks to all the makers of this fascinating project.
>
> I'm an amateur coder and an Ubuntu newbie, but I managed to grok the
> instructions and compiled all components ( videobridge/ meet/jicofo/nginx
> and prosody) after a few false starts.
>
> Then I doubleclicked on index.html to open the page in firefox and got
the
> following reports from 'Inspect Element' - as shown in screengrab above:
>
>
>
>
>
>
>
>
>
>
>
>
> *ReferenceError: config is not defined[Learn More]
> do_external_connect.js:23:9[modules/RTC/RTCBrowserType.js] <o>: This
> appears to be Firefox, ver: 50 lib-jitsi-meet.min.js:6:20271DEPRECATED
JS
> - Cookie has been deprecated since 5.8.0 and will be removed in a future
> release. Use cookie instead.
> t.default@file:///home/raghuram/Desktop/wip/jitsi-
meet/libs/app.bundle.min.js?v=139:1:4710ReferenceError:
> interfaceConfig is not defined[Learn More]
> app.bundle.min.js:12:21172TypeError: a.default.tablesorter is
> undefined[Learn More] app.bundle.min.js:64:4528*
>
> I refreshed the page a few times, and reset the package.json to point to
> local lib as stated in github instructions, but no grant access to
> mic/camera prompt appeared.
>
> Right-clicking on each error message gives me the option to 'store as
> global variable', which didn't seem like the right thing to do, so I
> requested to sign up for all the jitsi mailing lists instead and am here.
> (Thanks Emil Ivov!)
>
> Any advice on how to set this up correctly is greatly appreciated - I've
> already signed up for an http(s) on a webpage I maintain, but will need
> more disk space to ftp this bundle to my httpdocs if *get it working,
> that is *- I gathered secure http(s) protocol would be necessary for this
> to work online.
>
> During compile I followed all instructions in the detailed Manual
> Installation on github, except I used *jitmeet*.example.com everywhere
> and not *jitsi*.example.com - no idea if this variance is of any
> consequence.
>
> For localhost poking around, I've installed ssl on apache2 in my ubuntu
> trusty tahr 14.04 workspace. Do I need an Apache script or something?
>
> PS: I am an amateur coder and cannot follow code lingo that falutes high
-
> I'm only accustomed to following instructions/cutpasting snippets and
> working with jquery plugins so I'm probably looking for DIY-type
> easy-to-follow instructables/ manuals/forum posts if any are extant.
>
> Thanks and kind regards,
> MKR
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jitsi.org/pipermail/dev/attachments/
20161207/e6069c66/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 111673 bytes
Desc: not available
URL: <http://lists.jitsi.org/pipermail/dev/attachments/
20161207/e6069c66/attachment.png>

------------------------------

Subject: Digest Footer

_______________________________________________
dev mailing list
dev@jitsi.org
http://lists.jitsi.org/mailman/listinfo/dev

------------------------------

End of dev Digest, Vol 45, Issue 22
***********************************


#2

Which webserver do you use, maybe it is not configure correctly or it
is missing serverside includes?
Why don't you just try the default installation instructions:
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

···

On Wed, Dec 7, 2016 at 1:04 PM, mkr <info.steppenwolf@gmail.com> wrote:

Thanks,@ damencho@jitsi.org

However, nothing shows up even if I boot back into windows and/or serve
index.html securely via chrome browser addon (its called 'Web Server for
Chrome')
at 127.0.0.1:8080 / 127.0.01:8887.

I get the same errors as before.

Should I set it it to another port number? Do I need something like
adapter.js or some other javascript to interoperate the components?

My entire compile is g-zipped and drop-boxed here,for anybody interested in
poking around.Also attached, a screenshot of index.html via secure
localhost.

Best Regards,
MKR

PS: I'm not looking for free code- I'm just looking for a way to make this
work - and hopefully learn something! Thanks for any help/pointers!

-----------------------------------------------------------------------------------------------------------------

On Wed, Dec 7, 2016 at 9:34 PM, <dev-request@jitsi.org> wrote:

Send dev mailing list submissions to
        dev@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.jitsi.org/mailman/listinfo/dev
or, via email, send a message with subject or body 'help' to
        dev-request@jitsi.org

You can reach the person managing the list at
        dev-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of dev digest..."

Today's Topics:

   1. Re: Jitsi Set Up - Guidance Request (Damian Minkov)

----------------------------------------------------------------------

Message: 1
Date: Wed, 7 Dec 2016 09:59:49 -0600
From: Damian Minkov <damencho@jitsi.org>
To: Jitsi Developers <dev@jitsi.org>
Subject: Re: [jitsi-dev] Jitsi Set Up - Guidance Request
Message-ID:

<CAE07f0LzmkM2FkE9zfiDp+7WHY-q-d+z2uTfRaTdCs6yAH1N3w@mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Hi,

The first thing I notice in the screenshot is that you are opening the
index.html from your local PC (file://...) you need to open it from your
webserver, https://jitmeet.example.com, and it should be https not http.
I have the impression you are installing using the manual install
instructions, it is a complicated process and not recommended anyway,
especially for starters. We recommend installing the packages on
debian/ubuntu server.

Regards
damencho

On Wed, Dec 7, 2016 at 6:14 AM, mkr <info.steppenwolf@gmail.com> wrote:

> [image: Inline image 1]
>
> Thanks to all the makers of this fascinating project.
>
> I'm an amateur coder and an Ubuntu newbie, but I managed to grok the
> instructions and compiled all components ( videobridge/
> meet/jicofo/nginx
> and prosody) after a few false starts.
>
> Then I doubleclicked on index.html to open the page in firefox and got
> the
> following reports from 'Inspect Element' - as shown in screengrab above:
>
>
>
>
>
>
>
>
>
>
>
>
> *ReferenceError: config is not defined[Learn More]
> do_external_connect.js:23:9[modules/RTC/RTCBrowserType.js] <o>: This
> appears to be Firefox, ver: 50 lib-jitsi-meet.min.js:6:20271DEPRECATED
> JS
> - Cookie has been deprecated since 5.8.0 and will be removed in a future
> release. Use cookie instead.
>
> t.default@file:///home/raghuram/Desktop/wip/jitsi-meet/libs/app.bundle.min.js?v=139:1:4710ReferenceError:
> interfaceConfig is not defined[Learn More]
> app.bundle.min.js:12:21172TypeError: a.default.tablesorter is
> undefined[Learn More] app.bundle.min.js:64:4528*
>
> I refreshed the page a few times, and reset the package.json to point to
> local lib as stated in github instructions, but no grant access to
> mic/camera prompt appeared.
>
> Right-clicking on each error message gives me the option to 'store as
> global variable', which didn't seem like the right thing to do, so I
> requested to sign up for all the jitsi mailing lists instead and am
> here.
> (Thanks Emil Ivov!)
>
> Any advice on how to set this up correctly is greatly appreciated - I've
> already signed up for an http(s) on a webpage I maintain, but will need
> more disk space to ftp this bundle to my httpdocs if *get it working,
> that is *- I gathered secure http(s) protocol would be necessary for
> this
> to work online.
>
> During compile I followed all instructions in the detailed Manual
> Installation on github, except I used *jitmeet*.example.com everywhere
> and not *jitsi*.example.com - no idea if this variance is of any
> consequence.
>
> For localhost poking around, I've installed ssl on apache2 in my ubuntu
> trusty tahr 14.04 workspace. Do I need an Apache script or something?
>
> PS: I am an amateur coder and cannot follow code lingo that falutes high
> -
> I'm only accustomed to following instructions/cutpasting snippets and
> working with jquery plugins so I'm probably looking for DIY-type
> easy-to-follow instructables/ manuals/forum posts if any are extant.
>
> Thanks and kind regards,
> MKR
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://lists.jitsi.org/pipermail/dev/attachments/20161207/e6069c66/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 111673 bytes
Desc: not available
URL:
<http://lists.jitsi.org/pipermail/dev/attachments/20161207/e6069c66/attachment.png>

------------------------------

Subject: Digest Footer

_______________________________________________
dev mailing list
dev@jitsi.org
http://lists.jitsi.org/mailman/listinfo/dev

------------------------------

End of dev Digest, Vol 45, Issue 22
***********************************

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev