[jitsi-dev] custom notification sound file does not loop


#1

Forwarding so that everyone could follow.

From: Jeff Swicegood <jguru108@gmail.com>

Hey Jeff,

Hi,

Just one small issue: A chosen custom notification sound file does not
loop. It only plays once, thus there is no way to know if the call is
still active (if you can't see the screen).

Just making sure I understand: are you saying that you had looping audio
notifications for incoming calls and then switched to another file and
they started playing only once?

Yes, the default wav file loops just fine (IncomingCall.wav). But when I
switched to another file, it plays only once.

What OS are you on? Have you tried with other audio files as well?

Ubuntu 10.04. Yes I have tried other audio files with the same result.

···

-------- Original Message --------
Subject: Re: [jitsi-dev] custom notification sound file does not loop
Date: Fri, 13 Apr 2012 10:16:03 -0400
To: Emil Ivov <emcho@jitsi.org>
On 04/13/2012 08:49 AM, Emil Ivov wrote:

On 12.04.12 16:42, Jeff Swicegood wrote:

Emil


#2

Hi Jeff,

I tried to replace the "incomingCall.wav" with a custom "wav" file, but I am not able to reproduce this issue on my side (it loops normally).

Thereby, can you provide:
- the "wav" file that produces the "play incoming call sound only once" behavior
- and the corresponding logs (http://jitsi.org/index.php/Documentation/FAQ#logs).

Regards,
Vincent

···

On 04/13/2012 04:42 PM, Emil Ivov wrote:

Forwarding so that everyone could follow.

-------- Original Message --------
Subject: Re: [jitsi-dev] custom notification sound file does not loop
Date: Fri, 13 Apr 2012 10:16:03 -0400
From: Jeff Swicegood<jguru108@gmail.com>
To: Emil Ivov<emcho@jitsi.org>

On 04/13/2012 08:49 AM, Emil Ivov wrote:

Hey Jeff,

On 12.04.12 16:42, Jeff Swicegood wrote:

Hi,

Just one small issue: A chosen custom notification sound file does not
loop. It only plays once, thus there is no way to know if the call is
still active (if you can't see the screen).

Just making sure I understand: are you saying that you had looping audio
notifications for incoming calls and then switched to another file and
they started playing only once?

Yes, the default wav file loops just fine (IncomingCall.wav). But when I
switched to another file, it plays only once.

What OS are you on? Have you tried with other audio files as well?

Ubuntu 10.04. Yes I have tried other audio files with the same result.

Emil

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#3

Vincent,

To be clear, I did not replace the "incomingCall.wav" with a custom "wav" file, I merely selected the custom "wav" file in the

events dialog.

Attached: screenshot of events dialog, logs

Jeff

2012-04-23@06.39.59-logs.zip (911 KB)

···

On 04/23/2012 04:46 AM, Vincent Lucas wrote:

Hi Jeff,

I tried to replace the "incomingCall.wav" with a custom "wav" file, but I am not able to reproduce this issue on my side (it loops normally).

Thereby, can you provide:
- the "wav" file that produces the "play incoming call sound only once" behavior
- and the corresponding logs (http://jitsi.org/index.php/Documentation/FAQ#logs).

Regards,
Vincent

On 04/13/2012 04:42 PM, Emil Ivov wrote:

Forwarding so that everyone could follow.

-------- Original Message --------
Subject: Re: [jitsi-dev] custom notification sound file does not loop
Date: Fri, 13 Apr 2012 10:16:03 -0400
From: Jeff Swicegood<jguru108@gmail.com>
To: Emil Ivov<emcho@jitsi.org>

On 04/13/2012 08:49 AM, Emil Ivov wrote:

Hey Jeff,

On 12.04.12 16:42, Jeff Swicegood wrote:

Hi,

Just one small issue: A chosen custom notification sound file does not
loop. It only plays once, thus there is no way to know if the call is
still active (if you can't see the screen).

Just making sure I understand: are you saying that you had looping audio
notifications for incoming calls and then switched to another file and
they started playing only once?

Yes, the default wav file loops just fine (IncomingCall.wav). But when I
switched to another file, it plays only once.

What OS are you on? Have you tried with other audio files as well?

Ubuntu 10.04. Yes I have tried other audio files with the same result.

Emil


#4

Oops, I forgot to include the wav file.

Jeff

CallRingingIn.wav (114 KB)

···

On 04/23/2012 06:44 AM, Jeff Swicegood wrote:

Vincent,

To be clear, I did not replace the "incomingCall.wav" with a custom "wav" file, I merely selected the custom "wav" file in the >events dialog.

Attached: screenshot of events dialog, logs

Jeff

On 04/23/2012 04:46 AM, Vincent Lucas wrote:

Hi Jeff,

I tried to replace the "incomingCall.wav" with a custom "wav" file, but I am not able to reproduce this issue on my side (it loops normally).

Thereby, can you provide:
- the "wav" file that produces the "play incoming call sound only once" behavior
- and the corresponding logs (http://jitsi.org/index.php/Documentation/FAQ#logs).

Regards,
Vincent

On 04/13/2012 04:42 PM, Emil Ivov wrote:

Forwarding so that everyone could follow.

-------- Original Message --------
Subject: Re: [jitsi-dev] custom notification sound file does not loop
Date: Fri, 13 Apr 2012 10:16:03 -0400
From: Jeff Swicegood<jguru108@gmail.com>
To: Emil Ivov<emcho@jitsi.org>

On 04/13/2012 08:49 AM, Emil Ivov wrote:

Hey Jeff,

On 12.04.12 16:42, Jeff Swicegood wrote:

Hi,

Just one small issue: A chosen custom notification sound file does not
loop. It only plays once, thus there is no way to know if the call is
still active (if you can't see the screen).

Just making sure I understand: are you saying that you had looping audio
notifications for incoming calls and then switched to another file and
they started playing only once?

Yes, the default wav file loops just fine (IncomingCall.wav). But when I
switched to another file, it plays only once.

What OS are you on? Have you tried with other audio files as well?

Ubuntu 10.04. Yes I have tried other audio files with the same result.

Emil


#5

Hi Jeff,

Thank you for the provided details. The correction for this issue is available with svn revision #9550 corresponding to build #4011.

Please give it a try to confirm that it works on your side.

Regards,
Vincent

···

On 04/23/2012 12:44 PM, Jeff Swicegood wrote:

Vincent,

To be clear, I did not replace the "incomingCall.wav" with a custom
"wav" file, I merely selected the custom "wav" file in the
>events dialog.

Attached: screenshot of events dialog, logs

Jeff

On 04/23/2012 04:46 AM, Vincent Lucas wrote:

Hi Jeff,

I tried to replace the "incomingCall.wav" with a custom "wav" file,
but I am not able to reproduce this issue on my side (it loops normally).

Thereby, can you provide:
- the "wav" file that produces the "play incoming call sound only
once" behavior
- and the corresponding logs
(http://jitsi.org/index.php/Documentation/FAQ#logs).

Regards,
Vincent

On 04/13/2012 04:42 PM, Emil Ivov wrote:

Forwarding so that everyone could follow.

-------- Original Message --------
Subject: Re: [jitsi-dev] custom notification sound file does not loop
Date: Fri, 13 Apr 2012 10:16:03 -0400
From: Jeff Swicegood<jguru108@gmail.com>
To: Emil Ivov<emcho@jitsi.org>

On 04/13/2012 08:49 AM, Emil Ivov wrote:

Hey Jeff,

On 12.04.12 16:42, Jeff Swicegood wrote:

Hi,

Just one small issue: A chosen custom notification sound file does not
loop. It only plays once, thus there is no way to know if the call is
still active (if you can't see the screen).

Just making sure I understand: are you saying that you had looping
audio
notifications for incoming calls and then switched to another file and
they started playing only once?

Yes, the default wav file loops just fine (IncomingCall.wav). But when I
switched to another file, it plays only once.

What OS are you on? Have you tried with other audio files as well?

Ubuntu 10.04. Yes I have tried other audio files with the same result.

Emil

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#6

Vincent,

Yes, it works! How cool is that.

Jeff

···

On 04/23/2012 11:08 AM, Vincent Lucas wrote:

Hi Jeff,

Thank you for the provided details. The correction for this issue is available with svn revision #9550 corresponding to build #4011.

Please give it a try to confirm that it works on your side.

Regards,
Vincent

On 04/23/2012 12:44 PM, Jeff Swicegood wrote:

Vincent,

To be clear, I did not replace the "incomingCall.wav" with a custom
"wav" file, I merely selected the custom "wav" file in the
>events dialog.

Attached: screenshot of events dialog, logs

Jeff

On 04/23/2012 04:46 AM, Vincent Lucas wrote:

Hi Jeff,

I tried to replace the "incomingCall.wav" with a custom "wav" file,
but I am not able to reproduce this issue on my side (it loops normally).

Thereby, can you provide:
- the "wav" file that produces the "play incoming call sound only
once" behavior
- and the corresponding logs
(http://jitsi.org/index.php/Documentation/FAQ#logs).

Regards,
Vincent

On 04/13/2012 04:42 PM, Emil Ivov wrote:

Forwarding so that everyone could follow.

-------- Original Message --------
Subject: Re: [jitsi-dev] custom notification sound file does not loop
Date: Fri, 13 Apr 2012 10:16:03 -0400
From: Jeff Swicegood<jguru108@gmail.com>
To: Emil Ivov<emcho@jitsi.org>

On 04/13/2012 08:49 AM, Emil Ivov wrote:

Hey Jeff,

On 12.04.12 16:42, Jeff Swicegood wrote:

Hi,

Just one small issue: A chosen custom notification sound file does not
loop. It only plays once, thus there is no way to know if the call is
still active (if you can't see the screen).

Just making sure I understand: are you saying that you had looping
audio
notifications for incoming calls and then switched to another file and
they started playing only once?

Yes, the default wav file loops just fine (IncomingCall.wav). But when I
switched to another file, it plays only once.

What OS are you on? Have you tried with other audio files as well?

Ubuntu 10.04. Yes I have tried other audio files with the same result.

Emil