[jitsi-dev] Configure jitsi-meet/videobridge to let web browsers use local ICE candidate ip address


#1

Is it possible to configure jitsi-videobridge/jitsi-meet (I'm not sure where to configure on between those two components) to allow local address candidate to be used for media stream, instead of their public IP address?
Both of web browser endpoint is in the same LAN and network segment, behind a NAT router.
I'm running jitsi-meet on my Internet hosted servers.
Normal function: video and audio stream is working normally.
I'm using Firefox 52 for both of my client.
I checked about:webrtc, and it shows in the ICE local and remote candidate both local ip address and public ip address, but the one with public ip address is always nominated and selected.
The reason: to help with media quality, during poor Internet bandwidth quality.
I checked jitsi-meet, jitsi-videobridge, and ice4j docs, but I think I didn't find the configuraion related to this.
Thanks!

Best regards,
Anzhari Purnomo
+62 852 2130 0832

Dikirim dari Email untuk Windows 10


#2

Hi,

As I understand jvb is hosted somewhere outside of your local network.
That is the reason the public addresses are used, your local browsers
are sending media to the video bridge, currently jitsi-meet and
videobridge do not have a mode to use p2p mode, but this is on the
roadmap.

Regards
damencho

ยทยทยท

On Mon, Jan 23, 2017 at 8:37 AM, <anzhari.p@gmail.com> wrote:

Is it possible to configure jitsi-videobridge/jitsi-meet (I'm not sure where
to configure on between those two components) to allow local address
candidate to be used for media stream, instead of their public IP address?

Both of web browser endpoint is in the same LAN and network segment, behind
a NAT router.

I'm running jitsi-meet on my Internet hosted servers.

Normal function: video and audio stream is working normally.

I'm using Firefox 52 for both of my client.

I checked about:webrtc, and it shows in the ICE local and remote candidate
both local ip address and public ip address, but the one with public ip
address is always nominated and selected.

The reason: to help with media quality, during poor Internet bandwidth
quality.

I checked jitsi-meet, jitsi-videobridge, and ice4j docs, but I think I
didn't find the configuraion related to this.

Thanks!

Best regards,
Anzhari Purnomo
+62 852 2130 0832

Dikirim dari Email untuk Windows 10

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev