[jitsi-dev] Conference focus error


#1

Hello,

I can’t make works Jitsi-meet on my debian server.

- I have installed a fresh debian 8.6 on a VM (I use virtualbox. Connection attached bridged adapter)

- I have followed carefully the quick-install (my hostname is my local ip)

- It first didn’t work. Running nginx -t show me that cert/key are not valid inside /etc/prosody/certs. I just execute prosodyctl cert generate again and it works

- I can see the jitsi-meet index page, and can create a chan

- At this moment, I can see my webcam but I receive multiples toast erros

"Conference focus"
"focus MY_IP not available"

- Here is my log inside /var/log/jitsy/jicofo

WARNING: Skipped empty cmd line argument: domain=
And it’s the same for port, secret, user_domain, etc…

I suppose that my jicofo was not well installed ? How can I fix that? Thanks.


#2

Check your configs in /etc/jitsi/jicofo/config
It should look like:
JICOFO_HOST=127.0.0.1

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME=domain.example.net

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=somesecret

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN=auth.domain.example.net

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus

# sets the password to use for XMPP user logins
JICOFO_AUTH_PASSWORD=somepassword

# extra options to pass to the jicofo daemon
JICOFO_OPTS=""

# adds java system props that are passed to jicofo (default are for
home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi
-Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo
-Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi
-Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

It will also help if you just attach the log files.
Using virtual machine you need to make sure ports tcp 443, 4443 and
udp 10000 (and 10001-20000 udp which is the fallback for single port)
are accessible from clients that try to connect.

Regards
damencho

···

On Sat, Nov 5, 2016 at 10:47 AM, dahevos dahevos <dahevos@outlook.fr> wrote:

Hello,

I can’t make works Jitsi-meet on my debian server.

- I have installed a fresh debian 8.6 on a VM (I use virtualbox.
Connection attached bridged adapter)

- I have followed carefully the quick-install (my hostname is my
local ip)

- It first didn’t work. Running nginx -t show me that cert/key are
not valid inside /etc/prosody/certs. I just execute prosodyctl cert generate
again and it works

- I can see the jitsi-meet index page, and can create a chan

- At this moment, I can see my webcam but I receive multiples toast
erros

"Conference focus"
"focus MY_IP not available"

- Here is my log inside /var/log/jitsy/jicofo

WARNING: Skipped empty cmd line argument: domain=

And it’s the same for port, secret, user_domain, etc…

I suppose that my jicofo was not well installed ? How can I fix that?
Thanks.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hello Damian and thanks for answering my question.

My config file was empty and I don't understand how and why (since I use apt-get install jitsi-meet, shouldn't be empty, maybe it's a bug in the auto install script).

I edit the config file but I don't know what to put for JICOFO_AUTH_PASSWORD since I don't know what is the password used during the apt-get install jitsi-meet.

I use prosodyctl register focus auth.192.168.31.180 root in order to reset the password of focus to "root", hope it works.

Unfortunately, I still have the issue. I check that my iptables are empty so no issue from the firewall. I check jicofo log file and now I just have "connection refused" (so is a good progress since yesterday :-)).

I attached to this email all important file. Thanks for your help.

files.tar.gz (173 KB)

···

________________________________
De : dev <dev-bounces@jitsi.org> de la part de Damian Minkov <damencho@jitsi.org>
Envoyé : samedi 5 novembre 2016 22:03:46
À : Jitsi Developers
Objet : Re: [jitsi-dev] Conference focus error

Check your configs in /etc/jitsi/jicofo/config
It should look like:
JICOFO_HOST=127.0.0.1

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME=domain.example.net

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=somesecret

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN=auth.domain.example.net

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus

# sets the password to use for XMPP user logins
JICOFO_AUTH_PASSWORD=somepassword

# extra options to pass to the jicofo daemon
JICOFO_OPTS=""

# adds java system props that are passed to jicofo (default are for
home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi
-Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo
-Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi
-Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

It will also help if you just attach the log files.
Using virtual machine you need to make sure ports tcp 443, 4443 and
udp 10000 (and 10001-20000 udp which is the fallback for single port)
are accessible from clients that try to connect.

Regards
damencho

On Sat, Nov 5, 2016 at 10:47 AM, dahevos dahevos <dahevos@outlook.fr> wrote:

Hello,

I can’t make works Jitsi-meet on my debian server.

- I have installed a fresh debian 8.6 on a VM (I use virtualbox.
Connection attached bridged adapter)

- I have followed carefully the quick-install (my hostname is my
local ip)

- It first didn’t work. Running nginx -t show me that cert/key are
not valid inside /etc/prosody/certs. I just execute prosodyctl cert generate
again and it works

- I can see the jitsi-meet index page, and can create a chan

- At this moment, I can see my webcam but I receive multiples toast
erros

"Conference focus"
"focus MY_IP not available"

- Here is my log inside /var/log/jitsy/jicofo

WARNING: Skipped empty cmd line argument: domain=

And it’s the same for port, secret, user_domain, etc…

I suppose that my jicofo was not well installed ? How can I fix that?
Thanks.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi,

You have JICOFO_HOST=192.168.31.180
confirm that prosody is listening there on port 5347, or change it
depending where prosody is listening for component connections. By
default, I think it is 127.0.0.1. You can check jvb, it should use the
same port and address to connect to prosody.

Regards
damencho

···

On Sat, Nov 5, 2016 at 11:41 PM, dahevos dahevos <dahevos@outlook.fr> wrote:

Hello Damian and thanks for answering my question.

My config file was empty and I don't understand how and why (since I use
apt-get install jitsi-meet, shouldn't be empty, maybe it's a bug in the auto
install script).

I edit the config file but I don't know what to put for JICOFO_AUTH_PASSWORD
since I don't know what is the password used during the apt-get install
jitsi-meet.

I use prosodyctl register focus auth.192.168.31.180 root in order to reset
the password of focus to "root", hope it works.

Unfortunately, I still have the issue. I check that my iptables are empty so
no issue from the firewall. I check jicofo log file and now I just have
"connection refused" (so is a good progress since yesterday :-)).

I attached to this email all important file. Thanks for your help.

________________________________
De : dev <dev-bounces@jitsi.org> de la part de Damian Minkov
<damencho@jitsi.org>
Envoyé : samedi 5 novembre 2016 22:03:46
À : Jitsi Developers
Objet : Re: [jitsi-dev] Conference focus error

Check your configs in /etc/jitsi/jicofo/config
It should look like:
JICOFO_HOST=127.0.0.1

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME=domain.example.net

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=somesecret

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN=auth.domain.example.net

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus

# sets the password to use for XMPP user logins
JICOFO_AUTH_PASSWORD=somepassword

# extra options to pass to the jicofo daemon
JICOFO_OPTS=""

# adds java system props that are passed to jicofo (default are for
home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi
-Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo
-Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi
-Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

It will also help if you just attach the log files.
Using virtual machine you need to make sure ports tcp 443, 4443 and
udp 10000 (and 10001-20000 udp which is the fallback for single port)
are accessible from clients that try to connect.

Regards
damencho

On Sat, Nov 5, 2016 at 10:47 AM, dahevos dahevos <dahevos@outlook.fr> wrote:

Hello,

I can’t make works Jitsi-meet on my debian server.

- I have installed a fresh debian 8.6 on a VM (I use virtualbox.
Connection attached bridged adapter)

- I have followed carefully the quick-install (my hostname is my
local ip)

- It first didn’t work. Running nginx -t show me that cert/key
are
not valid inside /etc/prosody/certs. I just execute prosodyctl cert
generate
again and it works

- I can see the jitsi-meet index page, and can create a chan

- At this moment, I can see my webcam but I receive multiples
toast
erros

"Conference focus"
"focus MY_IP not available"

- Here is my log inside /var/log/jitsy/jicofo

WARNING: Skipped empty cmd line argument: domain=

And it’s the same for port, secret, user_domain, etc…

I suppose that my jicofo was not well installed ? How can I fix that?
Thanks.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev