[jitsi-dev] Closer to Nirvana


#1

I now get:

1/01/2017, 14:33:45 onRemoteDataChannel

label: default, reliable: true

and:
number of conferences 1 id:5cff3ecd703d0fb6
audiochannels:1
Endpoint: org.jitsi.videobridge.Endpoint 4b698e Id:bc9cfac31879b9ba cb-id:4b698e
videochannels:1
Endpoint: org.jitsi.videobridge.Endpoint 4b698e Id:eb63cfcdbe8a3e75 cb-id:4b698e
datachannels:1
Endpoint: org.jitsi.videobridge.Endpoint 4b698e Id:79f6e61a57ed7cb1 cb-id:4b698e

Although it still opens up two audio and two datachannels on the formation of the conference. (which later on expire)

The client says

conference ID: 5cff3ecd703d0fb6
Content: audio
Channel source: 2731552508
Content: video
Channel source: 3745644235
Content: data

Chrome logs say:
INFORMATION 6444 10012 14:39:33-155 0 VideoSendStream stats: 277187214, {input_fps: 30, encode_fps: 30, encode_ms: 9, encode_usage_perc: 21, target_bps: 300000, media_bps: 302622, preferred_media_bitrate_bps: 1700, suspended: false, bw_adapted: false} {ssrc: 3440236023, width: 640, height: 480, key: 4, delta: 10548, total_bps: 300984, retransmit_bps: 0, avg_delay_ms: 14, max_delay_ms: 29, cum_loss: 0, max_ext_seq: 0, nack: 0, fir: 0, pli: 0}
INFORMATION 6444 10012 14:39:33-155 0 VideoReceiveStream stats: 277187214, {ssrc: 3745644235, total_bps: 0, width: 0, height: 0, key: 0, delta: 0, network_fps: 0, decode_fps: 0, render_fps: 0, decode_ms: 0, max_decode_ms: 0, cur_delay_ms: 0, targ_delay_ms: 10, jb_delay_ms: 0, min_playout_delay_ms: 0, discarded: 0, sync_offset_ms: 2147483647, cum_loss: 0, max_ext_seq: 0, nack: 0, fir: 0, pli: 0}
INFORMATION 6444 10012 14:39:33-155 0 Call stats: 277187214, {send_bw_bps: 300000, recv_bw_bps: 0, max_pad_bps: 0, pacer_delay_ms: 4, rtt_ms: -1}
INFORMATION 6444 13396 14:39:41-403 0 Number of frames: captured 1804, dropped (due to encoder blocked) 1, interval_ms 60000

and WebRtc internals has me sending, but not receiving.

Progress is, however, being made.