[jitsi-dev] Chromium support


#1

Hi Jitsi team!,

Today I wanted to use Chromium with Jitsi Meet and I found the following
message, which was a surprise for me: "It looks like you're using a
browser we don't support. Please try again with the latest version of
Chrome, Firefox or" (the sentence ends with that "or").

This seems to have been introduced in some previous update because I was
using Chromium without problem in Debian Jessie.

Is there any reason why Chromium is no longer a supported browser?

Thanks in advance.

Kind regards,
Daniel


#2

Hi,

Nope, there is no reason for that. We will investigate it and fix this.

Regards
damencho

···

On Mon, Nov 13, 2017 at 7:41 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi Jitsi team!,

Today I wanted to use Chromium with Jitsi Meet and I found the following
message, which was a surprise for me: "It looks like you're using a
browser we don't support. Please try again with the latest version of
Chrome, Firefox or" (the sentence ends with that "or").

This seems to have been introduced in some previous update because I was
using Chromium without problem in Debian Jessie.

Is there any reason why Chromium is no longer a supported browser?

Thanks in advance.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Today I wanted to use Chromium with Jitsi Meet and I found the following
message, which was a surprise for me: "It looks like you're using a
browser we don't support. Please try again with the latest version of
Chrome, Firefox or" (the sentence ends with that "or").

This seems to have been introduced in some previous update because I was
using Chromium without problem in Debian Jessie.

Is there any reason why Chromium is no longer a supported browser?

Hi,

Hi, Damian.

Nope, there is no reason for that. We will investigate it and fix
this.

Thanks for the prompt reply.

It's weird because Chrome works without problems. These are the versions
I'm using:

Chromium: 57.0.2987.98
Chrome: 62.0.3202.89

I found the same behavior against meet.jit.si (by the way, I found a
message in Chrome saying that Jitsi Meet cannot access the microphone;
this does not happen in Firefox).

Let me know if I can provide more information.

Thanks for your time.

Kind regards,
Daniel

···

On 13/11/17 10:50, Damian Minkov wrote:


#4

Hi,

Today I wanted to use Chromium with Jitsi Meet and I found the following
message, which was a surprise for me: "It looks like you're using a
browser we don't support. Please try again with the latest version of
Chrome, Firefox or" (the sentence ends with that "or").

This seems to have been introduced in some previous update because I was
using Chromium without problem in Debian Jessie.

Is there any reason why Chromium is no longer a supported browser?

Hi,

Hi, Damian.

Nope, there is no reason for that. We will investigate it and fix
this.

Thanks for the prompt reply.

It's weird because Chrome works without problems. These are the versions
I'm using:

Chromium: 57.0.2987.98
Chrome: 62.0.3202.89

I found the same behavior against meet.jit.si (by the way, I found a
message in Chrome saying that Jitsi Meet cannot access the microphone;
this does not happen in Firefox).

Let me know if I can provide more information.

Do you see the unsupported browser page when using Chromium and
meet.jit.si. I just downloaded chromium and it works just fine here,
but it is a newer version.

Regards
damencho

···

On Mon, Nov 13, 2017 at 8:15 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 13/11/17 10:50, Damian Minkov wrote:

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

I just reproduced the problem you have. Will investigate and will come
later with more info.
Tried with Chromium 57 and I see the same.

Thanks
damencho

···

On Mon, Nov 13, 2017 at 8:31 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

On Mon, Nov 13, 2017 at 8:15 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 13/11/17 10:50, Damian Minkov wrote:

Today I wanted to use Chromium with Jitsi Meet and I found the following
message, which was a surprise for me: "It looks like you're using a
browser we don't support. Please try again with the latest version of
Chrome, Firefox or" (the sentence ends with that "or").

This seems to have been introduced in some previous update because I was
using Chromium without problem in Debian Jessie.

Is there any reason why Chromium is no longer a supported browser?

Hi,

Hi, Damian.

Nope, there is no reason for that. We will investigate it and fix
this.

Thanks for the prompt reply.

It's weird because Chrome works without problems. These are the versions
I'm using:

Chromium: 57.0.2987.98
Chrome: 62.0.3202.89

I found the same behavior against meet.jit.si (by the way, I found a
message in Chrome saying that Jitsi Meet cannot access the microphone;
this does not happen in Firefox).

Let me know if I can provide more information.

Do you see the unsupported browser page when using Chromium and
meet.jit.si. I just downloaded chromium and it works just fine here,
but it is a newer version.

Regards
damencho

Thanks for your time.

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hi,

Hi, Damian.

Do you see the unsupported browser page when using Chromium and
meet.jit.si. I just downloaded chromium and it works just fine here,
but it is a newer version.

Thanks for doing this test.

Yes, I've tested with Chromium 57.0.2987.98 in meet.jit.si and I see the
unsupported browser page.

Are you doing some version checking in the code to define compatibility?

Kind regards,
Daniel

···

On 13/11/17 11:31, Damian Minkov wrote:


#7

Hi,

Hi, Damian.

I just reproduced the problem you have. Will investigate and will come
later with more info.
Tried with Chromium 57 and I see the same.

I just saw this message.

Thank you very much.

Kind regards,
Daniel

···

On 13/11/17 11:41, Damian Minkov wrote:


#8

Yes, based on the user agent string. Can you check what yours is (type "navigator.userAgent" in the javascript console).

Boris

···

On 13/11/2017 08:44, Daniel Bareiro wrote:

On 13/11/17 11:31, Damian Minkov wrote:

Hi,

Hi, Damian.

Do you see the unsupported browser page when using Chromium and
meet.jit.si. I just downloaded chromium and it works just fine here,
but it is a newer version.

Thanks for doing this test.

Yes, I've tested with Chromium 57.0.2987.98 in meet.jit.si and I see the
unsupported browser page.

Are you doing some version checking in the code to define compatibility?


#9

We fixed it in the source code, the build with the fix will be out in
a couple of minutes (20-30). We will also update meet.jit.si in few
hours with that.

···

On Mon, Nov 13, 2017 at 12:05 PM, Boris Grozev <boris@jitsi.org> wrote:

On 13/11/2017 08:44, Daniel Bareiro wrote:

On 13/11/17 11:31, Damian Minkov wrote:

Hi,

Hi, Damian.

Do you see the unsupported browser page when using Chromium and
meet.jit.si. I just downloaded chromium and it works just fine here,
but it is a newer version.

Thanks for doing this test.

Yes, I've tested with Chromium 57.0.2987.98 in meet.jit.si and I see the
unsupported browser page.

Are you doing some version checking in the code to define compatibility?

Yes, based on the user agent string. Can you check what yours is (type
"navigator.userAgent" in the javascript console).

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi, Boris.

···

On 13/11/17 15:05, Boris Grozev wrote:

Do you see the unsupported browser page when using Chromium and
meet.jit.si. I just downloaded chromium and it works just fine here,
but it is a newer version.

Thanks for doing this test.

Yes, I've tested with Chromium 57.0.2987.98 in meet.jit.si and I see the
unsupported browser page.

Are you doing some version checking in the code to define compatibility?

Yes, based on the user agent string. Can you check what yours is (type
"navigator.userAgent" in the javascript console).

Thanks for your reply. This is the output:

---------------------------------------------------------------------------
"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko)
Chrome/57.0.2987.98 Safari/537.36"
---------------------------------------------------------------------------

I also just saw other errors in the Javascript error console:

---------------------------------------------------------------------------
lib-jitsi-meet.min.js:2 [modules/RTC/RTCUtils.js] <T>: Browser does not
appear to be WebRTC-capable

[react/features/base/connection/actions.web.js] <>: Error: Browser does
not appear to be WebRTC-capable
    at T (lib-jitsi-meet.min.js:2)
    at lib-jitsi-meet.min.js:2
    at Promise (<anonymous>)
    at t.value (lib-jitsi-meet.min.js:2)
    at Function.value (lib-jitsi-meet.min.js:2)
    at Object.init (lib-jitsi-meet.min.js:2)
    at Object.init (app.bundle.min.js:2)
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at Object.dispatch (app.bundle.min.js:2)
    at t.value (app.bundle.min.js:2)
    at commitLifeCycles (app.bundle.min.js:2)
    at n (app.bundle.min.js:2)
    at l (app.bundle.min.js:2)
    at c (app.bundle.min.js:2)
    at g (app.bundle.min.js:2)
    at h (app.bundle.min.js:2)
    at Object.enqueueSetState (app.bundle.min.js:2)
    at t.i.setState (app.bundle.min.js:2)
    at app.bundle.min.js:2
    at Promise (<anonymous>)
    at t.value (app.bundle.min.js:2)
    at t.value (app.bundle.min.js:2)
    at I (app.bundle.min.js:2)
    at j (app.bundle.min.js:2)
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at app.bundle.min.js:2
    at dispatch (app.bundle.min.js:2)
    at app.bundle.min.js:2

Failed to load resource: the server responded with a status of 404 (Not
Found)
---------------------------------------------------------------------------

Maybe the issue is related to that.

Kind regards,
Daniel


#11

Hi, Damian.

···

On 13/11/17 15:18, Damian Minkov wrote:

We fixed it in the source code, the build with the fix will be out in
a couple of minutes (20-30). We will also update meet.jit.si in few
hours with that.

Thank you very much for the quick fix. Much appreciated.

Kind regards,
Daniel


#12

Hi, Damian.

···

On 13/11/17 15:27, Daniel Bareiro wrote:

We fixed it in the source code, the build with the fix will be out in
a couple of minutes (20-30). We will also update meet.jit.si in few
hours with that.

Thank you very much for the quick fix. Much appreciated.

It seems that the new packages from the testing repo were not generated
yet. I read an update of Github where you said that there is a problem
with the CI machine. Could it be that the generation of the packages is
delayed by that?

Kind regards,
Daniel


#13

Nope. The packages go in testing repo after some testing is done,
apparently, this failed I need to check why is that.
Our ci had some free space issues, which were affecting the pr-testing
and those are now fixed.

···

On Tue, Nov 14, 2017 at 8:48 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi, Damian.

On 13/11/17 15:27, Daniel Bareiro wrote:

We fixed it in the source code, the build with the fix will be out in
a couple of minutes (20-30). We will also update meet.jit.si in few
hours with that.

Thank you very much for the quick fix. Much appreciated.

It seems that the new packages from the testing repo were not generated
yet. I read an update of Github where you said that there is a problem
with the CI machine. Could it be that the generation of the packages is
delayed by that?

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Hi, Damian,

···

On 14/11/17 11:56, Damian Minkov wrote:

Nope. The packages go in testing repo after some testing is done,
apparently, this failed I need to check why is that.
Our ci had some free space issues, which were affecting the pr-testing
and those are now fixed.

Thanks you very much. When the new package is available I will do a
test, but I have already tried with meet.jit.si and the fix seems to work.

Kind regards,
Daniel


#15

Hi, Damian.

Nope. The packages go in testing repo after some testing is done,
apparently, this failed I need to check why is that.
Our ci had some free space issues, which were affecting the pr-testing
and those are now fixed.

Thanks you very much. When the new package is available I will do a
test, but I have already tried with meet.jit.si and the fix seems to work.

I think I was not seeing the new versions of the packages because the
host was automatically running an "aptitude update" (I've already
disabled this). Then I found this available updates:

jicofo [1.0-386-1 -> 1.0-388-1]
jitsi-meet [1.0.2625-1 -> 1.0.2645-1]
jitsi-meet-prosody [1.0.2434-1 -> 1.0.2450-1]
jitsi-meet-web [1.0.2434-1 -> 1.0.2450-1]
jitsi-meet-web-config [1.0.2434-1 -> 1.0.2450-1]
jitsi-videobridge [1010-1 -> 1013-1]

The update of these versions of jitsi-meet solved the problem with
Chromium (although I don't know if the fix was introduced in this
version or maybe a previous one). Thank you very much.

By the way, is it possible that this version also includes a fix for
this [1]? It seems that now I'm not having that problem in Chromium but
I'm not sure if this is because I cleaned the cache, because you
introduced a fix, or just because it does not always happen (it seems to
be due to a race condition if I understood correctly what Leonard told me).

Kind regards,
Daniel

[1] https://github.com/jitsi/jitsi-meet/issues/2160

···

On 16/11/17 11:48, Daniel Bareiro wrote:


#16

I don't think we had pushed a fix for that. Maybe it was cache.

···

On Nov 18, 2017 17:06, "Daniel Bareiro" <daniel-listas@gmx.net> wrote:

Hi, Damian.

On 16/11/17 11:48, Daniel Bareiro wrote:

>> Nope. The packages go in testing repo after some testing is done,
>> apparently, this failed I need to check why is that.
>> Our ci had some free space issues, which were affecting the pr-testing
>> and those are now fixed.

> Thanks you very much. When the new package is available I will do a
> test, but I have already tried with meet.jit.si and the fix seems to
work.

I think I was not seeing the new versions of the packages because the
host was automatically running an "aptitude update" (I've already
disabled this). Then I found this available updates:

jicofo [1.0-386-1 -> 1.0-388-1]
jitsi-meet [1.0.2625-1 -> 1.0.2645-1]
jitsi-meet-prosody [1.0.2434-1 -> 1.0.2450-1]
jitsi-meet-web [1.0.2434-1 -> 1.0.2450-1]
jitsi-meet-web-config [1.0.2434-1 -> 1.0.2450-1]
jitsi-videobridge [1010-1 -> 1013-1]

The update of these versions of jitsi-meet solved the problem with
Chromium (although I don't know if the fix was introduced in this
version or maybe a previous one). Thank you very much.

By the way, is it possible that this version also includes a fix for
this [1]? It seems that now I'm not having that problem in Chromium but
I'm not sure if this is because I cleaned the cache, because you
introduced a fix, or just because it does not always happen (it seems to
be due to a race condition if I understood correctly what Leonard told me).

Kind regards,
Daniel

[1] https://github.com/jitsi/jitsi-meet/issues/2160

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#17

Hi, Damian.

···

On 18/11/17 23:22, Damian Minkov wrote:

> By the way, is it possible that this version also includes a fix for
> this [1]? It seems that now I'm not having that problem in Chromium but
> I'm not sure if this is because I cleaned the cache, because you
> introduced a fix, or just because it does not always happen (it seems to
> be due to a race condition if I understood correctly what Leonard
> told me).
>
> [...]
>
> [1] https://github.com/jitsi/jitsi-meet/issues/2160

I don't think we had pushed a fix for that. Maybe it was cache.

Confirmed. The symptoms have reappeared :frowning:

Thanks for your reply.

Kind regards,
Daniel