[jitsi-dev] @ character stripped from XMPP passwords


#1

Hi,

using the latest nightly build, I cannot authenticate to my Jabber server.

My password contains the @ character and, sniffing on the connection on
the server-side, this @ is never sent. It seems to be stripped from the
password before Jitsi sends it on the wire.

I am pretty sure this is a bug.

···

--
Cheers,
Nik

PGP-Fingerprint: 8BC7 ABAB C2F2 4D5E 24FC
                 FC1C DB0E A4BC E210 7412

Please contact me for a face-to-face meeting
if you wish to exchange signatures with me.

Signature Policy: https://www.dominik-george.de/gpg-policy.txt.asc
Public key: https://www.dominik-george.de/gpg.asc

X.509 certificate fingerprint for key download:
51:D8:36:36:7E:20:3F:E7:AB:EF:B8:83:25:A6:BB:74:48:03:3D:F0

Please do NOT send HTML mail!


#2

Hey Nik,

···

On 16.09.12, 20:11, Dominik George wrote:

Hi,

using the latest nightly build, I cannot authenticate to my Jabber server.

My password contains the @ character and, sniffing on the connection on
the server-side, this @ is never sent. It seems to be stripped from the
password before Jitsi sends it on the wire.

I am pretty sure this is a bug.

I just tried using an @ in various XMPP passwords and didn't have any
issues.

Does connection work if you remove the @ from yours?

Emil


#3

Hi,

Does connection work if you remove the @ from yours?

yes, it does.

Shall I try setting another password containing an @ but that is different
apart from that and try again?

···

--
Cheers,
Nik

PGP-Fingerprint: 8BC7 ABAB C2F2 4D5E 24FC
                 FC1C DB0E A4BC E210 7412

Please contact me for a face-to-face meeting
if you wish to exchange signatures with me.

Signature Policy: https://www.dominik-george.de/gpg-policy.txt.asc
Public key: https://www.dominik-george.de/gpg.asc

X.509 certificate fingerprint for key download:
51:D8:36:36:7E:20:3F:E7:AB:EF:B8:83:25:A6:BB:74:48:03:3D:F0

Please do NOT send HTML mail!