[jitsi-dev] CALLING_DISABLED - Possible Issue


#1

Can anyone reproduce this? I am running Windows 8 x64 + Jitsi 2.4.4997 x64

How to Reproduce: Add net.java.sip.communicator.impl.protocol.jabber.CALLING_DISABLED=true to jitsi-defaults.properties

Outcome: "Sign In" window does not automatically pop-up upon first Jitsi load (or any subsequent load until first account is added).

Is there a property I can add to Jitsi-defaults.properties that tells Jitsi to load the "Sign In" window thus overriding this odd behavior?

Aaron


#2

Can anyone reproduce this? I am running Windows 8 x64 + Jitsi 2.4.4997 x64

How to Reproduce: Add
net.java.sip.communicator.impl.protocol.jabber.CALLING_DISABLED=true to
jitsi-defaults.properties

Outcome: "Sign In" window does not automatically pop-up upon first Jitsi

load

(or any subsequent load until first account is added).

Is there a property I can add to Jitsi-defaults.properties that tells

Jitsi

to load the "Sign In" window thus overriding this odd behavior?

This is because the Sign-In window looks for registered accounts by checking
for properties that start with
"net.java.sip.communicator.impl.protocol.jabber". It is only shown when no
account is configured yet. Now the calling disabled property is not really
an account and it should show anyway.

Yana, I think this is mostly your baby, but I think the following would
work:
- Check for net.java.sip.communicator.impl.protocol.jabber.acc (instead of
just net.java.sip.communicator.impl.protocol.jabber)
- Don't match the prefix exactly
Are you okay with that?

Aaron

Ingo


#3

Yana or Emil,

Do we think we will be able to implement this change? Would be much appreciated!

Aaron Dixon | IT Specialist | SSDC Services
Office: 248-277-9304 | Cell: 248-935-7353 | aaron.dixon@ssdcservices.com

ยทยทยท

-----Original Message-----
From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Thursday, January 9, 2014 5:16 PM
To: 'Jitsi Developers'
Subject: Re: [jitsi-dev] CALLING_DISABLED - Possible Issue

Can anyone reproduce this? I am running Windows 8 x64 + Jitsi 2.4.4997
x64

How to Reproduce: Add
net.java.sip.communicator.impl.protocol.jabber.CALLING_DISABLED=true
to jitsi-defaults.properties

Outcome: "Sign In" window does not automatically pop-up upon first
Jitsi

load

(or any subsequent load until first account is added).

Is there a property I can add to Jitsi-defaults.properties that tells

Jitsi

to load the "Sign In" window thus overriding this odd behavior?

This is because the Sign-In window looks for registered accounts by checking for properties that start with "net.java.sip.communicator.impl.protocol.jabber". It is only shown when no account is configured yet. Now the calling disabled property is not really an account and it should show anyway.

Yana, I think this is mostly your baby, but I think the following would
work:
- Check for net.java.sip.communicator.impl.protocol.jabber.acc (instead of just net.java.sip.communicator.impl.protocol.jabber)
- Don't match the prefix exactly
Are you okay with that?

Aaron

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Do we think we will be able to implement this change? Would be much
appreciated!

Already done:
https://github.com/jitsi/jitsi/commit/1946279843a2d011e2a4043b71c6958aaa4869
b6

First available in build 2.5.5018

Aaron Dixon

Ingo