[jitsi-dev] Building libjitsi native ffmpeg + fdk-aac


#1

Following this guide
https://github.com/jitsi/jitsi-lgpl-dependencies/tree/master/src/native/ffmpeg
I
have added fdk-aac and have run into some issue with opencl at ffmpeg
configure time; not being a C/C++ dev, I'm not sure how to resolve it; any
assistance would be appreciated. Here is a link for the config.log:
http://pastebin.com/CxffdBJg

Thanks
Paul


#2

Nevermind, resolved this by adding "--disable-opencl" to the x264 configure
like so:
./configure --enable-pic --enable-debug --disable-opencl && make

May want to add that to the readme? Answer found here:
http://wiki.serviio.org/doku.php?id=build_ffmpeg_linux
tl;dr
NOTE: New version of x264 contains by default support of OpenCL. If not
installed or without sense (example Ubuntu 12.04LTS on VMWare) add to
configure additional option –disable-opencl../configure --disable-opencl

Without this option ffmpeg could not be configured (ERROR: libx264 not
found).

···

On Wed, Feb 3, 2016 at 10:11 AM Mondain <mondain@gmail.com> wrote:

Following this guide
https://github.com/jitsi/jitsi-lgpl-dependencies/tree/master/src/native/ffmpeg I
have added fdk-aac and have run into some issue with opencl at ffmpeg
configure time; not being a C/C++ dev, I'm not sure how to resolve it; any
assistance would be appreciated. Here is a link for the config.log:
http://pastebin.com/CxffdBJg

Thanks
Paul


#3

New error when doing ant ffmpeg:

ffmpeg:
     [echo]
       [cc] 0 total files to be compiled.
       [cc] Starting link
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] collect2: error: ld returned 1 exit status

Any ideas?

···

On Wed, Feb 3, 2016 at 10:30 AM Mondain <mondain@gmail.com> wrote:

Nevermind, resolved this by adding "--disable-opencl" to the x264
configure like so:
./configure --enable-pic --enable-debug --disable-opencl && make

May want to add that to the readme? Answer found here:
http://wiki.serviio.org/doku.php?id=build_ffmpeg_linux
tl;dr
NOTE: New version of x264 contains by default support of OpenCL. If not
installed or without sense (example Ubuntu 12.04LTS on VMWare) add to
configure additional option –disable-opencl../configure --disable-opencl

Without this option ffmpeg could not be configured (ERROR: libx264 not
found).

On Wed, Feb 3, 2016 at 10:11 AM Mondain <mondain@gmail.com> wrote:

Following this guide
https://github.com/jitsi/jitsi-lgpl-dependencies/tree/master/src/native/ffmpeg I
have added fdk-aac and have run into some issue with opencl at ffmpeg
configure time; not being a C/C++ dev, I'm not sure how to resolve it; any
assistance would be appreciated. Here is a link for the config.log:
http://pastebin.com/CxffdBJg

Thanks
Paul


#4

Is the error with the build, an issue with my gcc version?

/usr/bin/gcc -v
Using built-in specs.
COLLECT_GCC=/usr/bin/gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.8.4-2ubuntu1~14.04'
--with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs
--enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr
--program-suffix=-4.8 --enable-shared --enable-linker-build-id
--libexecdir=/usr/lib --without-included-gettext --enable-threads=posix
--with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls
--with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug
--enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap
--enable-plugin --with-system-zlib --disable-browser-plugin
--enable-java-awt=gtk --enable-gtk-cairo
--with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre
--enable-java-home
--with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64
--with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64
--with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar
--enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686
--with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic
--enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu
--target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04)

···

On Wed, Feb 3, 2016 at 10:39 AM Mondain <mondain@gmail.com> wrote:

New error when doing ant ffmpeg:

ffmpeg:
     [echo]
       [cc] 0 total files to be compiled.
       [cc] Starting link
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] collect2: error: ld returned 1 exit status

Any ideas?

On Wed, Feb 3, 2016 at 10:30 AM Mondain <mondain@gmail.com> wrote:

Nevermind, resolved this by adding "--disable-opencl" to the x264
configure like so:
./configure --enable-pic --enable-debug --disable-opencl && make

May want to add that to the readme? Answer found here:
http://wiki.serviio.org/doku.php?id=build_ffmpeg_linux
tl;dr
NOTE: New version of x264 contains by default support of OpenCL. If not
installed or without sense (example Ubuntu 12.04LTS on VMWare) add to
configure additional option –disable-opencl../configure --disable-opencl

Without this option ffmpeg could not be configured (ERROR: libx264 not
found).

On Wed, Feb 3, 2016 at 10:11 AM Mondain <mondain@gmail.com> wrote:

Following this guide
https://github.com/jitsi/jitsi-lgpl-dependencies/tree/master/src/native/ffmpeg I
have added fdk-aac and have run into some issue with opencl at ffmpeg
configure time; not being a C/C++ dev, I'm not sure how to resolve it; any
assistance would be appreciated. Here is a link for the config.log:
http://pastebin.com/CxffdBJg

Thanks
Paul


#5

I've continued to debug this to no avail. The so's are clearly where they
should be and setting a libset still yields an error:

ffmpeg:
     [echo]
       [cc] 0 total files to be compiled.
       [cc] Starting link
       [cc] /usr/bin/ld: cannot find -llibgcc_s.so.1
       [cc] /usr/bin/ld: cannot find -lgcc_s.so.1
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] collect2: error: ld returned 1 exit status

Libset:
<!--
      <libset dir="/usr/lib/gcc/x86_64-linux-gnu/4.8"
        libs="libgcc_s.so"
        />
-->
      <libset dir="/lib/x86_64-linux-gnu"
        libs="libgcc_s.so.1,gcc_s.so.1"
        />
Files exist:
ls -l /usr/lib/gcc/x86_64-linux-gnu/4.8/libgcc_s.so
lrwxrwxrwx 1 root root 35 May 14 2015
/usr/lib/gcc/x86_64-linux-gnu/4.8/libgcc_s.so ->
/lib/x86_64-linux-gnu/libgcc_s.so.1

ls -l /lib/x86_64-linux-gnu/libgcc_s.so.1
-rw-r--r-- 1 root root 90160 Nov 24 19:02
/lib/x86_64-linux-gnu/libgcc_s.so.1

···

On Wed, Feb 3, 2016 at 10:44 AM Mondain <mondain@gmail.com> wrote:

Is the error with the build, an issue with my gcc version?

/usr/bin/gcc -v
Using built-in specs.
COLLECT_GCC=/usr/bin/gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.8.4-2ubuntu1~14.04'
--with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs
--enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr
--program-suffix=-4.8 --enable-shared --enable-linker-build-id
--libexecdir=/usr/lib --without-included-gettext --enable-threads=posix
--with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls
--with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug
--enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap
--enable-plugin --with-system-zlib --disable-browser-plugin
--enable-java-awt=gtk --enable-gtk-cairo
--with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre
--enable-java-home
--with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64
--with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64
--with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar
--enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686
--with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic
--enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu
--target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04)

On Wed, Feb 3, 2016 at 10:39 AM Mondain <mondain@gmail.com> wrote:

New error when doing ant ffmpeg:

ffmpeg:
     [echo]
       [cc] 0 total files to be compiled.
       [cc] Starting link
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] collect2: error: ld returned 1 exit status

Any ideas?

On Wed, Feb 3, 2016 at 10:30 AM Mondain <mondain@gmail.com> wrote:

Nevermind, resolved this by adding "--disable-opencl" to the x264
configure like so:
./configure --enable-pic --enable-debug --disable-opencl && make

May want to add that to the readme? Answer found here:
http://wiki.serviio.org/doku.php?id=build_ffmpeg_linux
tl;dr
NOTE: New version of x264 contains by default support of OpenCL. If not
installed or without sense (example Ubuntu 12.04LTS on VMWare) add to
configure additional option –disable-opencl../configure --disable-opencl

Without this option ffmpeg could not be configured (ERROR: libx264 not
found).

On Wed, Feb 3, 2016 at 10:11 AM Mondain <mondain@gmail.com> wrote:

Following this guide
https://github.com/jitsi/jitsi-lgpl-dependencies/tree/master/src/native/ffmpeg I
have added fdk-aac and have run into some issue with opencl at ffmpeg
configure time; not being a C/C++ dev, I'm not sure how to resolve it; any
assistance would be appreciated. Here is a link for the config.log:
http://pastebin.com/CxffdBJg

Thanks
Paul


#6

Is anyone out there building the native portion of libjitsi? I just can't
seem to figure this one out; even setting the linker arg directly doesn't
allow cc to find the gcc_s which as I said before exists!

<linkerarg value="-L/usr/lib/gcc/x86_64-linux-gnu/4.8" />

···

On Wed, Feb 3, 2016 at 1:14 PM Mondain <mondain@gmail.com> wrote:

I've continued to debug this to no avail. The so's are clearly where they
should be and setting a libset still yields an error:

ffmpeg:
     [echo]
       [cc] 0 total files to be compiled.
       [cc] Starting link
       [cc] /usr/bin/ld: cannot find -llibgcc_s.so.1
       [cc] /usr/bin/ld: cannot find -lgcc_s.so.1
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] collect2: error: ld returned 1 exit status

Libset:
<!--
      <libset dir="/usr/lib/gcc/x86_64-linux-gnu/4.8"
        libs="libgcc_s.so"
        />
-->
      <libset dir="/lib/x86_64-linux-gnu"
        libs="libgcc_s.so.1,gcc_s.so.1"
        />
Files exist:
ls -l /usr/lib/gcc/x86_64-linux-gnu/4.8/libgcc_s.so
lrwxrwxrwx 1 root root 35 May 14 2015
/usr/lib/gcc/x86_64-linux-gnu/4.8/libgcc_s.so ->
/lib/x86_64-linux-gnu/libgcc_s.so.1

ls -l /lib/x86_64-linux-gnu/libgcc_s.so.1
-rw-r--r-- 1 root root 90160 Nov 24 19:02
/lib/x86_64-linux-gnu/libgcc_s.so.1

On Wed, Feb 3, 2016 at 10:44 AM Mondain <mondain@gmail.com> wrote:

Is the error with the build, an issue with my gcc version?

/usr/bin/gcc -v
Using built-in specs.
COLLECT_GCC=/usr/bin/gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.8.4-2ubuntu1~14.04'
--with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs
--enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr
--program-suffix=-4.8 --enable-shared --enable-linker-build-id
--libexecdir=/usr/lib --without-included-gettext --enable-threads=posix
--with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls
--with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug
--enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap
--enable-plugin --with-system-zlib --disable-browser-plugin
--enable-java-awt=gtk --enable-gtk-cairo
--with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre
--enable-java-home
--with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64
--with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64
--with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar
--enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686
--with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic
--enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu
--target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04)

On Wed, Feb 3, 2016 at 10:39 AM Mondain <mondain@gmail.com> wrote:

New error when doing ant ffmpeg:

ffmpeg:
     [echo]
       [cc] 0 total files to be compiled.
       [cc] Starting link
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] /usr/bin/ld: cannot find -lgcc_s
       [cc] collect2: error: ld returned 1 exit status

Any ideas?

On Wed, Feb 3, 2016 at 10:30 AM Mondain <mondain@gmail.com> wrote:

Nevermind, resolved this by adding "--disable-opencl" to the x264
configure like so:
./configure --enable-pic --enable-debug --disable-opencl && make

May want to add that to the readme? Answer found here:
http://wiki.serviio.org/doku.php?id=build_ffmpeg_linux
tl;dr
NOTE: New version of x264 contains by default support of OpenCL. If not
installed or without sense (example Ubuntu 12.04LTS on VMWare) add to
configure additional option –disable-opencl../configure --disable-opencl

Without this option ffmpeg could not be configured (ERROR: libx264 not
found).

On Wed, Feb 3, 2016 at 10:11 AM Mondain <mondain@gmail.com> wrote:

Following this guide
https://github.com/jitsi/jitsi-lgpl-dependencies/tree/master/src/native/ffmpeg I
have added fdk-aac and have run into some issue with opencl at ffmpeg
configure time; not being a C/C++ dev, I'm not sure how to resolve it; any
assistance would be appreciated. Here is a link for the config.log:
http://pastebin.com/CxffdBJg

Thanks
Paul


#7

You can try running ant with "-v" to see the exact arguments passed to the linker.

Boris

···

On 03/02/16 14:43, Mondain wrote:

Is anyone out there building the native portion of libjitsi? I just
can't seem to figure this one out; even setting the linker arg directly
doesn't allow cc to find the gcc_s which as I said before exists!

<linkerarg value="-L/usr/lib/gcc/x86_64-linux-gnu/4.8" />


#8

Done, http://pastebin.com/9C4X2mBA

···

On Wed, Feb 3, 2016 at 4:00 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 14:43, Mondain wrote:
> Is anyone out there building the native portion of libjitsi? I just
> can't seem to figure this one out; even setting the linker arg directly
> doesn't allow cc to find the gcc_s which as I said before exists!
>
> <linkerarg value="-L/usr/lib/gcc/x86_64-linux-gnu/4.8" />

You can try running ant with "-v" to see the exact arguments passed to
the linker.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

I ran the gcc command directly, minus my lib directory addition and it
yielded this:
gcc
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavcodec
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavfilter
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavformat
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavutil
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libswscale
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/fdk-aac/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/vo-amrwbenc/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/x264 -m64
-Wl,-V,-z,relro -Wl,-Bsymbolic -g -shared -o libjnffmpeg.so
GNU ld (GNU Binutils for Ubuntu) 2.24
  Supported emulations:
   elf_x86_64
   elf32_x86_64
   elf_i386
   i386linux
   elf_l1om
   elf_k1om
   i386pep
   i386pe

So what is this emulation stuff? I'm not a C/C++ dev..

···

On Wed, Feb 3, 2016 at 4:03 PM Mondain <mondain@gmail.com> wrote:

Done, http://pastebin.com/9C4X2mBA

On Wed, Feb 3, 2016 at 4:00 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 14:43, Mondain wrote:
> Is anyone out there building the native portion of libjitsi? I just
> can't seem to figure this one out; even setting the linker arg directly
> doesn't allow cc to find the gcc_s which as I said before exists!
>
> <linkerarg value="-L/usr/lib/gcc/x86_64-linux-gnu/4.8" />

You can try running ant with "-v" to see the exact arguments passed to
the linker.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

I only end up with a tiny jnffmpeg.so 7691 bytes so I assume this missing
emulation "flag" keeps the linker from working?

···

On Wed, Feb 3, 2016 at 4:11 PM Mondain <mondain@gmail.com> wrote:

I ran the gcc command directly, minus my lib directory addition and it
yielded this:
gcc
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavcodec
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavfilter
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavformat
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavutil
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libswscale
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/fdk-aac/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/vo-amrwbenc/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/x264 -m64
-Wl,-V,-z,relro -Wl,-Bsymbolic -g -shared -o libjnffmpeg.so
GNU ld (GNU Binutils for Ubuntu) 2.24
  Supported emulations:
   elf_x86_64
   elf32_x86_64
   elf_i386
   i386linux
   elf_l1om
   elf_k1om
   i386pep
   i386pe

So what is this emulation stuff? I'm not a C/C++ dev..

On Wed, Feb 3, 2016 at 4:03 PM Mondain <mondain@gmail.com> wrote:

Done, http://pastebin.com/9C4X2mBA

On Wed, Feb 3, 2016 at 4:00 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 14:43, Mondain wrote:
> Is anyone out there building the native portion of libjitsi? I just
> can't seem to figure this one out; even setting the linker arg directly
> doesn't allow cc to find the gcc_s which as I said before exists!
>
> <linkerarg value="-L/usr/lib/gcc/x86_64-linux-gnu/4.8" />

You can try running ant with "-v" to see the exact arguments passed to
the linker.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

Heres the command with gcc -v; I'm clearly targeting x64 linux on x64 linux
so I don't get the whole emulation thing and not cross compiling
http://pastebin.com/zDqidRKn
Any ideas on what's going on or whats missing are appreciated.

Paul

···

On Wed, Feb 3, 2016 at 4:18 PM Mondain <mondain@gmail.com> wrote:

I only end up with a tiny jnffmpeg.so 7691 bytes so I assume this missing
emulation "flag" keeps the linker from working?

On Wed, Feb 3, 2016 at 4:11 PM Mondain <mondain@gmail.com> wrote:

I ran the gcc command directly, minus my lib directory addition and it
yielded this:
gcc
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavcodec
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavfilter
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavformat
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavutil
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libswscale
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/fdk-aac/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/vo-amrwbenc/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/x264 -m64
-Wl,-V,-z,relro -Wl,-Bsymbolic -g -shared -o libjnffmpeg.so
GNU ld (GNU Binutils for Ubuntu) 2.24
  Supported emulations:
   elf_x86_64
   elf32_x86_64
   elf_i386
   i386linux
   elf_l1om
   elf_k1om
   i386pep
   i386pe

So what is this emulation stuff? I'm not a C/C++ dev..

On Wed, Feb 3, 2016 at 4:03 PM Mondain <mondain@gmail.com> wrote:

Done, http://pastebin.com/9C4X2mBA

On Wed, Feb 3, 2016 at 4:00 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 14:43, Mondain wrote:
> Is anyone out there building the native portion of libjitsi? I just
> can't seem to figure this one out; even setting the linker arg
directly
> doesn't allow cc to find the gcc_s which as I said before exists!
>
> <linkerarg value="-L/usr/lib/gcc/x86_64-linux-gnu/4.8" />

You can try running ant with "-v" to see the exact arguments passed to
the linker.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Heres my updated gcc command: http://pastebin.com/uEhfbVzC
Heres its output: http://pastebin.com/XZumeJY7

···

On Wed, Feb 3, 2016 at 4:58 PM Mondain <mondain@gmail.com> wrote:

Heres the command with gcc -v; I'm clearly targeting x64 linux on x64
linux so I don't get the whole emulation thing and not cross compiling
http://pastebin.com/zDqidRKn
Any ideas on what's going on or whats missing are appreciated.

Paul

On Wed, Feb 3, 2016 at 4:18 PM Mondain <mondain@gmail.com> wrote:

I only end up with a tiny jnffmpeg.so 7691 bytes so I assume this missing
emulation "flag" keeps the linker from working?

On Wed, Feb 3, 2016 at 4:11 PM Mondain <mondain@gmail.com> wrote:

I ran the gcc command directly, minus my lib directory addition and it
yielded this:
gcc
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavcodec
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavfilter
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavformat
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libavutil
-L/home/mondain/workspace/github/libjitsi/src/native/extras/ffmpeg/libswscale
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame
-L/home/mondain/workspace/github/libjitsi/src/native/extras/lame/libmp3lame/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/fdk-aac/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/vo-amrwbenc/.libs
-L/home/mondain/workspace/github/libjitsi/src/native/extras/x264 -m64
-Wl,-V,-z,relro -Wl,-Bsymbolic -g -shared -o libjnffmpeg.so
GNU ld (GNU Binutils for Ubuntu) 2.24
  Supported emulations:
   elf_x86_64
   elf32_x86_64
   elf_i386
   i386linux
   elf_l1om
   elf_k1om
   i386pep
   i386pe

So what is this emulation stuff? I'm not a C/C++ dev..

On Wed, Feb 3, 2016 at 4:03 PM Mondain <mondain@gmail.com> wrote:

Done, http://pastebin.com/9C4X2mBA

On Wed, Feb 3, 2016 at 4:00 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 14:43, Mondain wrote:
> Is anyone out there building the native portion of libjitsi? I just
> can't seem to figure this one out; even setting the linker arg
directly
> doesn't allow cc to find the gcc_s which as I said before exists!
>
> <linkerarg value="-L/usr/lib/gcc/x86_64-linux-gnu/4.8" />

You can try running ant with "-v" to see the exact arguments passed to
the linker.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

/home/mondain/workspace/github/libjitsi/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c:77:5: warning: implicit declaration of function ‘avcodec_alloc_frame’ [-Wimplicit-function-declaration]
      return (jlong) (intptr_t) avcodec_alloc_frame();

Current versions of ffmpeg don't include avcodec_alloc_frame.

Regards,
Boris

···

On 03/02/16 17:19, Mondain wrote:

Heres my updated gcc command: http://pastebin.com/uEhfbVzC
Heres its output: http://pastebin.com/XZumeJY7


#14

Ok, so where did this function come from? I'm using the unmodified Jitsi
FFmpeg.c from github and the latest tarball source for FFMpeg.

···

On Wed, Feb 3, 2016 at 6:34 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 17:19, Mondain wrote:
> Heres my updated gcc command: http://pastebin.com/uEhfbVzC
> Heres its output: http://pastebin.com/XZumeJY7

/home/mondain/workspace/github/libjitsi/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c:77:5:
warning: implicit declaration of function ‘avcodec_alloc_frame’
[-Wimplicit-function-declaration]
      return (jlong) (intptr_t) avcodec_alloc_frame();

Current versions of ffmpeg don't include avcodec_alloc_frame.

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

Looks like 1.0.10 was used last time:
https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/native/ffmpeg/README#L2

Boris

···

On 04/02/16 09:06, Mondain wrote:

Which version of ffmpeg do I need to target to compile
https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c


#16

Which version of ffmpeg do I need to target to compile
https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c

···

On Thu, Feb 4, 2016 at 7:26 AM, Mondain <mondain@gmail.com> wrote:

Ok, so where did this function come from? I'm using the unmodified Jitsi
FFmpeg.c from github and the latest tarball source for FFMpeg.

On Wed, Feb 3, 2016 at 6:34 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 17:19, Mondain wrote:
> Heres my updated gcc command: http://pastebin.com/uEhfbVzC
> Heres its output: http://pastebin.com/XZumeJY7

/home/mondain/workspace/github/libjitsi/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c:77:5:
warning: implicit declaration of function ‘avcodec_alloc_frame’
[-Wimplicit-function-declaration]
      return (jlong) (intptr_t) avcodec_alloc_frame();

Current versions of ffmpeg don't include avcodec_alloc_frame.

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>


#17

Since avcodec_alloc_frame is being referenced in two spots:

https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c#L77
https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/include/org/jitsi/impl/neomedia/codec/FFmpeg.h#L47

Is there a newer version of the .c and .h file?

···

On Thu, Feb 4, 2016 at 10:06 AM, Mondain <mondain@gmail.com> wrote:

Which version of ffmpeg do I need to target to compile
https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c

On Thu, Feb 4, 2016 at 7:26 AM, Mondain <mondain@gmail.com> wrote:

Ok, so where did this function come from? I'm using the unmodified Jitsi
FFmpeg.c from github and the latest tarball source for FFMpeg.

On Wed, Feb 3, 2016 at 6:34 PM Boris Grozev <boris@jitsi.org> wrote:

On 03/02/16 17:19, Mondain wrote:
> Heres my updated gcc command: http://pastebin.com/uEhfbVzC
> Heres its output: http://pastebin.com/XZumeJY7

/home/mondain/workspace/github/libjitsi/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c:77:5:
warning: implicit declaration of function ‘avcodec_alloc_frame’
[-Wimplicit-function-declaration]
      return (jlong) (intptr_t) avcodec_alloc_frame();

Current versions of ffmpeg don't include avcodec_alloc_frame.

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>


#18

Ok, I'll try the 1.x versions then; also that note is from 2013, is it
still relevant?

···

On Thu, Feb 4, 2016 at 10:19 AM, Boris Grozev <boris@jitsi.org> wrote:

On 04/02/16 09:06, Mondain wrote:

Which version of ffmpeg do I need to target to compile

https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c

Looks like 1.0.10 was used last time:

https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/native/ffmpeg/README#L2

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>


#19

These guys ran into a similar issue with ffmpeg and resolved it with a name
change:
https://github.com/nareix/codec/issues/3

I tried this with jitsi source and it only resolved it for the one function
:frowning:

···

On Thu, Feb 4, 2016 at 10:24 AM, Mondain <mondain@gmail.com> wrote:

Ok, I'll try the 1.x versions then; also that note is from 2013, is it
still relevant?

On Thu, Feb 4, 2016 at 10:19 AM, Boris Grozev <boris@jitsi.org> wrote:

On 04/02/16 09:06, Mondain wrote:

Which version of ffmpeg do I need to target to compile

https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c

Looks like 1.0.10 was used last time:

https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/native/ffmpeg/README#L2

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>


#20

Seems that function and others are deprecated in ffmpeg 1.2
https://github.com/FFmpeg/FFmpeg/blob/1dba8371d93cf1c83bcd5c432d921905206a60f3/doc/APIchanges#L685

···

On Thu, Feb 4, 2016 at 10:41 AM Mondain <mondain@gmail.com> wrote:

These guys ran into a similar issue with ffmpeg and resolved it with a
name change:
https://github.com/nareix/codec/issues/3

I tried this with jitsi source and it only resolved it for the one
function :frowning:

On Thu, Feb 4, 2016 at 10:24 AM, Mondain <mondain@gmail.com> wrote:

Ok, I'll try the 1.x versions then; also that note is from 2013, is it
still relevant?

On Thu, Feb 4, 2016 at 10:19 AM, Boris Grozev <boris@jitsi.org> wrote:

On 04/02/16 09:06, Mondain wrote:

Which version of ffmpeg do I need to target to compile

https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/main/c/org/jitsi/impl/neomedia/codec/FFmpeg.c

Looks like 1.0.10 was used last time:

https://github.com/jitsi/jitsi-lgpl-dependencies/blob/master/src/native/ffmpeg/README#L2

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>

--
http://gregoire.org/
https://github.com/Red5 <http://code.google.com/p/red5/>