[jitsi-dev] Build Windows Jitsi package


#1

I am able to build windows jitsi and test run in eclipse environment without
problem.

However, I am trying to build the installation package for Windows (MSI) by
running the “build-installation-wix-base”.
I have try to add the make.exe from internet download and put into the
windows environment, but it still won’t work. (fail at the same point of
followings).

The build script failed.

The following is the “error message”…

====================>
Buildfile: C:\Users\alanmacwin\workspace\jitsi\build.xml
clean-install-windows:
   [delete] Deleting directory
C:\Users\alanmacwin\workspace\jitsi\release\windows
    [mkdir] Created dir: C:\Users\alanmacwin\workspace\jitsi\release\windows
    [mkdir] Created dir:
C:\Users\alanmacwin\workspace\jitsi\release\windows\tmp
define-ant-contrib-task:
build-installation-wix-base:
[propertyfile] Creating new property file:
C:\Users\alanmacwin\workspace\jitsi\release\windows\versionupdate.properties
    [mkdir] Created dir:
C:\Users\alanmacwin\workspace\jitsi\release\windows\tmp\light

BUILD FAILED
C:\Users\alanmacwin\workspace\jitsi\resources\install\build.xml:417: Execute
failed: java.io.IOException: Cannot run program "make.exe" (in directory
"C:\Users\alanmacwin\workspace\jitsi\src\native\windows\run"): CreateProcess
error=2, °Lt2£Y?°Li?uc

Total time: 2 seconds

<=================

Any missing tools or setting needed.

Alan


#2

I suppose make.exe is not really in the PATH.

···

2014-09-17 14:33 GMT+03:00 Alan_Lin <alanl@azblink.com>:

Cannot run program "make.exe" (in directory
"C:\Users\alanmacwin\workspace\jitsi\src\native\windows\run"): CreateProcess
error=2, °Lt2£Y?°Li?uc