[jitsi-dev] Bug While Running Ant in "Install" Directory


#1

Whenever I try to run

ant make

in the jitsi/resources/install directory, I get an error. So, to try and
better diagnose the issue, I ran the command below, and got the output
that follows it.

C:\jitsi\resources\install>ant make -v > log.txt

BUILD FAILED

C:\jitsi\build.xml:1035: The archive laf-widget.jar doesn't exist
at
org.apache.tools.ant.types.ArchiveFileSet.getDirectoryScanner(ArchiveFileSet.java:290)
at org.apache.tools.ant.taskdefs.Zip.grabResources(Zip.java:1547)
        at
org.apache.tools.ant.taskdefs.Zip.getResourcesToAdd(Zip.java:1286)
at org.apache.tools.ant.taskdefs.Zip.getResourcesToAdd(Zip.java:1220)
        at org.apache.tools.ant.taskdefs.Jar.getResourcesToAdd(Jar.java:868)
at org.apache.tools.ant.taskdefs.Zip.executeMain(Zip.java:615)
        at org.apache.tools.ant.taskdefs.Zip.execute(Zip.java:568)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
        at
org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)

        at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
        at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
        at org.apache.tools.ant.Main.runBuild(Main.java:809)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
Total time: 3 minutes 32 seconds

C:\jitsi\resources\install>

The log file I got from the shell redirection is over 3 MB in size, so I
will not include it unless asked to do so. Is this a bug worth filing in
the issue tracker?

Tyler Kavanaugh

---System Information---
OS: Windows XP SP3
JDK: JDK 1.6U24
Ant Version: Ant 1.8.2
Got source code from: Subversion (head revision)


#2

Hi,

its not supposed to run ant from within resources/install. You should
always do it through the main build.xml (which includes the one from
resources/install).

Cheers
damencho

···

On Wed, Mar 23, 2011 at 5:38 AM, Tyler Kavanaugh <twkav@kc.rr.com> wrote:

Whenever I try to run

ant make

in the jitsi/resources/install directory, I get an error. So, to try and
better diagnose the issue, I ran the command below, and got the output
that follows it.

C:\jitsi\resources\install>ant make -v > log.txt

BUILD FAILED

C:\jitsi\build.xml:1035: The archive laf-widget.jar doesn't exist
at
org.apache.tools.ant.types.ArchiveFileSet.getDirectoryScanner(ArchiveFileSet.java:290)
at org.apache.tools.ant.taskdefs.Zip.grabResources(Zip.java:1547)
at
org.apache.tools.ant.taskdefs.Zip.getResourcesToAdd(Zip.java:1286)
at org.apache.tools.ant.taskdefs.Zip.getResourcesToAdd(Zip.java:1220)
at org.apache.tools.ant.taskdefs.Jar.getResourcesToAdd(Jar.java:868)
at org.apache.tools.ant.taskdefs.Zip.executeMain(Zip.java:615)
at org.apache.tools.ant.taskdefs.Zip.execute(Zip.java:568)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at
org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)

   at org\.apache\.tools\.ant\.Task\.perform\(Task\.java:348\)

at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
at org.apache.tools.ant.Main.runBuild(Main.java:809)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
Total time: 3 minutes 32 seconds

C:\jitsi\resources\install>

The log file I got from the shell redirection is over 3 MB in size, so I
will not include it unless asked to do so. Is this a bug worth filing in
the issue tracker?

Tyler Kavanaugh

---System Information---
OS: Windows XP SP3
JDK: JDK 1.6U24
Ant Version: Ant 1.8.2
Got source code from: Subversion (head revision)