[jitsi-dev] Bug report - Jitsi on Mac 10.7 audio input issues - and not switching during a call


#1

Hi,

I downloaded Jitsi 1.0-beta1-nightly.build.3651onto my iMac running Mac OS X 10.7 today to connect into the VUC call where Emil was speaking about Jitsi. It worked fine, but I did notice one thing that didn't work as I expected.

When I was in the call, I discovered that Jitsi wasn't using my iMac's internal mic but was rather using an external mic I have for podcasting that connects in through a USB audio connector. While that worked, I wanted to switch to using the internal mic.

My first action was to go the Audio panel of the Mac System Preferences where I found that in the input was set to be from the USB audio device (so Jitsi correctly picked up the system setting). I changed it there to be the internal mic, but found it did not change in Jitsi.

My next action was to look in the Jitsi Preferences window where I saw that I could set the audio device there. I changed that to the internal mic, but again, it did not change during the call. Still the external mic was the one that worked.

I subsequently dropped the call and called back in to the ZipDX bridge ... and found that I could hear the call but I then had NO audio input.

After verifying that the Preferences were for the Built-in Mic, I quit Jitsi and restarted it, reconnected into the VUC call and found that again I had no audio input. I verified in the Audio panel of Mac System Preferences that the Built-in Mic *was* working correctly, but Jitsi was somehow not connecting to the Built-in mic.

I switched back to the external USB audio device, called in again, and found that audio input worked.

Anyway... I hope all of this is somewhat helpful. If you would like me to do any further testing, please feel free to contact me directly as I am not a subscriber to this list. (Just following your instructions in the VUC call, Emil.)

Regards,
Dan

···

--
Dan York dyork@lodestar2.com
http://www.danyork.com/ skype:danyork
Phone: +1-802-735-1624

NEW BOOKS -> Migrating Applications to IPv6
http://migratingappstoipv6.com/

Seven Deadliest Unified Communications Attacks
http://www.7ducattacks.com/

Disruptive Telephony - http://www.disruptivetelephony.com
Disruptive Conversations - http://www.disruptiveconversations.com/
Code.DanYork.com - http://code.danyork.com/
Voice of VOIPSA - http://www.voipsa.org/blog
Voxeo weblogs - http://blogs.voxeo.com/
Twitter - http://twitter.com/danyork


#2

Hey Dan,

На 02.09.11 20:29, Dan York написа:

Hi,

I downloaded Jitsi 1.0-beta1-nightly.build.3651onto my iMac running Mac
OS X 10.7 today to connect into the VUC call where Emil was speaking
about Jitsi. It worked fine, but I did notice one thing that didn't
work as I expected.

When I was in the call, I discovered that Jitsi wasn't using my iMac's
internal mic but was rather using an external mic I have for podcasting
that connects in through a USB audio connector. While that worked, I
wanted to switch to using the internal mic.

My first action was to go the Audio panel of the Mac System Preferences
where I found that in the input was set to be from the USB audio device
(so Jitsi correctly picked up the system setting). I changed it there
to be the internal mic, but found it did not change in Jitsi.

That's to be expected. Jitsi discovers all devices available on the
system and it also picks the default one - the one that's currently
selected in your system preferences. From that point on however it
doesn't track any changes you make on an OS level, assuming that a
user's telephony configuration should not necessarily be the same as
that of other applications..

My next action was to look in the Jitsi Preferences window where I saw
that I could set the audio device there. I changed that to the internal
mic, but again, it did not change during the call. Still the external
mic was the one that worked.

Expected again. We don't currently support mid-call switching. You have
to hangup and call again for the change to make a difference. We know it
would be better otherwise, we just haven't gotten around to that.

I subsequently dropped the call and called back in to the ZipDX bridge
... and found that I could hear the call but I then had NO audio input.

Now that's weird. This should have worked.

After verifying that the Preferences were for the Built-in Mic, I quit
Jitsi and restarted it, reconnected into the VUC call and found that
again I had no audio input. I verified in the Audio panel of Mac System
Preferences that the Built-in Mic *was* working correctly, but Jitsi was
somehow not connecting to the Built-in mic.

I switched back to the external USB audio device, called in again, and
found that audio input worked.

OK, so it does seem like we had a problem with your built-in mic. Did
you confirm it was actually working with another application? I suppose
you did, but it's worth asking.

Are you still experiencing the problem or was it just that one time? If
you are then, could you please send us your logs after one unsuccessful
attempt to use that mike?

Here's how to get them:

http://jitsi.org/faq/logs

Anyway... I hope all of this is somewhat helpful.

It definitely is!

Thanks,
Emil

···

If you would like me
to do any further testing, please feel free to contact me directly as I
am not a subscriber to this list. (Just following your instructions in
the VUC call, Emil.)

Regards,
Dan

--
Dan York dyork@lodestar2.com <mailto:dyork@lodestar2.com>
http://www.danyork.com/ skype:danyork
Phone: +1-802-735-1624

NEW BOOKS -> Migrating Applications to IPv6
http://migratingappstoipv6.com/

Seven Deadliest Unified Communications Attacks
http://www.7ducattacks.com/

Disruptive Telephony - http://www.disruptivetelephony.com
<http://www.disruptivetelephony.com/>
Disruptive Conversations - http://www.disruptiveconversations.com/
Code.DanYork.com <http://Code.DanYork.com> - http://code.danyork.com/
Voice of VOIPSA - http://www.voipsa.org/blog
Voxeo weblogs - http://blogs.voxeo.com/
Twitter - http://twitter.com/danyork

--
http://jitsi.org